Creating HTML extensions

  1. Adobe Animate User Guide
  2. Introduction to Animate
    1. What's New in Animate
    2. Visual Glossary
    3. Animate system requirements
    4. Animate keyboard shortcuts
    5. Work with Multiple File Types in Animate
  3. Animation
    1. Animation basics in Animate
    2. How to use frames and keyframes in Animate
    3. Frame-by-frame animation in Animate
    4. How to work with classic tween animation in Animate
    5. Brush Tool
    6. Motion Guide
    7. Motion tween and ActionScript 3.0
    8. About Motion Tween Animation
    9. Motion tween animations
    10. Creating a Motion tween animation
    11. Using property keyframes
    12. Animate position with a tween
    13. How to edit motion tweens using Motion Editor
    14. Editing the motion path of a tween animation
    15. Manipulating motion tweens
    16. Adding custom eases
    17. Creating and applying Motion presets
    18. Setting up animation tween spans
    19. Working with Motion tweens saved as XML files
    20. Motion tweens vs Classic tweens
    21. Shape tweening
    22. Using Bone tool animation in Animate
    23. Work with character rigging in Animate
    24. How to use mask layers in Adobe Animate
    25. How to work with scenes in Animate
  4. Interactivity
    1. How to create buttons with Animate
    2. Convert Animate projects to other document type formats
    3. Create and publish HTML5 Canvas documents in Animate
    4. Add interactivity with code snippets in Animate
    5. Creating custom HTML5 Components
    6. Using Components in HTML5 Canvas
    7. Creating custom Components: Examples
    8. Code Snippets for custom Components
    9. Best practices - Advertising with Animate
    10. Virtual Reality authoring and publishing
  5. Workspace and workflow
    1. Creating and managing Paint brushes
    2. Using Google fonts in HTML5 Canvas documents
    3. Using Creative Cloud Libraries and Adobe Animate
    4. Use the Stage and Tools panel for Animate
    5. Animate workflow and workspace
    6. Using web fonts in HTML5 Canvas documents
    7. Timelines and ActionScript
    8. Working with multiple timelines
    9. Set preferences
    10. Using Animate authoring panels
    11. Create timeline layers with Animate
    12. Export animations for mobile apps and game engines
    13. Moving and copying objects
    14. Templates
    15. Find and Replace in Animate
    16. Undo, redo, and the History panel
    17. Keyboard shortcuts
    18. How to use the timeline in Animate
    19. Creating HTML extensions
    20. Optimization options for Images and Animated GIFs
    21. Export settings for Images and GIFs
    22. Assets Panel in Animate
  6. Multimedia and Video
    1. Transforming and combining graphic objects in Animate
    2. Creating and working with symbol instances in Animate
    3. Image Trace
    4. How to use sound in Adobe Animate
    5. Exporting SVG files
    6. Create video files for use in Animate
    7. How to add a video in Animate
    8. Working with video cue points
    9. Draw and create objects with Animate
    10. Reshape lines and shapes
    11. Strokes, fills, and gradients with Animate CC
    12. Working with Adobe Premiere Pro and After Effects
    13. Color Panels in Animate CC
    14. Opening Flash CS6 files with Animate
    15. Work with classic text in Animate
    16. Placing artwork into Animate
    17. Imported bitmaps in Animate
    18. 3D graphics
    19. Working with symbols in Animate
    20. Draw lines & shapes with Adobe Animate
    21. Work with the libraries in Animate
    22. Exporting Sounds
    23. Selecting objects in Animate CC
    24. Working with Illustrator AI files in Animate
    25. Apply patterns with the Spray Brushtool
    26. Applying blend modes
    27. Arranging objects
    28. Automating tasks with the Commands menu
    29. Multilanguage text
    30. Using camera in Animate
    31. Using Animate with Adobe Scout
    32. Working with Fireworks files
    33. Graphic filters
    34. Sound and ActionScript
    35. Drawing preferences
    36. Drawing with the Pen tool
  7. Platforms
    1. Convert Animate projects to other document type formats
    2. Custom Platform Support
    3. Create and publish HTML5 Canvas documents in Animate
    4. Creating and publishing a WebGL document
    5. How to package applications for AIR for iOS
    6. Publishing AIR for Android applications
    7. Publishing for Adobe AIR for desktop
    8. ActionScript publish settings
    9. Best practices - Organizing ActionScript in an application
    10. How to use ActionScript with Animate
    11. Best practices - Accessibility guidelines
    12. Accessibility in the Animate workspace
    13. Writing and managing scripts
    14. Enabling Support for Custom Platforms
    15. Custom Platform Support Overview
    16. Creating accessible content
    17. Working with Custom Platform Support Plug-in
    18. Debugging ActionScript 3.0
    19. Enabling Support for Custom Platforms
  8. Exporting and Publishing
    1. How to export files from Animate CC
    2. OAM publishing
    3. Exporting SVG files
    4. Export graphics and videos with Animate
    5. Publishing AS3 documents
    6. Export animations for mobile apps and game engines
    7. Exporting Sounds
    8. Export QuickTime video files
    9. Controlling external video playback with ActionScript
    10. Best practices - Tips for creating content for mobile devices
    11. Best practices - Video conventions
    12. Best practices - SWF application authoring guidelines
    13. Best practices - Structuring FLA files
    14. Best Practices to optimize FLA files for Animate
    15. ActionScript publish settings
    16. Specify publish settings for Animate
    17. Exporting projector files
    18. Export Images and Animated GIFs
    19. HTML publishing templates
    20. Working with Adobe Premiere Pro and After Effects
    21. Quick share and publish your animations

Animate can be extended using HTML extensions. Adobe Extension Builder 3 allows you to create HTML extensions for Animate. Earlier, you could only extend Animate using SWF extensions. However, Adobe Extension Builder 3 allows you to create HTML extensions for Creative Cloud applications. To get started, you need to download and install Eclipse and Extension Builder 3.0. For more information, visit this link.

Creating an HTML extension

To create an HTML extension, do the following.

  1. Launch Eclipse. 
  2. On the New Project wizard, create a new Application Extension Project. Provide a meaningful name for the project, then click Next.
  3. On the New Adobe Application Extension Project panel, choose Adobe Animate. Click Next.
  4. Configure your extension using the available options:
    1. Bundle ID uniquely identifies your extension.
    2. Menu name is the display name for your extension. The Menu Name appears in Window > Extensions menu within Animate.
    3. Window Details use these options to customize the extension window type and size.

      Click Next.
  5. You can further customize the reference libraries for your extension in the next few screens:
    1. CEP Interface Library provides functions for interacting with the host application. The option is selected by default.
    2. Frameworks are for common Javascript libraries such as jQuery.
    3. Services include the Adobe IPC Communication Toolkit, which enables communication between Adobe applications, extensions, and external applications. It provides a protocol for messaging through the CEP Service Manager, which acts as a hub for Creative Cloud communications.

      Click Finish to create a new Eclipse project.

Debugging your extension in Animate 

You can run your extension directly from Eclipse:

  1. Right-click the project, and select Run As > Adobe Flash Extension. This launches Animate.
  2. In Animate, select Window > Extensions menu item. This opens the extension panel.

Exporting your extension

To distribute your extension, you need to export it as a ZXP package. The ZXP package is then downloaded and run by Adobe Extension Manager on Creative Cloud applications:

  1. In Eclipse, switch to the Script Explorer view to right-click on your project and select Export > Adobe Extension Builder 3 > Application Extension. This displays the Export Wizard.
  2. You must have a certificate to sign the extension package. Browse to an existing certificate or click Create to create a new one.
  3. Click Finish.
  4. When the export is complete, you will find the ZXP package for your extension in the project folder, ready for distribution.

Note: To install you will need to access the <extension>\.staged-extension\CSXS\manifest.xml file and update the host tag to set the minimum version of Animate to 13.0.

Installing your extension in Animate 

You can install HTML extensions within Animate using Adobe Extension Manager. HTML extensions can help you extend functionalities and capabilities of Animate. To install extensions, see this link.

Adding interactivity to HTML extensions

You can build an HTML extension to interact with Animate by adding controls, defining behavior, and obtain information about the host (includes Animate and the operating system) environment. This can be accomplished in two ways:

  1. Using the CEP interface library: The CEP interface library provides APIs for obtaining information about the host environment and an eval script that allows you to run JSFLs. To know more about CEP interface library, open Help > Help Contents > Adobe Extension Builder > References within Eclipse.
  2. Using JSFL: JSFL scripts can be run using the Eval script API of CEP interface Library. To know more about JSFLs, see this link.

    Apart from JSFLs, the CEP infrastructure within Animate also expose the following events that can used within HTML panels only.
    • com.adobe.events.flash.documentChanged is triggered due to a change in the current active document.
    • com.adobe.events.flash.timelineChanged is triggered when you make a change in the timeline of the current active document.
    • com.adobe.events.flash.documentSaved is triggered when you save the current document.
    • com.adobe.events.flash.documentOpened is triggered when you open a new document.
    • com.adobe.events.flash.documentClosed is triggered when you close the current active document.
    • com.adobe.events.flash.documentNew is triggered when you create a new document.
    • com.adobe.events.flash.layerChanged is triggered when you select a different layer.
    • com.adobe.events.flash.frameChanged is triggered when you select a different frame.
    • com.adobe.events.flash.selectionChanged is triggered when you select a different object on stage.
    • com.adobe.events.flash.mouseMove is triggered when you move your Mouse over the Stage.

Example

csinterface.addEventListener("com.adobe.events.flash.selectionChanged", CallbackFunction)

In the above code snippet:

  • csinterface: Object of CEP interface library.
  • com.adobe.events.flash.selectionChanged: Event that triggers a change in the selection of an object. You can use any of the above mentioned events too.
  • CallbackFunction: Method that listens to triggered event.
Adobe-logoen

Logg på kontoen din