Note:

In Photoshop CS6, 3D functionality was part of Photoshop Extended. All features in Photoshop Extended are part of Photoshop CC. Photoshop CC does not have a separate Extended offering.

Understand and display 3D files

Photoshop lets you position and animate 3D models, edit textures and lighting, and choose from several render modes.

3D fundamentals

3D files consist of the following components:

Meshes

Provide the underlying structure of a 3D model. A mesh is often visualized as a wireframe, a skeletal structure built from thousands of individual polygons. A 3D model always has at least one mesh, and may combine multiple meshes. In Photoshop you can view meshes in a variety of render modes, and manipulate meshes independently of each other. While you can’t alter the actual polygons in a mesh, you can change its orientation and transform it by scaling along different axes. You can also create your own 3D meshes, using pre-supplied shapes or by converting existing 2D layers. See 3D Mesh settings.

Note:

To edit the polygon mesh of the 3D model itself, you must use a 3D authoring program.

Materials

A mesh can have one or more materials associated with it, which control the appearance of all or part of the mesh. The material in turn relies on subcomponents called texture maps, whose cumulative effect creates the appearance of a material. The texture map itself is a 2D image file that creates various qualities such as color, pattern, shininess, or bumpiness. A Photoshop material can use up to nine different texture map types to define its overall appearance. See 3D Materials settings.

Lights

Types include Infinite, Spot, Point lights, as well as Image-based lights that wrap around a scene. You can move and adjust color and intensity of existing lights, and add new lights to your 3D scene. See 3D Lights settings.

Open a 3D file

Photoshop can open the following 3D formats: DAE (Collada), OBJ, 3DS, U3D, and KMZ (Google Earth).

  • Do one of the following:

    • To open a 3D file on its own, choose File > Open, and select the file.

    • To add a 3D file as a layer in an open file, choose 3D > New Layer From 3D File, and then select the 3D file. The new layer reflects the dimensions of the open file and presents the 3D model over a transparent background.

3D performance and display preferences

  1. Choose Edit > Preferences > 3D (Windows) or Photoshop > Preferences 3D (Mac OS).

  2. For information about options, hover the pointer over them, and read the Description section at the bottom of the dialog box.

3D object and camera tools

The 3D object and camera tools become active when a 3D layer is selected. Use the 3D object tools to change the position or scale of a 3D model; use the 3D camera tools to change the view of the scene. If your system supports OpenGL, you can also use the 3D Axis to manipulate 3D models and cameras. See Using the 3D Axis.

Move, rotate, or scale a model with 3D object tools

You can use the 3D object tools to rotate, reposition, or scale a model. While you manipulate the 3D model, the camera view remains fixed.

Note:

For tips about each 3D tool, choose panel Options from the Info panel menu , and select Show Tool Hints. Click a tool, then move the cursor into the image window to view tool details in the Info Panel.

Photoshop 3D object tools and options
3D object tools and options

A. Return to initial object position B. Rotate C. Roll D. Pan E. Slide F. Scale G. Position menu H. Save current position I. Delete current position J. Position coordinates 
  • In the Tools panel, click a 3D object tool, and hold down the mouse button to select from the following types:

    Note:

    Hold down Shift as you drag to constrain the Rotate, Pan, Slide, or Scale tool to a single direction of movement.

    Rotate

    Drag up or down to rotate the model around its x-axis, or side to side to rotate it around its y axis. Hold down Alt (Windows) or Option (Mac OS) as you drag to roll the model.

    Roll

    Drag side to side to rotate the model around its z axis.

    Pan

    Drag side to side to move the model horizontally, or up or down to move it vertically. Hold down Alt (Windows) or Option (Mac OS) as you drag to move in the x/z direction.

    Slide

    Drag side to side to move the model horizontally, or up or down to move it closer or farther away. Hold down Alt (Windows) or Option (Mac OS) as you drag to move in the x/y direction.

    Scale

    Drag up or down to scale the model larger or smaller. Hold down Alt (Windows) or Option (Mac OS) as you drag to scale in the z direction.

Click the Return To Initial Position icon  in the options bar to return the model to its initial view.

To numerically adjust position, rotation, or scaling, enter values on the right side of the options bar.

Move the 3D camera

Use the 3D camera tools to move the camera view while leaving the position of the 3D object fixed.

Note:

For tips about each 3D tool, choose Panel Options from the Info panel menu , and select Show Tool Hints. Click a tool, then move the cursor into the image window to view tool details in the Info panel.

Photoshop 3D camera tools and options
3D camera tools and options

A. Return to initial camera position B. Rotate C. Roll D. Pan E. Walk F. Zoom G. View menu H. Save current camera view I. Delete current camera view J. Camera position coordinates 
  • In the Tools panel, click a 3D camera tool, and hold down the mouse button to select from the following types:

    Note:

    Hold down Shift as you drag to constrain the Rotate, Pan, or Walk tools to a single direction of movement.

    Rotate

    Drag to orbit the camera in the x or y direction. Hold down Alt (Windows) or Option (Mac OS) as you drag to roll the camera.

    Roll

    Drag to roll the camera.

    Pan

    Drag to pan the camera in the x or y direction. Hold down Alt (Windows) or Option (Mac OS) as you drag to pan in the x or z direction.

    Walk

    Drag to walk the camera (z translation and y rotation). Hold down Alt (Windows) or Option (Mac OS) as you drag to walk in the z/x direction (z translation and x rotation).

    Zoom

    Drag to change the field of view of the 3D camera. Maximum field of view is 180.

    Perspective Camera (Zoom only)

    Displays parallel lines converging to vanishing points.

    Orthographic Camera (Zoom only)

    Maintains parallel lines without convergence. Displays the model in accurate scale view without any perspective distortion.

    DOF (Zoom only)

    Sets depth of field. Distance determines how far the in-focus field is from the camera. Blur obscures the remainder of the image.

    Note:

    Animate DOF to simulate camera focusing effects.

In the options bar, numeric values show the x, y, and z position of the 3D camera. You can also edit these values manually to adjust the camera view.

Change or create 3D camera views

  • Do one of the following:

    • Select a preset camera view of the model from the View menu.

    Note:

    All preset camera views use orthographic projection.

    • To add a custom view, place the 3D camera in the desired position using the 3D camera tools, then click Save in the options bar.

    Note:

    To return to the default camera view, select a 3D camera tool, and click the Return To Initial Camera Position icon in the options bar.

3D Axis

The 3D Axis shows the current X, Y, and Z-axis orientation of models, cameras, lights, and meshes in 3D space. It appears when you select any 3D tool, providing an alternative way to manipulate the selected item.

Photoshop 3D Axis
3D Axis with Mesh Rotate tool selected

A. Selected tool B. Minimize or maximize 3D Axis C. Move item along axis D. Rotate item E. Compress or elongate item F. Resize item 

Note:

OpenGL must be enabled to display the 3D Axis. 

Show or hide the 3D Axis

  • Choose View > Show > 3D Axis.

Minimize, restore, move, or resize the 3D Axis

  1. Move the pointer over the 3D Axis to display the control bar.

  2. Do one of the following:

    • To move the 3D Axis, drag the control bar.

    • To minimize, click the minimize icon.

    • To restore to normal size, click the minimized 3D Axis.

    • To resize, drag the zoom icon.

Move, rotate, or scale selected items with the 3D Axis

To use the 3D Axis, move the mouse pointer over an axis control to highlight it, and then drag as follows:

Note:

Available axis controls vary depending upon the current editing mode (object, camera, mesh, or light).

  • To move the selected item along the X, Y, or Z-axis, highlight the conical tip of any axis. Drag in either direction along the axis.

  • To rotate the item, click the curved rotation segment just inside an axis tip. A yellow circle appears showing the rotation plane. Drag in a clockwise or counterclockwise circle around the 3D Axis center. To rotate more gradually, move the mouse farther away from the center of the 3D Axis.

  • To resize the item, drag the center cube in the 3D Axis up or down.

  • To compress or elongate the item along an axis, drag one of the colored transform cubes either toward or away from the center cube.

  • To constrain movement to an object plane, move the mouse pointer into the area where two axes intersect, near the center cube. A yellow plane icon appears between two axes. Drag in any direction. You can also move the pointer over the lower part of the center cube to activate the plane icon.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy