Photoshop CC 2015 rolls out exciting new features for designers and digital photographers. Read on for a quick introduction to these features and links to resources offering more information.

Note: For answers to common questions asked about Photoshop CC 2015, see the FAQ.

For a summary of features introduced in earlier releases of Photoshop CC, see:


Photoshop CC 2015.5 (June 2016 release)

Note:

Plug-ins from earlier versions of Photoshop CC are not migrated to Photoshop CC 2015.5. After you install Photoshop CC 2015.5, install the latest versions of the plug-ins directly from the manufacturer's website. For your convenience, we have compiled a list of third party plug-ins for Photoshop, along with their download locations, here. If you're facing issues while installing plug-ins, refer to this troubleshooting document.

Face-Aware Liquify

 New in this release of Photoshop CC

The Liquify filter now features advanced face-aware functionality that automatically identifies eyes, noses, mouths, and other facial features, making it easy for you to adjust them. Face-Aware Liquify is great for retouching portrait photos, creating caricatures, and doing much more.

You can use Face-Aware Liquify as a smart filter for non-destructive editing. Select Filter > Liquify and then choose the Face () tool in the Liquify dialog.

For more information, see Use the Liquify filter.

Eye settings

Nose settings

Mouth settings

Face Shape settings

Select and Mask workspace

 New in this release of Photoshop CC

Creating accurate selections and masks in Photoshop is now quicker and easier than ever before. A dedicated new workspace now helps you make precise selections and masks. Use tools like Refine Edge Brush to cleanly separate foreground and background elements and do much more.

To invoke the workspace, click Select And Mask in the Options bar when a selection tool is enabled. Alternatively, press Ctrl+Alt+R (Windows) or Cmd+Option+R (Mac).

For more information, see Select and Mask workspace.

Note:

The Select and Mask workspace replaces the Refine Edge dialog in earlier versions of Photoshop, offering the same functionality in a streamlined way.

Match Font

 New in this release of Photoshop CC

Take the guesswork out of identifying certain fonts and let Photoshop CC do the hard work for you. Thanks to the magic of intelligent imaging analysis, using just a picture of a Latin font, Photoshop CC can use machine learning to detect which font it is and match it to licensed fonts on your computer or on Typekit, suggesting similar fonts.

Simply select the area of the image containing the text whose font you want to analyze. Now, select Type > Match Font

For more information, see Fonts.

Note:

Keep the following best practices in mind while selecting text for Match Font:

  • Draw the selection box, such that it includes a single line of text.
  • Closely crop the selection box to the left and right edges of the text.
  • Select a single typeface and style. Don't mix typefaces and styles in a selection.
  • If necessary, straighten or correct perspective on the image before you choose Type > Match Font.

Note:

Match Font, font classification, and font similarity features currently work only for Roman/Latin characters.

Find fonts matching the font in an image

Content-Aware Crop

 Enhanced in this release of Photoshop CC

Photoshop CC now uses content-aware technology to intelligently fill in the gaps when you use the Crop tool for rotating or straightening an image, or expanding your canvas beyond the image's original size.

While using the Crop () tool, select Content-Aware in the Options bar.

For more information, see Crop and straighten photos.

Note:

Content-Aware Fill On Crop is not supported in the Classic mode of the Crop tool. To disable the Classic mode, do the following:

  1. With the Crop tool selected, click the (Set Additional Crop Options) icon in the toolbar. 
  2. In the settings menu that appears, deselect Use Classic Mode.

In action: Content-Aware Crop

Improvements to Adobe Stock integration

 Enhanced in this release of Photoshop CC

You can now open assets in Photoshop directly from the Adobe Stock website. Also, licensing watermarked previews while working in Photostop is now easier than ever before. License previews from the Layers panel, the Properties panel, or from the canvas; simply right-click the stock asset and then select License Image.

Finding the right stock asset for your project is now also a breeze. Use the new filtered search on the Adobe Stock website and within your libraries. Licensed Adobe Stock assets are badged for easy identification; video assets now have linked previews.

For more information, see:

Embed color profiles into exported assets

 Enhanced in this release of Photoshop CC

Embed color profiles into PNG or JPG files using the Export As dialog. Select File > Export > Export As or right-click a layer in the Layers panel and then select Export As.

For more information, see Export artboards, layers, and more.

Export As dialog | Embed Color Profile

On-canvas glyph alternatives

 New in this release of Photoshop CC

When you select a glyph in a Type layer, Photoshop now displays the available glyph alternatives right on the canvas. Clicking the icon in the alternatives grid opens the Glyphs panel.

If necessary, you can turn off this behavior. To do so, deselect Preferences > Type > Enable Type Layer Glyph Alternates.

For more information, see Glyphs panel.


3D printing

 Enhanced in this release of Photoshop CC

  • You can now print 3D models as 3D Manufacturing Format (3MF) files. While specifying the 3D Print Settings, select Print To: Local and Printer: 3MF File.
Print 3D objects as 3MF files


  • Ability to read Product Representation Compact (PRC) format data embedded in PDF files
  • Support for new online 3D printing services

For more information, see Print 3D objects.

More improvements to artboards

 Enhanced in this release of Photoshop CC

You can now duplicate a layer or layer group into other artboards, quickly change artboard backgrounds, and view artboards with transparent backgrounds.

If you've specified an artboard background, you can now also include it while exporting the artboard as PDF or supported image formats. While exporting the artboard as PDF, you can also include the artboard name and set custom font size, font color, canvas extension color, etc.

For more information, see Artboards.

Faster everyday tasks

 Enhanced in this release of Photoshop CC

Photoshop CC now opens documents faster and delivers great responsiveness. Content-Aware Fill is now up to 3X faster with even better results. The Font menu loads up the list of fonts up to 4X faster.


Enhancements to Creative Cloud Libraries

 Enhanced in this release of Photoshop CC

You can now share libraries with anyone who has a Creative Cloud account. While adding collaborators to a library, choose what level of permissions you want to give them. For example, you can allow others on your team to use shared assets in their designs but not modify those assets.

For more information, see these resources:

Work with Adobe Experience Design CC (Preview)

Copy and paste your Photoshop CC assets directly into Adobe XD, the new all-in-one tool for designing and prototyping user experiences for websites and mobile apps.

Try it now.


Adobe Portfolio

Use Adobe Portfolio to quickly and easily create a beautiful portfolio site to show off your Photoshop images. And now when you use Portfolio, you can create custom landing and contact pages to better connect with viewers.

Try it now...


Other enhancements

  • Up to 65% improvement in the Photoshop app download speed
  • Option to revert to the legacy Photoshop CC 2014 behavior for the Healing Brush tool. Select Preferences > Tools > Use Legacy Healing Algorithm For Healing Brush
  • For easier navigation, variants of a font—such as Bold and Italics—are now grouped under the same item in font lists. You can expand the item and select the desired variant. While navigating the fonts, you can even expand more than one item in the list.
  • Fonts are now grouped by font family. The Show Similar Fonts option now also displays fonts from Typekit.
  • Improved performance while exporting artboards to PDF; ability to include artboard names and artboard backgrounds
  • 3D imaging: Improvements to UV repacking algorithms
  • The document layer count is now displayed in the status box and the Info palette.
  • Help > System Info now shows the full file path for optional and disabled plug-ins.
  • Info panel option to always show composite (all layers) values
  • Reduced chances of metadata loss due to external metadata editing
  • Improved compatibility with some third-party Mac OS tools for resizing the application frame
  • The Oil Paint filter now works on lower-end graphics cards (GPUs)
  • Support for graphics card (GPU)-accelerated features over remote desktop connections
  • The Spot Channel dialog now includes names of colors selected from the Swatches palette.
  • Overall improvements to all content-aware features:
    • Better preservation of image details
    • Reduced blurs and smudges
    • Improved color adaptation handling for Content-Aware Fill
    • Up to 3X speed improvements for large images
  • 3D printing enhancements:
    • You can now print 3D models as 3D Manufacturing Format (3MF) files. While specifying the 3D Print Settings, select Print To: Local and Printer: 3MF File.
    • Support for new Stratasys online and local printer profiles
    • Ability to read Product Representation Compact (PRC) format data embedded in PDF files
  • Updated OpenEXR file format support includes newer variants of the format
  • Small color swatch size available again in the Swatches palette
  • Divide Slices command limits increased; performance improved
  • Improved brush performance
  • General Text layer optimizations
  • Improved detection of problematic graphics card drivers and crash prevention
  • Name or color value is now displayed in the tooltip for recently-used colors in the Swatches palette.
  • Ability to add keyboard shortcuts to toggle the brush pressure controls size and opacity
  • Ability to add keyboard shortcuts to toggle Airbrush mode

What's changed

  • For better user experience, the following gestures are now performed using three fingers instead of two fingers:
Step Back in History (Undo)

Step Forward in History (Redo)


  • The Color Adaptation setting is now enabled by default in the Fill dialog (Edit > Fill). Also, the color adaptation feature has been optimized for better results in this release.
  • 3D, 3D Printing, and some other features in Photoshop are no longer supported on 32-bit platforms. See Features unsupported on 32-bit platforms.
  • The Photoshop-Behance integration has been removed in this version. When you select File > Share On Behance, you are taken to https://www.behance.net, where you can click Add Work to post your creative work.
  • The Select and Mask workspace replaces the Refine Edge dialog in earlier versions of Photoshop, offering the same functionality in a streamlined way.

Known issues

Photoshop CC 2015.1 (November 2015 release)

Artboard improvements

 Enhanced in this release of Photoshop CC

Artboards are much easier to work with in this release of Photoshop CC.

  • Quickly add new artboards to a document by clicking the intuitive + icons alongside a selected artboard. Option/Alt+click to duplicate the selected artboard.
Photoshop add artboards to the canvas
Quickly add artboards to the canvas

  • Use guides and grids to precisely place elements within an artboard. With an artboard selected, drag guides from the ruler to the canvas. These guides now move with the artboard. When you duplicate the artboard, the associated guides are duplicated as well.
  • Filter layers in the Layers panel by artboard.
  • Align selected layers within an artboard.
  • Quickly dissolve an artboard into its constituent elements.
  • Lock the position of an artboard on the canvas.
Photoshop Lock the position of an artboard on the canvas
  • Prevent auto-nesting into or out of an artboard.
Photoshop Prevent auto-nesting into or out of an artboard
  • Specify your preferred artboard matte color and border type. Select Preferences > Interface > Appearance > Artboards.
Photoshop Artboards Appearance options

For more information, see Artboards.  

Improvements to Creative Cloud Libraries integration

 Enhanced in this release of Photoshop CC

Find content faster by searching across your libraries and across Adobe Stock. Drag and drop assets to and from the Layers panel, add your favorite brushes, and share your library with others.

For more information, see Creative Cloud Libraries in Photoshop.

Photoshop Layers panel; Create new library
Create a new library from assets contained in a document

Design Space (Preview) enhancements

 Enhanced in this release of Photoshop CC

Enhancements to Design Space (Preview) in this release further streamline and optimize design workflows with the following enhancements:

  • A unified sampling experience
  • Efficient masking
  • Robust app and cross-document search
  • Integrated layer and batch export.

Design Space (Preview) now also offers access to Creative Cloud Libraries as well as seamless movement to and from standard Photoshop CC.

For more information, see Design Space (Preview).

Oil paint filter

Reintroduced in this release of Photoshop CC

Photoshop Oil paint filter
Transform an image into a classic oil painting

The Oil Paint filter, reintroduced in this release of Photoshop CC, lets you quickly give an image the visual appearance of a classic oil painting.

Select Filter > Stylize > Oil Paint.

For more information, see Use the Oil Paint filter.

Touch workspace and gestures

 Enhanced in this release of Photoshop CC

Photoshop Touch workspace and gestures

If you own a Photoshop-supported Windows-powered device, such as the Surface Pro, you can use these convenient touch gestures while using Photoshop on it:

  • Two-finger pan
  • Two-finger pan and zoom
  • Two-finger pan and rotate
  • Five-finger cycle screen mode
  • Two-finger reset or restore view
  • Two-finger step back in history (Undo)
  • Two-finger step forward in history (Redo)
  • Three-finger history scrub
  • Two-finger free transform (Pan, zoom, and rotate)

For more information, see Touch capabilities and customizable workspaces.

Use 3D models in 2D designs

 New in this release of Photoshop CC

(Currently available only in English) Composite human characters from Adobe Fuse CC (Preview) into any Photoshop project from a layout to a final design and even print the characters with a 3D printer. Easily adjust camera angles and lighting within Photoshop CC to get just the look you want. Simply start with a model created in Adobe Fuse CC (Preview), apply poses and animations to it in the Properties panel in Photoshop CC, incorporate it into your image or design, and even add effects.

For more information, see Creative Cloud 3D Animation (Preview).

Photoshop Animate and composite 3D models from Fuse CC
Animate and composite 3D models from Fuse CC (Preview) in your Photoshop documents

Start and Recent Files workspaces

 New in this release of Photoshop CC

Note:

Start and Recent Files workspaces are currently available only in the English, French, German, and Japanese languages.

The brand new Start workspace in Photoshop gives you quick access to your recent files, libraries, and presets. Depending on your subscription status, this workspace may also display content tailored for your requirements. You can also look for the right Adobe Stock asset for your project directly from within the Start workspace.

Photoshop displays the Start workspace at launch or whenever no documents are open.

For more information, see:

Photoshop Start workspace
Brand new Start workspace

Note:

To quit the Start workspace, simply press the Esc key. If you so prefer, you can choose to disable this workspace. Select Preferences > General and then deselect Show Start Workspace When No Documents Are Open.

Recent Files workspace

The new Recent Files workspace in Photoshop displays your recent files in a pane for ready access when you're opening files. You can view the files as a list or in the thumbnail view. You can also search for Adobe Stock assets directly from within the Recent Files workspace.

Note:

The Recent Files pane is disabled by default. You can enable it by selecting Preferences > General > Show Recent Files Workspace When Opening Files.

Enhanced export experience

 Enhanced in this release of Photoshop CC

Export faster and with better compression for all file formats, especially JPEG. Additionally, while exporting assets, you can now do the following:

  • Add metadata, such as copyright, to your exported files.
  • Export assets at multiple sizes.
  • Convert exported files to the sRGB color space.
  • Select multiple assets at once while making file setting changes.

For more information, see Export layers, artboards, and more.

Photoshop Enhanced Export As dialog
Enhanced Export As dialog

Customizable toolbar

 Enhanced in this release of Photoshop CC

Customize the Photoshop toolbar by destacking, regrouping and even removing tools. You can also save and share customized toolbars as presets. Select Edit > Toolbar.

For more information, see Customize the toolbar.

Photoshop Customize Toolbar dialog
The Customize Toolbar dialog

Quickly find the right font

 Enhanced in this release of Photoshop CC

Quickly find the fonts you use often by starring individual fonts as favorites or selecting from recently used fonts. Narrow down your search by filtering fonts by classification, like serif or sans serif, or by visual similarity.  

Try: Select the Type tool and, while working with the font list, click the Show Similar Fonts icon.

For more information, see Search for fonts.

Photoshop Font options
Quickly find the fonts you need

A. Filter fonts by classification B. Show synchronized fonts from Typekit C. "Star" favorite fonts D. Show similar fonts 

Deeper integration with Adobe Stock

 Enhanced in this release of Photoshop CC

Photoshop Search and license Adobe Stock assets

You can now search for Adobe Stock assets and view the search results right within the Libraries panel. License your chosen asset straightaway from within the Libraries panel or continue to use its  watermarked preview until you're ready to license it. When you license the stock asset, all linked instances of the asset in your open documents are automatically updated to the high-resolution stock asset without the watermark. Effects that you apply to the watermarked stock asset are preserved when you license it later.

For more information, see these resources:

Modifier Keys palette

 New in this release of Photoshop CC

The new Modifier Keys palette lets you access frequently-used keyboard modifiers—Shift, Ctrl, and Alt—on Windows-powered touch devices, such as the Surface Pro.

● Select Window > Modifier Keys.


3D imaging

 Enhanced in this release of Photoshop CC

New Depth Map options

Photoshop now provides two additional Depth Map options—Solid Extrusion and Double-Sided Solid Extrusion.

  • 3D > New Mesh From Layer > Mesh Preset > Solid Extrusion
  • 3D > New Mesh From Layer > Mesh Preset > Two Sided Solid Extrusion

Render still 3D objects

You can now render still 3D objects using the Render Video dialog (3D > Render Document To File).

Import and export SVG files

 Enhanced in this release of Photoshop CC

Open and place native SVG files—which can rescale for any size device or any resolution—in your Photoshop designs. Just double-click the object to edit it in Adobe Illustrator. Also export SVG image assets using the new export experience.

Camera Raw | New features

 Enhanced in this release of Photoshop CC

Camera Raw New features

For a summary of the latest features in Camera Raw, see Adobe Camera Raw | New features summary.

Other enhancements

  • The Glyphs panel now displays the most-recently-used glyphs. See Most-recently-used glyphs.
  • Updated and refined Welcome experience
  • Ability to resize the Export As dialog
  • Improved PNG interface in the Export As dialog for exporting to PNG-32 or PNG-8
  • Option to skip transform when placing a Libraries object
  • New option to save to Libraries while pasting a Smart Object from Adobe Illustrator
  • Better default shape stroke value (1 px instead of 3 pt)
  • New 16 pt preset value for Font Size
  • Hyphenation now defaults to Off.
  • Several new Designer Favorites in the Glyphs panel
  • While moving a layer to a layer group or artboard, you can now choose to move it to bottom of the Z-order instead of top. Hold down the Shift key while moving the layer.
  • You'll no longer encounter the No Layers Selected error while clicking with the Move tool outside the canvas.
  • Device Preview: Option to check for devices connected to the computer. See Device Preview.
  • Support for exporting as sRGB
  • Options to better control Healing tool results. For more information, see Healing brush examples.
  • Locked Layers are now not auto-nested.
  • Improved baseline alignment of several dialogs and widgets
  • Improvements to Copy/Paste/Drag functionality between documents, the clipboard, and Creative Cloud Libraries
  • Artboard and marquee snapping improvements
  • New artboard preference for matte Color and Border Type
  • The Align command now works with a single selected layer within an artboard.
  • Persistent file type and quality settings between Exports
  • Set type layer position on canvas (X/Y) in the Properties panel
  • Artboard custom presets are now displayed in the Artboard tool bar/property presets menu.
  • Updated video presets with Digital Cinema Initiatives (DCI) 4K and 8K; HDTV has moved up the list

What's changed

  • Sync Settings has been removed in Photoshop CC 2015.1. The existing service in Photoshop CC and CC 2014 will become unavailable in the near future. To migrate your presets/settings from an earlier version of Photoshop CC to this release, see Migrate settings.
  • PNG format changes for asset export. The Format pop up menu now includes a simplified PNG option.
    • Selecting Transparency with PNG generates 32-bit PNG assets.
    • Selecting Smaller File generates 8-bit PNG assets.
    • Leaving the above options deselected generates 24-bit PNG assets.
  • The 3D Render Quality slider setting has now been moved to the Render Video dialog. It was earlier part of the 3D Preferences dialog.

Photoshop CC 2015 (June 2015 release)

Artboards

 New in this release of Photoshop CC

Photoshop Artboards
Artboards for different devices on the same canvas

If you are a web or UX designer, you increasingly find yourself designing websites or apps for multiple devices. Artboards, new in the 2015 release of Photoshop CC, help streamline your design process by giving you an infinite canvas on which you can lay out designs for different devices and screens. While creating artboards, you can choose from a wide variety of preset sizes or define your own custom artboard size.

Artboards are useful even if you normally design for just one screen size. For example, while designing a website, you can use artboards to view designs for different pages side-by-side and in context.

For more information, see Artboards.

Creative Cloud Libraries

 Enhanced in this release of Photoshop CC

Creative Cloud Libraries integration in Photoshop is now enhanced:

Library-linked assets

When you use a graphic from the Libraries panel, a library-linked asset is created. This asset behaves in much the same way as a locally linked smart object, but with the benefit of the asset being in the cloud. Also, when you create a new library graphic from a smart object, the corresponding layer is converted to a library-linked asset.

Adobe Stock integration with Libraries

You can now add a watermarked stock image to any of your libraries directly by using the Adobe Stock website. You can then use the watermarked image in your Photoshop documents as a library-linked asset. When you choose to license the image—which you can do directly from within the Libraries panel—all instances of the watermarked asset in your open documents are updated to the high-resolution licensed image.

Performance improvements

Libraries integration in Photoshop now offers reduced disk usage, more efficient bandwidth utilization, and faster propagation of library changes between Creative Cloud applications.

For more information, see Creative Cloud Libraries in Photoshop.

Adobe Stock

 New in this release of Photoshop CC

Adobe Stock

Adobe Stock is a new service that provides designers and businesses with access to 45 million high-quality, curated, royalty-free images, illustrations, and vector graphics for all their creative projects. You can search for Adobe Stock content directly from within Photoshop. Select File > Search Adobe Stock.

Adobe Stock is also deeply integrated with Creative Cloud Libraries. You can now add a watermarked stock image to any of your libraries directly by using the Adobe Stock website. You can then use the watermarked image in your Photoshop documents as a library-linked asset. When you choose to license the image—which you can do directly from within the Libraries panel—all instances of the watermarked asset in your open documents are updated to the high-resolution licensed image.

For more information, see:

Design Space (Preview)

 New in this release of Photoshop CC

Important: Design Space (Preview) requires Mac OS X 10.10 or Windows 8.1 64-bit OS or later and is currently displayed only in English.

Design Space (Preview) is aimed at becoming a modern design experience inside Photoshop streamlined for the requirements of web, UX, and mobile app designers. It's an HTML5/CSS/JS layer built on top of Photoshop. We’ve separated out standard Photoshop from the interface so that we can use this layer to create new UI, smarter interactions, and top-requested features. This release is a Technology Preview, which means it's an early look at this new direction. It's rough and the feature set is limited, but we wanted to get this out early so we can start hearing from you.

To enable Design Space (Preview), select Preferences > Technology Previews, and then choose Enable Design Space (Preview)

Help us shape Design Space (Preview) into the experience you want. Give us feedback @psdesign.

For more information and a list of known issues in this release, see Design Space (Preview).

Photoshop Design Space
Design Space

A. Tools B. Distribute and Align C. Transform D. Style E. Layers 

Export artboards, layers, and more

 New in this release of Photoshop CC

You can now export artboards, layers, layer groups, and Photoshop documents as JPEG, GIF, PNG, PNG-8, or SVG image assets. 

Select the artboards, layers, and layer groups in the Layers panel. Right-click the selection, and then select one of the following from the context menu:

  • Quick Export As [image_format]
  • Export As...

To export the current Photoshop document or all artboards in it, select File > Export As [image_format] or File > Export > Export As...

For more information, see Export artboards, layers, and more.

Photoshop Quick Export
The Export As dialog

Layer styles

 Enhanced in this release of Photoshop CC

The Layer Style dialog now lets you apply multiple effects—strokes, inner shadows, color overlays, gradient overlays, drop shadows, and so forth—to a single layer style. Also, more than one instance of some effects can now be applied to a layer style.

Follow these steps:

  1. Select Layer > Layer Style, and then select an option.
  2. Select the effects you want to add to the layer style. Effects with a icon can be applied more than once in the layer style.
  3. Adjust the settings for the effects. For example, adjust the size and opacity of a stroke.
  4. Click OK to apply the effects to the layer style.

UI changes to the Layer Style dialog

You can now use the left pane of the Layer Style dialog to perform the following operations:

  • Change the effect stacking order
  • Delete effects
  • Through a new flyout menu, accessible by clicking the  icon: 
    • Manage which effects appear in the section
    • Delete hidden effects
    • Reset any changes you’ve made to the default state of the left pane

Device Preview and the Preview CC companion app

 New in this release of Photoshop CC

Photoshop Device Preview
Device Preview

Get real-time previews of your Photoshop designs on multiple iOS devices with the new Device Preview feature in Photoshop and the Adobe Preview CC mobile app. Changes you make in Photoshop CC are displayed in Preview CC in real time. You can reliably connect multiple iOS devices to Photoshop using USB or over Wi-Fi.

If you have a document with artboards, Device Preview attempts to show you the correct artboard by matching the size and position of the artboard with the size of the connected device. You can also use the navigation bar to preview a specific artboard on the device or swipe through artboards that have matching widths.

Preview CC supports iOS devices running iOS 8 or later.

For more information, see:

 New in this release of Photoshop CC

Photoshop Blur Gallery
Restore grain/noise to make blurred areas look more realistic

Sometimes after you apply a Blur Gallery effect, the blurred area of the image looks synthetic or unnatural. You can now restore noise/grain to a blurred image area to give it a more realistic appearance.

Set the options in the blur Effects panel on the Noise tab.

For more information, see Restore noise in blurred areas.

Glyphs panel

 New in this release of Photoshop CC

Photoshop now has a new panel that lets you work more efficiently with glyphs.

To access the Glyphs panel, do one of the following:

  • Select Type > Panels > Glyphs panel.
  • Select Window > Glyphs.
For more information, see Glyphs panel.
Photoshop Glyphs panel
The new Glyphs panel

Content-aware move with tranform

 Enhanced in this release of Photoshop CC

The Content-Aware Move tool now incorporates a Transform On Drop option. This new option allows for the transformation—scaling, rotating, and flipping—of the foreground object before it is blended into the new location. This option is particularly useful when moving/replicating an object to a different depth and when rescaling is required.

Selecting the Transform On Drop option enables the familiar Transform tool menu that allows you to scale and rotate the object after it is moved to the new location.

  • To apply the transformation from the opposite corners, rather than just one side, hold the Option (Mac) or Alt (Windows) key while performing the transform operation.
  • Right-clicking the Transform tool area presents a context menu offering the ability to flip horizontally and vertically.

Once you've made the necessary changes, commit the changes. The content-aware move tool now begins to blend the object with its surroundings and fills in the old location.

Note:

If the Transform On Drop option is not enabled, the Content-Aware Move tool behaves as in earlier releases of Photoshop. The blending process in this case begins right after the mouse click is released.

Camera Raw | New features

For a summary of the latest features in Camera Raw, see Adobe Camera Raw | New features summary.

3D printing

 Enhanced in this release of Photoshop CC

Export as PDF or SVX files

You can now export 3D models as PDF or SVX files.

While specifying the 3D print settings, select Print To: Local. Then, select PDF File or SVX File as the printer.

For more information about 3D printing, see Print 3D objects.

Photoshop 3D printing
Export 3D models as PDF or SVX files

Control bump map depth

You can now control the depth or height of bump maps for printing. Follow these steps:
  1. Open a 3D file containing a bump map.

Photoshop control bump map
A sphere with a bump map

  1. In the 3D panel, choose Scene. Then, select the 3D Print Settings tab in the Properties panel.
Photoshop 3D print settings
3D print settings

  1. Under Surface Detail, specify appropriate values for the Min and Max fields. These values determine the new depth of the bump maps.
Photoshop surface detail
New depth for the bump map

Updated PLA profile for MakerBot

The MakerBot PLA profile has been updated for more reliable printouts.

Simplify meshes in preparation for printing

3D imaging

 Enhanced in this release of Photoshop CC

Simplify meshes

The 3D menu now has a new command (3D > Simplify Meshes) that lets you reduce the number of triangles in a mesh to a more manageable number. The command algorithmically reduces the number of triangles to the number you specify while attempting to maintain the fidelity of the model. This enhancement is useful for reducing the complexity of a file in preparation for 3D printing.

You can view a live preview of mesh simplification changes before they're implemented.

Photoshop Settings in the Simplify 3D Mesh dialog
Settings in the Simplify 3D Mesh dialog

Photoshop Preview of mesh simplification changes
Preview of mesh simplification changes

Improved export UI

The UI for exporting 3D layers as Collada DAE, Flash 3D, Google Earth KMZ, 3D PDF, STL, U3D, VRML, and OBJ formats is now improved.

Select 3D > Export 3D Layer.

Photoshop export 3D layer
The Export Properties dialog

Export a single mesh

A 3D scene typically comprises many elements or meshes. You can now right-click a mesh in the overall scene and export it individually.

Right-click the mesh in the 3D panel and choose Export Mesh from the context menu. This functionality currently exports meshes only in Collada or KMZ formats.

Generate better bump maps and normal maps

Photoshop now lets you tweak your bump or normal maps using tools such as Blur, Detail Scale, and High/Medium/Low Frequency.

Select Filter > 3D > Generate Bump Map or Filter > 3D > Generate Normal Map.

Photoshop Generate Bump Map
Generate better bump maps

Photoshop Generate Normal Map
Generate better normal maps

Create bump maps or normal maps from diffuse textures

You can now create bump maps or normal maps from diffuse textures. The texture attached to the diffuse texture is automatically loaded as filters for the purpose of creating bump maps or normal maps. Once you're satisfied with the way your map is looking, Photoshop applies the generated bump map or normal map to those textures.

Follow these broad steps:

  1. Open the file containing the diffuse map.
  2. Ensure that the desired texture is selected in the 3D panel.

Photoshop texture in the 3D panel
The desired texture is selected in the 3D panel

  1. Click the folder icon next to Bump or Normal in the Properties panel. Then, from the context menu, select Generate Bumps From Diffuse or Generate Normals From Diffuse.
Photoshop Generate bumps/normals from diffuse
Generate bumps/normals from diffuse

  1. Specify appropriate settings in the Generate Bump Map or Generate Normal Map dialog.
  2. Click OK to generate the map.

Convert a vertex color to a texture color

3D-scanned PLY files typically have vertex colors and no textures. You can convert a vertex color to a texture color. Do the following:

  1. Open the PLY file.
  2. In the Layers panel, under Textures in a 3D layer, double-click the diffuse to open the texture.
  3. Select 3D > Create Painting Overlay > Vertex Colors.

UI toolkit for plug-ins and scripts

 Enhanced in this release of Photoshop CC

The UI toolkit for building Photoshop plug-ins and scripts has been enhanced to support HiDPI/Retina displays. Also, plug-ins built using the toolkit now look more consistent with the overall Photoshop UI.

For more information, see Photoshop UI toolkit for plug-ins and scripts.

Other enhancements

  • In earlier releases of Photoshop, while painting with the Healing Brush, you'd see a semi-transparent gray area and a progress bar before the healed content became visible. In the 2015 release of Photoshop CC, Healing Brush changes render in real time as you paint.
  • The Content-Aware Move tool now has a Transform On Drop option. When this option is enabled, you can scale the part of the image that you've just moved to its new location.
  • Preference panels are organized better.
  • Photoshop now uses 80% less energy when idling.
  • The Welcome screen loads faster.
  • There's a new command to release all RAM and scratch disk use. Hold down the Option/Alt key and select About Photoshop. Or, select Edit > Purge > All.
  • The Photomerge dialog now has a Content Aware Fill Transparent Areas option. Use this option to give your panoramas that picture-perfect finish.
  • Most adjustments (Image > Adjustments) can now be applied as smart filters. Convert the layer to a smart object and then apply an adjustment to it. 
  • Syncing performance for Creative Cloud Libraries has improved.
  • Moving a layer to a group now moves it to the top of the Z-order instead of the bottom.
  • Step backward/forward operations no longer change the layer selection.
  • A new preference lets you revert Esc behavior while entering text.

What's changed

  • Experimental features are now called technology previews. For more information, see Technology previews
  • Scale the UI 200 percent for high-density displays is no longer a technology preview feature. It is now part of standard Photoshop functionality. To enable this feature, select Preferences > Interface > UI Scaling: 200.
  • The File > Save For Web option is now File > Export > Save For Web (Legacy). For more information, see Save For Web in Photoshop CC 2015.
  • The following options have moved to the File > Export submenu:
    • Export Layers To Files
    • Export Layer Comps To PDF
    • Export Layer Comps To Files
  • Extract assets functionality has been replaced with more intuitive options to export artboards, layers, layer groups, and documents as image assets. See Export artboards, layers, and more for information about these newer export options.
  • The Digimarc plug-in is no longer installed by default. You can, optionally, install it directly from http://www.digimarc.com/products/guardian/images/photoshop-plug-in.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy