Nie można przesłać pliku CSV

Błąd: Obcięcie danych — dane zbyt długie dla kolumny

Podczas próby przesłania pliku CSV do usługi Adobe Captivate Prime jest wyświetlany następujący komunikat o błędzie.

Przyczyna

Błąd występuje, gdy dane w określonej kolumnie mają więcej znaków niż limit zdefiniowany dla tej kolumny.

Rozwiązanie

  • Otwórz plik CSV.
  • Sprawdź dane w kolumnie z błędem.
  • Jeśli którakolwiek wartość jest duża (na przykład ma ponad 60 znaków), zmień ją na prawidłową.

Błąd: Pierwsza kolumna w pliku CSV powoduje wyświetlenie znaku specjalnego

Nie można przesłać pliku CSV, ponieważ pierwsza kolumna powoduje wyświetlenie znaku specjalnego podczas mapowania kolumn.

Przyczyna

Ten problem występuje w przypadku zapisania pliku CSV w formacie UTF-8 w programie Excel. W trakcie takiej operacji plik jest zapisywany w formacie UTF-BOM. Możesz to sprawdzić za pomocą programu Notepad++ lub podczas przesyłania pliku CSV do usługi Prime — podczas mapowania kolumn pierwsza z nich będzie zawierać znak specjalny.

Rozwiązanie

  • A. Zapisywanie w programie Excel:
    1. Otwórz plik CSV w programie Excel.
    2. Zapisz plik w normalnym formacie CSV.
  • B. Zapisywanie w programie Notepad lub Notepad ++:
    • Otwórz plik CSV w programie Notepad lub Notepad++.
    • Zapisz plik w formacie UTF-8.

Błąd: Adres e-mail użytkownika już istnieje w systemie

Nie można przesłać pliku CSV, ponieważ nie powiodło się jego przetworzenie. Jest wyświetlany poniższy komunikat o błędzie:

Przyczyna

Ten problem występuje, gdy w systemie istnieje już użytkownik o tym samym adresie e-mail lub identyfikatorze UUID.

Rozwiązanie

Scenariusz 1

Konta bez identyfikatorów UUID

W tym scenariuszu błąd może mieć dwie przyczyny:

  1. Próbujesz dodać użytkownika, który jest przełożonym profilu zewnętrznego. Aby rozwiązać ten problem, otwórz profil zewnętrzny, do którego należy ten użytkownik, zaznacz użytkownika, wybierz opcję Działania > Przypisz rolę > Przełożony i zmień przełożonego profilu.
  2. Próbujesz dodać użytkownika, którego konto zostało wyczyszczone.W tym scenariuszu nie można dodać użytkownika o tym samym adresie e-mail do momentu zakończenia procesu czyszczenia. Aby obejść ten problem, dodaj użytkownika przy użyciu pomocniczego adresu e-mail, aby umożliwić mu korzystanie z platformy. Po zakończeniu procesu czyszczenia zmień dane użytkownika — ustaw prawidłowy adres e-mail.

Scenariusz 2

Konta z identyfikatorami UUID

Gdy konto ma identyfikator UUID, ten problem może wystąpić, jeśli użytkownikowi przypisano identyfikator UUID używany już przez innego użytkownika na danym koncie lub użytkownik ma inny adres e-mail.

Załóżmy na przykład, że istnieje dwóch użytkowników A i B, którzy mają adresy e-mail a@xyz.com i b@xyz.com oraz odpowiednio identyfikatory UUID 1 i 2.

Jeśli zostanie przesłany plik CSV, w którym identyfikator UUID użytkownika A to 3, a użytkownika B — 2, wystąpi błąd.

Aby rozwiązać ten problem, należy ustawić tę samą parę adresu e-mail i identyfikatora UUID zarówno w pliku CSV, jak i w systemie.

Pomoc dostępna szybciej i łatwiej

Nowy użytkownik?