Dreamweaver 8 para Windows perde as configurações de login FTP

Última atualização em 27/04/2021

Problema

Alguns usuários do Windows relatam que os nomes de usuário e senhas FTP nas definições de site do Dreamweaver são apagados ao fecharem e reabrirem o Dreamweaver 8 ou ao reinicializarem o computador.Este problema não ocorre em versões anteriores do Dreamweaver. (Ref. 205051, 210466)

Motivo

Há duas causas conhecidas para este problema:

  • A causa mais comum é o Internet Explorer 7 (IE 7) estar instalado no mesmo computador que o Dreamweaver 8.

  • Uma causa menos provável é a seguinte chave de registro estar ausente ou vazia:



    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell Folders\AppData

Solução

Se você tem o Internet Explorer 7 instalado

Se você tem o Internet Explorer 7 instalado, instalar oDreamweaver 8.0.2 Updater deve resolver este problema. Antes de instalar o Dreamweaver 8.0.2 Updater, recomenda-se verificar a TechNote de problemas emergentes do Dreamweaver 8 para alterações que podem afetar seu fluxo de trabalho, principalmente se você criar páginas do lado do servidor (ASP, PHP, ColdFusion, etc.)ou inserir conteúdo Flash.

Observação: Após instalar o Dreamweaver 8.0.2 Updater, verifique se o atualizador foi instalado com sucesso. Alguns usuários acham que instalaram o 8.0.2, quando na verdade a instalação do atualizador não funcionou. No Dreamweaver, vá em Ajuda > Sobre o Dreamweaver > e clique no texto em movimento para revelar o número da versão. Deve aparecer Dreamweaver 8.0.2. Se ainda aparecer Dreamweaver 8.0 ou 8.0.1, consulte Não é possível instalar atualizadores do Dreamweaver 8 para Windows após cancelar o instalador do atualizador (TechNote 785362aa).

Observação: O Internet Explorer 7 foi lançado após o Dreamweaver 8 e, portanto, não foi testado com o Dreamweaver 8 e versões anteriores.

Se você não tiver o Internet Explorer 7 instalado ou se o Dreamweaver 8.0.2 Updater não resolver o problema

Se você não tinha o Internet Explorer 7 quando este problema ocorreu, instale o Dreamweaver 8.0.2 Updater conforme descrito acima e execute as seguintes etapas se você se sentir confortável editando o Registro do Windows.

Aviso: Editar o Registro do Windows incorretamente pode causar problemas sérios que podem exigir a reinstalação do sistema operacional. A Adobe não garante que os problemas causados pela edição incorreta do registro possam ser resolvidas. Edite o registro por sua conta e risco.

Inicie o Editor de Registro clicando no botão Iniciar, escolha Executar e digite "regedit". No Editor de Registro, navegue até esta pasta:



HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\User Shell Folders\
Veja se há uma chave chamada AppData, conforme mostrado na captura de tela abaixo:



Verificar se há uma chave AppData

Fazer backup da ramificação do registro Users Shell Folders da seguinte forma:
Clique com o botão direito na pasta Users Shell Folders e selecione "Exportar".
Na seção "Intervalo de exportação", escolha "Ramificação selecionada".
Salve o arquivo .reg no desktop.
Se ocorrerem problemas após editar o registro, clique duas vezes no arquivo .reg para reinstalar essa ramificação do registro.
Se a chave AppData estiver ausente, execute as seguintes etapas.Se a chave AppData existir, pule para a Etapa 5.
No lado direito do painel do explorador do Editor de Registro, clique com o botão direito em uma área em branco em qualquer lugar abaixo da última chave na lista.Você deve ver um menu de contexto que diz "Novo" com um menu suspenso.
No menu suspenso, selecione "Valor de string expansível" e nomeie a nova chave AppData.
Clique com o botão direito na nova chave AppData (ou na existente se já estiver lá), selecione Modificar e insira o seguinte no campo Dados do Valor: %USERPROFILE%\Application Data.Se os valores das outras chaves no diretório User Shell Folders não começarem com %USERPROFILE%, use o valor que suas outras chaves usam.Por exemplo, se sua chave Local Settings tiver um valor de u:\Local Settings, tente usar u:\Application Data.
Abra o Dreamweaver, insira novamente as informações de login do FTP para um dos seus locais e verifique se o login do FTP agora é salvo quando você fecha e reabre o Dreamweaver.

Se as soluções acima não resolverem o problema, entre em contato com o Suporte Técnico da Adobe ou envie um relatório de erro e especifique que você está enfrentando o problema descrito na TechNote 3491671c.