Erro: "Não é possível iniciar o sistema de ajuda" ao tentar abrir a Ajuda | Dreamweaver CS4 | Windows

Última atualização em 27/04/2021

Problema

Ao tentar abrir a Ajuda no Adobe Dreamweaver CS4 no Windows, o aplicativo retorna o erro "Não é possível iniciar o sistema de ajuda porque a pasta de ajuda está ausente.Instale a pasta de ajuda ou reinstale o Dreamweaver.

Motivo

As entradas do registro do Windows que armazenam configurações para o Protocolo de Transferência de Hipertexto (HTTP) estão ausentes ou danificadas.

Solução

Faça login no computador como administrador.Em seguida, execute uma ou ambas as soluções a seguir.

Solução 1: Defina seu navegador web preferido como padrão do sistema.

Para definir um navegador web padrão do sistema no Windows 7/Vista:

Feche todos os aplicativos.
Escolha Iniciar > Painel de controle.
Execute uma das seguintes opções:
  • Se o Painel de Controle estiver na exibição Página Inicial do Painel de Controle ou Categoria, clique em Programas.Na próxima tela, clique em Programas padrão.
  • Se o Painel de controle estiver na exibição clássica, clique duas vezes em Programas padrão.
Selecione Definir acesso ao programa e padrões do computador.
Na lista Escolher uma configuração, clique em Personalizado.
Em Escolher um navegador web padrão, selecione Internet Explorer, Firefox, Google Chrome ou Opera.
Clique em OK.

Para definir um navegador de web padrão do sistema no Windows XP:

Feche todos os aplicativos.
Selecione Iniciar > Painel de controle (ou Iniciar > Configurações > Painel de controle).
Clique duas vezes em Adicionar ou remover programas.
No painel esquerdo de Adicionar ou remover programas, selecione Definir acesso ao programa e padrões.
Na lista Escolher uma configuração, clique em Personalizado.
Em Escolher um navegador web padrão, selecione Internet Explorer, Firefox, Google Chrome, Opera ou Safari.
Clique em OK.

Solução 2: recriar a chave HTTP no registro do Windows.

Aviso: as etapas desta solução exigem que você modifique o registro do Windows.O registro contém informações relacionadas ao sistema que são cruciais para o computador e os aplicativos. Antes de modificar o registro, sempre faça o backup do mesmo. A Adobe não oferece suporte para problemas que possam resultar de uma modificação inadequada do registro. Para obter informações sobre o registro do Windows, consulte a documentação no Windows ou entre em contato com o Suporte Técnico Microsoft ou com o fabricante do computador.

Feche todos os aplicativos.
Siga um destes procedimentos:
  • Windows 7/Vista: Escolha Iniciar > Todos os programas > Acessórios.Em seguida, clique com o botão direito do mouse no Prompt de Comando e escolha Executar como administrador.
  • Windows XP: Escolha Iniciar > Todos os Programas > Acessórios > Prompt de Comando.
Na janela do prompt, digite o seguinte comando exatamente como aparece e pressione Enter:



reg export HKCR\http "%userprofile%\AdobeHelpBackup.reg"

Observação: O prompt pode exibir o erro "O sistema não conseguiu localizar a chave ou valor de registro especificados". Esta é uma mensagem esperada se a chave HTTP estiver ausente do registro do Windows. Se este erro aparecer, vá para a etapa 6; caso contrário, prossiga para a etapa 5.

 
Digite o seguinte comando exatamente como aparece e pressione Enter:



reg delete HKCR\http /f
Digite um dos seguintes comandos exatamente como aparece e pressione Enter (digite o comando que corresponde ao navegador no qual você gostaria de visualizar a Ajuda do Dreamweaver CS4):



Observação: Se você escolher um navegador diferente do Internet Explorer, esse navegador deverá estar instalado antes de você digitar o comando.



  • Internet Explorer

    reg add HKCR\http\shell\open\command /ve /f /d "\"%programfiles%\Internet Explorer\iexplore.exe\" "\"%1\""
  • Firefox

    reg copy HKCR\FirefoxURL\shell HKCR\http\shell /s /f
  • Opera

    reg copy HKCR\Opera.HTML\shell HKCR\http\shell /s /f
  • Safari

    reg copy HKCR\SafariURL\shell HKCR\http\shell /s /f
  • Google Chrome

    reg copy HKCR\ChromeHTML\shell HKCR\http\shell /s /f
Feche a janela do Interpretador de comandos.