Совместное использование ресурсов библиотеки во время выполнения

О ресурсах общей библиотеки времени выполнения

Ресурсы общей библиотеки позволяют использовать ресурсы из одного FLA-файла в другом FLA-файле. Это может быть полезно в следующих ситуациях.

  • Если несколько FLA-файлов должны использовать одни объекты или другие ресурсы.

  • Если разработчикам необходима возможность редактирования объектов и кода ActionScript в отдельных FLA-файлах для совместных проектов.

Совместное использование ресурсов библиотеки работает следующим образом.

  • Во время выполнения целевой документ ссылается на общие ресурсы исходного документа как на внешние файлы. Они загружаются в целевой документ в процессе его воспроизведения, то есть на стадии выполнения. При разработке целевого документа исходный документ, содержащий общий ресурс, необязательно должен быть доступен по локальной сети. Исходный документ должен быть опубликован по определенному URL-адресу, что обеспечит для целевого документа доступность общих ресурсов во время выполнения.

Работа с общими ресурсами во время выполнения

Использование общих ресурсов библиотеки во время выполнения включает две процедуры. Во-первых, автор исходного документа определяет общий ресурс в исходном документе и вводит строку идентификатора ресурса и URL-адрес (только HTTP или HTTPS), по которому будет опубликован исходный документ.

Во-вторых, автор целевого документа определяет общий ресурс в целевом документе и вводит строку идентификатора и URL-адрес, идентичные использованным для общего ресурса в исходном документе. Или же автор целевого документа может перетащить общие ресурсы из опубликованного исходного документа в библиотеку своего документа. Версия ActionScript, заданная в параметрах публикации, должна соответствовать версии в исходном документе.

В любом случае, чтобы общие ресурсы были доступны целевому документу, исходный документ должен быть опубликован по указанному URL-адресу.

Определение общих ресурсов во время выполнения в исходном документе

Для определения параметров разделения ресурса в исходном документе и обеспечения специальных возможностей для целевых документов предназначено диалоговое окно «Свойства символа» или «Свойства связывания».

  1. Откройте исходный документ и выберите меню «Окно» > «Библиотека».
  2. Выполните одно из следующих действий.
    • Выделите фрагмент ролика, кнопку или графический символ на панели «Библиотека», а затем выберите из меню панели «Библиотека» пункт «Свойства». Нажмите кнопку «Дополнительно».

    • Выделите символ шрифта, звука или растрового изображения, а затем выберите из меню панели «Библиотека» пункт «Связывание».

  3. Чтобы выполнить связывание, выберите режим «Экспортировать для совместного использования во время выполнения», который позволяет обеспечить доступность ресурса при связывании с целевым документом.
  4. Введите идентификатор символа. Не включайте в него пробелы. По этому имени Animate идентифицирует ресурс при связывании с целевым документом.

    Примечание.

    Идентификатор связывания также нужен Animate для того, чтобы идентифицировать фрагмент ролика или кнопку, которые используются как объект в сценарии ActionScript. 

  5. Введите URL-адрес, по которому будет опубликован SWF-файл, содержащий общий ресурс, и нажмите кнопку «ОК».

    При этом публикация SWF-файла должна производиться по указанному URL-адресу, чтобы общие ресурсы были доступны в целевых документах.

Чтобы установить связь с общим ресурсом, нужно ввести его URL или перетащить ресурс в документ назначения.

  1. В целевом документе выберите меню «Окно» > «Библиотека».
  2. Выполните одно из следующих действий.
    • На панели «Библиотека» выделите фрагмент ролика, кнопку, графический символ, растровое изображение или звук, а затем выберите из меню панели «Библиотека» пункт «Свойства». Нажмите кнопку «Дополнительно».

    • Выделите символ шрифта, звука или растрового изображения, а затем выберите в меню панели «Библиотека» пункт «Связывание».

  3. Чтобы выполнить связывание, выберите режим «Импортировать для совместного использования во время выполнения», который обеспечивает связывание с ресурсом в исходном документе.
  4. Введите идентификатор символа, растрового изображения или звука, соответствующий идентификатору символа в исходном документе. Не включайте в него пробелы.
  5. Введите URL-адрес, по которому опубликован исходный SWF-файл, содержащий общий ресурс, а затем нажмите кнопку «ОК».
  1. В целевом документе выполните одно из следующих действий.
    • Выберите меню «Файл» > «Открыть».

    • Выберите меню «Файл» > «Импорт» > «Открыть внешнюю библиотеку».

  2. Выделите исходный документ и нажмите кнопку «Открыть».
  3. Перетащите общий ресурс из панели «Библиотека» исходного документа на панель «Библиотека» или в рабочую область целевого документа.

Отключение разделения символа в целевом документе

  1. Выделите связанный символ на панели «Библиотека» целевого документа и выполните одно из следующих действий.
    • Если ресурс является фрагментом ролика, кнопкой или графическим символом, то выберите из меню панели «Библиотека» пункт «Свойства».

    • Если ресурс является символом шрифта, то выберите из меню панели «Библиотека» пункт «Связывание».

  2. Сбросьте параметр «Импортировать для совместного использования во время выполнения» и нажмите кнопку «ОК».

Совместное использование ресурсов библиотеки во время разработки

Совместное использование ресурсов во время дает следующие преимущества.

  • Это позволяет избежать избыточных копий ресурсов, используемых в нескольких FLA-файлов. Например, если создается один FLA-файл для веб-браузера, другой — для iOS, а третий — для Android, все три файла могут совместно использовать ресурсы.

  • При редактировании общего ресурса в одном FLA-файле изменения отражаются в других использующих его FLA-файлах, когда они открываются или попадают в фокус.

Существует два способа совместного использования ресурсов библиотеки во время разработки:

  • Использование символов из внешних FLA-файлов путем их связывания с символами в другом FLA-файле.

  • Совместное использование символов в FLA-файлах, которые входят в состав одного проекта Animate на панели «Проект». Сведения об использовании панели «Проект» см. в разделе Работа с проектами Animate.

Совместное использование путем создания ссылки на символы в отдельных FLA-файлах обеспечивается следующим образом.

  • В общих ресурсах, разделяемых на этапе разработки, любой символ в FLA-файле обновляется или заменяется любым другим символом в любом другом FLA-файл, доступном по локальной сети.

  • Обновление символа в целевом документе производится по мере разработки документа.

  • Символ в целевом документе сохраняет первоначальное имя и свойства, но его содержимое обновляется и заменяется содержимым выбранного символа.

Совместное использование символов с помощью панели «Проект» обеспечивается следующим образом:

  • Необходимо сначала создать проект на панели «Проект», а затем FLA-файл в этом проекте.

  • В этом FLA-файле нужно указать, какие символы требуется использовать совместно с другими файлами, путем установки флажка для каждого элемента на панели «Библиотека».

  • Теперь создайте второй FLA-файл в проекте.

  • Скопируйте и вставьте слои, кадры или элементы рабочей области из первого FLA-файла во второй.

  • Animate перемещает общие элементы библиотеки во вставленных элементах в отдельный файл с именем AuthortimeSharedAssets.FLA в папке проекта.

В рамках проекта можно совместно использовать следующие типы ресурсов.

Тип ресурса

Доступен для совместного использования самостоятельно?

Доступен для совместного использования в фрагменте ролика?

Символ фрагмента ролика

Да

Да

Графический символ

Да

Да

Символ кнопки

Да

Да

Символ шрифта

Нет

Да

FLV-видео

Нет

Да

Встроенное видео

Нет

Да

Звук (в любом формате)

Нет

Да

Растровое изображение (в любом формате)

Нет

Да

Скомпилированный фрагмент (SWC)

Нет

Да

Компонент (на основе символа)

Да

Да

Обновление и замена совместно используемых символов

Фрагмент ролика, кнопку или графический символ в документе можно обновить или заменить любым другим символом в FLA-файле, доступном по локальной сети. Первоначальное имя и свойства символа в целевом документе сохраняются, но содержимое символа заменяется содержимым другого, выбранного пользователем, символа. Все ресурсы, используемые выбранным символом, также копируются в целевой документ.

  1. Открыв документ, выделите фрагмент ролика, кнопку или графический символ на панели «Библиотека», а затем выберите «Свойства» из меню «Параметры».
  2. Если области «Связывание» и «Источник» в диалоговом окне «Свойства символа» не видны, нажмите кнопку «Дополнительно».
  3. Чтобы выбрать новый FLA-файл, нажмите кнопку «Обзор».
  4. Перейдите к FLA-файлу, который содержит символ для обновления или замены выбранного символа на панели «Библиотека», а затем нажмите кнопку «Открыть».
  5. Перейдите к символу и нажмите кнопку «ОК».
  6. Выполните одно из следующих действий.
    • Для параметра «Источник» в диалоговом окне «Свойства символа» выберите значение «Всегда обновлять перед публикацией» и нажмите кнопку «ОК».

    • Для параметра «Общий доступ во время создания» в диалоговом окне «Свойства символа» выберите значение «Обновлять автоматически» и нажмите кнопку «ОК».

Определение ресурсов для совместного использования в проекте

При совместном использовании ресурсов FLA-файлами в проекте можно редактировать ресурс в одном файле, так что изменения отображаются в остальных FLA-файлах, использующих этот ресурс.

  1. Создайте проект Animate. 

  2. Для всех ресурсов библиотеки FLA-файла в проекте, которые предназначены для совместного использования с другими FLA-файлами в проекте, выполните одно из следующих действий.

    • Откройте панель «Библиотека» и установите флажок «Связать» рядом с именем ресурса.

    • Выделив актив на панели «Библиотека», выберите пункт «Свойства» из меню «Параметры» и нажмите кнопку «Совместно использовать в проекте».

  3. На временной шкале или в рабочей области скопируйте слои, кадры или элементы рабочей области, содержащие общие ресурсы.

  4. В отдельном FLA-файле в том же проекте вставьте слои, кадры или элементы рабочей области в отдельный FLA-файл в том же проекте.

Видеоматериалы и руководства

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет