О файлах Animate

Animate позволяет работать с различными типами видео, каждый из которых имеет особое назначение., различных типов видео, каждый из которых имеет особое назначение.

  • FLA-файлы, основные файлы, с которыми приходится работать в, содержат информацию об основных мультимедиа-ресурсах, временной шкале и сценариях документа Animate. Медиа-объекты — это графические, текстовые, звуковые и видеообъекты, которые составляют содержимое документа Animate. Временная шкала — это место, в котором пользователь указывает программе, какие объекты в какой момент должны отображаться в рабочей области. Код ActionScript®, который может быть добавлен в документы Animate, позволяет лучше управлять их поведением и взаимодействием с пользователем.

  • Несжатые XFL-файлы похожи на FLA-файлы. XFL-файл и другие связанные файлы в той же папке, представляют собой несжатый эквивалент FLA-файла. Этот формат облегчает для групп пользователей одновременную работу с различными элементами проекта Animate. Дополнительные сведения см. в разделе Работа с несжатыми XFL-файлами.

  • SWF-файлы (скомпилированные варианты FLA-файлов) предназначены для отображения на веб-страницах. При публикации FLA-файла Animate создает SWF-файл.

    Формат SWF-файла Animate является открытым стандартом, который поддерживают другие приложения. Дополнительные сведения о форматах файлов Animate см. на странице www.adobe.com/go/flashplayer_ru.

  • AS-файлы — это файлы ActionScript, в которых может частично или полностью храниться исходный текст ActionScript, не сохраненный в FLA-файлах, что позволяет лучше организовать хранение кода и работу над проектами, где разные участники работают над различными фрагментами содержимого Animate.

  • SWC-файлы содержат повторно используемые компоненты Animate. Каждый SWC-файл содержит скомпилированный фрагмент ролика, исходный текст ActionScript и прочие ресурсы, необходимые компоненту. Примечание. SWC-файлы нельзя импортировать в Animate.
  • В ASC-файлах хранятся сценарии ActionScript, которые будут выполняться на компьютере с сервером Adobe Media Server. Они обеспечивают возможность реализации логики на стороне сервера, взаимодействующей со сценариями ActionScript в SWF-файлах. Примечание. ASC-файлы не поддерживаются в Animate CC.
  • JSFL-файлы представляют собой файлы JavaScript, позволяющие добавлять новые функции в средства разработки Animate.
  • Файлы APR позволяют упаковывать шаблон публикации холста с его настройками профиля публикации. Теперь любой новый ресурс, связанный с профилем публикации, также упаковывается для общего доступа. Дополнительные сведения см. в разделе Параметры публикации.

 

 

Что представляет собой ПО Animate CC?

Что представляет собой ПО Animate CC?
Adobe

В следующих дополнительных видео и руководствах показаны принципы работы с Animate/Flash Pro. В некоторых видеоматериалах может быть показана рабочая среда Flash CS3 или CS4, но они также относятся к Flash Pro CS5.

Работа с другими приложениями Adobe

Программа Animate поддерживает работу с другими приложениями Adobe®, обеспечивая широкое разнообразие творческих процессов. Файлы Illustrator® и Photoshop® могут быть импортированы непосредственно в программу Animate. Видеоролик, созданный в Animate, может быть отредактирован в программе Adobe® Premiere® Pro или After Effects®, а видеоролик, созданный любым из этих приложений, может быть загружен в программу Animate. При публикации SWF-файлов программа Dreamweaver® позволяет внедрять содержимое в веб-страницы и запускать Animate непосредственно из Dreamweaver для его редактирования.

Открытие XFL-файлов

Начиная с Animate CC XFL является внутренним форматом создаваемых FLA-файлов. В Animate файл сохраняется с расширением FLA, однако его внутренний формат — XFL.

Другие приложения Adobe®, такие как After Effects®, могут экспортировать файлы в формате XFL. Эти файлы имеют расширение XFL, а не FLA. Из InDesign® можно экспортировать напрямую в формат FLA, внутренним форматом которого является XFL. Это позволяет начать работу над проектом в After Effects, а затем продолжать ее в Animate.

XFL-файлы можно открывать и редактировать в Animate так же, как и файлы в формате FLA. При открытии файла XFL в Animate его можно сохранить в формате файла FLA или несжатого файла XFL.

В следующих видеоруководствах показан экспорт из программ InDesign и AfterEffects в Animate с помощью XFL- и FLA-файлов:

Открытие XFL-файла в Animate:

  1. В другом приложении Adobe®, таком как InDesign или After Effects, экспортируйте работу как XFL-файл.

    Приложение сохраняет в XFL-файле все слои и другие объекты исходного файла.

  2. В Animate выберите «Файл» > «Открыть» и перейдите к XFL-файлу. Нажмите кнопку «Открыть».

    XFL-файл открывается в Animate так же, как файл в формате FLA. Все слои исходного файла представлены на временной шкале, а исходные объекты помещаются в библиотеку.

    Теперь с файлом можно работать в обычном порядке.

  3. Для сохранения файла выберите «Файл» > «Сохранить».

    Animate просит присвоить имя новому FLA-файлу в диалоговом окне «Сохранить как».

  4. Введите имя и сохраните FLA-файл.

Работа с несжатыми XFL-файлами

В Animate CC появилась возможность работать с файлами Animate в несжатом формате XFL. Этот формат позволяет просматривать отдельные части, или вложенные файлы, входящие в состав файла Animate. В число этих частей входят следующие.

  • Файл XML с описанием всего файла Animate.

  • Отдельные файлы XML с описанием каждого символа библиотеки.

  • Дополнительные файлы XML, содержащие настройки публикации, настройки для мобильных устройств и прочие настройки.

  • Папки с внешними активами, например растровыми изображениями, используемыми в файле Animate.

Несжатый формат XFL позволяет обрабатывать каждую часть файла Animate по отдельности различными пользователями. Для управления изменениями каждого вложенного файла в несжатом XFL-файле используется система управления источником. Все эти функции значительно облегчают работу дизайнеров и разработчиков над крупными проектами.

Обновление XFL-файлов

Возможность обновлять редактируемые активы для несжатых документов XFL позволяет редактировать любые активы библиотеки в несжатом XFL-документе, когда сам документ открыт в Animate. Внесенные в актив изменения отображаются в Animate по завершении редактирования актива в другом приложении.

Редактирование актива несжатого документа XFL в другом приложении:

  1. Сохраните документ Animate в несжатом формате XFL.

  2. Откройте редактируемый актив из папки LIBRARY несжатого документа XFL в соответствующем редакторе, например в Photoshop.

  3. Отредактируйте актив и сохраните изменения.

  4. Вернитесь в Animate.

    Внесенные в актив изменения сразу же отобразятся в Animate.

Редактирование SWF-файла из Dreamweaver в программе Animate

Если на компьютер установлено как приложение Animate, так и приложение Dreamweaver, можно выбрать SWF-файл в документе Dreamweaver и использовать для его редактирования приложение Animate. Animate не позволяет редактировать SWF-файл непосредственно, вместо этого производится редактирование исходного документа (FLA-файла) и его повторный экспорт в SWF-файл.

  1. Откройте в приложении Dreamweaver инспектор свойств («Окно» > «Свойства»).
  2. Выполните в документе Dreamweaver одно из следующих действий:
    • Щелкните закладку SWF-файла, чтобы выбрать его, затем нажмите кнопку «Изменить» в инспекторе свойств.

    • Щелкните правой кнопкой мыши (Windows) или удерживая клавишу Control (Macintosh) закладку SWF-файла и выберите команду «Изменить с помощью Animate» в контекстном меню.

      Dreamweaver передаст фокус приложению Animate, которое попытается определить местоположение исходного FLA-файла для выбранного SWF-файла. Если не удалось найти исходный файл Animate, пользователю будет предложено указать его местоположение.

      Примечание. Если FLA- или SWF-файл заблокирован, снимите блокировку с файла в приложении Dreamweaver.

  3. Отредактируйте FLA-файл в приложении Animate. Окно документа Animate указывает, что файл редактируется в приложении Dreamweaver.

  4. Нажмите кнопку «Готово» по завершении редактирования.

    Animate обновит FLA-файл, повторно экспортирует его в виде SWF-файла и возвратит фокус в документ Dreamweaver.

    Примечание.

    Чтобы обновить SWF-файл, не закрывая приложение Animate, выберите в его меню команду «Файл» > «Обновить для Dreamweaver».

  5. Нажмите кнопку «Воспроизвести» для просмотра обновленного файла в документе с помощью инспектора свойств Dreamweaver или клавишу F12 для предварительного просмотра страницы в окне браузера.
  1. Запустите Animate.

  2. На главном экране Animate выберите «Создать новый» > «Файл Animate (мобильный)».

  3. В приложении Device Central выберите «Версия проигрывателя» и «Версия ActionScript».
  4. Выберите тип содержимого.
  5. В списке «Доступные устройства» выберите одно или несколько целевых устройств (либо выберите набор или отдельное устройство в списке «Наборы устройств»).
  6. Нажмите кнопку «Создать».
  7. Добавьте содержимое в новый документ Animate.

  8. Чтобы проверить документ, выберите пункт «Управление» > «Тестировать ролик».

Создание нового документа

Animate позволяет создавать новые документы или открывать ранее сохраненные, а также открывать в процессе работы новые окна. Могут быть заданы свойства для новых и существующих документов.

Вы можете выбрать назначение анимации с помощью набора настроек, предоставляемых Animate. Задайте предполагаемый замысел на вкладках вверху экрана: «Анимация персонажей», «Социальные сети», «Игры», «Образование», «Реклама», «Интернет» и «Дополнительно».

Укажите подходящий набор настроек для каждого замысла и щелкните Создать, чтобы начать создавать анимации. Последние использовавшиеся ресурсы отображаются на левой панели. Примеры ресурсов находятся внизу начального экрана.

Launch-screen

Создание документа

  1. Выберите «Файл» > «Создать».

    Новый документ
    Новый документ
  2. Задайте предполагаемый замысел на вкладках вверху экрана: «Анимация персонажей», «Социальные сети», «Игры», «Образование», «Реклама», «Интернет» и «Дополнительно».

  3. Укажите подходящий набор настроек для каждого замысла и щелкните Создать.

    Можно также выбрать параметры для документа. См. раздел «Установка свойств нового или существующего документа».

Создание документа на основе шаблона

  1. Выберите «Файл» > «Новый из шаблона».

    Диалоговое окно «Создание из шаблона».
    Диалоговое окно «Создание из шаблона».
  2. Выберите категорию в списке «Категория», документ в списке элементов категории и нажмите кнопку «ОК». Может быть выбран как стандартный, поставляемый с Animate, так и предварительно сохраненный шаблон.

Открытие существующего документа

  1. Выберите меню «Файл» > «Открыть».

  2. В диалоговом окне «Открыть» перейдите к файлу или введите путь к нему в поле «Перейти к».
  3. Нажмите кнопку «Открыть».

Просмотр документа, если открыто несколько документов

Если открыто несколько документов, то вкладки в верхней части окна «Документ» показывают открытые документы и обеспечивают удобное переключение между ними. Вкладки появляются только тогда, когда документы развернуты на все окно «Документ».

  1. Щелкните вкладку документа, который необходимо просмотреть.

    По умолчанию вкладки перечислены в порядке создания документов. Перетаскивая их, порядок размещения документов можно изменить.

Открытие нового окна для текущего документа

  1. Выберите меню «Окно» > «Дублировать окно».

Установка свойств нового или существующего документа

  1. В открытом документе выберите меню «Модификация» > «Документ».

    Открывается диалоговое окно «Настройки документа».

  2. Чтобы задать размеры рабочей области, выполните одно из следующих действий.
    • Чтобы указать размер рабочей области в пикселях, введите значения в полях «Ширина» и «Высота». Минимальный размер составляет 1 x 1 пиксель, максимальный — 2880 x 2880 пикселей.

    • Чтобы задать для рабочей области размер точно в соответствии с пространством, которое занимает содержимое рабочей области, выберите параметр «Синхронизировать с содержимым».

    • Чтобы установить размер рабочей области равным максимальной доступной области печати, выберите параметр «Синхронизировать с принтером». Эта область определяется размером листа бумаги за вычетом текущих полей, заданных в области «Поля» диалогового окна «Параметры страницы» (Windows) или Print Margins (Macintosh).

    • Чтобы установить размер рабочей области по умолчанию, то есть 550 x 400 пикселей, выберите параметр «Синхронизировать по умолчанию».

  3. Чтобы скорректировать положение и ориентацию 3D-объектов в рабочей области для сохранения их внешнего вида относительно границ рабочей области, установите флажок «Настроить угол 3D-перспективы, чтобы сохранить текущую проекцию рабочей области».

    Этот параметр доступен только в том случае, если изменен размер рабочей области.

  4. (Только для CS5.5) Чтобы автоматически масштабировать содержимое рабочей области с учетом изменения ее размера, установите флажок «Масштабировать содержимое вместе с рабочей областью».

    Этот параметр доступен только в том случае, если изменен размер рабочей области. В настройках можно при желании задать масштабирование содержимого в заблокированных и скрытых слоях. Дополнительные сведения см. в разделе «Задание настроек "Общие"».

  5. Чтобы задать единицу измерения для линеек, отображаемых в рабочей области, выберите необходимый параметр в меню «Единицы измерения линеек». Этот параметр также определяет единицы измерения, используемые на панели «Информация».
  6. Чтобы задать цвет фона документа, щелкните образец цвета «Цвет фона» и выберите цвет из палитры.
  7. В поле «Частота кадров» введите число кадров анимации, отображаемых в секунду.

    Для большинства анимаций, отображаемых на компьютере, в особенности при воспроизведении с веб-сайта, будет достаточно от 8 до 15 кадров в секунду (fps). При изменении частоты кадров новое значение становится частотой по умолчанию.

  8. (Только CS5.5) Чтобы автоматически сохранять документ через заданные интервалы времени, выберите параметр «Автосохранение» и укажите количество минут между сохранениями.
  9. Выполните одно из следующих действий.
    • Чтобы применить новые параметры только к текущему документу, нажмите кнопку «ОК».

    • Чтобы сделать новые настройки свойствами по умолчанию всех вновь создаваемых документов, нажмите кнопку «Использовать по умолчанию».

Изменение свойств при помощи инспектора свойств

  1. Щелкните в рабочей зоне за пределами рабочей области, чтобы отменить выделение всех объектов в рабочей области. Свойства документа отображаются в инспекторе свойств. Чтобы открыть инспектор свойств, выберите («Окно» >«Свойства»).
  2. (Только для CS5.5) В разделе «Публикация» выберите версию Flash Player и версию ActionScript для документа. Для доступа к дополнительным параметрам публикации нажмите кнопку «Параметры публикации». Дополнительные сведения см. в разделе Параметры публикации.

  3. В разделе «Свойства» для параметра FPS (количество кадров в секунду) введите число кадров анимации, воспроизводимых каждую секунду.
  4. Чтобы изменить размер рабочей области, введите значения ширины и высоты рабочей области.
  5. Чтобы выбрать цвет фона для рабочей области, щелкните образец цвета рядом со свойством рабочей области и выберите цвет из палитры.
  6. Чтобы изменить дополнительные свойства документа, нажмите кнопку «Изменить» рядом со свойством «Размер». Дополнительные сведения о всех свойствах документа см. в разделе «Задание свойств нового или существующего документа».

Добавление в документ метаданных XMP

Можно включать в FLA-файлы метаданные XMP, такие как заголовок, автора, описание, авторские права и др. XMP — это формат метаданных, распознаваемый некоторыми приложениями Adobe®. Метаданные можно просматривать в Animate и Adobe® Bridge. Дополнительные сведения о метаданных XMP см. в разделе Метаданные и ключевые слова справки по Bridge.

Примечание. Bridge для 32-битных систем не поддерживается в Adobe Animate CC.

Внедрение метаданных позволяет поисковым машинам возвращать осмысленные результаты при поиске в Интернете по содержимому Animate. Поисковые метаданные основаны на спецификациях XMP (Extensible Metadata Platform) и хранятся в FLA-файле, соответствующем рекомендациям W3C.

Метаданные файла содержат сведения о содержимом, авторских правах, источнике и истории файла. В диалоговом окне «Сведения о файле» можно просматривать и редактировать метаданные для текущего файла.

В зависимости от выбранного файла могут отображаться следующие типы метаданных.

Описание

Содержит сведения об авторе, названии, авторских правах и другие.

IPTC

Отображает метаданные, доступные для редактирования. Позволяет добавлять в файлы сопроводительные подписи, а также информацию об авторском праве. Ядро IPTC — это спецификация, утвержденная IPTC (Международным советом по издательским телекоммуникациям) в октябре 2004 г. В ней, по сравнению с прежней спецификацией IPTC (IIM, устаревшей), добавлены новые свойства, а отдельные свойства переименованы или удалены.

Данные фотокамеры (Exif)

Отображает информацию, добавленную цифровыми камерами, включая настройки камеры в момент создания снимка.

Данные видео

Отображает метаданные для видеофайлов, включая соотношение сторон пикселя, монтажный кадр и снимок.

Звуковые данные

Отображает метаданные для аудиофайлов, включая исполнителя, альбом, номер композиции и жанр.

Мобильный SWF

Показывает информацию о SWF-файлах, включая название, автора, описание и авторские права.

Журнал

Содержит журнал изменений, внесенных в изображения с помощью Photoshop.

Примечание. В Photoshop должна быть включена функцию «Журнал», чтобы вместе с метаданными файла сохранялся журнал.

Version Cue

Отображает сведения о версии файла Version Cue.

DICOM

Информация об изображениях, сохраненных в формате DICOM.

Для добавления метаданных выполните следующее.

  1. Выберите «Файл» > «Сведения о файле».
  2. В появившемся диалоговом окне «Сведения о файле» введите необходимые метаданные. Можно в любой момент добавить или удалить метаданные FLA-файла.

Сохранение документов Animate

FLA-документ Animate может быть сохранен как в ту же папку и с тем же именем, так и в другую папку и с другим именем.

Если документ содержит несохраненные изменения, то после имени документа в строке заголовка документа, строке заголовка приложения и вкладке документа отображается звездочка (*). После сохранения документа звездочка исчезает.

Сохранение документа Animate в формате FLA по умолчанию

  1. Выполните одно из следующих действий.
    • Чтобы заменить текущую версию файла на диске, выберите меню «Файл» > «Сохранить».

    • Чтобы сохранить документ в другом месте и/или с другим именем либо сжать его, выберите меню «Файл» > «Сохранить как».

  2. Если выбрана команда «Сохранить как», или если документ никогда ранее не сохранялся, введите местоположение и имя файла.
  3. Нажмите кнопку «Сохранить».

Сохранение документа в несжатом формате XFL

  1. Выберите меню «Файл» > «Сохранить как».
  2. В меню «Сохранить как» выберите «Документ Animate CC без сжатия (*xfl)».

  3. Выберите имя и расположение файла, затем нажмите кнопку «Сохранить».

Возврат к последней сохраненной версии документа

  1. Выберите меню «Файл» > «Вернуться».

Сохранение документа как шаблона

  1. Выберите меню «Файл» > «Сохранить как шаблон».
  2. В диалоговом окне «Сохранить как шаблон» в поле «Имя» введите имя шаблона.
  3. Выберите категорию из всплывающего меню «Категория» или введите ее название, чтобы создать новую категорию.
  4. В поле «Описание» введите описание шаблона (не более 255 символов) и нажмите кнопку «ОК».

    Описание отображается только в том случае, если шаблон выбран в диалоговом окне «Создать документ».

    Чтобы удалить сохраненный шаблон, перейдите в одну из следующих папок и удалите FLA-файл шаблона из содержащей его папки категории.

    • Windows XP — C:\Documents and Settings\<имя пользователя>\Local Settings\Application Data\Adobe\Flash CS5\ru_RU\Configuration\Templates\

    • Windows Vista и 7 — C:\Users\<имя пользователя>\AppData\Local\Adobe\Flash CS5\<язык>\Configuration\Templates\

    • Mac OS — <жесткий диск>/Users/<имя пользователя>/Library/Application Support/Adobe/Flash CS5/<язык>/Configuration/Templates/

Сохранение документа в формате Animate CC

  1. Выберите меню «Файл» > «Сохранить как».
  2. Введите местоположение и имя файла.
  3. Из всплывающего меню «Формат» выберите пункт «Документ Animate CC» и нажмите кнопку «Сохранить».

    Примечание.

    Если появляется предупреждение, что в случае сохранения в формате Animate будет удалено содержимое, то нажмите кнопку «Сохранить как Animate CC».Такое может случиться, если документ содержит функции, доступные только в версии Animate CC. Animate не сохраняет эти компоненты при сохранении документа в формате Animate CC.

Сохранение документов при выходе из Animate

  1. Выберите меню «Файл» > «Выйти» (Windows) или «Animate» > «Выйти из Animate» (Macintosh).

  2. Если есть документы, содержащие несохраненные изменения, то Animate для каждого документа предлагает сохранить или отменить изменения.

    • Нажмите кнопку «Да», чтобы сохранить изменения и закрыть документ.

    • Нажмите кнопку «Нет», чтобы закрыть документ, не сохраняя изменений.

Печать документов Animate (не поддерживается в Flash Professional CC)

Просмотр и редактирование документов, печать кадров из документов Animate или задание кадров для печати из Flash Player.

При печати кадров из документа Animate для указания диапазона монтажных кадров или кадров и количества копий используется диалоговое окно «Печать». В ОС Windows диалоговое окно «Параметры страницы» задает размер бумаги, ориентацию и различные настройки печати, в том числе установку полей и необходимость напечатать каждый кадр на отдельной странице. В Macintosh эти параметры делятся между диалоговыми окнами «Параметры страницы» и «Поля печати».

Диалоговые окна «Печать» и «Параметры страницы» одинаковы в обеих операционных системах, а их внешний вид зависит от драйвера принтера.

  1. Выберите «Файл» > «Параметры страницы» (Windows) или «Файл» > «Поля печати» (Macintosh).
  2. Установите поля страницы. Выберите оба параметра «Центрировать», чтобы напечатать кадр в центре страницы.
  3. В меню «Кадры» выберите, нужно ли печатать все кадры в документе или только первый кадр каждого монтажного кадра.
  4. В меню «Макет» выберите один из следующих вариантов.

    Фактический размер

    Печать кадра в полном размере. Введите значение масштаба, чтобы уменьшить или увеличить кадр на печати.

    Подогнать к размеру страницы

    Уменьшение или увеличение каждого кадра, чтобы он заполнял область печати на странице.

    Раскадровка

    Печать нескольких миниатюр на одной странице. Выберите параметр «прямоугольники», «сетка» или «пустая». В поле «Кадры» введите количество миниатюр на странице. В поле «Границы кадра» установите промежуток между кадрами и выберите «Метки кадров», чтобы напечатать метку кадра в виде миниатюры.

  5. Для печати кадров выберите «Файл» > «Печать».

Использование меток кадра для отмены печати

Чтобы отменить печать любого кадра на временной шкале, пометьте его знаком !#p, чтобы отменить печать всего SWF-файла. Если присвоить метку кадра !#p, затеняется команда «Печать» в контекстном меню проигрывателя Flash Player. Можно также отключить контекстное меню Flash Player.

Если отключить печать из Flash Player, пользователи могут использовать для печати кадров меню «Печать» в браузере. Поскольку эта команда является функцией браузера, нельзя использовать Animate для управления или отключения печати.

Отключение печати в контекстном меню Flash Player

  1. Откройте или сделайте активным документ Animate (FLA-файл), предназначенный для публикации.

  2. Выберите первый ключевой кадр в основной временной шкале.
  3. Выберите «Окно» > «Свойства» для просмотра инспектора свойств.
  4. В инспекторе свойств в поле «Метка кадра» введите !#p, чтобы указать, что этот кадр не предназначен для печати.

    Задайте только одну метку !#p, чтобы деактивировать команду «Печать» в контекстном меню Flash Player.

    Примечание.

    Можно также выбрать пустой кадр (а не ключевой) и присвоить ему метку #p.

Отключение печати путем удаления контекстного меню Flash Player

  1. Откройте или сделайте активным документ Animate (FLA-файл), предназначенный для публикации.

  2. Выберите «Файл» > «Параметры публикации».
  3. Откройте вкладку «HTML», снимите флажок «Отображать меню» и нажмите кнопку «ОК».

Указание области печати при печати кадров

  1. Откройте документ Animate (FLA-файл), содержащий нужные кадры для печати.

  2. Выберите неуказанный для печати кадр с меткой кадра #p, находящийся в том же слое, что и кадр с меткой #p.

    Выберите кадр, следующий за кадром с меткой #p.

  3. Создайте в рабочей области фигуру с размерами, равными нужной области печати. Чтобы использовать ограничительную рамку кадра, выберите кадр с любым объектом, соответствующим размерам области печати.
  4. На временной шкале выберите кадр, содержащий фигуру, которая будет использоваться в качестве ограничительной рамки.
  5. В инспекторе свойств («Окно» > «Свойства») введите #b для метки кадра, чтобы задать выбранную фигуру в качестве ограничительной рамки для области печати.

    В каждой временной шкале допустимо наличие только одного кадра с меткой #b. Этот параметр равнозначен выбору ограничительной рамки «Ролик» в наборе параметров действия «Печать».

Изменение цвета фона при печати

Цвет фона при печати можно изменить в диалоговом окне «Свойства документа». Изменяйте цвет фона только для распечатываемых кадров, расположив цветной объект в самом нижнем слое распечатываемой временной шкалы.

  1. Поместите фигуру с заливкой, закрывающую рабочую область, в самом нижнем слое временной шкалы, которая будет выводиться на печать.
  2. Выделите эту фигуру и выберите «Модификация» > «Документ». Выберите цвет фона на печати.

    Это действие изменяет цвет фона всего документа, включая цвет фона фрагментов ролика и загруженных SWF-файлов.

  3. Выполните одно из следующих действий.
    • Чтобы изменить цвет фона документа, выберите для печати кадр, в который помещена фигура.

    • Чтобы сохранить цвет фона для кадров, не предназначенных для печати, повторите шаги 2 и 3. Затем поместите эту фигуру в самом нижнем слое временной шкалы во всех кадрах, не предназначенных для печати.

Для печати кадров из любого SWF-файла Animate используйте команду «Печать» в контекстном меню Flash Player.

Команда «Печать» в контекстном меню не может печатать эффекты прозрачности и цветовые эффекты, а также не может печатать кадры из других фрагментов ролика. Для расширенных возможностей печати используется объект PrintJob или функция print().

  1. Откройте документ.

    Эта команда печатает кадры с меткой #p, используя в качестве области печати размеры рабочей области или заданную ограничительную рамку.

    Если не назначены кадры для печати, будут напечатаны все кадры основной временной шкалы документа.

  2. Выберите «Файл» > «Просмотр публикации» > «По умолчанию» или нажмите клавишу «F12», чтобы просмотреть содержимое Animate в браузере.

  3. Чтобы отобразить контекстное меню Flash Player, щелкните правой кнопкой мыши (Windows) или щелкните, удерживая нажатой клавишу «Control» (Macintosh), содержимое Animate в окне браузера.

  4. Выберите в контекстном меню Flash Player команду «Печать», чтобы отобразить диалоговое окно «Печать».
  5. В Windows выберите нужный диапазон кадров.
  6. В Macintosh в диалоговом окне «Печать» выберите страницы для печати.
  7. Выберите другие параметры печати, соответствующие свойствам принтера.
  8. Нажмите кнопку «ОК» (Windows) или «Печать» (Macintosh).

Примечание.

Печать из контекстного меню не взаимодействует с вызовами объекта PrintJob.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет