Узнайте, как устранить неполадки, которые могут возникнуть при печати или экспорте файла в PDF из InDesign.

Следуйте рекомендациям, приведенным в этом документе. Выполняйте их по порядку, пока проблема не будет устранена.

Известные неполадки печати/экспорта и способы устранения некоторых неполадок подробно описаны в базе знаний службы поддержки Adobe на веб-сайте Adobe по адресу https://helpx.adobe.com/ru/indesign.html.

Определение уровня неполадки

Чтобы устранить неполадку печати/экспорта, сначала необходимо определить условия, при которых возникает данная неполадка. Например, возникла ли данная неполадка лишь однажды или она возникает постоянно при выполнении определенных действий,
связана ли ошибка с печатью/экспортом всех документов, некоторых документов или только одного конкретного документа? Шаги и способы проверки, приведенные ниже, помогут определить условия, при которых возникает данная ошибка, и найти способ ее устранения.

1. Перезапустите компьютер.

Если ошибка больше не возникает, то причиной ее появления могли быть временные неполадки передачи данных, недостаточный объем системных ресурсов или другие временные факторы среды. Если после перезапуска компьютера печать/экспорт выполняются без ошибок, но позднее неполадка возникает снова, необходимо устранить неполадку на уровне системы.

2. Выключите и снова включите принтер.

Если ошибка больше не возникает, то причиной ее появления могли быть неполадки с памятью принтера. Если ошибка не устранена, перейдите к выполнению шага 3.

3. Создайте новый документ.

Если печать/экспорт нового документа выполняются без ошибок, но при работе с исходным документом возникают неполадки, необходимо устранить неполадку на уровне документа.

4. Выполните печать/экспорт в другой программе.

Если печать из других программ (например, WordPad, TextEdit) или экспорт/сохранение как PDF (например из Illustrator, Photoshop) выполняются без ошибок, необходимо устранить неполадку на уровне приложения.

5. Выполните печать на другом принтере.

При возможности попробуйте отправить документ в печать на другой принтер. Если на другом принтере печать выполняется без ошибок, убедитесь, что используемый ранее принтер включен и подключен к Интернету. Отсоедините и повторно подсоедините кабели принтера. Убедитесь, что кабели правильно присоединены, и запустите проверку функций принтера, чтобы выявить возможные механические неполадки или повреждение кабелей. Если эти шаги не помогли устранить ошибку, необходимо рассмотреть неполадки на уровне системы.

6. Используйте другой способ создания файла PDF.

  • Если неполадка возникает при экспорте в PDF из InDesign и на компьютере установлено приложение Adobe Acrobat Standard, Pro или Pro Extended, распечатайте документ через принтер Adobe PDF. (Если вы используете Mac OS v10.6 или более поздней версии с установленным Acrobat 9, cм. «Сохранение документа Acrobat 9 как Adobe PDF.)
  • Если неполадка возникает при использовании функции «Печать» для создания файла PDF, выберите «Файл» > «Экспорт в PDF.

Устранение неполадок печати/экспорта на уровне документа

Если при печати/экспорте нового документа ошибки не возникают, неполадка может быть связана с настройками печати или экспорта для ихсодного документа, отдельным объектом или шрифтом, используемым в документе, или поврежденной структурой документа. Попробуйте выполнить один или несколько из приведенных шагов.

Примечание.

В зависимости от используемого принтера, расположение настроек может быть разным и отличаться от сведений, приведенных в процедурах ниже. Обратитесь к документации принтера.   

1. Экспортируйте документ в формат IDML (для InDesign CS4 и более поздних версий) или INX (для InDesign CS3 и более ранних версий).

Документ может быть поврежден. Повреждения документов особенно распространены при преобразовании формата с использованием предыдущих версий InDesign или из документов QuarkXPress. Экспорт в формат InDesign Markup Language (IDML) или InDesign Interchange (INX) поможет исключить поврежденные данные.

2. (Только для принтеров PostScript) Включение обработчика ошибок PostScript.

Windows

  1. Выберите меню «Файл» > «Печать».
  2. Нажмите кнопку «Настройка».
  3. Если появится диалоговое окно, нажмите кнопку«ОК»: "Если требуемый параметр печати доступен в диалоговом окне InDesign «Печать», задайте его непосредственно в окне во избежание конфликтов при печати".
  4. Щелкните принтер правой кнопкой мыши и выберите пункт«Свойства»
  5. На вкладке «Общие» нажмите кнопку «Настройка печати».
  6. Выберите пункт «Дополнительно».
  7. Разверните раздел параметров документа и затем разверните раздел параметров PostScript. Если для параметра «Отправить обработчик ошибок PostScript» не установлено значение «Да», щелкните параметр и выберите значение «Да» во всплывающем меню.

Mac OS X

  1. Выберите меню «Файл» > «Печать».
  2. Выберите принтер.
  3. В меню раздела предустановленных параметров выберите пункт «Обработка ошибок».
  4. Выберите функцию «Печать подробного отчета» и нажмите кнопку «Печать».

Если неполадка связана с ошибкой PostScript, обработчик ошибок PostScript распечатает страницу с информацией о неполадке. См. «Устранение неполадок PostScript».

3. Исключите графику из документа.

Исключите графику при печати документа

  1. Выберите меню «Файл» > «Печать».
  2. Выберите пункт «Графика» и затем установите значение «Нет» в меню отправки данных.
  3. Нажмите кнопку «Печать».

Исключите графику при экспорте документа

  1. Выберите меню «Файл» > «Экспорт» и выберите «Adobe PDF (Печать)» в качестве формата или из пункта «Тип файла».
  2. Укажите расположение и нажмите кнопку «Сохранить».
  3. Нажмите кнопку «Дополнительно» и установите все три флажка для парметра «Пропускать для OPI»: EPS, PDF ирастровых изображений.
  4. Чтобы разрешить исключение графических изображений, установите для параметра «Стандарт» значение«Нет».
  5. Нажмите кнопку «Экспорт».

Если в этом случае печать или экспорт документа выполняются без ошибок, возможно, был поврежден один или несколько графических объектов на странице. Чтобы пропустить 50 % графики, удалите страницы или графические рамки на отдельной странице. Отправляйте документ в печать или на экспорт после каждого изменения, чтобы определить, является ли поврежденный графический объект в группе причиной неполадки. Если после внесения изменений печать или экспорт документа выполняется без ошибок, восстановите исходный вид документа и удалите оставшиеся 50 % графических элементов. Если возникает ошибка, удалите следующие 50 % графических объектов и так далее. После выявления графических объектов, вызывающих неполадку, удалите и замените их. Возможно, понадобится осуществить повторный экспорт графических элементов из приложения, в котором они были созданы.

Успешная печать страниц без графики также может указывать на недостаточный объем памяти принтера. Общими признаками недостаточного объема памяти принтера являются замена шрифтов, отсутствие графики или неполная печать. Попробуйте распечатывать документ по диапазону страниц или упростить публикацию, чтобы проверить, будут ли возникать ошибки при меньшем объеме графических объектов. Попробуйте выполнить печать в более низком разрешении.

Примечание.

Если документ содержит только графические элементы, результатом печати станет пустая страница при условии, что в приложении InDesign установлен параметр, разрешающий печать пустых страниц. В диалоговом окне «Печать» перейдите к разделу «Общие» и выберите параметр «Печать пустых страниц».

4. Исключите или уменьшите количество используемых шрифтов.

Исключите шрифты при печати

  1. Выберите меню «Файл» > «Печать».
  2. Выберите пункт «Графика»
  3. В разделе «Шрифты» откройте меню «Загрузка» и установите значение «Нет»
  4. Нажмите кнопку «Печать».

Уменьшение количества используемых шрифтов при экспорте в PDF

При экспорте документа шрифты невозможно исключить, но можно уменьшить количество используемых шрифтов.

  1. Выберите меню «Текст» > «Найти шрифт»
  2. В списке «Шрифты» в документе выберите первый шрифт и затем, удерживая клавишу Shift, щелкните последний шрифт, чтобы выделить все шрифты в списке.
  3. В списке «Заменить на: гарнитура» выберите шрифт, который работает без ошибок в других документах, например Arial, Verdana.
  4. Нажмите кнопку «Заменить все».
  5. Нажмите кнопку Готово.
  6. Выберите пункты «Файл» > «Экспорт» и в качестве формата выберите Adobe PDF (Печать)
  7. Укажите расположение, затем нажмите кнопку «Сохранить».
  8. Нажмите кнопку «Экспорт».

Если при печати/экспорте документа не возникают ошибки, причиной неполадки могли быть шрифты, используемые в документе. Если в документе используется большое количество шрифтов, исключение шрифтов позволяет упростить структуру документа. Сохраните документ под новым именем и проверьте используемые шрифты в новом документе, чтобы определить, являются ли они поврежденными. Если при использовании какого-либо шрифта постоянно возникает ошибка, проверьте, не открыто ли несколько активных экземпляров этого шрифта, или переустановите шрифт, загрузив его повторно с сайта разработчика.

5. Убедитесь, что ссылки в документе действительны.

Чтобы просмотреть состояние ссылок, выберите пункты «Окно» > «Ссылки». Выберите файлы с именами, в начале которых находится вопросительный знак или другой символ, и отмените или заново создайте для них ссылки. Для получения подробной информации о ссылках в InDesign, cм. раздел справки InDesign «Управление ссылками и встроенной графикой».

6. Отключите настройки.

Иногда ошибки возникают в результате определенной функции печати/экспорта, которая обрабатывает какое-либо содержимое в документе. По возможности исключите как можно больше подобных функций. Если
исключение функций приводит к ошибке, отключайте функции по группам, чтобы выявить те, которые являются причиной неполадки.

Примечание.

В зависимости от используемого типа принтера некоторые настройки могут быть недоступны.

Чтобы открыть диалоговое окно «Печать», выберите «Файл» > «Печать» Затем измените настройки на следующих панелях:

На панели «Общие»

  • Установите количество копий -1.
  • Выберите «Страницы», для которых необходимо отключить «Функцию разворота».
  • Отключите «Печать шаблонов страниц», «Печать непечатаемых объектов» и «Печать видимых направляющих и базовых линий».
  • Установите для параметра «Печать слоев» значение «Видимые и печатаемые слои».

На панели «Настройки»

  • Установите параметр «Размер бумаги определяется драйвером».
  • Установите для масштаба ширины и высоты значение 100 %.
  • Отключите параметры «Миниатюры» и «Мозаика».

На панели «Типографские метки» и «Выпуск за обрез»

  • Отключите все «Метки»,«Выпуск за обрез», и«Служебное поле».

На панели «Вывод»

  • Установите для цвета параметр «Композитные без изменений».
  • Отключите «Треппинг»,отключите параметр «Текст черным цветом» и параметр «Имитировать наложение».
  • В «Диспетчере красок» отключите «Использование псевдонимов красок».

На панели «Графика»

  • Для параметра «Изображения: отправить данные» выберите «Нет» или «Все».
  • Для параметра «Шрифты: загрузка» выберите «Нет» или «Все».
  • Установите для PostScript уровень 2.
  • Установите для формата данных значение «ASCII».

На панели «Управление цветом»

  • Для параметра «Обработка цвета» выберите значение«Принтер PostScript определяет цвета».
  • Включите «Сохранение значений CMYK»

На панели «Страницы» (за пределами диалогового окна «Печать»):

Выделите все страницы и во всплывающем меню панели выберите пункты «Атрибуты страницы» > «Сведение разворотов» > «Нет (игнорировать прозрачность)».

7. Устраните неполадки, связанные c внешними модулями.

Удалите внешние модули сторонних производителей из папки модулей InDesign и перезапустите InDesign. Если неполадка не устранена, поместите модули обратно в папку InDesign. Если неполадка больше не возникает, выявите конфликтующие внешние модули:

  1. Выберите пункты «Справка» > «Настроить внешние модули» (в Windows) или «InDesign» > «Настроить внешние модули» (в Mac OS).
  2. Выберите все внешние модули для набора и отмените выбор всех параметров в разделе «Отображение», за исключением пункта «Сторонние разработчики». Создайте список внешних модулей.
  3. Закройте InDesign и переместите эти модули из папки внешних модулей:
    • Windows: /Program Files/Adobe/Adobe InDesign [версия]/Plug-Ins
    • Mac OS: /Applications/Adobe InDesign [Version]/Plug-Ins
  4. Перезапустите InDesign и повторите шаги, приведшие к возникновению неполадки.
    • Если неполадка больше не возникает, повторите шаги 3 и 4 с добавлением некоторых модулей сторонних разработчиков в папку внешних модулей.
    • Если неполадка не устранена, свяжитесь с разработчиком внешнего модуля, который вы переместили в папку последним, и получите информацию об обновлениях.

8. Печать/экспорт с использованием новой учетной записи пользователя.

Иногда причиной неполадок в работе приложения является поврежденная учетная запись пользователя, препятствующая записи и считыванию необходимых файлов и папок. Создайте новую учетную запись пользователя (не удаляйте исходную учетную запись), войдите в систему и повторно выполните печать/экспорт документа.

Windows

Выберите «Пуск» > «Панель управления» > «Учетные записи пользователей».

Mac OS X

Выберите меню «Apple» > «Системные настройки» > «Пользователи и группы».

9. Определите, поврежден ли документ.

Устранение неполадок печати/экспорта на уровне приложения

Если при печати любого документа InDesign возникает ошибка, попробуйте выполнить следующие шаги для устранения неполадки на уровне приложения.

1. Повторно создайте файлы установок InDesign.

Если InDesign работает с перебоями, при помощи удаления установок (также именуемого как «очистка установок» или «сброс установок») и их повторного создания часто можно решить эту проблему.

Существуют 2 способа повторного создания установок:

  • Автоматически:  этот способ быстро удаляет текущие файлы установок, а затем восстанавливает новый набор файлов установок по умолчанию. Однако после этого любые пользовательские настройки будут утеряны.

-или-

  • Вручную:  Если вы хотите сохранить пользовательские настройки, переименуйте текущие файлы установок перед восстановлением нового набора файлов установок по умолчанию. Если новые файлы установок не помогут устранить неполадки печати/экспорта, у вас будет сохранена резервная копия исходных файлов установок (включая любые пользовательские настройки), которые можно использовать для замены новых файлов установок.

Повторное создание файлов установок InDesign автоматически

Примечание.

При повторном создании файлов установок InDesign все ранее созданные файлы установок, в том числе любые пользовательские настройки, будут удалены. Если вы хотите сохранить пользовательские настройки, повторно создайте файлы установок вручную.

  1. Завершите работу с InDesign.
  2. Перезапустите InDesign и быстро нажмите и удерживайте соответствующие комбинации клавиш для своей операционной системы:
    • Mac OS: Control+Option+Command+Shift
    • Windows: Control + Alt + Shift
  3. Откроется диалоговое окно с запросом на удаление файлов установок InDesign. Нажмите «Да». Запуск InDesign будет осуществлен с восстановленными по умолчанию установками.

Повторное создание файлов установок InDesign вручную

Переименуйте два файла установок (например, измените имя файла «InDesign SavedData» на «InDesign SavedData backup», а «InDesign Defaults» на «InDesign Defaults backup»). Расположение файлов установок:

  • Mac OS X

    InDesign Defaults:

    Users/[пользователь]/Library/Preferences/Adobe InDesign/Version [версия]/[язык]/InDesign Defaults

InDesign SavedData:

Users/[пользователь]/Library/Caches/Adobe InDesign/Version [версия]/[язык]/InDesign SavedData

  • Windows XP

    InDesign Defaults:

    /Documents and Settings/[user]/Application Data/Adobe/InDesign/Version [version]/InDesign Defaults

По умолчанию скрыта. Узнайте, как отобразить скрытые файлы.

InDesign SavedData:

/Documents and Settings/[user]/Local Settings/Application Data/Adobe/InDesign/Version[version]/Caches/InDesign SavedData

  • Windows 7 и 8

InDesign Defaults:

C:\Users\DC-work\AppData\Roaming\Adobe\InDesign\Version 11.0\[язык]\InDesign Defaults

По умолчанию скрыта. Узнайте, как отобразить скрытые файлы.

InDesign SavedData:

/Users/[user]/AppData/Local/Adobe/InDesign/Version[версия]/[язык]/Caches/InDesign SavedData

Снова запустите InDesign. InDesign создает новый набор файлов установок по умолчанию.

Если проблема печати/экспорта не устранена, можно восстановить исходные установки. Для этого присвойте файлам установок исходные имена: InDesign SavedData and InDesign Defaults.

2. (Только для windows) Убедитесь, что на компьютере установлена последняя версия драйвера принтера.

Установите последнюю версию драйвера принтера:

  • Если используется принтер PostScript, загрузите программу установки Adobe Universal PostScript Windows Driver Installer.
  • Если используется принтер, отличный от PostScript, запросите новейшую версию драйвера у производителя принтера.

3. (Windows, только для принтера PostScript ) Оптимизация скорости PostScript.

  1. Выберите меню «Файл» > «Печать».
  2. Нажмите «Настройки», выберите принтер, нажмите «Установки», а затем нажмите кнопку «Дополнительно».
  3. Разверните раздел параметров документа и затем параметров PostScript.
  4. Выберите«Параметры вывода PostScript».
  5. Во всплывающем меню выберите пункт «Оптимальная скорость»и нажмите кнопку «ОК».
  6. Нажмите кнопку «ОК», а затем «Печать».

4. Отключите функцию защиты страниц в принтере

Для получения информации об отключении этой функции обратитесь к документации, поставляемой с принтером.

5. Подключите компьютер к принтеру.

Если ошибка возникает во время печати через сеть, подключите принтер непосредственно к компьютеру и повторите попытку печати.

Если невозможно подключить принтер напрямую, сохраните документ как файл PostScript. Для отправки файла на принтер используйте командную строку на компьютере, напрямую подключенном к принтеру. 

6. Сохраните файл как PDF на жестком диске.

Если проблема возникает при попытке экспорта файла PDF в сетевую папку, попробуйте сохранить файл PDF на жестком диске.

Причиной возникновения неполадок при экспорте на сетевые диски может быть нестабильная работа сети или ошибки прав доступа. Если вы можете экспортировать файл на локальный диск, но не в требуемую папку на сетевом диске, обратитесь в свой ИТ-отдел для рассмотрения этой ошибки.

Устранение неполадок печати на уровне принтера

Устранение неполадок печати на принтере PostScript

При проблемах печати, возникающих при использовании принтера PostScript, попробуйте выполнить один или несколько следующих шагов. Выполняйте печать после каждого шага.

1. Используйте обновленный драйвер принтера.

Загрузите самую последнюю версию драйвера принтера PostScript дляMac илиWindows.

Примечание.

Если используется сетевой принтер, то, возможно, используемый драйвер принтера может быть совместим с операционной системой сервера печати, но не с ОС на вашем компьютере. Для установки драйвера принтера, совместимого с используемой операционной системой, повторно настройте сетевой принтер с помощью мастера добавления принтера. См. «Установка драйвера принтера, совместимого с используемой операционной системой».

2. Используйте обновленный файл PPD.

Файл PPD описывает функции принтера PostScript для таких параметров, как поля, цвет и разрешение. Неправильные или устаревшие файлы PPD могут увеличить время печати. Используйте для настройки параметров принтера файл PPD, рекомендуемый производителем принтера.

Чтобы получить файл PPD для устройства, обратитесь к производителю принтера или посетите веб-сайт Adobe.

3. (Только для windows) Настройка драйвера принтера для вывода оптимизированного кода PostScript.

Для Windows 7:

  1. Выберите «Пуск» > «Устройства и принтеры».
  2. Щелкните правой кнопкой мыши и выберите «Настройка печати» > «Дополнительно».
  3. Разверните раздел параметров документа и затем параметров PostScript.
  4. Установите для параметра вывода PostScript значение «Оптимальная совместимость» .

4. Выделите больше свободного места на диске.

Убедитесь, что на жестком диске доступно достаточно свободного места. Следите за тем, чтобы объем свободного пространства составлял не менее 10% от общей емкости жесткого диска. Чтобы выделить свободное пространство, найдите и удалите временные файлы (.tmp) и очистите кэш диска, используемый браузером. Для получения информации об очистке кэша диска, см. документацию для браузера.

Для ознакомления с другими способами освобождения дискового пространства, см. документацию для вашей ОС (например, «Советы по освобождению дискового пространства на вашем ПК» для Windows, или «Увеличение дискового пространства» для Mac OS).

5. Печать на локальном принтере.

Если при печати на сетевом принтере возникают ошибки, распечатайте файл на локальном принтере, напрямую подключенном к компьютеру. Если печать на локальном принтере выполняется без ошибок, неполадка может быть связана с работой сети. В этом случае обратитесь за помощью к администратору сети.

6. (только для Windows) Установите драйвер принтера, совместимый с используемой операционной системой.

При использовании сетевого принтера установите драйвер принтера, совместимый с операционной системой на вашем компьютере. Серверы печати не всегда предоставляют драйверы для операционных систем, установленных на клиентских компьютерах. Таким образом, возможно, что используемый драйвер принтера совместим с операционной системой сервера печати, но не с ОС вашего компьютера.

Для Windows 7:

  1. В меню «Пуск» > «Устройства и принтеры».
  2. Нажмите«Добавить принтер».
  3. Выберите «Добавить локальный принтер».
  4. Выберите «Создать новый порт» > «Локальный порт» > «Далее».
  5. Введите имя порта (например, \\[printservername]\[printername]) и нажмите кнопку«ОК».
  6. Следуйте инструкциям на экране для установки драйвера, соответствующего торговой марке и модели сетевого принтера.

Устранение неполадок печати на принтере, отличном от PostScript

Если возникают трудности с печатью на принтере, отличном от Postscript, попробуйте выполнить один или несколько следующих шагов. Выполняйте печать после каждого шага.

Примечание.

Для некоторых из приведенных ниже способов потребуется изменить свойства драйвера принтера. Местонахождение определенных свойств принтера может различаться в зависимости от принтера и драйвера принтера. Свяжитесь с изготовителем принтера или просмотрите документацию принтера для получения подробной информации.

1. Распечатайте документ как растровое изображение.

  1. Выберите «Файл» > «Печать».
  2. Убедитесь, что выбран принтер, отличный от PostScript, затем выберите панель «Дополнительно» .
  3. Установите флажок «Печатать как растровое изображение» и выберите соответствующее разрешение для принтера.

2. Убедитесь, что на принтере достаточно памяти.

Для печати с установкой 300 dpi объем доступной памяти принтера должен быть не менее 2 МБ. Для печати с 600 dpi объем доступной памяти принтера должен составлять не менее 4 – 6 МБ ОЗУ. Инструкции по определению объема доступной памяти принтера см. в документации принтера.

3. Если доступно, используйте режим PostScript на принтере.

Подробные сведения см. в документации принтера.

4. (Только для Windows) используйте стандартный драйвер SVGA.

Чтобы определить, является ли причиной неполадки видеодрайвер сторонних производителей, используйте стандартный драйвер SVGA в Windows. Если в этом случае неполадка не возникает, обратитесь к производителю видеокарты для получения обновленного драйвера. Если вы уже используете новейшую версию драйвера, попробуйте изменить разрешение видео (например, 1024 x 768, но не более высокие настройки).

Устранение неполадок печати/экспорта на уровне системы

Если невозможно выполнить печать/экспорт файла PDF ни из одной программы, обратитесь к производителю принтера или в службу технической поддержки Apple или Microsoft. Перед обращением за помощью обязательно проверьте физическое подключение принтера или компьютера, так как зачастую неполадки можно устранить повторным соединением кабелей.

Также отметьте недавние изменения в системе, которые могут повлиять на процесс печати/экспорта. Например, вспомните, выполняли ли вы любое из указанных ниже действий?

  • Модернизация аппаратного обеспечения, добавление или удаление аппаратных компонентов
  • Установка, обновление или удаление программного обеспечения
  • Установка или удаление шрифтов
  • Подключение к сети
  • Очистка жесткого диска или удаление неиспользуемых файлов
  • Обнаружение случайных системных ошибок или ошибок в других приложениях

Часто неполадки печати являются следствием изменений в системе. Запишите и сохраните список изменений, внесенных в систему, в качестве ресурса для устранения неполадок печати и других ошибок.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет