Узнайте, как устранить неполадки в поврежденных или испорченных файлах InDesign.

Документ InDesign может быть поврежден только в том случае, если при работе с данным документом возникает ошибка или другое непредвиденное поведение. InDesign имеет функцию автоматического восстановления документа, которая может предотвратить повреждение, вызванное вследствие системных сбоев или отключения электропитания. Однако эта функция не сможет предотвратить повреждение, вызванное другими проблемами на уровне системы, такими как конфликты программного обеспечения, из-за недостаточного свободного пространства на диске или по причине заражения системы вирусами. Это руководство по поиску и устранению неполадок поможет выявить и устранить неполадки в поврежденных документах InDesign. Оно также поможет выявить и устранить неполадки на уровне системы, которые связаны с повреждением документа, но вызваны по другим причинам.

Устранение неполадок на уровне системы

Неполадки на уровне системы могут вызывать ошибки и другое непредвиденное поведение. Перед тем как сделать предположение о том, что документ поврежден, убедитесь в том, что в используемой системе отсутствуют проблемы. Перед выполнением приведенных ниже процедур по устранению неполадок в поврежденных документах, рекомендуем, например, запустить утилиту восстановления диска, затем при повторном открытии документа убедиться, что проблема устранена.

Для Windows: см. «Проверка жесткого диска на наличие ошибок».

Для Mac OS: см. «Разрешение проблем при запуске и проведение обслуживания диска».

Устранение неполадок с поврежденным документом

Выполните следующие шаги по порядку. Выполняйте приведенные шаги до тех пор, пока проблема не будет устранена. 

Примечание.

По завершении выполнения каждого из шагов по устранению неполадок, перезапустите InDesign и откройте документ, чтобы убедиться, что проблема устранена. Откройте документ следующим образом:

Нажмите «Файл» > «Открыть», выберите необходимый документ, после чего нажмите «Копировать». Сохраните документ повторно, присвоив ему новое имя, затем убедитесь, что проблема устранена.

1. Создайте резервную копию документа.

Прежде чем приступить к процедуре устранения неполадок, создайте резервную копию поврежденного документа. Для выполнения некоторых из следующих шагов необходимо изменить или удалить информацию в документе. Резервная копия документа позволяет быстро восстановить информацию. Если документ находится на сетевом диске или съемном носителе (например, компакт-диске или флеш-накопителе), переместите резервную копию документа на локальный диск.

2. Установите последнее обновление InDesign.

  • В пункте InDesign выберите Справка >Обновления.

-или-

-или-

3. Повторно создайте файлы установок.

InDesign хранит информацию о внешних модулях, функциях и самом приложении в следующих файлах установок: InDesign, SavedData и InDesign Defaults. Поврежденный файл установок InDesign может вызвать непредвиденное поведение документа InDesign. Можно легко определить, связана ли проблема с файлами установок путем их повторного создания.

Примечание.

При повторном создании файлов установок InDesign устанавливаются значения по умолчанию, поэтому все пользовательские настройки, связанные со старыми файлами установок, будут утеряны. Чтобы сохранить пользовательские настройки, переименуйте старые файлы установок.

Чтобы повторно создать файлы установок InDesign, выполните следующее:

  1. Завершите работу с InDesign.

  2. Перезапустите InDesign и удерживайте соответствующие комбинации клавиш в соответствии с установленной ОС:

    • Mac OS X: Control + Option +Command + Shift
    • Windows: Control + Alt + Shift
  3. Когда вам будет предложено удалить файлы установок InDesign, нажмите «Да». InDesign запустится с настройками по умолчанию и восстановленными файлами установок.

    Примечание.

    Если вам не будет предложено удалить файлы установок, можно удалить их вручную.

  4. Откройте документ и убедитесь, что проблема устранена. Если проблема не устранена, перейдите к следующему шагу 4 ниже.

    Удалите или переименуйте файлы установок вручную

    В качестве альтернативы можно выполнить следующее:

    • Удалите файлы установок вручную (например, если при запуске InDesign вам не будет предложено удалить установки, как описано в предыдущем шаге)

    -или-

    • Переименуйте файлы установок вручную (например, если у вас имеются пользовательские настройки, связанные со старыми файлами установок, которые необходимо сохранить)

    Найдите вашу ОС в приведенной таблице и посмотрите, в каких папках находятся файлы.

    ОС Расположение файлов установок
    Mac OS X

    InDesign Defaults

    Users/[user]/Library/Preferences/Adobe InDesign/Version [version]/[language]/InDesign Defaults

    InDesign SavedData

    Users/[пользователь]/Library/Caches/Adobe InDesign/Version [версия]/InDesign SavedData

    Windows XP

    InDesign Defaults

    C:\Documents and Settings\[user]\Application Data\Adobe\InDesign\Version [version]\InDesign Defaults

    По умолчанию скрыта. Узнайте, как отобразить скрытые файлы.

    InDesign SavedData

    C:\Documents and Settings\[user]\Local Settings\Application Data\Adobe\InDesign\Version[version]\Caches\InDesign SavedData

    Windows 7/8

    InDesign Defaults

    C:\Users\[user]\AppData\Adobe\InDesign\Version[version]\[language]\InDesign Defaults

    По умолчанию скрыта. Узнайте, как отобразить скрытые файлы.

    InDesign SavedData

    C:\Users\[user]\AppData\Local\Adobe\InDesign\Version[version]\[language]\Caches\InDesign SavedData

    После того как файлы удалены или переименованы, перезапустите InDesign для восстановления файлов установок, после чего откройте документ и убедитесь, что проблема устранена.

    Если проблема не устранена, можно восстановить исходные установки после удаления новых файлов и назначения исходных имен предыдущим файлам установок.

4. Сохраните документ в формате IDML (для InDesign CS4 и более поздних версий) или INX (для InDesign CS3 и более ранних версий).

  1. Откройте файл в InDesign.

  2. Выберите «Файл» > «Экспорт».

  3. В меню «Текст», в пункте «Сохранить как» выберите «InDesign Markup» (для CS4 и более поздних версий) или«InDesign Interchange» (для CS3 и более ранних версий).

  4. Задайте имя и расположение для файла, после чего нажмите «Сохранить».

  5. В InDesign откройте экспортированный файл IDML или INX.

    Если проблема устранена, продолжайте использовать файл IDML или INX вместо исходного документа. Если проблема не устранена, перейдите к следующему шагу.

5. Устраните неполадки с преобразованным документом в исходной программе.

Если документ был преобразован в QuarkXPress, Adobe PageMaker или предыдущей версии InDesign, попробуйте выполнить повторное преобразование документа. Если неполадка не устранена, перед повторным преобразованием проверьте исходный документ на повреждения в исходном приложении. Поврежденный документ PageMaker или QuarkXPress вероятнее всего останется поврежденным после преобразования.

Для получения более подробной информации об устранении неполадок в поврежденных публикациях PageMaker, см. «Устранение неполадок в поврежденных публикациях». Для получении более подробной информации об устранении неполадок с поврежденным документом QuarkXPress, посетитеофициальный веб-сайт Quark.

6. Удаление стилей символов и абзацев.

Стили, созданные в InDesign или импортируемые с файлами, созданными в других приложениях, могут быть повреждены. Чтобы убедиться, что проблема заключается в этом, удалите стили, после чего сохраните документ повторно.

Для удаления стилей символов:

  1. В InDesign откройте документ и выберите «Текст» > «Стили символов».

  2. В меню палитры «Стили символов» выберите все стили, за исключением [без стиля символа]. Для выбора нескольких стилей, нажмите и удерживайте Ctrl (Windows) или Command (Mac OS) при выделении стилей.

  3. В меню палитры «Стили символов» выберите «Удалить стили».

  4. Сохраните документ и убедитесь, что проблема устранена. Если проблема не устранена, попробуйте удалить стили абзацев.

Для удаления стилей абзацев:

  1. В InDesign откройте документ и выберите «Текст» > «Стили абзацев».

  2. В меню палитры «Стили абзацев» выберите все стили, за исключением «[без стиля абзаца]». Для выбора несколких стилей нажмите и удерживайте Ctrl (Windows) или Command (Mac OS) при выделении стилей.

  3. В меню палитры «Стили абзацев» выберите «Удалить стили».

  4. Сохраните документ и убедитесь, что проблема устранена. Если проблема не устранена, перейдите к 7 шагу ниже.

7. Проверка шрифтов на повреждения.

Чтобы определить, связана ли проблема с поврежденным шрифтом, замените все шрифты, используемые в документе, на стандартный шрифт, например, Arial или Times New Roman.

Если после изменения шрифтов неполадка не устранена, это значит, что она не связана со шрифтом. Если неполадка больше не возникает, то исходный шрифт или шрифты могут быть устаревшими или поврежденными. Попробуйте переустановить исходные шрифты или запросите обновленную версию у производителя шрифтов.

8. Проверьте объекты и графику на повреждения.

Попробуйте определить, является ли конкретный элемент на странице-шаблоне или на странице документа источником проблемы. Чтобы изолировать элементы, необходимо сначала удалить пустые страницы и ненужные элементы, например, элементы из области монтажного стола или скрытого слоя.

Чтобы удалить страницы:

  1. В InDesign откройте документ и выберите «Окно» > «Страницы».

  2. В меню палитры «Страницы» используйте инструмент «Выбор» для выделения страниц, которые необходимо удалить. Нажмите клавишу Ctrl (Windows) или Command (Mac OS) для выбора нескольких страниц, или нажмите клавишу Shift для выбора непрерывного диапазона страниц.

    Удаление страниц
    В палитре «страницы» выберите страницы, которые необходимо удалить.

  3. В меню палитры «Страницы» щелкните значок «Удалить».

  4. Нажмите кнопку «ОК», чтобы подтвердить удаление.

Если после удаления нескольких страниц неполадка не устранена, удалите часть оставшихся страниц и сохраните документ, присвоив ему новое имя. Затем попробуйте повторно создать проблему.

  • Если неполадка не устранена, то одна из оставшихся страниц может содержать поврежденный элемент. Продолжайте удалять страницы до тех пор, пока не обнаружите страницу, которая вызывает проблему.
  • Если неполадка больше не возникает, то одна из удаленных страниц могла содержать поврежденный элемент. Заменяйте удаленные страницы до тех пор, пока не будет обнаружена страница, которая вызывает проблему.

После того страница, вызывающая проблему, определена, удалите и замените ее элементы, включая импортированную графику, объекты, нарисованные в InDesign, а также текстовые фреймы на странице.

9. Скопируйте элементы на странице в новый документ.

Копирование элементов на странице в новый документ позволяет избежать возникновения структурных (внутренних) повреждений. Если после копирования элементов на странице в новый документ неполадка не устранена, удаляйте элементы по одному и постарайтесь определить, какой из элементов является источником проблемы.

Чтобы скопировать элементы на странице в новый документ:

  1. В InDesign откройте исходный документ.

  2. Выберите «Файл» > «Новый» и нажмите «ОК» в диалоговом окне «Новый документ».

  3. Выберите «Окно» > «Мозаика», чтобы отобразить оба документа.

  4. Щелкните по исходному документу для его вызова.

  5. Выберите «Окно» > «Страницы» для вызова меню палитры «Страницы».

  6. Перетащите страницу или разворот в окно с новым документом. InDesign скопирует страницу или разворот в новый документ, добавляя при необходимости страницы.

  7. Сохраните новый документ , присвоив ему новое имя (отличное от имени исходного документа), и попытайтесь повторно создать проблему.

    • Если неполадка не устранена, в таком случае повреждение не является структурным (например, на страницах-шаблонах или страницах документа). Удаляйте элементы по очереди, чтобы определить, является ли один из элементов источником проблемы.
    • Если неполадка устранена, то, возможно, повреждение является структурным. Повторите шаги с 4 по 7 для каждой из оставшихся страниц или разворота.

10. Получите еще одну копию документа.

Если вы получили документ по электронной почте, FTP или со съемного носителя (например, компакт-диска), то постарайтесь получить копию иным способом. Или отправьте документ повторно. Поврежденный носитель или возникновение неполадок при передаче файла по электронной почте могут повредить документ. Если документ отправляется по электронной почте, попросите отправителя сжать его (например, при помощи WinZip или Smith Micro's StuffIt) для защиты данных.

Другие советы

Неполадка не устранена? Обратите внимание на эти рекомендации.

Удалите внешние модули сторонних разработчиков.

Попробуйте удалить внешние модули сторонних разработчиков InDesign. Иногда внешние модули могут приводить к повреждению файла. См. «Устранение неполадок в работе с внешними модулями сторонних разработчиков InDesign».

Попробуйте открыть документ на другом компьютере.

Путем переключения на другую системную среду можно удалять переменные, которые являются источником проблемы.

Посетите форумы пользователей продукции Adobe.

Вы не одни! Возможно, другие пользователи, у которых возникли подобные проблемы при работе с документом, опубликовали ее решение. См. форумы пользователей InDesign.

Создайте документ повторно.

Если прочие способы не помогают, повторно создайте документ. Старайтесь чаще создавать резервные копии и периодически проверять документ, чтобы убедиться в том, что импортированные элементы не вызывают проблем.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет