При помещении графического объекта в макете отображается версия файла с разрешением экрана, позволяющая просмотреть и расположить его. Однако можно выполнить связывание или встраивание текущего графического файла.

  • Связанный графический объект привязывается, однако хранится независимо от документа, не увеличивая его размер. Он может быть изменен при помощи инструментов трансформирования и эффектов, однако нельзя выбирать и редактировать его отдельные компоненты. Связанный графический объект можно использовать многократно без значительного увеличения размера документа. Все связи можно обновить за один раз. При экспорте или печати извлекается исходное изображение, создается конечный выходной файл с полным разрешением оригинала.

  • Встроенный графический объект копируется в документ в полном разрешении, приводя к увеличению его размеров. Есть возможность управления версиями и обновлением файла в произвольный момент времени. Документ становится самодостаточным после встраивания в него графического объекта.

Чтобы определить, является графический объект связанным или встроенным, или изменить это состояние, воспользуйтесь палитрой «Связи».

Если помещаемое растровое изображение имеет размер не более 48 КБ, InDesign автоматически встраивает в макет изображение с полным разрешением, а не версию низкого разрешения. InDesign отображает такие изображения на палитре «Связи», позволяя управлять версиями и обновлять файл в любой момент времени, однако эта связь не является необходимой для оптимального вывода.

Примечание.

При перемещении документа в другую папку или на другой диск (например, при передаче поставщику услуг) обязательно перенесите туда же связанные графические файлы, они не содержатся внутри документа. Копирование всех связанных файлов можно выполнять автоматически при помощи функций упаковки и предпечатной проверки.

Все файлы, помещенные в документ, перечислены в палитре «Связи». Сюда входят как локальные файлы (расположенные на диске), так и ресурсы, расположенные на сервере. Файлы, вставленные с веб-сайта в Internet Explorer, в этой палитре отсутствуют.

В палитре «Связи» программы InCopy также отображаются связанные материалы. При выборе связанного материала на палитре «Связи» в разделе «Информация о связи» отображается такая информация, как количество примечаний, управляемое состояние и состояние отслеживаемых изменений.

Палитра «Связи»
Палитра «Связи»

A. Столбцы категорий B. Показать/скрыть информацию о связи C. Значок изменения одного или нескольких экземпляров D. Значок изменения E. Значок отсутствующей связи F. Значок встроенной связи 

Если один графический объект появляется в документе несколько раз, связи группируются под треугольником раскрытия в палитре «Связи». Если связанный графический объект EPS или документ InDesign имеет связи, эти связи тоже группируются под треугольником раскрытия.

Связанный файл может отображаться в палитре «Связи» следующим образом.

Обновлен

Обновленный файл в колонке состояния пуст.

Изменен

Этот значок означает, что файл на диске имеет более новую версию. Например, этот значок появляется, если после импорта графического объекта Photoshop в InDesign исходный графический объект был изменен и сохранен в Photoshop.

Немного другой значок изменения появляется после изменения графического объекта и обновления только одного или нескольких экземпляров.

Отсутствует

Графический объект отсутствует в местоположении, из которого он был импортирован, хотя он может находиться в другом месте. Отсутствующие связи могут появиться, если после импорта исходный файл был удален или перемещен в другую папку или на другой сервер. Имеет ли файл новую версию, определить невозможно до тех пор, пока он не будет помещен в прежнее место. Печать и экспорт документа с этим значком не могут быть выполнены с полным разрешением.

Встроен

Встраивание содержимого связанного файла приостанавливает работу с данными для этой связи. Если для выбранной связи активна операция редактирования «на месте», этот параметр недоступен. Отмена встраивания файла восстанавливает работу по управлению этой связью.

Если связанный объект не отображается на определенной странице документа, следующие коды указывают место его отображения: МС (монтажный стол), СШ (страница-шаблон), ВТ (вытесненный текст) и СТ (скрытый текст).

Видео с инструкцией по использованию палитры «Связи» см. по адресу _ru www.adobe.com/go/lrvid4027_id.

InDesign Secrets представляет видеоролик о методах использования палитры «Связи»: Экономия времени при использовании палитры «Связи».

  • Для отображения палитры «Связи» выберите меню «Окно» > «Связи». Все связанные и автоматически встроенные файлы идентифицируются по именам.
  • Для просмотра связанного графического объекта выберите связь в палитре «Связи» и нажмите кнопку «Перейти к связанному элементу» , нажмите номер страницы связи в колонке «Страница» или выберите «Перейти к связанному элементу» в меню палитры «Связи». InDesign центрирует область отображения вокруг выделенного графического объекта. Для просмотра скрытого объекта необходимо указать слой (или условие для привязанного объекта).
  • Для разворачивания или сворачивания вложенных связей нажмите значок треугольника слева от связи. Вложенные связи появляются, если один графический объект отображается в документе несколько раз или если связанный графический объект EPS или документ InDesign имеет связи.
  • Для сортировки связей в палитре нажмите название категории, по которой необходимо отсортировать связи, в верхней части палитры «Связи». Снова щелкните ту же категорию для сортировки в обратном порядке. Например, после нажатия категории «Страница» связи отображаются в порядке с первой по последнюю страницу. Если нажать категорию «Страница» еще раз, связи сортируются в обратном порядке: с последней по первую страницу. Используйте параметры палитры для добавления столбцов к палитре «Связи».

Для отображения дополнительных сведений о графических объектах можно добавить на палитру «Связи» дополнительные категории, например «Дата создания» и «Слой». Для каждой категории можно задать отображение сведений в виде столбца на палитре «Связи» и в разделе «Информация о связи» в нижней части палитры «Связи».

  1. Выберите «Параметры палитры» в меню палитры «Связи».
  2. Чтобы добавить столбцы на палитру «Связи», установите соответствующие флажки в разделе «Показать столбец».

    «Папка 0» - это папка, в которой находится связанный файл; «Папка 1» - это папка, в которой находится «Папка 0» и т. д.

  3. Для отображения сведений в разделе «Информация о связи» в нижней части палитры «Связи», установите соответствующие флажки в разделе «Показать в Информации о связи».
  4. Нажмите кнопку «ОК».

Можно менять порядок столбцов, выбрав один из них и перетащив его в новое положение. Чтобы изменить ширину столбца, перетащите его границы. Чтобы отсортировать связи по какой-либо категории в порядке возрастания, нажмите название этой категории. Нажмите еще раз, чтобы отсортировать в порядке убывания.

  1. Выберите «Параметры палитры» в меню палитры «Связи».
  2. В поле «Размер строки» выберите «Малые строки», «Обычные строки» или «Большие строки».
  3. В поле «Миниатюры» можно указать необходимость отображения миниатюрных изображений графических объектов в столбце имени и в разделе «Информация о связи» в нижней части палитры «Связи».
  4. Нажмите кнопку «ОК».

В разделе «Информация о связи» палитры «Связи» указана информация о выбранном связанном файле.

Примечание.

Чтобы изменить информацию в разделе «Информация о связи» палитры «Связи», выберите «Параметры палитры» в меню палитры «Связи» и установите соответствующие флажки в столбце «Показать в Информации о связи».

  1. Дважды щелкните связь или выберите связь и щелкните значок «Показать/скрыть информацию о связи» (треугольник в левой части палитры).

Если связанный или встроенный файл содержит метаданные, их можно просмотреть в палитре «Связи». Редактирование или замещение метаданных, относящихся к связанному файлу, невозможно.

  1. Выберите файл на палитре «Связи», затем в меню палитры выберите пункт «Служебные программы» > «Информация о файле XMP».

Встраивание изображения в документ

Вместо помещения в документ связи с файлом можно встроить (сохранить) сам файл. При встраивании файла связь с оригиналом нарушается. Поскольку связь с исходным файлом отсутствует, палитра «Связи» не будет сигнализировать об изменении оригинала и не сможет автоматически его обновлять.

Встраивание файла увеличивает размер файла документа.

Встраивание связанного файла

  1. Выделите файл на палитре «Связи».
  2. Выполните одно из следующих действий:
    • Выберите в меню палитры «Связи» команду «Встроить ссылку».

    • Если существует несколько экземпляров файла, выберите «Встроить все экземпляры [имя файла]» в меню палитры «Связи». Чтобы встроить только один экземпляр, выберите необходимый экземпляр и нажмите «Встроить ссылку».

Файл остается в палитре «Связи» и помечается значком встроенной связи .

Примечание.

Для текстового файла, который отображается в палитре «Связи», выберите пункт «Отменить связь» в меню палитры «Связи». При встраивании текстового файла его имя удаляется из палитры «Связи».

Отмена встраивания связанного файла

  1. Выделите в палитре «Связи» один или несколько встроенных файлов.
  2. Выполните одно из следующих действий:
    • Выберите в меню палитры «Связи» пункт «Отменить встраивание ссылки». Если существует несколько экземпляров файла, выберите «Отменить встраивание всех экземпляров [Имя файла]» в меню палитры «Связи».

    • Нажмите кнопку «Связать заново»  или выберите пункт «Связать заново» в меню палитры «Связи».

  3. Выберите связь с исходным файлом или папкой, которую InDesign создал для встроенных данных, сохраненных в документе.

Палитра «Связи» позволяет проверить состояние любой связи и заменить файлы обновленными или альтернативными.

При обновлении или повторном установлении связи с файлом (повторном связывании) все трансформации, выполненные в программе InDesign, сохраняются (если выбран параметр «Сохранять размеры при повторном создании связей» в разделе установок «Обработка файлов»). Например, был импортирован квадратный графический объект, который затем был развернут на 30°. Если его связать заново с неизмененным исходным изображением, InDesign развернет его на 30°, приводя заменяемое изображение в соответствии с макетом.

Примечание.

Помещаемые EPS-файлы могут содержать ссылки OPI, которые отображаются в палитре «Связи». Не связывайте заново ссылки OPI с файлами, кроме тех, которые изначально предназначались автором EPS-файла, поскольку это может вызвать проблемы при загрузке шрифтов и цветоделении.

Выбор метода масштабирования заново связываемых графических объектов

При замене одного графического объекта другим его размеры могут быть либо сохранены, либо заменены размерами нового объекта из другого исходного файла.

  1. Выберите «Редактирование» > «Установки» > «Обработка файлов» (Windows) или «InDesign» > «Установки» > «Обработка файлов» (Mac OS).

  2. Чтобы изображения сохранили размеры заменяемых изображений, выберите «Сохранять размеры изображения при повторном создании связей». Отмените выбор этого параметра, чтобы заново связываемые изображения сохранили свой текущий размер.

InDesign вначале ищет отсутствующую связь в папке, в которой расположен файл, на который указывала связь во время текущего сеанса. Затем выполняется поиск в папке, в которой расположен документ. Если связь не была найдена, выполняется поиск в корневой папке документа.

Измененные связи также называются «устаревшими» связями.

  1. Выполните в палитре «Связи» одно из следующих действий.
    • Для обновления одной или нескольких связей, помеченных значком , выделите их. Нажмите кнопку «Обновить связь»  или выберите «Обновить связь» в меню палитры «Связи».

    • Для обновления всех измененных связей выберите «Обновить все связи» в меню палитры «Связи» или выделите измененную связи и щелкните кнопку «Обновить связь», удерживая нажатой клавишу Alt (Windows) или Option (Mac OS).

    • Для обновления только одной связи с графическим объектом, который отображается в документе в нескольких местах, выберите соответствующую дочернюю связь и нажмите «Обновить связь». Выбрав «родительскую» связь, можно обновить все связи измененного графического объекта.

  1. Выберите связь в палитре «Связи» и нажмите кнопку «Связать заново»  или нажмите «Связать заново» в меню палитры «Связи». Выделив «родительскую» связь нескольких экземпляров, выберите «Связать заново все экземпляры [Имя файла]» в меню палитры «Связи».

    Если материал не извлечен, повторное создание связей в управляемых материалах отключено.

  2. Для поиска программой InDesign файлов в папке, имена которых совпадают с именами других отсутствующих связанных файлов, выберите в появившемся диалоговом окне «Поиск отсутствующих связей в этой папке». Если этот параметр не выбран, будет заново связано только выделенное изображение.
  3. Выберите Показать параметры импорта для управления процедурой импорта нового исходного файла.
  4. Найдите и дважды щелкните новый исходный файл.
  5. Задайте параметры импорта, если был установлен флажок «Показать параметры импорта» (см. раздел Параметры импорта графических объектов).
  1. Чтобы восстановить отсутствующую связь, выделите в палитре «Связи» связь, помеченную значком , и нажмите кнопку «Связать заново» .
  2. Чтобы заново связать отсутствующий файл, который отображается в указанной папке, выберите в появившемся диалоговом окне «Поиск отсутствующих связей в папке». Найдите и дважды щелкните файл.

По умолчанию InDesign проверяет наличие отсутствующих связей и пытается разрешить их при открытии документа. Два параметра установки позволяют InDesign автоматически проверять наличие и находить отсутствующие связи при открытии документа.

Проверка связей перед открытием документа

Если этот параметр выключен, InDesign сразу же открывает документ и после определяет состояние связей: обновленные, отсутствующие или измененные. Если этот параметр включен, InDesign проверяет наличие измененных и отсутствующих связей.

Поиск отсутствующих связей перед открытием документа

Если этот параметр выключен, InDesign не будет пытаться разрешить отсутствующие связи. Этот параметр можно отключить, если связи замедляют работу сервера или если появляются непредусмотренные связи. Этот параметр недоступен, если отключена «Проверка связей перед открытием документа».

Поиск отсутствующих связей

Команда «Поиск отсутствующих связей» позволяет выполнять поиск и разрешать отсутствующие связи в документе. Эта команда может оказаться полезной, если отсутствующие связи появляются при отключенном параметре поиска отсутствующих связей при открытии документа. Эта команда может оказаться полезной при выполнении подключения к серверу, где хранятся изображения, после открытия документа.

  • Для изменения настроек связей откройте раздел «Обработка файлов» в диалоговом окне «Установки» и при необходимости выберите параметры «Проверять связи перед открытием документа» и «Находить отсутствующие связи перед открытием документа».
  • Для попытки разрешения отсутствующих связей в программе InDesign выберите «Служебные программы» > «Поиск отсутствующих связей» в меню палитры «Связи».

    Эта команда недоступна, если в документе нет отсутствующих связей.

  1. Выберите «Обработка файлов» в диалоговом окне «Установки».
  2. В меню «Папка повторного создания связей по умолчанию» выберите один из перечисленных ниже параметров и нажмите кнопку «OК»:

    Последняя папка повторного создания связей

    При выборе этого параметра отображается последняя использованная папка, которая была указана при повторном создании связей, соответствующая поведению InDesign CS3.

    Исходная папка связи

    При выборе этого параметра отображается исходное положение связанного файла, соответствующего поведению InDesign CS2 или более ранней версии.

Команда «Копирование связей в» позволяет копировать графические файлы в другую папку и перенаправлять связи в скопированные файлы. Эта команда особенно удобна для перемещения файлов на другой накопитель, например при перемещении файлов с DVD-диска на жесткий диск.

  1. Выделите связи с копируемыми файлами и выберите «Служебные программы» > «Копировать связи» в меню палитры «Связи».
  2. Укажите папку, в которую необходимо скопировать связанные файлы, и нажмите кнопку «Выбрать».

При использовании команды «Связать заново с папкой» можно указать папку с файлами, имена которых совпадают с устаревшими связями. Например, если текущие связи указывают на изображения с низким разрешением, можно указать другую папку, содержащую изображения с высоким разрешением. Можно указать другие расширения для файлов, что позволяет менять связи, например, с .jpg на .tiff.

Если материал не извлечен, команда «Связать заново с папкой» недоступна в управляемых материалах InCopy.

  1. Выберите одну или несколько связей в палитре «Связи».
  2. Выберите «Связать заново с папкой» в меню палитры «Связи».
  3. Укажите местоположение новой папки.
  4. Чтобы использовать другое расширение, выберите «Совпадение по имени файла, кроме расширения» и укажите новое расширение (AI, TIFF или PSD).
  5. Нажмите кнопку «Выбрать».

Команда «Связать повторно с расширением файла» позволяет заменять изображения на основе файловых расширений. Например, можно заменить изображения JPEG в документе на файлы PSD. Файлы с другими расширениями должны располагаться в той же папке, что и заменяемые связанные файлы.

  1. Убедитесь, что файлы с другими расширениями находятся в той же папке, что и исходные файлы.
  2. Выберите одну или несколько связей в палитре «Связи».
  3. Выберите «Связать повторно с расширением файла» в меню палитры «Связи».
  4. Укажите расширение файла для замены и щелкните «Связать повторно».

Замена импортированного файла с помощью команды «Поместить»

  1. Выполните одно из следующих действий:
    • Чтобы заменить содержимое графического фрейма (например, импортированного графического объекта), выделите его инструментом «Выделение» .

      Чтобы заменить содержимое графического фрейма (например, импортированного графического объекта), выделите изображение с помощью инструмента «Позиционирование».

    • Для замены содержимого текстового фрейма щелкните точку ввода в текстовом фрейме, используя инструмент «Текст», и выберите «Редактировать» > Выбрать все.

  2. Выберите меню «Файл» > «Поместить».
  3. Найдите и выберите новый файл.
  4. Убедитесь, что установлен параметр «Заменить выделенный элемент», и нажмите кнопку «Открыть».
  5. Нажмите кнопку «Открыть».

Можно копировать полный путь связанных изображений или путь стиля платформы. Копирование полного пути изображения удобно для уведомления членов команды о месте размещения иллюстраций. Например, можно скопировать полный путь и вставить его в сообщение электронной почты. Копирование пути стиля платформы удобно при работе со сценариями или для указания полей изображений при объединении данных.

  1. Выберите связь на палитре «Связи».
  2. В меню палитры «Связи» выберите «Копировать сведения» > «Копировать полный путь» или «Копировать путь стиля платформы».
  3. Вставьте путь.

Редактирование исходного графического объекта

С помощью команды «Редактировать оригинал» можно открывать и редактировать большинство графических файлов в приложениях, где они были созданы. После сохранения исходного файла документ, содержащий связь с ним, будет обновляться с каждой новой версией.

Примечание.

Если в InDesign извлечь и выбрать управляемый графический фрейм (экспортированный в InCopy), то графический файл откроется не в самом InDesign, а в InCopy.

Редактирование исходного графического объекта в приложении по умолчанию

По умолчанию программа InDesign предоставляет выбор приложения для открытия исходного объекта операционной системе.

  1. Выделите одно или несколько изображений на странице или в палитре «Связи».
  2. Выполните одно из следующих действий:
    • В палитре «Связи» нажмите кнопку «Редактировать оригинал» .

    • Выберите «Редактирование» > «Редактировать оригинал».

  3. После внесения изменений в исходном приложении сохраните файл.

Редактирование исходного графического объекта в другом приложении

  1. Выберите изображение.
  2. Выберите меню «Редактирование» > «Редактировать с помощью» и укажите приложение, с помощью которого открыть файл. Если необходимого приложения нет в списке, выберите «Другое», чтобы найти его.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет