Для получения подробных сведений и инструкций перейдите по указанным ниже ссылкам.

Способы импорта и верстки XML

После импорта XML-данных содержимое отображается в виде элементов на панели «Структура» (основные составные элементы XML). При импорте XML-данных новые фреймы и страницы не создаются.

Присоединение и объединение

Импорт XML-данных может быть выполнен одним из двух методов: присоединением или объединением. Выбор метода зависит от используемого рабочего процесса (ручной или автоматический), способа обработки существующего содержимого документа, а также от необходимости использования для обработки импортируемых данных дополнительных параметров.

Режим присоединения

При присоединении импортируемого содержимого существующая структура и содержимое документа не изменяются. Элементы, представляющие новое XML-содержимое, добавляются в нижнюю часть панели «Структура».

Режим объединения

При объединении импортируемого содержимого InDesign сравнивает входящий XML со структурой и именами элементов, которые уже имеются в документе. Если элементы совпадают, то импортированные данные замещают существующее содержимое документа и добавляются во фреймы (или шаблонные элементы) макета, имеющие правильную разметку. Элементы, для которых имя и положение в иерархии не найдены, помещаются на панель «Структура», чтобы их можно было разместить вручную. Режим объединения не только позволяет автоматизировать верстку, но и реализует при импорте большее число дополнительных параметров, включая возможность фильтрации входящего текста и клонирования элементов для повтора данных.

Верстка содержимого

Следующее действие после импорта XML-содержимого — его размещение в документе. Содержимое может быть размещено вручную, автоматически или при помощи сценариев. Выбор метода зависит от импортируемого содержимого, макета документа и применяемого рабочего процесса.

Размещение содержимого вручную

Данный способ заключается в перетаскивании элементов с панели «Структура» на страницы документа или внутрь фреймов. Он почти не требует настройки и планирования и хорошо подходит для импорта содержимого различных типов или при получении содержимого из нескольких источников.

Размещение XML-содержимого после импорта вручную
Размещение XML-содержимого после импорта вручную

Автоматическое размещение содержимого

Процесс размещения XML-данных в макете можно автоматизировать, выполнив предварительную подготовку. Для этого необходимо сначала подготовить документ, создав для входящих XML-данных размеченные тегами шаблонные фреймы. Программа InDesign размещает импортируемые XML-данные в документе автоматически, если XML-структура и имена тегов входящего содержимого совпадают с именами тегов и структурой шаблонных фреймов. InDesign может также клонировать элементы для обработки повторяющихся данных (например, списков адресов и материалов каталогов). Автоматическая верстка применяется как часть структурированного рабочего процесса, позволяя сократить время выполнения операций и повысить производительность.

Выделенный шаблонный фрейм размечен элементом «Материал»
Выделенный шаблонный фрейм (сверху) размечен элементом «Материал». При импорте XML-данных (снизу) шаблонный фрейм элемента «Материал» автоматически заполняется содержимым элемента «Материал».

Примечание.

InDesign распознает специальные атрибуты пространства имен, которые могут указывать на стили абзацев и символов в XML. Дополнительная информация представлена в техническом руководстве по XML.

Об объединении

XML-данные могут быть помещены в документ в режиме объединения или присоединения. Режим объединения позволяет автоматизировать процесс размещения содержимого, а также фильтровать данные в XML-файле, что позволяет размещать только определенные части содержимого.

XML-содержимое следует объединять в следующих случаях.

  • Документ содержит шаблонные фреймы, и их в результате импорта необходимо заполнить XML-содержимым.

  • Документ включает XML-содержимое, и в результате импорта его необходимо заменить XML-содержимым.

  • Документ не содержит XML-структуры, и InDesign должен заменить корневой элемент по умолчанию корневым элементом входящего XML-файла.

В режиме объединения входящие XML-данные сравниваются с элементами, которые уже содержатся в документе. Программа исследует файл, один за другим сравнивая входящие элементы с существующими элементами следующим образом:

1. В InDesign сравнение начинается с корневого элемента

  • Если корневые элементы импортированного XML-файла и документа InDesign не совпадают и на панели «Структура» не содержится существующей структуры, то InDesign подменяет корень документа InDesign на корень входящего XML-файла и импортирует этот файл.

  • Если корневые элементы не совпадают и на панели «Структура» уже содержатся элементы, InDesign присоединяет файл к концу существующей структуры.

  • Если корневые элементы совпадают, то процесс объединения (и сопоставления) продолжается дальше.

2. В InDesign производится переход к элементу, расположенному под корневым

Начиная с элемента, расположенного сразу под корневым во входящем XML-файле, выполняется поиск совпадающего элемента на панели «Структура». Чтобы обеспечить совпадение, имена входящего XML-элемента и существующего элемента на панели «Структура» должны совпадать, причем оба элемента должны находиться на одном и том же уровне в иерархии.

  • Если обнаружен совпадающий элемент на панели «Структура», он замещается элементом из входящего XML-файла.

  • В противном случае входящий элемент вставляется в начальной точке поиска. Например, если поиск начинается сразу под корневым элементом и совпадение не обнаружено, то входящий элемент помещается сразу под корневым.

3. В InDesign продолжается сравнение элементов

InDesign продолжает один за другим сравнивать входящие XML-данные с существующей структурой. Начальная точка поиска на панели «Структура» в ходе поиска изменяется. Каждый новый поиск начинается сразу под последним вставленным или замещенным элементом. Поиск всегда производится вниз от текущей позиции, элементы никогда не помещаются над предыдущим вставленным или замененным.

Импорт и присоединение XML-данных

При импорте XML-содержимого новые элементы помещаются на панель «Структура», откуда перетаскиванием могут быть перемещены в документ.

  1. Откройте документ InDesign или создайте новый для получения XML-содержимого.
  2. Откройте панель «Структура» (выберите меню «Просмотр» > «Структура» > «Показать структуру»).
  3. Выберите «Файл» > «Импорт XML» (или выберите команду «Импорт XML» в меню панели «Структура»), а затем выберите XML-файл, который необходимо импортировать.
  4. Выберите параметр «Показать параметры импорта XML».
  5. Выберите команду «Присоединить содержимое» и нажмите кнопку «Открыть».
  6. Чтобы связать XML-содержимое с исходным XML-файлом, выберите параметр «Создать связь».

    XML-файл будет добавлен на палитру «Связи», и при каждом его изменении на палитре будет отображаться предупреждающий значок треугольника желтого цвета.

  7. Нажмите кнопку «ОК».

Верстка XML-файла вручную

XML-содержимое можно поместить в макет документа вручную, перетаскивая элементы с панели «Структура» на страницу или в существующие фреймы. При размещении элемента происходит также размещение его дочерних элементов и всех дочерних элементов, расположенных под ними (если они есть).

При помещении элемента в документ на панель «Структура» на его значке появляется характерный ромб синего цвета. Если элемент не был помещен, отображается указывающий на это значок.

Примечание.

Если XML-данные были импортированы с использованием параметра «Объединить содержимое», то некоторые элементы могли быть уже размещены. При объединении импортированного содержимого, если элементы имеют соответствующую структуру и разметку тегами, InDesign автоматически переносит их в существующие фреймы.

  1. Откройте панель «Структура» (меню «Просмотр» > «Структура» > «Показать структуру») и выделите элемент, который необходимо разместить.
  2. Выполните одно из следующих действий для каждого из элементов, помещаемых в документ.
    • Перетащите элемент на страницу. InDesign создает для этого элемента отдельный фрейм.

    • Перетащите элемент в существующий фрейм. Если фрейм имеет содержимое, оно будет заменено XML-данными.

  3. Чтобы отформатировать размещаемые элементы, выполните одно из следующих действий:
    • Преобразуйте XML-теги в стили абзацев, шрифтов, таблиц и ячеек.

    • Примените стили к элементам.

    • Отформатируйте выделенное содержимое вручную, задав параметры текста на палитре управления.

Преобразование XML-тегов в стили

XML-теги только описывают данные и не содержат инструкций по их форматированию. Поэтому после импорта и размещения XML-содержимого его необходимо отформатировать. Это можно сделать, преобразовав XML-теги в стили абзацев, символов, таблиц и ячеек. Например, тег Byline может быть преобразован в стиль символов «Author», чтобы для всего импортированного и размещенного XML-содержимого для тега Byline автоматически назначался стиль символов «Автор». Преобразование тегов в стили облегчает и ускоряет процесс форматирования XML-содержимого после импорта.

Это исключает необходимость форматирования каждого тега. Некоторые элементы могут отсутствовать в макете, а другие, возможно, будет проще отформатировать по очереди. Кроме того, дочерние элементы наследуют стиль абзацев или символов от своих родительских элементов. Поэтому преобразование родительских и дочерних элементов следует производить аккуратно, по отдельности, чтобы не создать путаницы.

Примечание.

Команда «Преобразовать теги в стили» повторно применяет стили по всему документу, что иногда может привести к нежелательным результатам. Тексту, который ранее имел один стиль, может быть назначен другой, согласно его XML-тегу. Если текст был отформатирован, удобнее будет применить стили вручную, избежав нежелательного применения стилей абзацев и символов.

  1. В меню палитры «Теги» или панели «Структура» выберите команду «Преобразовать теги в стили».
    Диалоговое окно «Преобразований тегов в стили»
    В диалоговом окне «Преобразовать теги в стили» для каждого из тегов будет отображено меню стилей.

  2. Выполните одно из следующих действий:
    • Чтобы импортировать стили, теги и определения сопоставлений из другого документа, нажмите «Загрузить», выберите документ и нажмите кнопку «Открыть».

    • Чтобы преобразовать теги в стили по отдельности, щелкните смежную с тегом колонку «Style» и выберите стиль абзацев или символов в появившемся меню (символ конца абзаца указывает в меню на стили абзацев, а символ «А» — на стили символов). Повторите это действие для каждого тега, который необходимо преобразовать.

    • Чтобы автоматически преобразовать теги в стили с теми же именами, выберите «Сопоставлять по имени». Стили с именами, которые совпадают с именами тегов, выделяются в колонке «Style». Тег и стиль совпадают только в том случае, если имеют и одинаковые имена, и регистр символов. Например, H1 и h1 не считаются одинаковыми. Если стили с одинаковыми именами имеются в двух разных группах, команда «Сопоставлять по имени» не будет выполнена — на экран выдается предупреждение о необходимости переименовать один из стилей.

  3. Нажмите кнопку «ОК».

Об автоматической верстке

InDesign позволяет помещать импортированное XML-содержимое в макет автоматически. Для этого сначала создайте шаблонные фреймы или таблицы, добавьте в них теги с именами XML-элементов, которые необходимо в них поместить. Затем в режиме объединения произведите импорт XML-содержимого в шаблонные элементы. Если тегу найдено соответствие по имени и месту в иерархии, InDesign производит объединение, заменяя XML-содержимым существующее содержимое документа.

Этот способ удобен в тех случаях, когда один и тот же макет необходимо использовать для различных наборов содержимого. Например, для еженедельной газеты может изо дня в день использоваться один и тот же макет, но в каждой публикации читателям предлагается различное содержимое.

Для объединения импортируемого XML-файла непосредственно в макет документ должен отвечать следующим требованиям.

  • Фреймы (или таблицы) документа должны быть размечены тегами с именами, совпадающими с элементами импортируемого XML-файла.

  • Документ должен иметь структуру (как показано на панели «Структура»), параллельную структуре импортируемого XML-файла. Иными словами, в обоих файлах элементы с одинаковыми именами должны находиться на одних и тех же уровнях иерархической структуры. Возможно, для этого придется изменить расположение и порядок элементов (и их дочерних элементов) на панели «Структура» или воспользоваться при импорте XML-файла параметром «Применить XSLT».

Примечание.

В режиме объединения InDesign размещает XML-содержимое только в существующих фреймах. Содержимое элемента, которое не помещается в отведенный для него фрейм (или цепочку связанных фреймов), становится вытесненным.

Работа с повторяющимися данными

XML-содержимое является повторяющимся, если в строке несколько раз появляется одна и та же конфигурация элементов, но в каждом экземпляре содержатся уникальные данные. Например, повторяющимися являются записи базы данных. Адреса в таблице базы данных содержат повторяющуюся информацию (имя, улица, дом, город, область, почтовый индекс), относящуюся к разным людям.

При импорте XML-содержимого можно выбрать параметр «Клонировать повторяющиеся элементы текста» в диалоговом окне «Параметры импорта XML». При выборе этого параметра InDesign будет выполнять клонирование повторяющихся элементов структуры. Это позволит объединять в документе повторяющиеся XML-данные, не создавая при этом на панели «Структура» шаблонные элементы (или шаблонный текст во фреймах) для каждой отдельной записи. Например, при импорте XML-списка адресов, содержащего 25 записей, создайте на панели «Структура» соответствующую структуру элементов для одной записи. При импорте списка InDesign произведет клонирование этой структуры, создав соответствующие элементы для всех 25 записей.

При объединении повторяющееся XML-содержимое вставляется в документ единым материалом. Если шаблонные фреймы связаны в цепочку, содержимое будет перетекать из одного фрейма в другой. Если в шаблонном фрейме (фреймах) недостаточно места для размещения XML-содержимого, вытесненный текст можно разместить автоматически, добавив в цепочку еще несколько фреймов. Вручную перетаскивать элементы с панели «Структура» в отдельные фреймы не нужно.

Макет
Связанные шаблонные элементы в макете (слева) и макет после импорта (справа)

Создание шаблонных элементов для автоматической верстки

Для выполнения автоматической верстки XML-содержимого при импорте создайте в документе шаблонные фреймы или таблицы.

Примечание.

В режиме объединения InDesign размещает XML-содержимое только в существующих фреймах. Содержимое, которое в них не помещается, становится вытесненным текстом.

Чтобы обеспечить правильное размещение и форматирование XML-данных на странице, можно также создать шаблонный текст. В шаблонный текст помимо XML-элементов, которые будут отображаться во фрейме, могут быть включены символы табуляции, пробелы и надписи (называемые статическим текстом).

Шаблонный текст с тегами и макет после импорта
Шаблонный текст с тегами (слева) и макет после импорта (справа)

A. Символы перевода строки и статический текст вставлены между элементами B. Шаблонный текст 

Например, при импорте и размещении информации о продукте имя, описание и стоимость продукта могут быть отделены друг от друга символом табуляции, а также добавлены надписи (например, «Продукт:» или «Стоимость:») перед шаблонным текстом для этих элементов. При выполнении объединения XML-данных внутри фрейма статические надписи, пробелы и символы табуляции между элементами содержимого сохраняются.

Примечание.

Если при объединении повторяющихся XML-данных они клонируются, то статический текст и пробелы будут также клонироваться для каждого экземпляра данных.

Создание шаблонного фрейма

  1. При помощи инструмента «Текст» создайте текстовый фрейм для XML-содержимого.

    Примечание.

    Чтобы при импорте XML-содержимое перетекало из одного фрейма в другой, создайте несколько фреймов и свяжите их друг с другом.

  2. Откройте панель «Структура» (меню «Просмотр» > «Структура» > «Показать структуру») и палитру «Теги» (меню «Окно»> «Утилиты» > «Теги»).
  3. Если палитра «Теги» не содержит теги с именами, идентичными XML-элементам, которые нужно импортировать, создайте их или загрузите из XML-файла.
  4. Задайте для шаблонного фрейма соответствующий тег из палитры «Теги» (этот тег будет автоматически назначен всем связанным с ним фреймам).
  5. При необходимости упорядочьте или добавьте элементы на панель «Структура», чтобы они соответствовали структуре импортируемого XML-файла.

Создание шаблонной таблицы

Импорт XML-элементов производится в шаблонную таблицу или в шаблонный фрейм. В таблице каждая ячейка представлена в виде элемента. InDesign помещает XML-содержимое в таблицу (одна ячейка за другой, один элемент за другим), начиная с верхнего левого угла, сопоставляя каждый элемент с ячейкой, которой назначен тег. При создании шаблонных таблиц тегами должна быть размечена вся таблица и каждая ячейка в ней (объединенная ячейка считается за одну ячейку).

Поскольку при импорте InDesign строки и колонки не различает, количество колонок в шаблонном элементе должно соответствовать количеству колонок в импортируемом содержимом. Кроме того, все элементы ячеек таблицы должны располагаться внутри одного элемента таблицы. Иными словами, ячейки являются элементами одного уровня и имеют общего родителя.

Шаблонная таблица
Шаблонная таблица (сверху) и заполнение шаблонной таблицы XML-содержимым (снизу)

  1. Откройте палитру «Теги» (меню «Окно» > «Утилиты» > «Теги») и панель «Структура» (меню «Просмотр» > «Структура» > «Показать структуру»).
  2. Если палитра «Теги» не содержит теги с именами, идентичными XML-элементам импортируемой таблицы, создайте их или загрузите из существующего документа.

    Примечание.

    Как минимум, необходимо наличие тегов для родительского элемента ячеек таблицы и элемента, в котором будет размещаться таблица.

  3. Создайте для XML-содержимого таблицу с соответствующим количеством колонок. Точное количество строк задавать необязательно, при необходимости они будут добавлены в таблицу.
  4. Поместив точку ввода в таблицу, выберите меню «Таблица» > «Выделить» > «Таблица», а затем на палитре «Теги» выберите соответствующий тег.
  5. Проставьте тег для каждой ячейки таблицы. В зависимости от структуры XML-содержимого каждую ячейку можно выделить и разметить тегами отдельно, либо выделить всю строку (колонку): например, если первую строку (строку заголовка) и все выделенные ячейки необходимо разметить одним и тем же тегом.
  6. При необходимости упорядочьте или добавьте элементы на панель «Структура», чтобы документ имел ту же структуру, что и импортируемый XML-файл.

Создание шаблонной структуры для повторяющихся данных

При объединении повторяющихся XML-данных применяются те же правила, что и при объединении XML. Структура элементов панели «Структура» должна совпадать со структурой импортируемых XML-данных, а все шаблонные фреймы должны быть размечены тегами с теми же именами, что и у родительских элементов в XML-файле.

Панель «Структура», отображающая структуру шаблонного текста
Панель «Структура», отображающая структуру шаблонного текста

A. Элемент, который будет содержать все повторяющиеся элементы B. Элемент, который будет клонирован при импорте повторяющегося XML-содержимого C. Дочерние элементы для данных, содержащихся в повторяющемся элементе 
  1. Для начала необходимо наличие родительского или корневого элемента, который описывает набор импортируемых данных или записей.

    Например, элемент Chapter, в который будет включено несколько рецептов.

  2. Под этим родительским элементом создайте еще один элемент, описывающий повторяющуюся информацию (или запись).

    Например, под элементом Chapter можно создать элемент Recipe. Именно этот элемент будет клонироваться для каждой записи XML при импорте.

  3. Под этим элементом создайте дочерние элементы, которые будут описывать единицы информации (или поля), входящие в состав записи.

    Например, под элементом Recipe можно создать элементы Recipename, Ingredients, Instructions, Notes и Serving.

Примечание.

Чтобы включить надписи, переводы строки и табуляции между элементами «полей» повторяющихся XML-данных, создайте шаблонные элементы в тех фреймах, где будет объединяться содержимое при импорте. При необходимости вставьте между ними пробелы и надписи.

Подготовка шаблонного текста

  1. Откройте существующий документ или создайте новый для XML-файла.
  2. Откройте палитру «Теги» (меню «Окно» > «Утилиты» > «Теги») и панель «Структура» (меню «Просмотр» > «Структура» > «Показать структуру»).
  3. Убедитесь, что палитра «Теги» содержит имена тегов, которые совпадают с именами элементов в импортируемом XML-файле. При необходимости создайте новые теги или загрузите недостающие.

    Примечание.

    Импорт образца XML-содержимого — это наиболее простой способ получить все необходимые теги и обеспечить соответствие структуры документа XML-файлу.

  4. Создайте для XML-содержимого шаблонные фреймы (и свяжите их друг с другом).
  5. При помощи инструмента «Текст» щелкните первый фрейм, установив в нем точку ввода, и введите шаблонный текст для каждого элемента, который необходимо объединить в этот фрейм. Вставьте между элементами необходимые интервалы, а также добавьте статический текст.

    Примечание.

    Для импорта повторяющихся данных нужно будет создать один экземпляр образца текста для повторяющихся элементов.

  6. Отформатируйте текст так, как он должен отображаться в окончательном варианте документа.
  7. Добавьте к текстовому фрейму тег для родительского элемента, который будет содержать элементы (или повторяющиеся данные), подлежащие импорту в этот фрейм.
  8. Установите точку ввода в шаблонный текст и выберите меню «Редактирование» > «Редактировать в редакторе материалов».
  9. Выберите меню «Просмотр» > «Структура» > «Показать маркеры тегов».
  10. Выберите «Редактирование» > Выбрать все.
  11. На палитре «Теги» выберите команду «Добавить тег» и щелкните тег, назначенный для фрейма.

    InDesign разметит шаблонный текст этим тегом и добавит элемент на панель «Структура».

  12. Выделите текст, представляющий первый дочерний элемент, и щелкните его тег на палитре «Теги». Повторяйте до тех пор, пока тегами не будет размечен весь шаблонный текст дочернего элемента.

    Примечание.

    При разметке шаблонного текста не выделяйте пробелы или статический текст, который должен остаться между элементами. Тегами следует размечать только текст, который должен быть замещен XML-содержимым.

  13. На панели «Структура» просмотрите созданную в процессе разметки иерархию и убедитесь, что она соответствует структуре импортируемого XML-содержимого.

Импорт и объединение XML

Создав и разметив тегами шаблонные фреймы, таблицы и текст, а также убедившись, что документ и входящий XML-файл имеют одинаковые теги и структуру, можно приступить к импорту XML-содержимого в макет.

Импорт XML в шаблонные элементы (или замена существующего содержимого документа) выполняется параметром «Объединить содержимое». InDesign заменяет элементы документа, имеющие те же теги и положение в иерархии, что и импортируемые XML-элементы. Дополнительные параметры импорта позволяют исключить (отфильтровать) содержимое, не соответствующее структуре документа, удалить элементы документа, которые не соответствуют или не замещаются импортированными XML-элементами, а также клонировать повторяющиеся XML-элементы.

Если импортируемый XML-файл содержит элементы, которых нет в документе, InDesign помещает их на панель «Структура», не размещая в документе.

Для успешного объединения XML в шаблонные элементы следует соблюдать следующие правила.

  • Шаблонные элементы должны быть размечены тегами с теми же именами, что и у XML-элементов, которые их замещают (заполняют).

  • Убедитесь, что в шаблонном тексте все пробелы, переводы строки, табуляции и статический текст расположены за пределами тегов шаблонных элементов, но внутри родительского элемента материала.

  • При импорте XML выберите параметр «Не импортировать содержимое элементов, состоящих из одних пробелов». Это позволяет сохранить пробелы и статический текст, если импортируемые XML-элементы состоят из одних пробелов.

Объединение XML в существующее содержимое или шаблонные элементы

  1. Откройте документ InDesign, содержащий шаблонные элементы для XML-содержимого.
  2. Откройте панель «Структура» (меню «Просмотр» > «Структура» > «Показать структуру»).
  3. Выберите меню «Файл» > «Импорт XML» (или выберите команду «Импорт XML» в меню панели «Структура»), а затем выберите XML-файл, который необходимо импортировать.
  4. Выберите параметр «Показать параметры импорта XML».
  5. Выберите команду «Объединить содержимое» и нажмите кнопку «Открыть».
  6. Чтобы связать XML-содержимое с исходным XML-файлом, выберите параметр «Создать связь».

    XML-файл будет добавлен на палитру «Связи», и при каждом его изменении на палитре будет отображаться предупреждающий значок треугольника желтого цвета.

  7. При необходимости задайте дополнительные параметры импорта.

    Клонировать повторяющиеся элементы текста.

    При импорте повторяющихся XML-данных InDesign клонирует шаблонный элемент, создавая контейнеры для каждой записи в файле.

    Импортировать только элементы, совпадающие с существующей конструкцией

    Фильтрует входящие XML-данные, не выполняя импорт элементов, отсутствующих на панели «Структура».

    Не импортировать содержимое элементов, состоящих из одних пробелов

    Сохраняет интервалы и статический текст между элементами в шаблонном фрейме.

    Удалить элементы, фреймы и содержимое, не совпадающие с импортированным XML

    После импорта XML все элементы или шаблонные элементы в документе, которые не совпали со входящими данными (или не были заменены), будут удалены.

  8. Нажмите кнопку «ОК».

InDesign объединяет содержимое в документ, начиная с первого элемента в XML-файле, для которого найдено соответствие.

Параметры импорта XML-файлов

При импорте и размещении XML-данных с использованием параметра «Объединить содержимое» появляется диалоговое окно «Параметры импорта XML», в котором доступны следующие параметры.

Создать связь

Создает связь с исходным XML-файлом. Она позволяет впоследствии обновлять XML-данные в документе InDesign при обновлении исходного файла.

Применить XSLT

Применяет таблицу стилей для определения преобразования импортируемого XML-файла. Нажмите кнопку «Обзор» (Windows) или «Выбрать» (Mac OS), чтобы выбрать XSLT-файл (с расширением .xsl или .xslt). Параметр «Использовать таблицу стилей из XML» (установлен по умолчанию) предписывает программе InDesign пользоваться для преобразования XML-данных инструкцией обработки XSLT (если она есть в XML-файле).

Клонировать повторяющиеся элементы текста.

При обработке повторяющегося содержимого дублирует форматирование, примененное к размеченному тегами шаблонному тексту. Макет одного экземпляра форматирования (например, адреса) используется для автоматического создания всех остальных экземпляров. См. раздел Работа с повторяющимися данными.

Импортировать только элементы, совпадающие с существующей конструкцией

Производит фильтрацию импортируемого XML-содержимого, импортируя только те элементы XML-файла, которые совпадают с элементами документа.

Импортировать элементы текста в таблицы, если теги совпадают

Импортирует элементы в таблицу, если теги совпадают с тегами, примененными к шаблонной таблице и ее ячейкам. Например, этот параметр позволяет помещать записи базы данных в таблицу для создания прайс-листов или инвентарных ведомостей.

Не импортировать содержимое элементов, состоящих из одних пробелов

Все существующее содержимое будет оставлено без изменений, если соответствующее XML-содержимое содержит только пробелы (а также переводы строки или символы табуляции). Установите этот параметр, если между элементами шаблонных фреймов был добавлен текст и его необходимо сохранить. Например, при импорте рецептов из базы данных могут быть добавлены надписи: «Ингредиенты», «Инструкции» и т. д. InDesign оставит надпись без изменений, если родительский элемент, в котором находится рецепт, содержит только пробельные символы.

Удалить элементы, фреймы и содержимое, не совпадающие с импортированным XML

Элементы будут удалены с панели «Структура» и макета документа, если они не совпадают с элементами в импортируемом XML-файле. Этот параметр позволяет реализовать фильтрацию данных в документе. Например, при импорте имен и адресов для элемента, содержащего имя компании, задан шаблонный текст. Если для одного из имен компания не указана, InDesign удалит элемент, содержащий шаблонный текст.

Импортировать таблицы CALS как таблицы InDesign

Импортирует таблицы CALS в XML-файле в виде таблиц InDesign.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет