Процесс кодирования

Чтобы закодировать элемент видео или аудио, добавьте его в очередь кодирования Adobe Media Encoder, затем выберите шаблон настроек кодирования или задайте собственные настройки. Можно выбрать вариант запуска кодирования сразу после добавления элемента в очередь или вариант кодирования по команде.

Добавление элемента в очередь кодирования. Перетащите аудио- или видеофайлы в очередь Adobe Media Encoder.

Кодирование элемента с использованием шаблонов настроек. Добавив элемент в очередь, выберите форматы и шаблоны настроек во всплывающих меню «Формат» и «Шаблоны настроек». Выберите шаблон настроек из браузера шаблонов настроек и перетащите его к любому элементу в очереди. Дополнительные сведения см. в разделе Кодирование с помощью шаблонов настроек.

Кодирование элемента с использованием пользовательских настроек. Выделите элемент и выберите «Редактирование» > «Настройки экспорта» и укажите нужные параметры. Дополнительные сведения см. в разделе Кодирование с помощью пользовательских настроек.

Чтобы запустить кодирование элементов в очереди автоматически (или отключить эту функцию), установите или снимите флажок параметр «Запускать очередь автоматически при отсутствии активности в течение» в диалоговом окне «Установки». Дополнительные сведения см. в статье Установки.

Экран AME
Основное окно Adobe Media Encoder

Импорт элементов в очередь кодирования

  • Чтобы добавить видео- или аудиофайлы, выполните одно из следующих действий:
    • Перетащите один или несколько файлов в очередь с рабочего стола или из браузера медиаданных.
    • Нажмите кнопку «Добавить источник» и выберите требуемые файлы.
    • Дважды щелкните в свободной области на панели «Очередь» и укажите требуемые файлы.
  • Чтобы добавить эпизод Adobe Premiere Pro, выполните одно из следующих действий:
    • Перейдите к проекту Adobe Premiere Pro в браузере медиаданных и перетащите эпизоды в очередь.
    • Выберите «Файл» > «Добавить эпизод Premiere Pro», затем укажите проект Premiere Pro и выберите в нем требуемые эпизоды.
    • Перетащите эпизод из панели «Проект» Adobe Premiere Pro в очередь.
    • Перетащите проект Premiere Pro с рабочего стола в очередь.
  • Чтобы добавить композицию Adobe After Effects, выполните одно из следующих действий:
    • Перейдите к проекту Adobe After Effects в браузере медиаданных и перетащите композиции в очередь.
    • Выберите «Файл» > «Добавить композицию After Effects», а затем укажите композицию в проекте.
    • Перетащите композицию с панели «Проект» After Effects в очередь.
    • Перетащите проект After Effects с рабочего стола в очередь.

Остановка кодирования

  • Выберите «Файл» > «Остановить текущий файл», чтобы прервать кодирование текущего элемента. Adobe Media Encoder продолжит кодирование оставшихся элементов в очереди.
  • Выберите «Файл» > «Остановить очередь», чтобы прервать кодирование всех элементов в очереди.

Интерпретация элементов в очереди кодирования

При импорте в Adobe Media Encoder видеоресурса, программа выполняет попытку определения пропорций пикселя, частоты кадров и порядка полей для этого ресурса, а также способа интерпретации информации об альфа-канале (прозрачности). Если Adobe Media Encoder определяет какие-либо характеристики неверно, пользователь может исправить их интерпретацию вручную.

  1. Выберите один или несколько элементов в очереди кодирования.

  2. Выберите «Файл» > «Интерпретировать материал». Также можно щелкнуть файл правой кнопкой мыши и выбрать «Интерпретировать материал».

    interpret selection
    Выбор команды «Интерпретировать материал»

  3. Выберите соответствующие настройки интерпретации.

    iterpret window
    Диалоговое окно «Интерпретировать материал»

Определить отсутствующие элементы в очереди кодирования

Перед кодированием можно определить исходные и выходные файлы в очереди, в которых есть отсутствующие элементы. Благодаря этому можно выявить и устранить проблемы еще до кодирования. Если в исходном или выходном файле есть отсутствующие элементы, рядом с ним отображается значок предупреждения. Наведите указатель мыши на значок, чтобы просмотреть краткое описание ошибки, связанной с этой проблемой. 

Adobe Media Encoder отображает значок предупреждения в следующих случаях:

  • В проектах Premiere Pro есть автономные медиаданные. В этом случае Adobe Media Encoder использует прокси-медиаданные вместо отсутствующего набора. Если прокси-медиаданных нет, используется графический элемент с надписью «Автономные медиаданные».
  • Отсутствуют некоторые шрифты, задействованные в проектах Premiere Pro.
  • В проектах Premiere Pro отсутствуют некоторые эффекты.
  • В эффектах наложения отсутствуют некоторые файлы. 
Выявление отсутствующих элементов
Выявление отсутствующих элементов

Папки отслеживания в Adobe Media Encoder  

Можно настроить Adobe Media Encoder для отслеживания появления видео- или аудиофайлов в определенных папках, называющихся папками отслеживания. При обнаружении программой Adobe Media Encoder видео- или аудиофайл в такой папке она кодирует этот файл согласно заданным параметрам кодирования и экспортирует результат в папку Output, создаваемую внутри папки отслеживания.

Для добавления попок и управления ими в Adobe Media Encoder можно пользоваться панелью «Папки отслеживания». Папку отслеживания можно добавить одним из следующих способов:

  1. Выберите «Файл» > «Добавить папку отслеживания» и укажите папку.
  2. Дважды щелкните на пустую область панели «Папки отслеживания» и выберите папку.
  3. Создайте папку в Explorer (Windows) или Finder (Mac OS), а затем перетащите ее на панель «Папки отслеживания».

После создания папки ее имя отобразится в левой колонке панели «Папки отслеживания».

Элементы, добавляемые в очередь папкой отслеживания, кодируются вместе с другими элементами очереди.

Примечание.

Если задан параметр «Запускать очередь автоматически при отсутствии активности в течение:» в диалоговом окне «Установки», кодирование запускается по истечении определенного промежутка времени после добавления папкой отслеживания нового элемента в очередь кодирования.

Примечание.

Установите флажок «Автоматически кодировать папки отслеживания», чтобы кодировать элементы при их добавлении в папку отслеживания.

Добавление шаблонов настроек

Формат и шаблон настроек можно выбрать во всплывающем меню папки отслеживания рядом с именем папки. Также можно перетащить шаблон настроек к папке отслеживания из браузера шаблона настроек.

Создание выходного файла в разных форматах из одного исходного элемента с помощью папок отслеживания

Папки отслеживания позволяют сформировать несколько выходных файлов за одну операцию. Например, необходимо создать видеофильм в формате AVI, а также эскиз в формате JPEG при выполнении операции перекодирования видеоресурса. Выполните следующие действия, чтобы создать эти файлы за одну операцию:

  1. Создайте папку с помощью Explorer (Windows) или Finder (Macintosh), назвав ее, например, «My_WatchFolder».

  2. Создайте папку наблюдения, нажав кнопку «Добавить папку», а затем перейдите в только что созданную папку «My_WatchFolder».

    1. Щелкните раскрывающееся меню «Формат» и выберите MPEG4.

    2. Щелкните раскрывающееся меню «Шаблон настроек» и выберите нужные настройки.

      preset and format
      Раскрывающиеся меню «Формат» и «Шаблон настроек»

    3. Щелкните «Выходная папка». Выберите местоположение для размещения созданного файла.

      Output Folder
      Выходная папка

  3. Создайте элемент папки отслеживания, который будет также указывать на папку «My_WatchFolder», аналогично действию 2.

    1. В меню «Формат» выберите формат AVI.

    2. В меню «Шаблон настроек» выберите шаблон настроек, а затем нажмите OK.

    3. Щелкните «Выходная папка». Выберите местоположение для размещения созданного файла.

  4. Создайте элемент папки отслеживания, который будет также указывать на папку «My_WatchFolder», аналогично действиям 2 и 3.

    1. В меню «Формат» выберите формат JPEG.

    2. В меню «Шаблон настроек» выберите шаблон настроек, а затем нажмите OK.

    3. Щелкните «Выходная папка». Выберите местоположение для размещения созданного файла.

  5. Перетащите исходный файл в папку «My_WatchFolder», а затем нажмите кнопку «Запустить очередь». Кодирование начнется автоматически, если включена функция «Автоматически кодировать папки отслеживания».

После завершения процесса создания файлов, каждый файл будет размещен в указанном местоположении выходных данных.

Примечание.

Стиль должен быть пользовательским, а параметр Экспортировать как эпизод должен быть отключен. При этом будет экспортирован только первый кадр видеоролика, который часто представляет собой черный экран.

Примечание.

При использовании папок отслеживания набора неподвижных изображений в качестве исходного отснятого материала не поддерживаются. Если набор неподвижных изображений будет помещен в отслеживаемую папку, каждый отдельный файл изображения добавляется в очередь как отдельный элемент (а не весь эпизод в виде единого отснятого материала).

Сохранение очереди кодирования

При выходе из Adobe Media Encoder очередь кодирования и все настройки кодирования сохраняются автоматически.

Очередь кодирования также сохраняется автоматически, когда пользователь запускает кодирование.

Чтобы сохранить очередь кодирования вручную, выберите Файл > Сохранить очередь.

Примечание.

Снимите флажок Установки > Удалить закодированные файлы из очереди при выходе, чтобы сохранить готовые элементы в очереди при закрытии и перезапуске Adobe Media Encoder.

Удаление элементов из очереди кодирования

  1. Выберите элемент или элементы, которые требуется удалить из очереди кодирования.

  2. Нажмите кнопку «Удалить» выберите «Редактировать» > «Стереть» или нажмите клавишу «Delete».

    Delete file new
    Удаление элементов из очереди кодирования

Дублирование элементов в очереди кодирования

  1. Выберите элемент или элементы, которые требуется продублировать в очереди кодирования.

  2. Выполните одно из следующих действий.

    • Нажмите кнопку «Дублировать», выберите Правка > Дублировать
    • Нажмите клавиши Ctrl-D (Windows) или Command-D (Mac OS)
    • Щелкните файл правой кнопкой мыши и выберите Дублировать.
    Duplicate item
    Дублирование элемента

Пропуск элементов в очереди кодирования

Пропуск элементов

  1. Выберите элемент или элементы, которые требуется пропустить в очереди кодирования.

  2. Откройте меню «Редактировать» > «Пропустить выбранное» или нажмите на файл правой кнопкой мыши и выберите команду «Пропустить выбранное».

    Skip selection
    Пропустить выбранное

Восстановление статуса кодирования пропущенного файла

  1. Выберите элементы в очереди кодирования, которые необходимо перевести в состояние «Готово».

  2. Откройте меню «Редактировать» > «Восстановить статус» или нажмите на файл правой кнопкой мыши и выберите команду «Редактировать» > «Восстановить статус».

    Reset status
    Сброс состояния пропущенного файла

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет