Adobe Media Encoder использует существующие шаблоны настроек или пользовательские настройки для кодирования и перекодирования медиафайлов в различные форматы видео и аудио.

Процесс кодирования

Чтобы закодировать элемент видео или аудио, добавьте его в очередь кодирования Adobe Media Encoder. Выберите существующий шаблон настроек кодирования или задайте пользовательские настройки. Можно выбрать вариант запуска кодирования сразу после добавления элемента в очередь или вариант кодирования по команде. С помощью Adobe Media Encoder можно выполнять следующие действия:

  • Добавление элемента в очередь кодирования. Перетащите аудио- или видеофайлы на панель очереди в Adobe Media Encoder. Дополнительные сведения см. в разделе Импорт элементов в очередь кодирования.
  • Кодирование элемента с использованием шаблонов настроек. Добавив элемент в очередь, выберите форматы и шаблоны настроек в раскрывающихся списках «Формат» и «Шаблон настроек». Выберите шаблон настроек из браузера шаблонов настроек и перетащите его к любому элементу в очереди. Дополнительные сведения см. в разделе Кодирование с помощью шаблонов настроек.
  • Кодирование элемента с использованием пользовательских настроек. Выберите требуемые элементы на панели очереди, а затем выберите Правка > Настройки экспорта или нажмите списки «Формат» и «Шаблон настроек» на панели очереди и выберите настройки. Дополнительные сведения см. в разделе Кодирование с помощью пользовательских настроек.

Чтобы кодирование элементов в очереди запускалось автоматически по истечении определенного промежутка времени, выберите параметр Запускать очередь автоматически при отсутствии активности в течение. Задайте требуемое время отсутствия активности в диалоговом окне «Установки». 

Установки
Установки

После включения этого параметра на панели «Кодирование» отображается обратный отсчет. Дополнительные сведения см. в разделе Установки.

Обратный отсчет до начала кодирования
Обратный отсчет до начала кодирования

Импорт элементов в очередь кодирования

Чтобы добавить видео- или аудиофайлы в очередь кодирования, выполните одно из следующих действий.

  • Перетащите один или несколько файлов на панель «Очередь» с рабочего стола или из браузера медиаданных.
  • Нажмите кнопку «Добавить источник» на панели «Очередь» и выберите требуемые файлы.
  • Дважды щелкните в свободной области на панели «Очередь» и укажите требуемые файлы.

Импорт из Premiere Pro

Чтобы добавить эпизод Adobe Premiere Pro, выполните одно из следующих действий.

  • Перейдите к проекту Adobe Premiere Pro в браузере медиаданных и перетащите эпизоды на панель «Очередь».
  • Выберите Файл > Добавить эпизод Premiere Pro. Укажите проект Premiere Pro и выберите в нем требуемые эпизоды.
  • Перетащите эпизод с панели «Проект» Adobe Premiere Pro на панель «Очередь».
  • Перетащите проект Premiere Pro с рабочего стола на панель «Очередь».

Импорт из After Effects

Чтобы добавить композицию Adobe After Effects, выполните одно из следующих действий.

  • Перейдите к проекту Adobe After Effects в браузере медиаданных и перетащите композиции на панель «Очередь».
  • Выберите Файл > Добавить композицию After Effects, а затем укажите композицию в проекте.
  • Перетащите композицию с панели «Проект» After Effects на панель «Очередь».
  • Перетащите проект After Effects с рабочего стола на панель «Очередь».

Остановка кодирования

Чтобы остановить кодирование, выполните одно из следующих действий.

  • Чтобы остановить кодирование текущего элемента, выберите Файл > Остановить кодирование текущего элемента. Adobe Media Encoder продолжит кодирование оставшихся элементов в очереди.
  • Чтобы остановить кодирование всех элементов в очереди, выберите Файл > Остановить очередь.

Сшивание клипов

Можно объединить несколько медиафайлов в один при добавлении в очередь. Для сшивания медиафайлов выполните следующие действия.

  1. Выберите Файл > Добавить исходный файл или нажмите кнопку «Добавить источник» на панели «Очередь». Открывается Проводник.

  2. Выберите ресурсы, которые требуется сшить вместе.

  3. Установите флажок Сшить клипы вместе.

    Сшить клипы вместе
    Сшить клипы вместе
  4. Нажмите кнопку Открыть, чтобы добавить сшитый клип в очередь.

Можно также выбрать клипы, которые требуется сшить. Затем перетащить их на панель «Очередь» и отпустить над разделом Перетащите сюда, чтобы сшить клипы.

Перетащите сюда, чтобы сшить клипы
Перетащите сюда, чтобы сшить клипы

Сшитые клипы загружаются в очередь. Для просмотра отдельных клипов нажмите Show sources (Показать исходные). По умолчанию клипы сортируются в алфавитном порядке. Вы можете изменить их порядок в соответствии с вашими предпочтениями.

В качестве имени сшитого клипа автоматически устанавливается имя первого клипа в последовательности. Чтобы изменить имя клипа, нажмите имя. Дополнительные сведения см. в разделе Сшивание клипов с помощью Adobe Media Encoder.

Примечание.

Сшитые клипы учитывают точки входа и выхода, заданные в браузере медиаданных. Однако длительность исходных файлов нельзя изменять после того, как они добавлены в сшитый клип.

Определить отсутствующие элементы в очереди кодирования

Перед началом кодирования можно определить элементы в очереди, в которых есть отсутствующие элементы. Это помогает выявить и устранить проблемы еще до кодирования. Если в исходном или выходном файле есть отсутствующие элементы, рядом с ним отображается значок предупреждения. Чтобы просмотреть краткое описание ошибки, связанной с этой проблемой, наведите указатель на значок.

Adobe Media Encoder отображает значок предупреждения в следующих случаях:

  • В проектах Premiere Pro есть автономные медиаданные. В этом случае Adobe Media Encoder использует прокси-медиаданные вместо отсутствующего набора медиаданных. Если прокси-медиаданных нет, используется графический элемент с сообщением «Автономные медиаданные».
  • Отсутствуют некоторые шрифты, задействованные в проектах Premiere Pro.
  • В проектах Premiere Pro отсутствуют некоторые эффекты.
  • В эффектах наложения отсутствуют некоторые файлы.
Краткое описание ошибки
Краткое описание ошибки

Интерпретация элементов в очереди кодирования

При импорте видеоресурса программа Adobe Media Encoder выполняет попытку определения частоты кадров, пропорции пикселя, порядка полей и альфа-канала для этого ресурса. Если Adobe Media Encoder определяет какие-либо характеристики неверно, пользователь может исправить их интерпретацию вручную.

  1. Выберите один или несколько элементов видео в очереди кодирования.

  2. Выполните одно из следующих действий.

    • Выберите Файл > Интерпретировать материал
    • Щелкните файл правой кнопкой мыши и выберите Интерпретировать материал.
  3. Выберите соответствующие настройки интерпретации.

Интерпретация отснятого материала
Интерпретация отснятого материала

Примечание.

Параметр «Интерпретировать материал» недоступен, если выбранный ресурс не является видео или изображением.

Кодирование с помощью шаблонов настроек или пользовательских настроек

Кодирование с помощью шаблонов настроек

шаблон настроек
A. Формат B. Шаблон настроек C. Место назначения 
  1. Добавьте элементы на панель «Очередь». Дополнительные сведения см. в разделе Импорт элементов в очередь кодирования.

  2. Выберите формат, который совместим с устройством вывода. Для этого нажмите текст в столбце «Формат» (A), чтобы открыть всплывающее меню Формат, которое содержит поддерживаемые форматы файлов.

  3. Выберите шаблон настроек, который совместим с устройством вывода. Для этого нажмите текст в столбце «Шаблон настроек» (B), чтобы открыть всплывающее меню Шаблон настроек, которое содержит стандартные отраслевые шаблоны настроек. Дополнительные сведения см. в разделе Создание пользовательских шаблонов настроек для Media Encoder.

    Также можно перетащить шаблон настроек на панель «Очередь» из браузера шаблонов настроек.

    Применить шаблон настроек
    Применить шаблон настроек
  4. Выберите местоположение для хранения файлов, нажав текст в столбце «Выходной файл» (C) и указав в диалоговом окне Сохранить как... каталог или папку для размещения файлов. Нажмите кнопку Сохранить.

  5. Нажмите кнопку Запустить очередь.

Файлы кодируются в выбранном формате с применением указанного шаблона настроек и сохраняются в указанном местоположении. После кодирования файла нажмите путь к выходному файлу, чтобы открыть папку, содержащую закодированный файл.

выходной файл
A. Выходной файл после кодирования B. Выходной файл до кодирования 

Примечание.

Если требуется приостановить процесс кодирования, снова нажмите кнопку Запустить очередь.

Кодирование с помощью пользовательских настроек

Для кодирования с помощью пользовательских настроек выполните следующие действия.

  1. Добавьте элементы на панель «Очередь». Дополнительные сведения см. в разделе Импорт элементов в очередь кодирования.

  2. Откройте диалоговое окно «Настройки экспорта», выполнив одно из следующих действий.

    • Выберите строку элемента с форматом, шаблоном настроек и путем к выходному файлу на панели очереди, а затем выберите Правка > Настройки экспорта
    • Щелкните правой кнопкой мыши строку с форматом, шаблоном настроек и путем к выходному файлу, а затем выберите Настройки экспорта
    • Нажмите Формат или Шаблон настроек, чтобы открыть диалоговое окно Настройки экспорта.
  3. Задайте параметры экспорта и нажмите OK. Дополнительные сведения см. в разделе Справка по настройкам экспорта Media Encoder.

  4. Закройте окно Настройки экспорта и нажмите кнопку Запустить очередь, чтобы начать кодирование.

Примечание.

Для повышения производительности при кодировании закройте панель «Кодирование». Для контроля хода кодирования можно использовать индикаторы выполнения на панели «Очередь».

В диалоговом окне Настройки экспорта можно выполнить следующие действия.

  • Выберите формат видео, аудио или неподвижного изображения в меню Формат. Дополнительные сведения см. в разделе Поддерживаемые форматы файлов для экспорта.

  • Выберите шаблон настроек кодирования в меню Шаблон настроек.

  • Выберите Экспорт видео, Экспорт аудио или оба параметра.

  • Укажите параметры обработки перед кодированием, включая кадрирование и обрезку. Дополнительные сведения см. в разделе Диалоговое окно «Настройки экспорта».

  • Задайте параметры для экспорта метаданных XMP. Дополнительные сведения см. разделе Экспорт и исключение метаданных XMP.

  • Выберите параметр Наилучшее качество визуализации или Визуализировать при максимальной разрядности.

  • Выберите параметр Использовать наложение кадров.

  • Введите имя и путь для кодируемого файла, нажав текст с подчеркиванием, расположенный рядом с именем выходного файла в верхней правой части окна «Настройки экспорта». Если имя не указано, Adobe Media Encoder использует имя файла исходного видеоклипа.

Примечание.

При указании формата P2 Movie назначение имени пользователем становится недоступно. При таком кодировании Adobe Media Encoder назначает шестизначное алфавитно-цифровое имя. Имя выходного файла сохраняется в метаданных клипа и показывается как имя клипа в Adobe Premiere Pro.

Можно задать папку назначения для сохранения кодируемого файла в соответствии с папкой, содержащей исходный видеоклип. При указании папки назначения убедитесь, что она существует. Если указать несуществующую папку, появится сообщение об ошибке, сообщающее, что файл не может быть закодирован из-за отсутствия папки назначения.

Сохранение очереди кодирования

При выходе из Adobe Media Encoder очередь кодирования и настройки кодирования сохраняются автоматически. Очередь кодирования также сохраняется автоматически, когда пользователь запускает процесс кодирования.

Чтобы сохранить очередь кодирования вручную, выберите Файл > Сохранить очередь.

Примечание.

Снимите флажок Установки > Удалить закодированные файлы из очереди при выходе, чтобы сохранить готовые элементы в очереди при закрытии и перезапуске Adobe Media Encoder.

Изменение пути к выходному файлу для нескольких исходных файлов

Выполните следующие действия, чтобы изменить путь к выходному файлу для нескольких выходных файлов (одновременно).

  1. Выберите несколько исходных файлов в очереди, щелкая их мышью при нажатой клавише Shift.

  2. Нажмите текст в столбце Выходной файл для одного из выбранных входных файлов.

  3. Выберите путь в диалоговом окне Выбор выходной папки и нажмите кнопку Выбрать.

Все выбранные выходные файлы будут сохраняться в новый каталог, но сохранят уникальные имена.

Папка отслеживания

Можно настроить Adobe Media Encoder для отслеживания появления видео- или аудиофайлов в определенных папках, называющихся папками отслеживания. Adobe Media Encoder автоматически кодирует файлы, помещаемые в папку отслеживания. Когда программа Adobe Media Encoder находит видео- или аудиофайл в папке отслеживания, она кодирует файл с использованием настроек кодирования, заданных для папки. Затем она экспортирует закодированный файл в выходную папку, созданную внутри папки отслеживания.

Используя папки отслеживания, Adobe Media Encoder автоматизирует процесс постановки в очередь и рендеринга медиафайлов. Можно создать несколько версий исходного файла, добавив разные экземпляры выходных файлов с использованием разных форматов или шаблонов настроек.

Панель «Папки отслеживания»
Панель «Папки отслеживания»

Для добавления папок и управления ими в Adobe Media Encoder можно использовать панель «Папки отслеживания». Папку отслеживания можно добавить одним из следующих способов:

  • Выберите Файл > Добавить папку отслеживания и укажите папку.
  • Дважды щелкните на пустую область панели «Папки отслеживания» и выберите папку.
  • Создайте папку в Проводнике (Windows) или Finder (Mac OS), а затем перетащите ее на панель «Папки отслеживания».

Элементы, добавляемые в очередь папкой отслеживания, кодируются вместе с другими элементами очереди при ее запуске.

Примечание.

Если задан параметр Запускать очередь автоматически при отсутствии активности в течение: в диалоговом окне «Установки», кодирование запускается по истечении определенного промежутка времени после добавления папкой отслеживания элемента в очередь кодирования.

Установите флажок Автоматически кодировать папки отслеживания, чтобы кодировать элементы при их добавлении в папку отслеживания.

Создание выходного файла в разных форматах с помощью папок отслеживания

Папки отслеживания позволяют сформировать несколько выходных файлов за одну операцию. Например, необходимо создать видеофильм в формате AVI, а также эскиз в формате JPEG при выполнении операции перекодирования видеоресурса.

Чтобы создать эти файлы за одну операцию, выполните следующие действия.

  1. Создайте папку с помощью Проводника (Windows) или Finder (macOS), назвав ее, например, «My_WatchFolder».

  2. Создайте папку отслеживания, нажав кнопку «Добавить папку», а затем перейдите в только что созданную папку My_WatchFolder.

    • Нажмите раскрывающееся меню Формат и выберите MPEG4.
    • Нажмите раскрывающееся меню Шаблон настроек и выберите нужные настройки.
    Настройки экспорта
    Настройки экспорта
    • Нажмите Выходная папка. Выберите местоположение для размещения выходного файла.
  3. Создайте элемент папки отслеживания, который будет также указывать на папку My_WatchFolder, аналогично действию 2.

    • Нажмите раскрывающееся меню Формат и выберите AVI.
    • Нажмите раскрывающееся меню Шаблон настроек и выберите нужные настройки.
    • Нажмите Выходная папка. Выберите местоположение для размещения выходного файла.
  4. Создайте элемент папки отслеживания, который будет также указывать на папку My_WatchFolder, аналогично действиям 2 и 3.

    • Нажмите раскрывающееся меню Формат и выберите JPEG.
    • Нажмите раскрывающееся меню Шаблон настроек и выберите нужные настройки.
    • Нажмите Выходная папка. Выберите местоположение для размещения выходного файла.
  5. Перетащите исходный файл в папку My_WatchFolder, а затем нажмите кнопку Запустить очередь. Кодирование начнется автоматически, если включена функция Автоматически кодировать папки отслеживания.

После завершения процесса создания файлов каждый файл будет размещен в указанном местоположении выходных данных.

Удаление, дублирование и пропуск элементов в очереди кодирования

Удаление, дублирование и пропуск элементов в очереди кодирования
Удаление, дублирование и пропуск элементов в очереди кодирования

Удаление элементов из очереди кодирования

Чтобы удалить элементы из очереди кодирования, выполните следующие действия.

  1. Выберите элемент или элементы, которые требуется удалить из очереди кодирования.

  2. Выполните одно из следующих действий.

    • Щелкните файл правой кнопкой мыши и выберите Удалить.
    • Выберите Правка > Стереть или нажмите клавишу Delete.
    • Выберите Да, чтобы подтвердить удаление. (Нажмите Не спрашивать снова, чтобы отключить показ окна подтверждения при каждом удалении элемента из очереди.)

Дублирование элементов в очереди кодирования

Чтобы дублировать элементы в очереди кодирования, выполните следующие действия.

  1. Выберите элемент или элементы, которые требуется продублировать в очереди кодирования.

  2. Выполните одно из следующих действий.

    • Щелкните файл правой кнопкой мыши и выберите Дублировать.
    • Нажмите кнопку «Дублировать», выберите Правка > Дублировать.
    • Нажмите клавиши Ctrl+D (Windows) или Command+D (macOS).

Пропуск элементов в очереди кодирования

Чтобы пропустить элементы в очереди кодирования, выполните следующие действия.

  1. Выберите элемент или элементы, которые требуется пропустить в очереди кодирования.

  2. Выполните одно из следующих действий.

    • Выберите Правка > Пропустить выбранное.
    • Щелкните файл правой кнопкой мыши и выберите Пропустить выбранное.

Сброс состояния элементов в очереди кодирования

Чтобы сбросить состояние файла в очереди кодирования, выполните следующие действия.

  1. Выберите элементы в очереди кодирования, которые необходимо перевести в состояние Готово.

  2. Выполните одно из следующих действий.

    • Выберите Правка > Сброс состояния.
    • Щелкните файл правой кнопкой мыши и выберите Правка > Сброс состояния.

Отслеживание хода кодирования

Во время кодирования в столбце Состояние очереди кодирования отображается состояние каждого элемента. Adobe Media Encoder может одновременно кодировать несколько выходных файлов из одного источника. Однако исходные файлы обрабатываются последовательно, согласно порядку в очереди.

Вы можете продолжать работу в приложении в то время, как выполняется кодирование. Можно добавлять, удалять или менять порядок элементов в очереди или просматривать папки отслеживания. Выходные файлы, кодирование которых выполняется в текущий момент времени, нельзя редактировать.

  • Готово
    Элемент находится в очереди, но еще не закодирован. Файл, который не был закодирован и не кодируется в текущий момент времени, можно удалить из очереди.
  • Выполнено
    Элемент был успешно закодирован.
  • Остановлено 
    Пользователь отменил процесс кодирования во время кодирования этого элемента.
  • Ошибка 
    Программа Adobe Media Encoder обнаружила ошибку при попытке кодирования указанного элемента.
  • Пропустить
    Пользователь может пропустить кодирование одного или нескольких выбранных файлов. Указав нужные файлы, выберите «Правка» > «Пропустить выбранное».

Звуковые сигналы, подаваемые при завершении выполнения заданий (успешно, с ошибками)

В Adobe Media Encoder предусмотрена подача звуковых сигналов. Они подаются при завершении выполнения заданий очереди. Если выявлена ошибка, раздается особый звуковой сигнал. Подачу звуковых сигналов можно отключить в диалоговом окне «Установки».

Установки
Установки

Отображение журнала

Чтобы увидеть подсказку с сообщением об ошибке, наведите указатель на значок состояния. Чтобы просмотреть журнал для какого-либо элемента, кодирование которого произведено успешно, остановлено или завершилось с ошибкой, нажмите значок состояния.

Отображение журнала
Отображение журнала

Параллельное кодирование

Adobe Media Encoder кодирует все исходные файлы последовательно, а все выходные файлы одного исходного файла — параллельно. Параллельное кодирование используется для одновременного экспорта одного и того же исходного файла в нескольких форматах, но не позволяет одновременно экспортировать разные исходные файлы.

Параллельное кодирование
Параллельное кодирование

Примечание.

Параллельное кодирование включено по умолчанию. Чтобы отменить параллельное кодирование выберите «Редактирование» > «Установки» и снимите флажок «Разрешить параллельное кодирование».

При одновременном кодировании нескольких выходных файлов на панели «Кодирование» отображаются предпросмотр миниатюр, индикатор выполнения и расчетное время завершения кодирования для каждого из выходных файлов.

В определенных случаях настройки экспорта требуют, чтобы вывод кодировался последовательно, а не в параллельном режиме. В таких случаях очередь возвращается к параллельному кодированию после того, как временное последовательное кодирование закончено.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет