Príručka používateľa Zrušiť

Prepare Illustrator assets for Aero

  1. Adobe Aero User Guide
  2. Introduction
    1. What is Adobe Aero
    2. Adobe Aero mobile (iOS) system requirements
    3. What is Augmented Reality
    4. Common AR terminologies
    5. Adobe Aero | Common questions
    6. Get started with the user interface
    7. In-app learning resources in Adobe Aero
    8. Using mobile gestures in Adobe Aero
    9. Key 3D modeling concepts
    10. What's new in Adobe Aero
  3. Aero desktop
    1. What's new in Adobe Aero
    2. Adobe Aero desktop | Common questions
    3. Workspace Basics
    4. Keyboard shortcuts
    5. Import assets into Aero
    6. Adobe Aero desktop system requirements
    7. Supported file formats
    8. Work with cloud documents
  4. Aero Player (Beta) on Android
    1. Discover Augmented Reality content in Aero Player (Beta)
    2. Adobe Aero (Beta) on Android | Common questions
    3. Adobe Aero (Beta) on Android System requirements
  5. Make your digital assets ready for AR
    1. Asset sources for Aero
    2. Prepare Photoshop assets for Aero
    3. Prepare Illustrator assets for Aero
    4. Prepare Dimension assets for Aero
  6. Import AR-ready assets
    1. Import assets into Aero
    2. Import Mixamo assets into Aero
    3. Supported file formats
    4. Import FBX files into Aero
  7. Design AR experiences
    1. Add audio to digital assets in Adobe Aero
    2. Scan a space and set a surface anchor
    3. Place digital assets and edit the scene
    4. Add interactivity to digital assets
    5. Set an Image Anchor
    6. Add animated assets in Adobe Aero
    7. Create animations using Directable characters
  8. Export, share, and work with Xcode
    1. Share your AR creations
    2. Collaborate with others on Adobe Aero documents
    3. Work with Xcode and Reality Composer
    4. View AR creations
  9. Cloud documents and storage
    1. Work with cloud documents
    2. Upgrade storage for Adobe Aero
  10. Examples, ideas, and inspirations
    1. Design an AR experience using starter assets
    2. Help visualize furniture through AR
    3. Create an AR-powered interactive product experience with Adobe Aero

Learn how to make your Adobe Illustrator assets ready for Adobe Aero.

Work with Illustrator assets

You can bring Illustrator assets as an image file or as a Photoshop document (PSD) with layers.

Illustrator files can be exported to PSD with their layers preserved for use in layered AR creations. To control which parts of the document become different layers in PSD (and therefore Aero), you need to do one of the two things:

  1. Separate your document into separate layers. Illustrator layers become Photoshop layers on export, which become Aero layers when imported.

  2. If your document is a single layer in Illustrator, you can use groups to control which elements become layers in your export. Note: In this case, elements next to each other in the Layers Panel in Illustrator are each collapsed into a single PSD layer.

Poznámka:

In Illustrator, elements on the same layer in the Layers Panel are collapsed into a single PSD layer.

Bring Illustrator assets as a flat image into Aero

To bring Illustrator images as an asset into Aero, you have to export as SVG from Illustrator. Aero imports it as a flat, single-layered image. The vector contents are rasterized upon importing into Aero.

  1. From Adobe Illustrator CC, go to File > Export > Export As.

  2. Choose SVG.

  3. Save the file somewhere you are able to access from your device. For example, your Creative Cloud Files.

  4. Open Aero on your device and import the asset.

Bring Illustrator assets as multi-layered content into Aero

To bring multi-layered assets from Illustrator into Aero, export as a PSD from Illustrator. This helps preserve the layers after importing into Aero. 

Poznámka:

If your creation is on a single layer but is separated into groups and elements, you can simply export as a PSD and then import assets

  1. From Adobe Illustrator CC, go to File>Export>Export As.

  2. Choose PSD.

  3. Click Export and click OK.

  4. Save the file that you want to import into Aero, in a place accessible from your mobile device (Creative Cloud or files).

  5. Optionally, edit the exported Photoshop Document.

  6. Open Aero on your device and import the asset.

  7. To space out the layers of your asset, select the layers and choose Spacing.

A few things to keep in mind

  • Every layer is rasterized upon import into Aero. Because every layer is rasterized, documents with a low number of layers are likely to have a better quality in Aero.
  • You can flatten layer groups from the Window > Layers panel in Adobe Illustrator. 
  • To use objects on different layers in Aero, separate the layers in Adobe Illustrator.
  • Layer groups at the top level are flattened into a single layer each.
  • Adjustment layers and blend modes at the top level are ignored.
  • Adjustment layers within layer groups are flattened.
  • Smart objects, text layers, layer effects, and vector layers are rasterized.
  • 3D layers at the top level are not processed. Upon import, the first normal layer is imported instead.
  • Channels applied as masks are a part of the layer composites. Extra channels are ignored.

What's next?

In Adobe Aero, follow the steps to import assets from Creative Cloud Files.

You can then place the asset, edit the scene, and add interactivity to your 3D content. 

Have a question or an idea?

If you have a question to ask or an idea to share, come and participate in Adobe Aero Community

Don’t forget to showcase your work on Behance and seek inspiration from others' work as well.

Logo Adobe

Prihláste sa do svojho účtu