Hata: Veri kırpma: Veri, sütun için çok uzun
Adobe Captivate Prime'da bir CSV yüklemeye çalışırken aşağıdaki hata mesajını görüntülüyorsunuz.
Neden
Belirtilen sütunda bulunan veriler sütun için tanımlanan karakter sınırını aşarsa hata oluşur.
Çözüm
- CSV'yi açın.
- Hatada belirtilen sütundaki verileri kontrol edin.
- Büyük bir değer (örneğin, 60 karakterden büyük) varsa verileri düzeltmek için değeri değiştirin.
Hata: CSV'deki ilk sütun, özel bir karakter görüntülüyor
İlk sütun, sütunları eşlerken özel bir karakter görüntülediği için CSV yükleyemiyorsunuz.
Neden
Sorun; CSV, Excel'de UTF-8 biçiminde kaydedildiğinde ortaya çıkar. Excel'de bir CSV'yi UTF-8 olarak kaydettiğinizde, dosya UTF-BOM biçiminde kaydedilir. Bunu Notepad++ kullanarak doğrulayabilir veya sütunları eşlerken bir CSV'yi Prime'a yüklediğinizde, ilk sütun özel bir karakter görüntülenir.
Çözüm
- A: Excel ile kaydetme:
- CSV'yi Excel ile açın.
- Dosyayı normal bir CSV olarak kaydedin.
- B: Notepad veya Notepad++ ile kaydetme:
- CSV'yi Notepad veya Notepad++ ile açın.
- Dosyayı UTF-8 formatında kaydedin.
Hata: Kullanıcının e-posta adresi sistemde zaten var
CSV işleme başarısız olduğu için CSV yükleyemiyorsunuz. Aşağıdaki hata mesajını görüntülüyorsunuz:
Neden
Bu sorun, sistemde zaten aynı e-posta adresine veya UUID'ye sahip bir kullanıcı varsa meydana gelir.
Çözüm
1. Senaryo
UUID'nin etkinleştirilmediği hesaplar.
Bu senaryoda, bu hatanın iki nedeni vardır:
- Eklemeye çalıştığınız kullanıcı, Harici bir profilin Müdürüdür. Bu sorunu çözmek için, kullanıcının bir parçası olduğu harici profili açıp kullanıcıyı seçin, Eylemler > Rol Ata > Yönetici seçeneğini tıklatın ve profilin Müdürünü değiştirin.
- Eklemeye çalıştığınız kullanıcı temizlenmiştir. Bu senaryoda, temizleme işlemi tamamlanana kadar aynı e-posta adresine sahip kullanıcıyı ekleyemezsiniz. Geçici bir çözüm olarak, platforma erişim sağlaması için kullanıcıyı ikincil bir e-posta adresi ile ekleyin. Temizleme işlemi tamamlandığında, kullanıcıyı düzenleyin ve e-posta adresini doğru e-posta adresiyle değiştirin.
2. Senaryo
UUID etkin hesaplar.
UUID etkin hesaplar için bu sorun; bir kullanıcıya, hesaptaki başka bir kullanıcı tarafından zaten kullanılmakta olan bir UUID atandığında veya kullanıcının farklı bir e-posta adresine sahip olması durumunda meydana gelebilir.
Örneğin; sırasıyla UUID 1 ve 2'ye sahip, e-posta adresleri a@xyz.com ve b@xyz.com olan A ve B adlı iki kullanıcıyı ele alalım.
Şimdi, A kullanıcısının UUID'sinin 3 ve B kullanıcısının UUID'sinin 2 olduğu bir CSV yüklerseniz hatayla karşılaşırsınız.
Bu sorunu çözmek için, CSV ve sistemdeki kullanıcıya ilişkin aynı e-posta adresine ve UUID'ye sahip olmalısınız.