使用手冊 取消

在 Animate 中使用多個檔案類型

  1. Adobe Animate 使用手冊
  2. Animate 簡介
    1. Animate 的新功能
    2. 視覺詞彙
    3. Animate 系統需求
    4. Animate 鍵盤快速鍵
    5. 在 Animate 中使用多個檔案類型
  3. 動畫
    1. Animate 中的動畫基本概念
    2. 如何在 Animate 中使用影格及關鍵影格
    3. Animate 中的逐格動畫
    4. 如何在 Animate 中使用傳統補間動畫
    5. 筆刷工具
    6. 移動導引線
    7. 移動補間動畫與 ActionScript 3.0
    8. 關於移動補間動畫
    9. 移動補間動畫
    10. 建立移動補間動畫
    11. 使用屬性關鍵影格
    12. 使用補間動畫將位置製成動畫
    13. 如何使用移動編輯器編輯移動補間動畫
    14. 編輯補間動畫的移動路徑
    15. 操作移動補間動畫
    16. 新增自訂加/減速
    17. 建立和套用移動預設效果
    18. 設定動畫補間動畫範圍
    19. 使用儲存為 XML 檔案的移動補間動畫
    20. 移動補間動畫與傳統補間動畫
    21. 形狀補間動畫
    22. 在 Animate 中使用骨塊工具動畫
    23. 在 Animate 進行角色製作
    24. 如何在 Adobe Animate 中使用遮色片圖層
    25. 如何在 Animate 中使用場景
  4. 互動
    1. 如何使用 Animate 建立按鈕
    2. 將 Animate 專案轉換成其他文件類型格式
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 在 Animate 中使用程式碼片段增加互動功能
    5. 建立自訂 HTML5 組件
    6. 在 HTML5 Canvas 中使用組件
    7. 建立自訂組件:範例
    8. 自訂組件的程式碼片段
    9. 最佳作法 - 使用 Animate 做廣告
    10. 虛擬實境編寫和發佈
  5. 工作區和工作流程
    1. 建立和管理繪圖筆刷
    2. 在 HTML5 Canvas 文件中使用 Google 字體
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作區
    6. 在 HTML5 Canvas 文件中使用網頁字體
    7. 時間軸與 ActionScript
    8. 使用多重時間軸
    9. 設定偏好設定
    10. 使用 Animate 編寫面板
    11. 使用 Animate 建立時間軸圖層
    12. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    13. 移動和複製物件
    14. 範本
    15. Animate 中的尋找和取代
    16. 還原、重做和操作記錄面板
    17. 鍵盤快速鍵
    18. 如何在 Animate 中使用時間軸
    19. 建立 HTML 擴充功能
    20. 影像和 GIF 動畫的最佳化選項
    21. 匯出影像和 GIF 的設定
    22. Animate 中的資源面板
  6. 多媒體和視訊
    1. 在 Animate 中變形及結合圖像物件
    2. 在 Animate 中建立並使用元件實體
    3. 影像描圖
    4. 如何在 Adobe Animate 中使用聲音
    5. 匯出 SVG 檔案
    6. 建立要在 Animate 中使用的視訊檔案
    7. 如何在 Animate 增加視訊
    8. 使用視訊提示點
    9. 使用 Animate 繪製及建立物件
    10. 調整線條和形狀
    11. 使用 Animate CC 中的筆畫、填色和漸層
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的色彩面板
    14. 使用 Animate 開啟 Flash CS6 檔案
    15. 在 Animate 中使用傳統文字
    16. 將圖案放入 Animate 中
    17. Animate 中匯入的點陣圖
    18. 3D 圖像
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 繪製線條和形狀
    21. 使用 Animate 中的元件庫
    22. 匯出聲音
    23. 在 Animate CC 中選取物件
    24. 在 Animate 中使用 Illustrator AI 檔案
    25. 使用噴刷工具套用圖樣
    26. 套用混合模式
    27. 排列物件
    28. 使用命令選單自動執行工作
    29. 多國語言文字
    30. 使用 Animate 中的攝影機
    31. 搭配使用 Animate 與 Adobe Scout
    32. 使用 Fireworks 檔案
    33. 圖像濾鏡
    34. 聲音和 ActionScript
    35. 繪圖偏好設定
    36. 使用鋼筆工具繪圖
  7. 平台
    1. 將 Animate 專案轉換成其他文件類型格式
    2. 自訂平台支援
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 建立並發佈 WebGL 文件
    5. 如何封裝 AIR for iOS 的應用程式
    6. 發佈 AIR for Android 應用程式
    7. Adobe AIR for Desktop 的發佈功能
    8. ActionScript 發佈設定
    9. 最佳作法 - 在應用程式中組織 ActionScript
    10. 如何搭配使用 ActionScript 與 Animate
    11. 最佳作法 - 輔助功能原則
    12. Animate 工作區中的輔助功能
    13. 撰寫和管理指令碼
    14. 啟用自訂平台的支援
    15. 自訂平台支援概觀
    16. 建立輔助功能內容
    17. 使用自訂平台支援外掛程式
    18. ActionScript 3.0 的除錯
    19. 啟用自訂平台的支援
  8. 匯出與發佈
    1. 如何從 Animate CC 匯出檔案
    2. OAM 發佈
    3. 匯出 SVG 檔案
    4. 使用 Animate 匯出圖像和視訊
    5. 發佈 AS3 文件
    6. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    7. 匯出聲音
    8. 匯出 QuickTime 視訊檔
    9. 使用 ActionScript 控制外部視訊播放
    10. 最佳作法 - 建立行動裝置內容的秘訣
    11. 最佳作法 - 視訊慣例
    12. 最佳作法 - SWF 應用程式編寫原則
    13. 最佳作法 - 建構 FLA 檔
    14. 最佳化 Animate 的 FLA 檔案的最佳作法
    15. ActionScript 發佈設定
    16. 指定 Animate 的發佈設定
    17. 匯出放映檔
    18. 匯出影像和 GIF 動畫
    19. HTML 發佈範本
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和發佈您的動畫

關於 Animate 檔案

在 Animate 中,您可以使用各種檔案類型,每個類型都有不同的用途:

  • 「FLA 檔案」是 Animate 的主要檔案,包含 Animate 文件的基本媒體、時間軸及指令碼資訊。「媒體物件」是構成 Animate 文件內容的圖像、文字、聲音和視訊物件。「時間軸」是 Animate 中的位置,您在此告知特定媒體物件應該出現在「舞台」上的時間。您可以將 ActionScript® 程式碼加入 Animate 文件,以便更精確地控制文件的行為,並使其回應使用者互動。

  • 未壓縮的 XFL 檔案類似於 FLA 檔案。XFL 檔案及位於相同資料夾內的其他相關聯檔案只是 FLA 檔案的未壓縮版。此格式更容易讓多個使用者同時處理 Animate 專案的不同元素。如需詳細資訊,請參閱使用未壓縮的 XFL 檔

  • 「SWF 檔」是 FLA 檔的壓縮版本,會顯示在網頁中。當您發佈 FLA 檔案,Animate 會建立 SWF 檔案。

    Animate SWF 檔案格式是其他應用程式支援的開放式標準。如需有關 Animate 檔案格式的詳細資訊,請參閱 www.adobe.com/go/flashplayer_tw

  • AS 檔案為 ActionScript 檔案,您可以使用這類檔案,在 FLA 檔案之外保留部分或全部 ActionScript 程式碼,這有助於程式碼組織以及專案中不同 Animate 內容部分的分工。

  • SWC 檔案包含可重複使用的 Animate 組件。每個 SWC 檔都包含一個編譯過的影片片段、ActionScript 程式碼以及任何組件所需要的資源。 注意:SWC 檔案無法匯入 Animate。
  • ASC 檔案是用來儲存在執行 Adobe Media Server 的電腦上所執行之 ActionScript 的檔案。這些檔案能夠實作伺服器端的邏輯,以便在 SWF 檔中與 ActionScript 一同運作。注意: Animate 不支援 ASC 檔案。
  • JSFL 檔案是 JavaScript 檔案,可讓您用來新增功能至 Animate 編寫工具。
  • APR 檔案可讓您將 Canvas 發佈範本與其發佈描述檔設定合併在一起。進一步地,連結至發佈描述檔的任何新資源也能合併、分享。如需詳細資訊,請參閱發佈設定

 

何謂 Animate?

Adobe

下列教學課程示範如何使用 Animate/Flash Pro。

使用其他 Adobe 應用程式

Animate 的設計可相容於其他 Adobe® 應用程式,讓您廣泛使用不同的應用程式來揮灑創意。您可以將 Illustrator® 與 Photoshop® 檔案直接匯入 Animate。您也可以從 Animate 建立視訊,再使用 Adobe® Premiere® Pro 或 After Effects® 加以編輯,或是使用這兩種應用程式的任一種將視訊匯入 Animate。當您發佈 SWF 檔案時,可以使用 Dreamweaver® 將內容嵌入網頁,並透過 Dreamweaver 直接啟動 Animate 來編輯其內容。

開啟 XFL 檔

從 Animate 開始,您所建立之 FLA 檔案的內部格式為 XFL。當您在 Animate 中儲存檔案時,預設格式為 FLA,但檔案的內部格式為 XFL。

其他 Adobe® 應用程式 (例如 After Effects®) 皆可匯出 XFL 格式的檔案。這些檔案的副檔名將會是 XFL,而不是 FLA。InDesign® 可直接以 FLA 格式匯出,其內部格式為 XFL。如此一來,您就可以先在 After Effects 或 InDesign 中使用專案,然後繼續在 Animate 中使用專案。

在 Animate 中開啟和使用 XFL 檔案的方式,就和 FLA 檔案一樣。當您在 Animate 開啟 XFL 檔案,您可以將檔案儲存為 FLA 檔案,或未壓縮的 XFL 檔案。

若要在 Animate 中開啟 XFL 檔案:

  1. 在另一個 Adobe® 應用程式中 (例如 InDesign 或 After Effects),將您的工作匯出為 XFL 檔。

    應用程式會在 XFL 檔中,保存原始檔案的所有圖層及物件。

  2. 在 Animate 中,選擇「檔案 > 開啟」,然後瀏覽至 XFL 檔案。按一下「開啟」。

    在 Animate 中開啟 XFL 檔案的方式,和開啟 FLA 檔案一樣。原始檔案的所有圖層都會顯示在「時間軸」中,原始物件則會顯示在「元件庫」面板中。

    現在,您可以正常使用檔案。

  3. 若要儲存檔案,請選擇「檔案 > 儲存」。

    Animate 會顯示「另存新檔」對話方塊,提示您為新的 FLA 檔案命名。

  4. 輸入名稱並儲存 FLA 檔。

使用未壓縮的 XFL 檔案

自 Animate 起,您可以選擇使用未壓縮 XFL 格式的 Animate 檔案。此格式可讓您查看組成 Animate 檔案的每個個別的部分或子檔案。這些部分如下:

  • 描述整個 Animate 檔案的單一 XML 檔案。

  • 描述每個「元件庫」元件的個別 XML 檔案。

  • 包含發佈設定、行動設定與其他設定的其他 XML 檔案。

  • 包含 Animate 檔案所使用之外部資源 (例如,點陣圖檔案) 的資料夾。

藉由使用未壓縮的 XFL 格式,您可以讓不同人員分別處理 Animate 檔案的每個部分。您也可以使用原始檔控制系統,管理未壓縮 XFL 檔案中針對每個子檔案所做的變更。整體而言,這些功能可讓涉及多位設計人員與開發人員的大型專案,更容易進行協作。

使用 XFL 檔案即時更新

藉由使用未壓縮 XFL 文件的即時更新可編輯資源,在 Animate 中開啟未壓縮 XFL 文件時,您就可以從文件編輯任何「元件庫」資源。當您在其他應用程式中完成編輯資源時,您對資源進行的變更將反映在 Animate 中。

在其他應用程式中編輯未壓縮 XFL 文件的資源:

  1. 以未壓縮的 XFL 格式儲存 Animate 文件。

  2. 在適當的編輯程式中 (例如,Photoshop),開啟未壓縮 XFL 文件 LIBRARY 資料夾中要編輯的資源。

  3. 編輯資源並儲存變更。

  4. 返回 Animate。

    對資源進行的更新將立即反映在 Animate 中。

在 Animate 中編輯 Dreamweaver 製作的 SWF 檔案

如果已安裝 Animate 和 Dreamweaver,則可以選取 Dreamweaver 文件中的 SWF 檔案,並以 Animate 進行編輯。Animate 不會直接編輯 SWF 檔案;它會編輯來源文件 (FLA 檔案),然後重新匯出 SWF 檔案。

  1. 在 Dreamweaver 中,開啟「屬性」檢視窗 (「視窗 > 屬性」)。
  2. 在 Dreamweaver 文件中執行下列其中一項作業:
    • 按一下 SWF 檔案預留位置來選取它,然後在「屬性」檢視窗中按一下「編輯」。

    • 按一下滑鼠右鍵 (Windows) 或按 Control 並按一下 (Macintosh) SWF 檔案的預留位置,然後從內容選單中選取「使用 Animate 編輯」。

      Dreamweaver 會將焦點切換到 Animate,而 Animate 會嘗試找出所選 SWF 檔案的 Animate 編寫檔案 (FLA)。如果 Animate 找不到 Animate 編寫檔案,系統會顯示尋找的提示。

      如果 FLA 檔案或 SWF 檔案遭到鎖定,請在 Dreamweaver 中取出檔案。

  3. 在 Animate 中編輯 FLA 檔案。「Animate 文件」視窗會顯示您正從 Dreamweaver 內修改檔案。

  4. 完成編輯後,請按一下「完成」。

    Animate 會更新 FLA 檔案,將其重新匯出為 SWF 檔案、關閉檔案,然後把焦點放回 Dreamweaver 文件。

    若要更新 SWF 檔案並讓 Animate 處於開啟狀態,請在 Animate 中選取 Dreamweaver 的「檔案 > 更新」。

  5. 只要按一下 Dreamweaver「屬性」檢視窗中的「播放」,或按 F12 鍵在瀏覽器視窗中預覽頁面,就可以檢視文件中已更新的檔案。

建立新文件

您可以建立新的文件或開啟先前在 Animate 中儲存的文件,而且可在工作時開啟新的視窗。此外,也可以設定新的或現有文件的屬性。

您可以從 Animate 提供的預設集格式中,依任何目的為您的動畫選擇目的地。請從畫面頂端的索引標籤中選擇您要的目的,例如「角色動畫」、「社交」、「遊戲」、「教育」、「廣告」、「網頁」和「進階」。

為每一個目的選取適用的預設集,並按一下「建立」開始建立動畫。您可以在左邊窗格檢視最近使用過的資源。樣本資源則在啟動畫面底部提供。

建立新文件

  1. 選取「檔案 > 新增」

    新增文件
    新增文件

  2. 請從畫面頂端的索引標籤中選擇您要的目的,例如「角色動畫」、「社交」、「遊戲」、「教育」、「廣告」、「網頁」和「進階」。

  3. 為每一個目的選取適用的預設集,並按一下「建立」

    此外,您也可以為文件選擇設定。請參閱設定新的或現有文件的屬性

使用 Animate 中的文件類型

將文件轉換成不同類型,例如 HTML 5、WegGl、GLTF、360 度、全景等,在 Animate 上只要按兩下就能辦到。想要透過各種選項轉換您的視訊,以便在不同平台上檢視嗎?請觀賞此範例結尾的教學課程並依照下列步驟執行。

  1. 在「Home」頁面中,按一下「進階」索引標籤。

  2. 檢視選項,以便在不同平台使用文件。

  3. 按一下「檔案 > 轉換為」並選取必要的選項。

如何使用 Animate 中的文件類型

請觀賞影片,深入了解每個功能的特性。

從範本建立新文件

  1. 選取「檔案 > 從範本新增」

    「從範本新增」對話方塊
    「從範本新增」對話方塊

  2. 從「類別」清單選取類別,再從「類別項目」清單選取文件,然後按一下「確定」。您可以從 Animate 所附的標準範本中選取,或是選取您已儲存的範本。

開啟現有文件

  1. 選取「檔案 > 開啟」

  2. 在「開啟舊檔」對話方塊中瀏覽至該檔案,或是在「前往」方塊中輸入該檔案的路徑。
  3. 按一下「開啟」。

在已開啟多份文件的情況下檢視文件

開啟多份文件時,「文件」視窗頂端的標籤便會辨識出已開啟的文件,讓您可以輕鬆地在這些文件之間進行瀏覽。只有當文件在「文件」視窗中以最大化顯示時,才會顯示標籤。

  1. 按一下您要檢視之文件的標籤。

    根據預設,標籤會依照文件建立的順序顯示。您可以透過拖曳方式,改變文件標籤的順序。

為目前的文件開啟新視窗

  1. 請選取「視窗 > 重製視窗」。

設定新的或現有文件的屬性

  1. 在該文件已開啟的情況下,選取「修改 > 文件」。

    會出現「文件設定」對話方塊。

  2. 若要設定舞台的尺寸,請執行下列其中一個步驟:
    • 若要以像素指定舞台大小,請在「寬度」與「高度」方塊中輸入數值。最小的「舞台」大小為 1 x 1 像素,最大則為 2880 x 2880 像素。

    • 若要使舞台大小完全符合舞台內容使用的空間量,請選取「符合: 內容」選項。

    • 若要將舞台大小設為最大可用的列印範圍,請選取「符合: 印表機」。此範圍是由紙張大小減去目前在「頁面設定」對話方塊 (Windows) 或「列印邊界」對話方塊 (Macintosh) 中的「邊界」範圍內所選取的邊界。

    • 若要將舞台大小設為預設大小 (550 x 400 像素),請選取「符合: 預設值」。

  3. 要指定影格速率,請使用「影格速率」選項輸入影格速率。

    影格速率

  4. 若要在舞台上調整 3D 物件的位置和方向,以維持它們相對於舞台邊緣的外觀,請選取「調整 3D 透視角度以保留目前的舞台投影」。

    只有當您變更舞台大小時,才能使用此選項。

  5. (僅限 CS5.5) 若要隨著舞台大小的變更來自動縮放舞台的內容,請選取「隨著舞台縮放內容」。

    只有當您變更舞台大小時,才能使用此選項。您可以在「偏好設定」中選擇是否縮放鎖定圖層與隱藏圖層中的內容。如需詳細資訊,請參閱設定一般偏好設定

  6. 若要指定工作區顯示之尺規的度量單位,請從「尺規單位」選單中選取選項。(這項設定也會決定在「資訊」面板中使用的單位)。
  7. 若要設定文件的背景顏色,請按一下「背景顏色」色票,再從色盤中選取顏色。
  8. 「影格速率」部分,請輸入每秒要顯示的動畫影格數目。

    對於大多數在電腦上顯示的動畫來說 (特別是透過網站播放的動畫),8 fps 至 15 fps 的每秒的影格數已相當足夠。當您變更影格速率時,新的影格速率就會變成新文件的預設速率。

  9. (僅限 CS5.5) 若要以指定的時間間隔自動儲存文件,請選取「自動儲存」選項,並指定儲存間隔的分鐘數。
  10. 執行下列其中一項:
    • 若只要將新的設定套用到目前的文件,請按一下「確定」。

    • 若要將這些新設定做為所有新文件的預設屬性,請按一下「設成預設」。

使用屬性檢測器變更文件屬性

  1. 在「舞台」外部的工作區域按一下,以取消選取「舞台」上的所有物件。文件屬性會顯示在「屬性」檢測器中。若要開啟「屬性」檢測器,請選擇「視窗 > 屬性」。
  2. (僅限 CS5.5) 在「發佈」區段中,選擇您文件適用的 Flash Player 版本與 ActionScript 版本。若要存取其他「發佈」設定,請按一下「發佈設定」按鈕。

  3. 在「屬性」區段中,針對 FPS (每秒影格數目) 輸入每秒播放的動畫影格數目。
  4. 若要變更「舞台」大小,請輸入「舞台」的寬度與長度值。
  5. 若要選取「舞台」的背景顏色,請按一下「舞台」屬性旁的色票,從色盤中選取一個顏色。
  6. 若要編輯其他文件屬性,請按一下「大小」屬性旁的「編輯」按鈕。如需所有文件屬性的詳細資訊,請參閱為新文件或現有文件設定屬性

Animate CC 容易使用,並且可讓您使用數個組件。想要了解如何在 Animate 上使用基本介面和工具嗎?請觀賞此範例結尾的教學課程並依照下列步驟執行。

將 XMP 中繼資料加入文件

您可以在 FLA 檔中包含「可延伸中繼資料平台」(XMP) 資料,例如標題、作者、說明、版權等等。XMP 為其他特定 Adobe® 應用程式可辨識的中繼資料格式。在 Animate 和 Adobe® Bridge 中,可以檢視此中繼資料。如需 XMP 中繼資料的詳細資訊,請參閱 Bridge「說明」中的「中繼資料與關鍵字」。

Adobe Animate 不支援 32 位元 Bridge。

嵌入中繼資料會改善網路搜尋引擎的能力,以傳回有意義的 Animate 內容搜尋結果。搜尋中繼資料是依據 XMP (可延伸中繼資料平台) 規格,儲存在採用 W3C 相容格式的 FLA 檔中。

檔案的中繼資料包含有關檔案的內容、版權狀態、來源和記錄的資訊。在「檔案資訊」對話方塊中,您可以檢視和編輯目前檔案的中繼資料。

視選取的檔案而定,可能會出現下列幾種中繼資料:

說明

包含作者、標題、版權及其他資訊。

IPTC

顯示可編輯的中繼資料。您可為檔案加入註解和版權資訊。IPTC Core 是由 IPTC (國際新聞通訊協會) 於 2004 年 10 月份批准的一項規格。這項規格與舊版的 IPTC (IIM,舊版) 不同之處在於:增加了新的屬性、某些屬性名稱已經變更,而且也刪除了一些屬性。

相機資料 (Exif)

顯示數位相機所指定的資料,包括拍照時採用的相機設定。

視訊資料

顯示視訊檔的中繼資料,包括像素比例、場景和運鏡。

音效資料

顯示音效檔的中繼資料,包括演出者、專輯、曲目編號和類型。

行動裝置 SWF

列出 SWF 檔的相關資訊,包括標題、作者、說明和版權資訊。

步驟記錄

保存以 Photoshop 所做的影像變更之記錄。

注意: 必須在 Photoshop 啟用「步驟記錄」偏好設定,此記錄才會存入檔案的中繼資料。

Version Cue

列出任何 Version Cue 檔案版本資訊。

DICOM

顯示儲存成「醫療數位影像暨通訊」(DICOM) 格式的影像之相關資訊。

加入中繼資料:

  1. 選擇「檔案 > 檔案資訊」。
  2. 在出現的「檔案資訊」對話方塊中,輸入您要包含的中繼資料。您隨時可以在 FLA 檔中新增或移除中繼資料。

儲存 Animate 文件

儲存 Animate FLA 文件時,您可以使用該文件目前的名稱和位置,或是不同的名稱或位置。

當文件包含尚未儲存的變更時,文件標題列、應用程式標題列及文件標籤中的文件名稱後方將會出現星號 (*)。儲存文件之後,星號便會消失。

以預設的 FLA 格式儲存 Animate 文件

  1. 執行下列其中一項:
    • 若要覆寫目前磁碟機上的版本,請選取「檔案 > 儲存檔案」。

    • 若要將文件以不同位置和/或不同名稱儲存,或是要壓縮文件時,請選取「檔案 > 另存新檔」。

  2. 當您選取了「另存新檔」命令,或是您從未儲存該文件時,請輸入檔名與位置。
  3. 按一下「儲存」。

以未壓縮的 XFL 格式儲存文件

  1. 請選擇「檔案 > 另存新檔」。
  2. 從「存檔類型」選單中,選擇「Animate 未壓縮文件 (*xfl)」。

  3. 選擇檔案的名稱和位置,然後按一下「儲存」。

回復成文件上次儲存的版本

  1. 請選取「檔案 > 回復至上次儲存」。

將文件另存成範本

  1. 請選取「檔案 > 另存成範本」。
  2. 請在「另存成範本」對話方塊的「名稱」方塊中輸入範本的名稱。
  3. 請在「類別」彈出式選單中選取類別,或輸入名稱以建立新類別。
  4. 在「說明」方塊中輸入該範本的說明 (最多 255 個字元),然後按一下「確定」。

    當您在「新增文件」對話方塊中選取該範本時,便會顯示這份說明。

    若要刪除儲存的範本,請瀏覽至下列其中一個資料夾,從包含範本 FLA 檔案的類別資料夾中將它刪除。

    • Windows 10 - C:\Users\<使用者名稱>\AppData\Local\Adobe\<版本>\<app_locale>\Configuration\Templates\
    • Mac OS - <HardDisk>/Users/<使用者名稱>/Library/Application Support/Adobe/Flash CS5/<語言>/Configuration/Templates/

結束 Animate 時儲存文件

  1. 選取「檔案 > 結束」(Windows) 或「Animate > 結束 Animate」(Macintosh)。

  2. 如果開啟的文件裡有尚未儲存的變更,Animate 會提示您儲存或放棄每個文件中的變更。

    • 按一下「是」儲存變更並關閉文件。

    • 按一下「否」在不儲存變更的情況下關閉文件。

列印 Animate 文件 (Flash Professional 不建議使用)

若要預覽並編輯文件,您可以從 Adobe Animate 文件中列印影格,或指定檢視者可透過 Flash Player 列印的影格。

從 Animate 文件中列印影格時,請使用「列印」對話方塊,指定要列印的場景或影格範圍,以及列印的份數。在 Windows 中,您可以使用「頁面設定」對話方塊指定紙張大小、方向與各種列印選項 (包括邊界設定、是否每頁的所有影格都要列印等等)。在 Macintosh 中,這些選項會分散到「頁面設定」與「列印邊界」對話方塊中。

「列印」與「版面設定」對話方塊在上述作業系統中都是標準形式,其外觀會依選取的印表機驅動程式有所不同。

  1. 選取「檔案 > 頁面設定」(Windows) 或「檔案 > 列印邊界」(Macintosh)。
  2. 設定頁面邊界。選取「置中」的兩個選項,以便將影格列印在頁面中間。
  3. 在「影格」選單中,選取是否要列印文件中的所有影格,或是僅列印每個場景的第一個影格。
  4. 在「版面」選單中,您會看到下列選項:

    實際尺寸

    以完整的大小列印影格。請在「縮放」中輸入值,縮小或放大即將列印的影格。

    調整至一頁

    縮小或大每個影格,使其剛好填滿頁面的列印區域。

    分鏡板

    將數個縮圖列印在一頁。選取「方框」、「格線」或「空白」。請在「影格」方塊中輸入每頁的縮圖數目,在「影格邊界」方塊中設定縮圖之間的間距,然後選取「標籤影格」,將影格標籤列印為縮圖。

  5. 若要列印影格,請選取「檔案 > 列印」。

使用影格標籤以停用列印功能

若要選取不列印主「時間軸」中的任何影格,請將某個影格標示為 ! #p,讓整個 SWF 檔都無法被列印。將影格標示為 ! #p 會使 Flash Player 快顯選單中的「列印」命令呈現灰色。您也可以移除 Flash Player 快顯選單。

如果您停用在 Flash Player 中的列印功能,使用者仍可使用瀏覽器的「列印」命令列印影格。因為這個命令屬於瀏覽器功能,您無法使用 Animate 控制或停用此功能。

停用 Flash Player 快顯選單中的列印功能

  1. 開啟或啟用 Animate 文件 (FLA 檔案) 以便發佈。

  2. 選取主時間軸中的第一個關鍵影格。
  3. 選取「視窗 > 屬性」,檢視「屬性」檢測器。
  4. 在「屬性」檢測器的「影格標籤」中,輸入 ! #p ,將該影格指定為非列印影格。

    若要讓快顯選單中的「列印」命令變暗,請僅指定一個 ! #p 標籤會讓快顯選單中的「列印」命令呈現灰色。

    另一個做法是選取空白影格 (而非關鍵影格) 並加上 #p。

移除 Flash Player 快顯選單以停用列印功能

  1. 開啟或啟用 Animate 文件 (FLA 檔案) 以便發佈。

  2. 選取「檔案 > 發佈設定」。
  3. 選取「HTML」標籤,再取消選取「顯示選單」,然後按一下「確定」。

在列印影格時指定列印區域

  1. 開啟含有想列印影格的 Animate 文件 (FLA 檔案)。

  2. 在已標有 #p 的影格所在相同圖層上,選取尚未使用 #p 影格標籤指定要列印的影格。

    若要組織您的工作,請選取標有 #p 標籤之影格的下一個影格。

  3. 在舞台上建立一個形狀,大小和您想要列印的區域相等。若要使用影格的範圍框,請選取包含適當列印區域大小之物件的影格。
  4. 在「時間軸」中選取含有您即將拿來當做範圍框使用之形狀的影格。
  5. 在「屬性」檢測器 (「視窗 > 屬性」) 的「影格標籤」中輸入 #b,將您選取的形狀指定為列印區域的範圍框。

    每一個「時間軸」只允許使用一個 #b 影格標籤。這個選項與使用「列印」動作選取「影片」範圍框選項相同。

變更列印的背景顏色

您可以列印在「文件屬性」對話方塊中設定的背景顏色。若您只想為要列印的影格變更背景顏色,請將有顏色的物件放在要列印之「時間軸」的最底層。

  1. 將一個涵蓋舞台的填色形狀放在即將列印的時間軸的最底層。
  2. 選取該形狀,然後選取「修改 > 文件」。選取列印背景的顏色。

    這個動作會變更整份文件的背景顏色,包括影片片段和載入的 SWF 檔。

  3. 執行下列其中一項:
    • 若要將該顏色列印為文件的背景顏色,請指定列印您在其中放置該形狀的影格。

    • 若要將非列印影格保持為不同的背景顏色,請重複步驟 2 和 3。然後,將位於「時間軸」最底層的形狀放置於所有未指定要列印的影格中。

您可以使用 Flash Player 快顯選單中的「列印」命令,列印任何 Animate SWF 檔案中的影格。

快顯選單中的「列印」命令無法列印透明度或顏色效果,亦無法列印其他影片片段中的影格。如需更多進階列印功能,請使用 PrintJob 物件或 print() 函數。

  1. 開啟文件。

    這個命令會使用列印區域的「舞台」或指定的範圍框,列印標有 #p 的影格。

    若您尚未指定要列印哪些特定影格,則會列印該份文件之主「時間軸」中的所有影格。

  2. 選取「檔案 > 發佈預覽 > 預設」,或是按 F12,在瀏覽器中檢視 Animate 內容。

  3. 在瀏覽器視窗的 Animate 內容中按一下右鍵 (Windows) 或按住 Control 並按一下 (Macintosh),顯示 Flash Player 快顯選單。

  4. 在 Flash Player 快顯選單中選取「列印」,顯示「列印」對話方塊。
  5. 在 Windows 中,請選取「列印範圍」以選取要列印哪些影格。
  6. 在 Macintosh 的「列印」對話方塊中,則是選取要列印的頁面。
  7. 根據您的印表機內容,選取其他列印選項。
  8. 按一下「確定」(Windows) 或「列印」(Macintosh)。

當您透過快顯選單進行列印時,並不會影響到 PrintJob 物件之呼叫。

Adobe 標誌

登入您的帳戶