關於 Adobe AIR

Adobe® AIR™ 是一種跨作業系統的執行階段,可讓您利用現有的網頁開發技術 (Adobe® Animate® 、Adobe® Flex™、Adobe® Flash Builder™ HTML、JavaScript®、Ajax) 建置多樣化網際網路應用程式 (Rich Internet Application,RIA),並將其部署至桌面。AIR 讓您能在熟悉的環境中作業,運用您最了解的工具和方法,並透過支援 Animate、Flex、HTML、JavaScript 和 Ajax,以建置符合您個人需求的絕佳體驗。

使用者與 AIR 應用程式互動的方式無異於與原生桌面應用程式互動。只要在使用者的電腦中安裝一次執行階段,之後便可以像其他桌面應用程式一樣安裝並執行多個 AIR 應用程式。執行階段會提供用於部署應用程式的一致性跨作業系統平台和架構,因此藉由確保能跨電腦提供一致的功能和互動,便不需執行跨瀏覽器測試。您不必再為特定作業系統開發程式,只要將重心放在執行階段即可。

AIR 大幅改變了應用程式的建立、部署方式與操作體驗。您不需要學習傳統的電腦部署技巧,就可以獲得更多具有創意的控制方式,並且擴充您的 Animate、Flex、HTML 和 Ajax 類型應用程式。

如需有關桌上型電腦及行動裝置 AIR 應用程式的硬體和軟體需求資訊,請參閱 AIR 系統需求

如需有關開發 Adobe AIR™ 應用程式的完整資訊,請參閱建立 Adobe AIR 應用程式

建立 Adobe AIR 檔

您可以使用 Animate「歡迎螢幕」或「檔案 > 新增」命令建立 Adobe AIR Animate 文件,或先建立 ActionScript® 3.0 Animate 檔案再透過「發佈設定」對話方塊將其轉換成 Adobe AIR 檔案。

若要建立 Adobe AIR 檔,請執行下列其中一項:

  • 啟動 Animate。「歡迎螢幕」便會出現。如果您已啟動 Animate,請關閉任何開啟的文件以返回「歡迎螢幕」。在「歡迎螢幕」中,選取 Adobe AIR 2 (CS5) 或 AIR (CS5.5)。

    注意:如果您已經停用 Animate「歡迎螢幕」,請選取「編輯 > 偏好設定」,再從「一般」類別的「啟動時文件狀態」彈出式選單中選取「歡迎螢幕」,就可以再度顯示該螢幕。

  • 從畫面頂端的索引標籤中選擇「檔案 > 新增 > 進階」,並選取「Adobe AIR 2 (CS5)」或「AIR (CS5.5)」,然後按一下「確定」。

Template_air
範本 Air
  • 開啟現有的 Animate 檔案,接著在「發佈設定」對話方塊 (「檔案 > 發佈設定」) 的「Animate」標籤上,從「播放程式」彈出式選單中選取「Adobe AIR」,將其轉換成 AIR 檔案。

註解:

(僅適用於 Flash CS5) 如果您將 Flash CS5 AIR 檔儲存成 Flash CS4 格式,則在 Flash CS4 中開啟該檔案時,請在「發佈設定」對話方塊中手動將播放程式版本設定為 AIR 1.5。Flash CS4 僅支援發佈成 AIR 1.5。

預覽或發佈 Adobe AIR 應用程式

您可以預覽 AIR SWF 檔顯示在 AIR 應用程式視窗中的外觀。預覽功能相當有用,讓您不需要封裝與安裝應用程式,就能查看應用程式的可見元素顯示情形。

  1. 確定已在「發佈設定」對話方塊的「Animate」索引標籤上,將「目標」設定設為「Adobe AIR」。

  2. 選取「控制 > 測試影片 > 測試」或按 Control+Enter。

若您尚未透過「AIR - 應用程式和安裝程式設定」對話方塊設定應用程式設定,Animate 就會在 SWF 檔案所寫入的相同資料夾中產生預設的應用程式描述器檔案 (swfname-app.xml)。如果您已使用「AIR 應用程式和安裝程式設定」對話方塊設定應用程式設定,則應用程式描述器檔案會反映該設定。

若要發佈 AIR 檔,請執行下列其中一項:

  • 在「發佈設定」對話方塊中,按一下「發佈」按鈕。

  • 在「AIR 應用程式和安裝程式設定」對話方塊中,按一下「發佈」按鈕。

  • 選擇「檔案 > 發佈」。

  • 選擇「檔案 > 發佈預覽」。

發佈 AIR 檔案時,Animate 會建立 SWF 檔案和 XML 應用程式描述器檔案,並將兩者的複本連同您已加入應用程式中的任何其他檔案一併封裝成 AIR 安裝程式檔案 (swfname.air)。

註解:

(僅適用於 Windows) 如果檔案名稱包含非英文字元,發佈 AIR 應用程式就會失敗。

建立 AIR 應用程式和安裝程式檔案

應用程式開發完成後,請為 AIR 應用程式描述器檔案和安裝程式檔案指定各項必要設定,以便部署應用程式。Animate 在發佈 AIR 檔案時,會連同 SWF 檔案一併建立描述器檔案和安裝程式檔案。

這些檔案的設定是在「AIR - 應用程式和安裝程式設定」對話方塊中指定。當您建立了 AIR 檔案之後,即可從以下位置開啟這個對話方塊:文件的「屬性」檢測器,或在「發佈設定」對話方塊的「Animate」標籤上,按一下「播放程式」選單旁的「設定」按鈕。

建立 Adobe AIR 應用程式和安裝程式檔案

  1. 在 Animate 中,開啟構成 Adobe AIR 應用程式的 FLA 檔案或一組檔案。

  2. 先儲存 Adobe AIR FLA 檔案,然後再開啟「AIR 設定」對話方塊。

  3. 選取「檔案 > AIR 2 設定」。

  4. 完成「AIR 設定」對話方塊,然後按一下「發佈」。

    當您按一下「發佈」按鈕後,將會封裝下列檔案:SWF 檔、應用程式描述器檔案、應用程式圖示檔案,以及列於「包含的檔案」文字方塊中的檔案。如果您尚未建立數位憑證,Animate 將在您按下「發佈」按鈕後顯示「數位簽名」對話方塊。

「AIR 應用程式和安裝程式設定」對話方塊分成 4 個標籤:「一般」、「簽名」、「圖示」與「進階」。如需有關這些設定的詳細資訊,請參閱下列各節。

一般設定

「AIR 應用程式和安裝程式設定」對話方塊中的「一般」標籤包含下列選項:

輸出檔案

使用「發佈」命令時,所建立 .air 檔案的名稱與位置。

輸出為

要建立的套件類型。

  • AIR 套件 - 建立標準 AIR 安裝程式檔案,其中假設 AIR 執行階段可以在安裝期間個別下載,或者已安裝在目標裝置上。
  • Mac 安裝程式 - 建立完整的 Macintosh 安裝程式檔案。
  • 內嵌執行階段的應用程式 - 建立 AIR 安裝程式檔案,其中包含 AIR 執行階段,因此,不需另外下載。

Windows 安裝程式

選取此選項,即可編譯原生、平台專用的 Windows 安裝程式 (.exe),而非與平台無關的 AIR 安裝程式 (.air)。

名稱

應用程式主要檔案的名稱。預設值為 FLA 檔的名稱。

版本

這是選擇性的。指定應用程式的版本號碼。預設值為 1.0。

應用程式 ID

透過此唯一 ID 來識別您的應用程式。您可以依個人需要變更預設 ID。請勿在 ID 中使用空格或特殊字元。有效字元僅限於 0-9、a-z、A-Z、. (點) 和 - (破折號),長度為 1 至 212 個字元。預設值為 com.adobe.example.applicationName

說明

這是選擇性的。讓您輸入應用程式的說明,以透過安裝程式視窗向安裝應用程式的使用者顯示。預設值為空白。

版權資訊

這是選擇性的。讓您輸入版權聲明。預設值為空白。

視窗樣式

指定當使用者在其電腦上執行應用程式時,使用者介面所採用的視窗樣式 (或色調)。您可以指定「系統顏色」(預設值),此選項是指作業系統所使用的標準視窗視覺樣式。您也可以指定「自訂顏色 (不透明)」或「自訂顏色 (透明)」。如果您不要以系統顏色顯示應用程式,請選取「無」。「系統顏色」會將作業系統的標準視窗控制項環繞在應用程式四周。「自訂顏色 (不透明)」則會移除標準系統色調,讓您可以自行建立應用程式的色調 (您可直接在 FLA 檔中建構自訂顏色)。「自訂顏色 (透明)」與「自訂顏色 (不透明)」相似,但還會使頁面邊緣呈現透明,讓應用程式視窗的形狀變成非正方形或非矩形。

顯示模式

讓您可以指定 AIR 執行階段顯示圖像內容的方法。選項包括:

  • 自動 - 自動偵測並使用主機裝置上最快的顯示方法。
  • CPU - 使用 CPU。
  • 直接 - 使用 Stage3D 顯示。這是最快的顯示方法。

如需不支援「直接」模式的處理器清單,請參閱 Stage3D 不支援的晶片組、驅動程式 | Flash Player 11,AIR 3


描述檔

建立 AIR 檔案時所要包括的描述檔。若要限制 AIR 應用程式使用特定的描述檔,請取消選取不需要的描述檔。 

內含的檔案

指定要在應用程式套件中包含哪些其他檔案和資料夾。按一下「加號 (+)」按鈕可加入檔案,按一下資料夾按鈕則可加入資料夾。若要刪除清單中的檔案或資料夾,請選取該檔案或資料夾,然後按一下「減號 (-)」按鈕。

根據預設,應用程式描述器檔案和主要的 SWF 檔會自動加入到套件清單中。即使您尚未發佈 Adobe AIR FLA 檔,這份套件清單仍會顯示這些檔案。此套件清單會以一般結構來顯示這些檔案和資料夾。資料夾中的檔案並未列出,而檔案的完整路徑雖會列出,但會在必要時截斷。

如果您曾經將任何 AIR 原生擴充功能檔案加入 ActionScript 元件庫路徑,那些檔案也出現在這份清單中。

圖示檔案不會包含於此清單中。Animate 對檔案進行封裝時,會將圖示檔案複製到相對於 SWF 檔案所在位置的暫存資料夾。待封裝完成後,Animate 隨即刪除該資料夾。

簽名設定

「AIR 應用程式和安裝程式設定」對話方塊中的「簽名」標籤可指定應用程式的程式碼簽署憑證。

如需有關數位簽名的詳細資訊,請參閱簽署您的應用程式為 AIR 檔加上數位簽名

圖示設定

「AIR 應用程式和安裝程式設定」對話方塊中的「圖示」標籤可指定應用程式的圖示。當您安裝該應用程式並在 Adobe AIR 執行階段中加以執行後,便會出現這個圖示。您可為圖示指定四種不同的大小 (128、48、32 和 16 像素) 以配合顯示圖示的不同檢視。例如,圖示可以在檔案瀏覽器中以縮圖、詳細資料和並排檢視加以顯示。圖示也可以顯示成桌面圖示、顯示在 AIR 應用程式視窗標題上,以及其他地方。

如果未指定任何其他圖示檔,圖示影像將預設為範例 AIR 應用程式圖示 (僅適用於 Flash CS5)。

若要指定圖示,請按一下「圖示」標籤上方的其中一個圖示大小,然後瀏覽至要使用此大小的檔案。檔案必須是 PNG (可攜式網路圖案) 格式。

如果您要自行指定影像,必須指定尺寸符合規格 (128x128、48x48、32x32 或 16x16) 的影像。若您並未提供某種特定圖示大小的影像,Adobe AIR 將會縮放其中一個已提供的影像來建立遺漏的圖示影像。

進階設定

「進階」標籤可指定應用程式描述器檔案的額外設定。

您可以指定 AIR 應用程式應處理的任何關聯檔案類型。例如,若要將您的應用程式設為用於處理 HTML 檔案的主要應用程式,請在「關聯的檔案類型」文字方塊中指定該檔案類型。

您也可以指定應用程式的下列各項設定:

  • 起始視窗的大小和位置

  • 將應用程式安裝在哪個資料夾

  • 將應用程式放置在哪個程式選單資料夾

此對話方塊提供了下列選項:

關聯的檔案類型

讓您指定 AIR 應用程式將要處理的關聯檔案類型。若要在文字方塊中加入新的檔案類型,請按一下「加號 (+)」按鈕。按下「加號」按鈕將會顯示「檔案類型設定」對話方塊。按下「減號 (-)」按鈕則可移除文字方塊中選取的項目。按下「鉛筆」按鈕也會顯示「檔案類型設定」對話方塊,讓您能夠編輯文字方塊中選取的項目。根據預設,「減號 (-)」和「鉛筆」按鈕都是呈現灰色。一旦您在文字方塊中選取項目,就能啟用「減號 (-)」和「鉛筆」按鈕,進而移除或編輯該項目。文字方塊中的預設值為「無」。

初始視窗設定

讓您指定初始應用程式視窗的大小和位置設定。

  • 寬度:指定視窗的起始寬度,以像素為單位。此值預設為空白。

  • 高度:指定視窗的起始高度,以像素為單位。此值預設為空白。

  • X:指定視窗的起始水平位置,以像素為單位。此值預設為空白。

  • Y:指定視窗的起始垂直位置,以像素為單位。此值預設為空白。

  • 最大寬度、最大高度:指定視窗的大小上限,以像素為單位。這些值預設為空白。

  • 最小寬度、最小高度:指定視窗的大小下限,以像素為單位。這些值預設為空白。

  • 可最大化:讓您指定使用者是否可將視窗最大化。此選項預設為已選取 (或 true)。

  • 可最小化:讓您指定使用者是否可將視窗最小化。此選項預設為已選取 (或 true)。

  • 可調整大小:讓您指定使用者是否可以調整視窗大小。如果沒有選取此選項,則「最大寬度」、「最大高度」、「最小寬度」和「最小高度」都將呈現灰色。此選項預設為已選取 (或 true)。

  • 可見:讓您指定是否一開始就顯示應用程式視窗。此選項預設為已選取 (或 true)。

其他設定

讓您指定與安裝有關的下列其他資訊:

  • 安裝資料夾:指定要將應用程式安裝在哪個資料夾。

  • 程式選單資料夾 (僅適用於 Windows):指定應用程式的程式選單資料夾名稱。

  • 使用自訂 UI 進行更新:指定一旦使用者開啟已安裝之應用程式的 AIR 安裝程式檔案時該如何處置。根據預設,AIR 會顯示對話方塊,讓使用者將已安裝的版本更新為 AIR 檔的版本。如果您希望應用程式能夠完全控制其更新方式,而不要讓使用者自己決定,請選取此選項。選取此選項將會覆寫預設行為,而由應用程式自行控制其更新方式。

語言設定

「語言」窗格可讓您選取應用程式商店或市場中,要與您的應用程式產生關聯的語言。透過選取語言,可讓使用該語言的作業系統使用者下載您的應用程式。請注意,這些語言設定不會進行其他動作來當地化您的應用程式使用者介面。

如果未選取語言,應用程式就會使用所有支援的語言來發佈。如此,您就不需要選取每個語言。列出的語言是 Adobe AIR 支援的語言。Android 可能支援其他語言。

檔案類型設定

當您在「進階」標籤的「關聯的檔案類型」區段中按一下「加號 (+)」按鈕或「鉛筆」按鈕,以加入或編輯 AIR 應用程式的關聯檔案類型時,Animate 便會顯示「檔案類型設定」對話方塊。

此對話方塊中的必填欄位只有兩個:「名稱」和「副檔名」。如果您未填入這其中任何一個欄位就按下「確定」,Animate 將顯示錯誤對話方塊。

針對關聯的檔案類型,您可以指定下列設定:

名稱

檔案類型的名稱 (例如「超文字標記語言」、「文字檔」或「範例」)。

副檔名

檔案副檔名 (例如 html、txt 或 xmpl),最多可為 39 個基本英數字元 (A-Z、a-z、0-9) 且不包含前置句號。

說明

這是選擇性的。指定檔案類型的說明 (例如「Adobe 視訊檔案」)。

內容類型

這是選擇性的。指定檔案的 MIME 類型。

檔案類型圖示設定

這是選擇性的。可讓您指定與檔案類型相關聯的圖示。您可為圖示指定四種不同的大小 (128x128、48x48、32x32 和 16x16 像素) 以配合顯示圖示的不同檢視。例如,圖示可以在檔案瀏覽器中以縮圖、詳細資料和並排檢視加以顯示。當您指定影像時,該影像的大小必須與您指定的值相同。如果您未針對某種特定的大小指定檔案,AIR 便會縮放相近大小的影像以符合該特定狀況的需求。若要指定圖示,請按一下各種圖示大小旁的資料夾,然後選取您要使用的圖示檔案,或在提示旁的文字方塊中輸入圖示檔案的路徑和檔名。圖示檔案必須是 PNG 格式。一旦您建立了新的檔案類型,該類型隨即顯示在「進階設定」對話方塊的「檔案類型」清單方塊中。

無法建立應用程式和安裝程式檔案

發生下列情況時,將無法建立應用程式和安裝程式檔案:

  • 應用程式 ID 字串的長度不正確,或是包含了無效字元。應用程式 ID 字串的長度可介於 1 到 212 個字元之間,且可以包含下列字元:0-9、a-z、A-Z、. (點)、- (破折號)。

  • 「包含的檔案」清單中的檔案不存在。

  • 自訂圖示檔案的大小不正確。

  • 沒有 AIR 目標資料夾的寫入權限。

  • 您尚未簽署應用程式,或是尚未指定該應用程式是稍後再簽署的 Adobe AIRI 應用程式。

簽署您的應用程式

所有 Adobe AIR 應用程式都必須經過簽署,才可安裝到其他系統。不過,Animate 能夠讓您建立未簽署的 Adobe AIR 安裝程式檔案,以便稍後再簽署應用程式。這些未簽署的 Adobe AIR 安裝程式檔案稱為 AIRI (AIR Intermediate) 套件。當憑證位於不同電腦上,或者簽署作業不是在應用程式開發過程中進行時,這項功能便可發揮作用。

使用預先向根憑證授權單位購買的數位憑證簽署 Adobe AIR 應用程式

  1. 選擇「檔案 > AIR 2 設定」,然後按一下「簽名」索引標籤。

    此標籤提供兩個選項按鈕,可讓您選擇使用數位憑證簽署您的 Adobe AIR 應用程式,或是準備 AIRI 套件。當您簽署 AIR 應用程式時,可以使用由根憑證授權單位所授予的數位憑證,或是建立自我簽署的憑證。自我簽署憑證雖然很容易建立,但其可信度不如根憑證授權單位所授予的憑證。

  2. 從彈出式選單中選取憑證檔案,或是按一下「瀏覽」按鈕以找出該憑證檔案。

  3. 選取憑證。

  4. 輸入密碼。

  5. 按一下「確定」。

如需簽署 AIR 應用程式的詳細資訊,請參閱為 AIR 檔加上數位簽名

建立自我簽署的數位憑證

  1. 按一下「建立」按鈕。「自我簽署的數位憑證」對話方塊便會開啟。

  2. 完成「發行者名稱」、「組織單位」、「組織名稱」、「國家/地區」、「密碼」和「確認密碼」等項目。針對「國家/地區」項目,您可從選單中選取值或輸入以兩個字母表示的國家碼 (若所需代碼未列於選單中)。如需有效的國家/地區碼清單,請參閱 http://www.iso.org/iso/country_codes

  3. 指定憑證的類型。

    「類型」選項表示該憑證的安全性等級。1024-RSA 使用 1024 位元金鑰 (較不安全),而 2048-RSA 則使用 2048 位元金鑰 (較安全)。預設值是 2048-RSA。 

    註解:

    在 Animate CC 中,對 1024 RSA 憑證的支援只到 2017.2 版本為止。如需有關暫時解決方法的詳細資訊,請按這裡

  4. 完成「另存新檔」項目,或按一下「瀏覽」按鈕並瀏覽到資料夾位置,以將這些資訊儲存成憑證檔案。

  5. 按一下「確定」。

  6. 在「數位簽名」對話方塊中,輸入您在本程序的第二個步驟指定的密碼,然後按一下「確定」。

如果要讓 Animate 記住這個工作階段所使用的密碼,請按一下「記住此工作階段的密碼」。

若您並未選取「時間戳記」選項就按下「確定」,便會出現警告對話方塊,指出一旦數位憑證過期將導致無法安裝應用程式。如果您按「是」回應這項警告,即會停用時間戳記。如果您按「否」,則會自動選取「時間戳記」選項並啟用時間戳記。

如需建立自我簽署數位憑證的詳細資訊,請參閱為 AIR 檔加上數位簽名

您也可以建立不含數位簽名的 AIR Intermediate (AIRI) 應用程式。不過,使用者只能安裝已加上數位簽名的應用程式到桌上型電腦。

準備稍後再簽署的 AIRI 套件

  1. 在「簽名」標籤中,選取「準備供稍後簽署的 AIR 中間 (AIRI) 檔」,並按一下「確定」。

    數位簽名狀態隨即變更,表示您已選擇準備稍後再簽署的 AIRI 套件,且「設定」按鈕會變成「變更」按鈕。

若您選擇稍後再簽署應用程式,將會需要用到 Animate 以及 AIR SDK 隨附的 AIR Developer Tool 命令列工具。如需詳細資訊,請參閱建立 Adobe AIR 應用程式

時間戳記伺服器 URL

Animate 支援最新的時間戳記伺服器,以及可為自訂時間戳記伺服器新增 URL 的選項。 

timestamp-url

新增或移除 AIR SDK 版本

您可以將 AIR SDK 的新版本和自訂版本加入 Animate。一旦加入,新的 SDK 就會出現在「發佈設定」的播放程式目標清單中。

若要新增 SDK 的新版本:

  1. 下載新的 AIR SDK 資料夾。
  2. 在 Animate 中,選擇「說明 > 管理 AIR SDK」。
  3. 在「管理 AIR SDK」對話方塊中,按一下加號「+」按鈕,然後瀏覽至新的 AIR SDK 資料夾。按一下「確定」。
  4. 按一下「管理 AIR SDK」對話方塊中的「確定」。

新的 SDK 隨即出現在「發佈設定」的「播放程式目標」清單中。可接受的最低 SDK 版本應大於 Animate 隨附的版本。

若要移除 SDK 版本:

  1. 在 Animate 中,選擇「說明 > 管理 AIR SDK」。
  2. 在「管理 AIR SDK」對話方塊中,選取您要移除的 SDK。
  3. 按一下減號「-」按鈕。按一下「確定」。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策