若要讓元素自動相互對齊,請使用「貼齊功能」。Animate 提供三種方式,讓您在「舞台」上對齊物件:

  • 「物件」貼齊可將物件直接貼齊其他物件的邊緣。
  • 「像素」貼齊可將物件直接貼齊「舞台」上的個別像素,或是由像素構成的線段。
  • 「貼齊」對齊可依指定的「貼齊容許度」貼齊物件,「貼齊容許度」是指物件與其他物件之間,或是物件與「舞台」邊緣之間的預設邊界。
  • 「將點陣圖貼齊至像素」會在製作階段將點陣圖貼齊至最接近的像素數,使畫布上的點陣圖看起來更加鮮明。

注意:您也可以貼齊格線或導引線。

 

開啟或關閉物件貼齊

若要開啟物件貼齊,請使用「選取」工具的「貼齊物件」修改選項,或是「檢視」選單中的「貼齊物件」命令。

如果「選取」工具的「貼齊物件」修改選項已經開啟,拖曳元素時,指標下面會出現一個黑色的小圈。如果物件已經進入另一個物件的貼齊距離內,小圈會變成大圈。

  1. 選取「檢視 > 貼齊 > 貼齊物件」。啟用此命令時,命令旁邊會出現核取記號。

    在移動物件或調整物件形狀時,物件上「選取」工具的位置為貼齊圈提供了參考點。例如,如果您拖曳某個填色物件中心點附近的部位將之移動,則其中心點將會貼齊其他物件。將形狀貼齊至動畫的移動路徑時,這個功能特別有用。

    註解:

    貼齊時若要進一步控制物件位置,請由轉角或中心點開始拖曳。

將點陣圖貼齊至像素

若要啟用點陣圖貼齊功能,請使用「檢視」選單中的「將點陣圖貼齊至像素」命令。這可確保在編寫內容時,將點陣圖放置在整數位置 (沒有分數值)。

  1. 選取「檢視 > 貼齊 > 將點陣圖貼齊至像素」。

  2. 這個選項旁邊的刻度標記表示功能已啟用。當刻度標記為停用狀態時,您可以在任何位置放置點陣圖。

    在製作階段將點陣圖貼齊至像素

調整物件貼齊容許度

  1. 選取「編輯 > 偏好設定」(Windows) 或「Animate > 偏好設定」(Macintosh),然後按一下「繪圖」。

  2. 在「繪圖設定」底下,調整「連接線段」設定。

使用像素貼齊

若要開啟像素貼齊,請使用「檢視」選單中的「貼齊像素」命令。如果「貼齊像素」已經開啟,將檢視顯示比例設定為 400% 以上時,畫面上會出現像素格線。像素格線代表 Animate 應用程式中出現的個別像素。在建立或移動物件時,該物件會被限制在像素格線內。

如果您建立的形狀邊緣落在像素邊界間 (例如,如果您使用帶小數點寬度的筆畫,如 3.5 像素),「貼齊像素」將會貼齊像素邊界,而不是形狀的邊緣。

  • 若要開啟或關閉像素貼齊,請選取「檢視 > 貼齊 > 貼齊像素」。如果將顯示比例設定為 400% 以上,會出現像素格線。啟用此命令時,命令旁邊會出現核取記號。

  • 若要暫時開啟或關閉像素貼齊,請按 C 鍵。放開 C 鍵,便會回到在「檢視 > 貼齊 > 貼齊像素」所選取的像素貼齊狀態。

  • 暫時隱藏像素格線,請按 X 鍵。放開 X 鍵時,像素格線會再度出現。

 

編輯貼齊對齊

如果選取「貼齊對齊」設定值,請設定物件的水平或垂直邊緣之間的貼齊容許度,以及物件邊緣與「舞台」邊界之間的貼齊容許度。您也可以在物件的水平中心及垂直中心之間開啟貼齊對齊。所有「貼齊對齊」的設定值均以像素做為單位。

  1. 選取「檢視 > 貼齊 > 編輯貼齊對齊」。
  2. 在「編輯貼齊對齊」對話方塊中,選取要貼齊的物件類型。選取「儲存預設」,將指定的設定儲存在 .fla 檔案中。使用中文件的已儲存設定隨即帶到新的文件中。

    編輯貼齊對齊

    在「編輯貼齊對齊」對話方塊中,選取要貼齊的物件類型。
  3. 按一下「進階」按鈕並選取下列任何項目:
    • 若要設定物件及舞台邊界之間的貼齊容許度,請輸入「影片邊框」的數值。

    • 若要設定物件的水平或垂直邊緣之間的貼齊容許度,請輸入「水平」和/或「垂直」的數值。

    • 若要開啟「水平置中對齊」或「垂直置中對齊」,請選取「水平置中對齊」或「垂直置中對齊」(兩者可同時選取)。

開啟貼齊對齊

開啟「貼齊對齊」之後,當您將物件拖曳至特定的貼齊容許度上時,「舞台」上便會出現虛線。舉例來說,若將「水平」貼齊容許度設為 18 像素 (預設設定),當拖曳的物件和另一個物件之間的距離剛好是 18 像素時,就會有一條虛線沿著物件的邊緣出現。若開啟了「水平置中對齊」,當兩個物件的水平中心點恰好對齊時,就會有一條虛線沿著兩個物件的水平中心點出現。

  1. 選取「檢視 > 貼齊 > 貼齊對齊」。啟用此命令時,命令旁邊會出現核取記號。

建立導引線圖層

為了在繪圖時協助對齊物件,請建立導引線圖層,然後將其他圖層上的物件對齊您在導引線圖層上建立的物件。這樣不會匯出導引線圖層,而導引線圖層也不會顯示在已發佈的 SWF 檔中。任何圖層都可以是導引線圖層。導引線圖層會以圖層名稱左邊的導引線圖示表示。

  1. 選取圖層後,在該圖層上按一下右鍵 (Windows) 或按 Control + 按一下該圖層 (Macintosh),再從快顯選單中選取「導引線」。若要將該圖層變更回一般圖層,請再次選取「導引線」。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策