版本: Illustrator CS2 至 CS5

涵蓋內容

Adobe Illustrator 已針對 PostScript 列印進行最佳化。事實上,許多 Illustrator 進階功能只能用 PostScript 頁面描述語言來描述。非 PostScript 印表機 (例如 Hewlett-Packard LaserJets、Canon BubbleJets 或 Epson Stylus) 不是使用完整編程語言 (例如 PCL 或 QuickDraw) 的印表機描述語言,且無法描述 Illustrator 圖稿中的所有物件和屬性。多數非 PostScript 印表機都需要仰賴顯示資訊、主機電腦資源,以及專屬印表機驅動程式將列印資訊轉送至印表機。

當您要從 Illustrator 連列至非 PostScript 印表機時,可能無法列印物件,或列印不正確。列印行為依不同印表機及不同印表機軟體版本而有所不同。非 PostScript 列印問題會透過多種方法顯現出來,包括 (但不限於) 下列方法:

  • 在頁面中,文字或其他物件部分或完全遺失。
  • 發生系統錯誤或凍結。

但是,以下疑難排解步驟可協助您將 Illustrator 文件列印至非 PostScript 印表機。在某些情況下,例如驅動程式不再更新的舊印表機,疑難排解步驟可能無法解決問題,您可能需要使用其他因應措施。本文底部列出了數種因應措施。

疑難排解步驟

本小節中的工作可協助您釐清 Illustrator 中最常見的列印問題起因。開始執行這些疑難排解步驟之前,請開啟新檔案並嘗試重現問題,以確保 Illustrator 檔案損壞不是問題起因。如果新檔案中沒有出現問題,則可能是您的 Illustrator 文件已損壞。如需有關疑難排解已損壞之 Illustrator 檔案的資訊,請參閱文件 320318,「疑難排解損壞的檔案 (Illustrator CS2 及更新版本)」。

發生系統錯誤後,請一律重新啟動電腦以重新整理電腦記憶體;繼續操作而不重新啟動可能會使問題複雜化。

1. 更新或重新安裝印表機驅動程式。

聯絡您的印表機製造商以取得最新版本的印表機驅動程式。如果您使用的是最新版本的印表機驅動程式,但問題仍然存在,請移除驅動程式,然後從原始安裝光碟或 CD-ROM 重新安裝。

2. 在 Illustrator 中變更點陣圖列印選項。

如果您使用 Windows 版 Illustrator,請在「列印」對話框中變更「列印成點陣圖」設定。亦即,若已選取該選項,請取消選取;若已取消選取,則請選取。

若要變更「點陣圖列印」選項,請選擇「檔案 > 列印 > 進階」,然後選取或取消選取「列印成點陣圖」。

注意: 如果在「列印」對話框中停用「列印成點陣圖」,Illustrator 將使用「圖形顯示介面 (GDI)」資訊和印表機驅動程式來建立向量式列印資料;列印速度會更快,但在某些裝置上可能會造成列印不一致。

3. 使用 Enhanced PCL。

如果您使用 Windows 且印表機支援 Enhanced PCL 印表機驅動程式,請安裝 Enhanced 驅動程式。如需為特定印表機安裝 Enhanced 驅動程式的指示,請參閱印表機文件或聯絡製造商。

4. 切換至標準 Windows 視訊卡驅動程式。

以 VGA 模式啟動 Windows,以切換至標準 Windows 視訊卡驅動程式:

  • 在 Windows Vista 和 Windows 7 中: 從啟動選項清單中選擇「啟用低解析度視訊 (640 x 480)」,然後按 Enter 鍵。如果此選單未出現或太快消失,請選擇「開始 > 控制台」,按一下「系統及維護」,然後按一下「系統」,並選擇「進階系統設定」。選取「進階」標籤,然後在「啟動及修復」區域中選取「設定」,並增加「顯示作業系統清單的時間」選項的值。
  • 在 Windows XP 中: 重新啟動 Windows,出現提示時按 F8 鍵,然後從選單中選擇「啟用 VGA 模式」。如果此功能表未出現或太快消失,請選擇「開始 > 設定 > 控制台」,連按兩下「系統」,然後按一下「進階」標籤。在「啟動及修復」區域中選取「設定」,並增加「顯示作業系統清單的時間」選項的值。
  • 在 Windows 2000 中: 重新啟動 Windows,出現提示時按 F8 鍵,然後從選單中選擇「VGA 模式」。如果此功能表未出現或太快消失,請選擇「開始 > 設定 > 控制台」,連按兩下「系統」,然後按一下「進階」標籤。選取「啟動及修復」,並增加「顯示作業系統清單秒數」選項的值。

如果使用 SuperVGA 或 VGA 驅動程式便可從 Illustrator 正確列印,則您的視訊卡驅動程式可能已損毀、過期,或者與印表機驅動程式或 Illustrator 不相容。若要取得更新的視訊卡驅動程式,請聯絡視訊卡製造商。

5. 變更文字格式。

如果文字未正確列印或完全未列印,請儲存 Illustrator 檔案副本,然後執行下列其中一個動作:

  • 對該類型套用零點白色筆畫。
  • 將文字轉換為外框。針對字體較小的文字 (即 24 點或更小),套用零點白色筆畫以防止筆畫扭曲轉換為外框的字元。
  • 使用「選取」工具並選擇「物件 > 點陣化」,在 Illustrator 中將文字點陣化。

6. 新增隱藏的彩色物件。

如果彩色文字以黑色列印,且是頁面上唯一的顏色元素,則可建立與文字相同顏色的隱藏物件:

  1. 選取「矩形」工具,然後繪製一個矩形,並用與繪製文字相同的顏色繪製。
  2. 繪製一個大矩形,其足以完全覆蓋您在步驟 1 中建立的矩形。將新矩形繪製為白色,並將其定位至覆蓋原本的矩形。

7. 將列印圖層選項變更為「所有圖層」。

選擇「檔案 > 列印」,按一下「一般」,然後從「列印圖層」選單選取「所有圖層」。

8. 將 PostScript 印表機設為預設印表機。(僅限 Windows)

在 Windows 中將 PostScript 印表機設為預設印表機。若要設定預設印表機,請選擇「開始 > 設定 > 印表機」(Windows XP、Windows 2000) 或「開始 > 控制台 > 硬體和音效 > 印表機」(Windows Vista)。以滑鼠右鍵按一下要使用的印表機,然後選擇「設定成預設值」。

注意: 如果您沒有 PostScript 印表機,仍可安裝並設定使用 PostScript 印表機驅動程式的印表機,作為您的預設印表機:

  1. 選擇「開始 > 設定 > 印表機」(Windows XP、Windows 2000) 或「開始 > 控制台 > 硬體和音效 > 印表機」(Windows Vista),然後選取「新增印表機」。
  2. 依照畫面上的指示操作,確定已新增 PostScript 印表機 (例如 Apple LaserWriter Pro),而不是非 PostScript 印表機 (例如 HP DeskJet)。如需「新增印表機」精靈的說明,請參閱 Windows 文件。

從 Windows 的 Illustrator 列印至預設印表機以外的印表機:

  1. 選擇「檔案 > 列印」。
  2. 從「印表機」選單中選擇印表機。
  3. 按一下「完成」以關閉「列印」對話框,然後保留該印表機,或按一下「列印」即可列印。

9. 列印至本機印表機。

如果您是透過網路連線至印表機,請將印表機直接連接至電腦。若正確列印檔案,便可能是網路相關問題所造成。請聯繫您的網路管理員以獲取幫助。

因應措施

如果執行疑難排解步驟後,仍然無法列印至非 PostScript 印表機,以下因應措施可能有助您列印 Illustrator 文件。

10. 將文件另存為可攜式文件格式 (PDF) 檔案。

從「另存新檔」對話框的彈出式選單選擇「Acrobat PDF」,將 Illustrator 檔案另存為 PDF 檔案,然後從 Adobe Reader 開啟並列印 PDF 檔案。

11. 從其他應用程式列印。

從其他應用程式 (例如,Adobe Photoshop 或 Adobe InDesign) 列印 Illustrator 檔案。

注意: 其他應用程式也可能會在列印至非 PostScript 印表機時出現問題。您可能需要以其他格式 (例如,TIFF 或 EPS) 儲存或轉存 Illustrator 檔案,或嘗試不同應用程式,直到圖稿按預期方式列印為止。

12. 列印至其他印表機。

列印至 PostScript 印表機或其他非 PostScript 印表機。

注意: 非PostScript 印表機的部分製造商 (例如,Hewlett-Packard 或 Epson) 會為其印表機提供 PostScript 硬體或軟體。若要確定您的印表機是否有可用的 PostScript 硬體或軟體,請聯絡製造商。

 

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策