Версії: із CS2 по CS5

Теми статті

Adobe Illustrator оптимізовано для друку на PostScript Насправді багато з розширених функцій Illustrator можна описати, лише використовуючи мову сторінки опису PostScript. Інші принтери (наприклад, Hewlett-Packard LaserJets, Canon BubbleJets або Epson Stylus) використовують мови опису принтера, які не є повноцінними мовами програмування (наприклад, PCL або QuickDraw) і не здатні описати всі об'єкти й атрибути графічних об'єктів Illustrator. Більшість принтерів, що не є принтерами PostScript, використовують інформацію дисплею, ресурси хост-комп'ютера та власні драйвери принтера для друку інформації на принтер.

Коли ви друкуєте з Illustrator на принтер, що не є принтером PostScript, об'єкти можуть не друкуватися або друкуватися неправильно. Ця поведінка може відрізнятися, залежно від принтерів і їх версій програмного забезпечення. Проблеми з друком на інших притерах можуть виражатися багатьма способами, зокрема, але не виключно, переліченими нижче.

  • Текст або інші об'єкти частково чи повністю відсутні на сторінці.
  • Виникла системна помилка чи зависання.

Однак наведені нижче кроки для усунення несправностей можуть допомогти вам друкувати документи Illustrator на інших принтерах (не PostScript). У деяких випадках, як-от у випадку старіших принтерів, чиї драйвери більше не оновлюються, дії для усунення несправностей можуть не вирішити проблему, а вам доведеться скористатись обхідним рішенням. Існує декілька способі усунення проблеми, які перелічені внизу цього документа.

Етапи вирішення проблем

Завдання в цьому розділі допоможуть ізолювати поширені причини проблем із друком, які виникають в Illustrator. Перш ніж почати виконувати ці дії для усунення несправностей, переконайтеся, що пошкоджений файл Illustrator не є причиною проблеми. Для цього відкрийте новий файл і спробуйте відтворити проблему. Якщо в новому файлі проблема не виникає, імовірно, у вас є пошкоджений файл Illustrator. Щоб дізнатись інформацію про усунення проблем із пошкодженими файлами Illustrator, див. документ 320318, «Усунення проблем із пошкодженими файлами (Illustrator CS2 та пізнішої версії)».

Завжди перезавантажуйте комп'ютер після появи системної помилки, щоб оновити пам'ять свого комп'ютера. Якщо продовжувати роботу, не перезавантаживши комп'ютер, проблема може ускладнитися.

1. Оновіть або перевстановіть драйвер принтера.

Щоб отримати останню версію драйвера для свого принтера, зв'яжіться з виробником принтера. Якщо ви використовуєте останню версію драйвера принтера, але проблема далі виникає, видаліть драйвер, а тоді повторно інсталюйте його з оригінальних інсталяційних дисків чи CD-ROM.

2. В Illustrator змініть опцію друку растрових зображень.

Якщо ви використовуєте Illustrator для Windows, змініть налаштування «Друкувати як растрове зображення» в діалоговому вікні «Друк». Тобто, якщо цей пункт вибраний, скасуйте його вибір, а якщо його не вибрано, виберіть його.

Щоб змінити параметр друку растрових зображень, виберіть «Файл» > «Друк» > «Додатково» та виберіть або скасуйте вибір пункту «Друкувати як растрове зображення».

Примітка. Якщо в діалоговому вікні «Друк» вимкнути параметр «Друкувати як растрове зображення», Illustrator використовує інформацію інтерфейсу графічного зображення (GDI) і драйвер принтера, щоб створити векторні дані друку, що друкуються швидше та можуть спричинити неправильний друк на деяких пристроях.

3. Використовуйте «Розширений PCL».

Якщо ви користуєтеся Windows, і ваш принтер підтримує драйвер принтера «Розширений PCL», інсталюйте розширений драйвер. Щоб отримати вказівки щодо інсталяції розширеного драйвера для вашого принтера, див. документацію принтера чи зв'яжіться з виробником.

4. Переключіться на стандартний драйвер відеокарти Windows.

Переключіться на стандартний драйвер відеокарти Windows, запустивши Windows у режимі VGA.

  • У Windows Vista та Windows 7: у списку параметрів запуску виберіть «Увімкнути відео в низькій роздільній здатності (640 x 480)» і натисніть клавішу Enter. Якщо це меню не відображається або мерехтить надто швидко, виберіть «Пуск» > «Панель керування», натисніть «Система та обслуговування», а тоді натисніть «Система» й виберіть «Додаткові настройки системи». Виберіть вкладку «Додатково», а тоді виберіть в області запуску та відновлення «Настройки» та збільште значення параметра «Час на відображення списку операційних систем».
  • У Windows XP: перезапустіть Windows, коли з'явиться запит, натисніть клавішу F8 і в меню виберіть «Увімкнути режим VGA». Якщо це меню не відображається або мерехтить надто швидко, виберіть «Пуск» > «Настройки» > «Панель керування», двічі натисніть «Система», а тоді натисніть вкладку «Додатково». В області запуску та відновлення виберіть параметр «Настройки» та збільште значення параметра «Час на відображення списку операційних систем».
  • У Windows 2000: перезапустіть Windows, коли з'явиться запит, натисніть клавішу F8 і в меню виберіть «Увімкнути режим VGA». Якщо це меню не відображається або мерехтить надто швидко, виберіть «Пуск» > «Настройки» > «Панель керування», двічі натисніть «Система», а тоді натисніть вкладку «Додатково». Виберіть «Запуск і відновлення» та збільште значення параметра «Відображати список операційних систем для секунд».

Якщо вдається належним чином надрукувати файл за допомогою Illustrator, використовуючи драйвер SuperVGA або VGA , можливо, драйвер відеокарти пошкоджений, застарілий або несумісний із драйвером принтера або програмою Illustrator. Щоб отримати оновлений драйвер відеокарти, зверніться до виробника відеокарти.

5. Змініть формат тексту.

Якщо текст друкується неправильно або взагалі не друкується, збережіть копію файлу Illustrator, а тоді виконайте одну з наведених нижче дій.

  • Застосуйте як тип білий мазок нульової точки.
  • Перетворіть текст на контури. Для маленьких текстів (тобто, 24 точки або менше), застосуйте білий мазок нульової точки, щоб завадити мазку спотворювати символи, що конвертовані в контури.
  • Растеризуйте текст в Illustrator, вибравши текст за допомогою інструмента вибору, й натиснувши меню «Об'єкт» > «Растеризувати».

6. Додайте схований кольоровий об'єкт.

Якщо кольоровий текст друкується чорним, і це єдиний кольоровий елемент на сторінці, створіть прихований об'єкт того ж кольору, що й текст.

  1. Виберіть інструмент «Прямокутник», а тоді намалюйте прямокутник та замалюйте його тим же кольором, яким замальовано текст.
  2. Намалюйте достатньо великий прямокутник, що повністю закривати прямокутник, який ви створили в кроці 1. Розмалюйте новий прямокутник білим кольором і розмістіть його так, щоб він закривав перший прямокутник.

7. Змініть параметр шарів друку на «Усі шари».

Виберіть «Файл» > «Друк», натисніть «Загальні», а тоді в меню «Шари друку» виберіть «Усі шари».

8. Налаштуйте принтер PostScript принтером за замовчуванням. (Лише для Windows)

Налаштуйте принтер PostScript як принтер за замовчуванням у Windows. Щоб налаштувати принтер за замовчуванням, виберіть «Пуск» > «Настройки» > «Принтери» (Windows XP, Windows 2000) або «Пуск» > «Панель керування» > «Апаратне забезпечення та звук»> «Принтери» (Windows Vista). Правою кнопкою миші натисніть потрібний принтер і виберіть «Налаштувати за замовчуванням».

Примітка. Якщо у вас немає принтера PostScript, ви можете інсталювати й налаштувати драйвер принтера PostScript принтером за замовчуванням:

  1. виберіть «Пуск» > «Настройки» > «Принтери» (Windows XP, Windows 2000) або «Пуск» > «Панель керування» > «Апаратне забезпечення та звук»> «Принтери» (Windows Vista), а тоді виберіть пункт «Додати принтер».
  2. Дотримуйтеся вказівок на екрані та переконайтеся, що додали принтер PostScript (наприклад, Apple LaserWriter Pro), а не інший принтер (наприклад, HP DeskJet). Щоб отримати вказівки щодо використання майстра «Додавання принтера», див. документацію Windows.

Щоб друкувати на другорядний принтер за допомогою Illustrator у Windows.

  1. Виберіть команду «Файл» > «Друк».
  2. У меню «Принтери» виберіть свій принтер.
  3. Натисніть «Готово», щоб закрити діалогове вікно «Друк» і дезактивувати принтер, або натисніть «Друк», щоб надрукувати.

9. Надрукуйте на локальному принтері.

Якщо пристрій під'єднано до принтера через мережу, тоді під'єднайте принтер безпосередньо до комп'ютера. Якщо файл друкується правильно, то проблему можуть викликати збої, пов'язані з мережею. Зверніться до адміністратора мережі по допомогу.

Рішення

Якщо після виконання дій для усунення несправностей ви все одно не можете друкувати на іншому принтері (не PostScript), наведені нижче кроки для усунення несправностей можуть допомогти вам друкувати документи Illustrator.

10. Збережіть файл як файл Portable Document Format (PDF).

Збережіть файл Illustrator як файл у форматі PDF, вибравши Acrobat PDF у спливаючому меню в діалозі «Зберегти як», а тоді відкрийте та надрукуйте файл PDF з Adobe Reader.

11. Надрукуйте з іншого розташування.

Надрукуйте файл Illustrator з іншого розташування (наприклад, Adobe Photoshop чи Adobe InDesign).

Примітка. В інших програмах також можуть виникати проблеми з друком на інших принтерах (не PostScript). Можливо, вам потрібно буде зберегти або експортувати файл Illustrator в іншому форматі (наприклад, TIFF або EPS) чи випробувати різні програми, доки графічний об'єкт надрукується належним чином.

12. Використайте інший принтер для друку.

Надрукуйте на принтері PostScript або іншому принтері.

Примітка. Деякі виробники принтерів (не PostScript) (наприклад, Hewlett-Packard або Epson) пропонують для своїх принтерів апаратне чи програмне забезпечення PostScript. Щоб визначити доступність апаратного чи програмного забезпечення PostScript для вашого принтера, зверніть до виробника.

 

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності