Procédure de codage

Pour coder un élément vidéo ou audio, ajoutez-le à la file d’attente de codage d’Adobe Media Encoder, puis sélectionnez les préconfigurations de codage ou créez vos propres paramètres personnalisés. Vous pouvez indiquer à l’application de démarrer le codage après avoir ajouté un élément à la file d’attente ou lui demander d’attendre jusqu’à ce que vous décidiez de démarrer le codage.

Ajout d’un élément à la file d’attente de codage : dans Adobe Media Encoder, faites glisser des fichiers vidéo ou audio dans la file d’attente.

Codage de l’élément à l’aide des préconfigurations : Sélectionnez, dans les menus contextuels Format et Préconfigurations, les formats et préconfigurations avec l’élément de la file d’attente. Vous pouvez également choisir une préconfiguration dans l'Explorateur de préconfigurations et la faire glisser vers l'un des éléments de la file d'attente. Pour plus d’informations, reportez-vous à la section Codage à l’aide des préconfigurations.

Codage de l’élément à l’aide des paramètres personnalisés : Sélectionnez l’élément, cliquez sur Modifier > Réglages d’exportation, puis choisissez vos paramètres. Pour plus d’informations, reportez-vous à la section Codage à l’aide des paramètres personnalisés.

Pour lancer automatiquement le codage des éléments dans la file d’attente (ou pour désactiver la fonction), sélectionnez ou désélectionnez l’option « Démarrer automatiquement la file d’attente en cas d’inactivité depuis » dans la boîte de dialogue Préférences. Pour plus d’informations, reportez-vous à l’article Préférences.

Écran AME
Fenêtre principale d’Adobe Media Encoder

Importation d’éléments dans la file d’attente de codage

  • Pour ajouter des fichiers vidéo ou audio, effectuez l'une des opérations suivantes :
    • Faites glisser un ou plusieurs fichiers dans la file d’attente à partir du bureau ou de l’explorateur de médias.
    • Cliquez sur le bouton « Ajouter la source » et sélectionnez un ou plusieurs fichiers.
    • Double-cliquez sur une zone ouverte du panneau File d’attente et sélectionnez un ou plusieurs fichiers.
  • Pour ajouter une séquence Adobe Premiere Pro, effectuez l'une des opérations suivantes :
    • Parcourez un projet Adobe Premiere Pro dans l’Explorateur de médias et faites glisser des séquences dans la file d’attente.
    • Sélectionnez Fichier > Ajouter une séquence Premiere Pro, choisissez un projet Adobe Premiere Pro, puis sélectionnez une ou plusieurs séquences dans ce projet.
    • Faites glisser une séquence du panneau Projet d’Adobe Premiere Pro vers la file d’attente.
    • Faites glisser un projet Adobe Premiere Pro du bureau vers la file d’attente.
  • Pour ajouter une composition Adobe After Effects, effectuez l’une des opérations suivantes :
    • Accédez à un projet Adobe After Effects dans l’Explorateur de médias et faites glisser des compositions dans la file d’attente.
    • Sélectionnez Fichier > Ajouter une composition After Effects, choisissez un projet After Effects et sélectionnez ensuite une composition dans ce projet.
    • Faites glisser une composition du panneau Projet d’After Effects vers la file d’attente.
    • Faites glisser un projet After Effects du bureau vers la file d’attente.

Arrêter le codage

  • Sélectionnez Fichier > Arrêter le fichier actuel pour arrêter le codage de l’élément actuel. Adobe Media Encoder continue de coder les autres éléments de la file d’attente.
  • Sélectionnez Fichier > Arrêter la file d’attente pour arrêter le codage de tous les éléments de la file d’attente.

Interprétation des éléments de la file d’attente de codage

Pendant l’importation d’un élément vidéo, Adobe Media Encoder tente de déterminer le format des pixels (ou rapport L/H en pixels), la fréquence d’image et l’ordre des trames de cet élément, ainsi que le mode d’interprétation des informations (de transparence) de la couche alpha. Si l’une de ces caractéristiques se révèle inexacte, vous avez la possibilité de déclarer explicitement l’interprétation exacte.

  1. Sélectionnez un ou plusieurs éléments dans la file d’attente de codage.

  2. Sélectionnez Fichier > Métrage. Vous pouvez également cliquer avec le bouton droit sur le fichier, puis sélectionner Métrage.

    interpret selection
    Sélection de métrage

  3. Sélectionnez les réglages d’interprétation appropriés.

    iterpret window
    Boîte de dialogue Métrage

Identification des éléments manquants dans la file d’attente de codage

Vous pouvez identifier, dans la file d’attente, les sources et les sorties qui contiennent des éléments manquants avant le codage. Cela vous permet d’identifier et de corriger les problèmes avant de procéder au codage. Un état d’avertissement s’affiche en regard de la source ou de la sortie qui contient des éléments manquants, le cas échéant. Passez le pointeur de la souris sur l’icône pour afficher un aperçu de l’erreur associée à ce problème. 

Adobe Media Encoder affiche une icône d’avertissement dans les cas suivants :

  • Les projets Adobe Premiere Pro contiennent des médias hors ligne. Dans ce cas, Adobe Media Encoder utilise des médias de doublure au lieu de l’ensemble manquant. En l’absence de doublures, une image avec le message « Média hors ligne » est utilisée.
  • Il manque des polices dans des projets Adobe Premiere Pro.
  • Il manque des effets dans des projets Adobe Premiere Pro.
  • Il manque des fichiers dans les effets d’incrustation.
Identification des éléments manquants
Identification des éléments manquants

Dossiers de contrôle dans Adobe Media Encoder

Vous pouvez configurer Adobe Media Encoder de telle sorte qu’il recherche des fichiers dans certains dossiers appelés dossiers de contrôle. Lorsque l’application trouve un fichier vidéo ou audio dans un dossier de contrôle, il le code conformément aux réglages de codage affectés à ce dossier, puis il exporte le fichier codé vers un dossier de sortie créé à l’intérieur du dossier de contrôle.

Le panneau Dossiers de contrôle d’Adobe Media Encoder permet d’ajouter et de gérer des dossiers. Vous pouvez ajouter un dossier de contrôle en procédant de l’une des manières suivantes :

  1. Sélectionnez Fichier > Ajouter un dossier de contrôle, puis choisissez un dossier.
  2. Double-cliquez sur une zone vide du panneau Dossiers de contrôle, puis sélectionnez un dossier.
  3. Créez un dossier dans l’Explorateur (Windows) ou le Finder (Mac OS), puis faites-le glisser vers le panneau Dossiers de contrôle.

Une fois le dossier créé, son nom s’affiche dans la colonne de gauche du panneau Dossiers de contrôle.

Les éléments ajoutés à la file d’attente de codage par le dossier de contrôle sont codés en même temps que les autres éléments présents dans la file dès le lancement de cette dernière.

Remarque :

Si la préférence « Démarrer automatiquement la file d’attente en cas d’inactivité depuis » est sélectionnée, le codage commence après l’expiration du délai défini après l’ajout, par le dossier de contrôle, d’un nouvel élément à la file d’attente de codage.

Remarque :

Laissez la case « Coder automatiquement les dossiers de contrôle » cochée afin de coder automatiquement les éléments lorsqu’ils sont ajoutés au dossier de contrôle.

Ajout de préconfigurations

Vous pouvez choisir un format et une préconfiguration dans les menus contextuels du dossier de contrôle, en regard du nom du dossier. Vous pouvez également faire glisser une préconfiguration vers le dossier de contrôle à partir de l’Explorateur de préconfigurations.

Création d’une sortie en plusieurs formats à partir d’un seul élément source à l’aide des dossiers de contrôle

Une seule opération suffit pour générer plusieurs sorties à l’aide des dossiers de contrôle. Vous pouvez par exemple générer une séquence AVI et une vignette JPEG chaque fois que vous transcodez un élément vidéo. Procédez comme suit pour créer ces fichiers en une seule opération :

  1. Dans l’Explorateur (Windows) ou le Finder (Macintosh), créez un dossier nommé, par exemple, Mon_dossier_contrôle.

  2. Créez un dossier de contrôle en cliquant sur le bouton Ajouter un dossier, puis accédez au dossier que vous venez de créer (Mon_dossier_contrôle).

    1. Cliquez sur Format et sélectionnez le format MPEG4 dans le menu contextuel.

    2. Cliquez sur Préconfiguration et sélectionnez ensuite le paramètre de votre choix dans le menu contextuel Préconfiguration.

      preset and format
      Menu contextuel Format et Préconfiguration

    3. Cliquez sur Dossier de sortie. Sélectionnez un emplacement où générer les résultats.

      Output Folder
      Dossier de sortie

  3. Créez un élément de dossier de contrôle qui pointe également vers le dossier « Mon_dossier_contrôle », comme vous venez de le faire à l’étape 2.

    1. Dans le menu Format, sélectionnez le format AVI.

    2. Dans le menu Préconfiguration, sélectionnez une préconfiguration, puis cliquez sur OK.

    3. Cliquez sur Dossier de sortie. Sélectionnez un emplacement où générer les résultats.

  4. Créez un élément Dossier de contrôle qui pointe également vers le dossier « Mon_dossier_contrôle », comme vous l’avez fait aux étapes 2 et 3.

    1. Dans le menu Format, sélectionnez le format JPEG.

    2. Dans le menu Préconfiguration, sélectionnez une préconfiguration, puis cliquez sur OK.

    3. Cliquez sur Dossier de sortie. Sélectionnez un emplacement où générer les résultats.

  5. Faites glisser le fichier source dans le dossier « Mon_dossier_contrôle », puis cliquez sur le bouton Démarrer la file d’attente. La procédure de codage commence automatiquement si l’option Coder automatiquement les dossiers de contrôle est activée.

Une fois le processus terminé, chaque fichier se trouve dans son emplacement de sortie prévu.

Remarque :

La préconfiguration doit être personnalisée et l’option Exporter sous forme de séquence doit être désélectionnée. Cette opération exporte uniquement la première image de la vidéo, qui est généralement noire.

Remarque :

Les séquences d’images fixes ne sont pas prises en charge en tant que métrage source par l’intermédiaire des dossiers de contrôle. Si un ensemble d’images fixes est placé dans le dossier contrôlé, chaque fichier d’image fixe individuel est ajouté dans la file d’attente en tant qu’élément distinct plutôt que la séquence entière en tant qu’un seul bloc de métrage.

Enregistrement de la file d’attente de codage

La file d’attente de codage et l’ensemble des réglages de codage sont enregistrés automatiquement à la fermeture d’Adobe Media Encoder.

La file d’attente de codage est également enregistrée automatiquement lorsque l’utilisateur commence à coder.

Pour enregistrer manuellement la file d’attente de codage, sélectionnez Fichier > Enregistrer la file d’attente.

Remarque :

Désactivez la case à cocher Préférences > Supprimer les fichiers terminés de la file d’attente en sortie si vous souhaitez conserver les éléments codés terminés dans la file d’attente après la fermeture et le redémarrage d’Adobe Media Encoder.

Retrait d’éléments de la file d’attente de codage

  1. Sélectionnez le ou les éléments à retirer de la file d’attente de codage.

  2. Cliquez sur le bouton Supprimer, sélectionnez Édition > Effacer ou appuyez sur la touche Suppr.

    Delete file new
    Suppression d’éléments de la file d’attente de codage

Duplication des éléments de la file d’attente de codage

  1. Sélectionnez le ou les éléments à dupliquer dans la file d’attente de codage.

  2. Effectuez l’une des opérations suivantes :

    • Cliquez sur le bouton Dupliquer, puis sélectionnez Édition > Dupliquer
    • Appuyez sur Ctrl + D (Windows) ou sur Commande + D (Mac OS)
    • Cliquez avec le bouton droit sur le fichier, puis sélectionnez Dupliquer.
    Duplicate item
    Dupliquer l’élément

Omission de fichiers dans la file d’attente de codage

Omission d’éléments

  1. Sélectionnez le ou les éléments à omettre dans la file d’attente de codage.

  2. Sélectionnez Édition > Ignorer la sélection ou cliquez avec le bouton droit de la souris sur le fichier et choisissez Ignorer la sélection.

    Skip selection
    Ignorer la sélection

Réinitialisation d’un fichier ignoré en vue de son codage

  1. Sélectionnez, dans la file d’attente de codage, les éléments dont vous souhaitez rétablir l’état Prêt.

  2. Sélectionnez Édition > Réinitialiser l’état ou cliquez avec le bouton droit de la souris sur le fichier et choisissez Édition > Réinitialiser l’état.

    Reset status
    Réinitialisation de l’état d’un fichier ignoré

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne