Handboek Annuleren

Tips and tricks

  1. Adobe XD User Guide
  2. Introduction
    1. What's new in Adobe XD
    2. Common questions
    3. Design, prototype, and share with Adobe XD
    4. System requirements
      1. Hardware and software requirements
      2. Adobe XD, Big Sur, and Apple silicon | macOS 11
    5. Workspace basics
    6. Change app language in Adobe XD
    7. Access UI design kits
    8. Accessibility in Adobe XD
    9. Keyboard shortcuts
    10. Tips and tricks
    11. Adobe XD subscription options
    12. Changes to XD Starter Plan
  3. Design
    1. Artboards, guides, and layers
      1. Get started with artboards
      2. Use guides and grids
      3. Create scrollable artboards
      4. Work with layers
      5. Create scroll groups
    2. Shapes, objects, and path
      1. Select, resize, and rotate objects
      2. Move, align, distribute, and arrange objects
      3. Group, lock, duplicate, copy, and flip objects
      4. Set stroke, fill, and drop shadow for objects
      5. Create repeating elements
      6. Create perspective designs with 3D transforms
      7. Edit objects using Boolean operations
    3. Text and fonts
      1. Work with drawing and text tools
      2. Fonts in Adobe XD
    4. Components and states
      1. Work with components
      2. Work with nested components
      3. Add multiple states to components
    5. Masking and effects
      1. Create a mask with shapes
      2. Work with blur effects
      3. Create and modify gradients
      4. Apply blend effects
    6. Layout
      1. Responsive resize and constraints
      2. Set fixed padding for components and groups
      3. Create dynamic designs with stacks
    7. Videos and Lottie animations
      1. Work with videos
      2. Create prototypes using videos
      3. Work with Lottie animations
  4. Prototype
    1. Create interactive prototypes
    2. Animate prototypes
    3. Object properties supported for auto-animate
    4. Create prototypes with keyboard and gamepad
    5. Create prototypes using voice commands and playback
    6. Create timed transitions
    7. Add overlays
    8. Design voice prototypes
    9. Create anchor links
    10. Create hyperlinks
    11. Preview designs and prototypes
  5. Share, export, and review
    1. Share selected artboards
    2. Share designs and prototypes
    3. Set access permissions for links
    4. Work with prototypes
    5. Review prototypes
    6. Work with design specs
    7. Share design specs
    8. Inspect design specs
    9. Navigate design specs
    10. Review and comment design specs
    11. Export design assets
    12. Export and download assets from design specs
    13. Group sharing for enterprise
  6. Design systems
    1. Design systems with Creative Cloud Libraries
    2. Work with document assets in Adobe XD
    3. Work with Creative Cloud Libraries in Adobe XD
    4. Migrate from linked assets to Creative Cloud Libraries
    5. Work with design tokens 
    6. Use assets from Creative Cloud Libraries
  7. Cloud documents
    1. Cloud documents in Adobe XD
    2. Collaborate and coedit designs
    3. Coedit documents shared with you
  8. Integrations and plugins
    1. Work with external assets
    2. Work with design assets from Photoshop
    3. Copy and paste assets from Photoshop
    4. Import or open Photoshop designs
    5. Work with Illustrator assets in Adobe XD
    6. Open or import Illustrator designs
    7. Copy vectors from Illustrator to XD
    8. Plugins for Adobe XD
    9. Create and manage plugins
    10. Jira integration for XD
    11. Slack plugin for XD
    12. Zoom plug-in for XD
    13. Publish design from XD to Behance
  9. XD for iOS and Android
    1. Preview on mobile devices
    2. Adobe XD on mobile FAQ
  10. Troubleshooting
    1. Known and fixed issues
      1. Known issues
      2. Fixed issues
    2. Installation and updates
      1. XD appears as not compatible on Windows
      2. Error code 191
      3. Error code 183
      4. Issues installing XD plugins
      5.  Prompt to uninstall and reinstall XD on Windows 10
      6. Issues with preferences migration
    3. Launch and crash
      1.  XD crashes when launched on Windows 10
      2.  XD quits when you sign out of Creative Cloud
      3. Issue with subscription status on Windows
      4. Blocked-app warning when launching  XD on Windows
      5. Crash dump generation on Windows
      6. Crash log collection and sharing
    4. Cloud documents and Creative Cloud Libraries
      1. Issues with XD cloud documents
      2. Issues with linked components
      3. Issues with libraries and links
    5. Prototype, publish, and review
      1. Unable to record prototype interactions on macOS Catalina
      2. Issues with publish workflows
      3. Published  links do not appear in browsers
      4. Prototypes do not render correctly in browsers
      5. Commenting panel suddenly showing up on shared links
      6. Unable to publish libraries
    6. Import, export, and working with other apps
      1. Import and export in XD
      2. Photoshop files in XD
      3. Illustrator files in XD
      4. Export to After Effects from XD
      5. Sketch files in XD
      6. Third-party apps not visible in Export

Design and create prototypes faster in Adobe XD using these tips and tricks.

Here are a few tricks to help you while using Adobe XD.

General tips and tricks

  • Rather than copy and pasting groups of items in your design, consider using the Repeat Grid tool (available in the Property Inspector).
  • You can duplicate a shape by selecting it, holding the Option key (on Mac), or Alt key (on Windows) and dragging a new copy of it.
  • Elements can be locked with Object > Lock (or Cmd + L) on Mac. This actually toggles lock, so use the same command to unlock the elements. On Windows, right-click an object and select Lock from the context menu.
  • Enable direct selection by holding the Cmd or Ctrl key. This allows you to select nested objects.
  • Quickly mask by dropping an image onto a shape: the shape’s fill becomes the image.
  • Create an editable mask by importing an image, and then draw a shape over it. Select both and then choose Object > Mask with Shape (on Mac), or right-click the objects and choose Mask with Shape from the context menu. You can edit the mask or the image later by double-clicking on the masked group.

Drawing and Text

  • You can turn the snap guides off by holding down the Cmd / Ctrl key.
  • Double-click any anchor point to toggle between a curve and an angle.
  • Press Opt/Alt while dragging a curve handle to make the curve handle independent. (To make them dependent again, double click to return to an angle, then double click again).
  • You can select anchor points when you draw using the pen tool.
  • Double click to enter a group’s edit context (you can add elements in this context), or simply Cmd /Ctrl click an object inside a group to select it.
  • Select a text item, then create a new one to apply all the styles from the first item to the second.
  • Path combinations (Add/Subtract/Intersect/Exclude Overlap) are nondestructive. You can toggle them on and off.

Importing content

  • To bring in content from Illustrator, select the vector shape in Illustrator, copy and then paste into Adobe XD.
  • To bring in bitmap content from Photoshop, select all (Cmd+A or Ctrl + A) in a bitmap or text layer (or first convert a vector layer or group to a Smart Object), copy, and then paste it in Adobe XD. The pasted layer will be a bitmap. You can also copy content from Photoshop by making a selection using the marquee tool. Then, from the menus, choose Edit >Copy (to get the selection on the current layer), or Edit > Copy Merged (to get the selection on all the layers within your selection).
  • To bring in content from Sketch, select one or more layers or groups, and click Make Exportable. Choose SVG as the format, and drag and drop the layer from Sketch into Adobe XD. This gives you editable vector content in Adobe XD.
  • To import assets (PNG, JPG, TIFF, GIF, SVGs), on Mac, you can use File > Import, or drag and drop, or copy and paste images into Adobe XD from Finder.
    On Windows, click the Hamburger menu and click Import, or drag and drop, or copy and paste images from File Explorer.
    You can also copy and paste from the browser to Adobe XD.

Keyboard controls

  • When adjusting corner radius you can hold down the OPTION key to restrict the adjustment to a single corner.
  • To temporarily disable snapping when moving or resizing elements, hold down the Cmd or Ctrl key.
  • Hold the SHIFT key while resizing an element to maintain the aspect ratio of the element.
  • Hold ALT while drawing a shape to draw from center rather than the default (which is in the top left corner).
  • To quickly change the opacity of a selected item, hit the following number keys. Here, 1= 10%, 2 = 20%, and so on; 0 = 100%.
  • When nudging a shape or control point using the arrow keys, hold down the SHIFT key to nudge by 10 px.
  • Hold down the SPACEBAR to engage the hand mode. You can click and drag to span through the canvas.

Artboards

  • To select an artboard, click the art board title, Cmd / Ctrl + Click on its background, or double click on its background.
  • To select an empty artboard, click on the background of the artboard.
  • To duplicate an artboard (and its contents), select the artboard, and press Cmd (on Mac) or Alr (on Windows) while dragging to make a copy.
  • To rename an artboard, double click on its title.

Repeat Grid

  • To adjust padding between repeating items in a Repeat Grid, select the repeat grid, then mouseover the space between elements, and drag. If you are editing an item within the repeat grid, you need to press ESCAPE to exit the editing mode.

Prototyping and Preview

  • Select any object on an artboard (or the whole artboard) and drag a wire to trigger an interaction between artboards.
  • Drag a wire off of a destination to unwire an interaction that you have set.
  • Use the Dissolve transition when designing for web.
  • You can see all the connections between your artboards (except those that are triggered directly from artboards) by pressing Cmd + A (on Mac) or Ctrl + A (on Windows)  in the Prototype mode.
  • The Preview window displays the artboard that has the current selection. If there is no selection, the Preview window opens with the Home artboard first.
  • You can record a video from the Preview window of your interactive prototype. Click on the record icon on the title bar to begin a video.
  • Clicking on the record button again OR press ESC to stop a video recording.
  • You can use keyboard shortcuts or gamepad triggers on prototypes based on the type of experience you design. 

Sharing

  • In order to share, you must be logged in with an Adobe account to either the Adobe Creative Cloud desktop app or any other Adobe application (such as Photoshop, Illustrator, and so on).
    Adobe IDs, Enterprise IDs, and Federated IDs are all supported.
  • If you share your design file without first adding interactions, all your artboards are uploaded and users will be able to navigate using the keyboard arrow keys. The order of your artboards will be from the top left and move to the right.
  • If your design includes interactions, only those artboards connected to the Home artboard will be uploaded and shared.
  • The artboard defined as your Home artboard is the first artboard users see when they view your shared design.
  • You can change the Home artboard by selecting the Home artboard icon next to the artboard, in the prototype mode. This Home artboard icon shows up only for artboards which are selected (or the destination of a selected target).
  • When viewing a prototype in a mobile web browser, you can save a shortcut to it on the device’s home screen. This makes the prototype feel more like a native application when presenting it.

Verwante informatie

Adobe-logo

Aanmelden bij je account