Keyboard shortcuts

List of all keyboard shortcuts that you can use in Adobe XD.

XD provides shortcuts to help you quickly work on documents. Many keyboard shortcuts appear next to the command names in menus.

Downloadable version of keyboard shortcuts

Download and print a print-friendly version of these keyboard shortcuts.

 Click to download.

XD has introduced a new plugin that lets you view all the keyboard shortcuts. To install the plugin, go to Plugins > Keyboard Shortcuts > Install. After installing the plugin, use the folllowing shortcuts to access the keyboard shortcuts:

  • Mac: Shift + ⌘ + f
  • Windows: Shift + Ctrl + f

General shortcuts

Result

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Quit

⌘Q

Alt + F4

Keys for Edit menu

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
Undo ⌘Z Ctrl + Z
Redo ⇧⌘Z Ctrl + Shift + Z
Cut ⌘X Ctrl + X
Copy ⌘C Ctrl + C
Paste ⌘V Ctrl + V
Paste Appearance (in Design mode), and
Paste Interaction (in Prototype mode)
⌥⌘V Ctrl + Alt +V
Duplicate ⌘D Ctrl + D
Delete Delete
Select All
⌘A Ctrl + A
Deselect All ⇧⌘A Ctrl + Shift + A

Keys for File menu

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
New ⌘N
Ctrl + N
Open... ⌘ + Shift + O Ctrl + Shift + O
Close ⌘W Alt + F4
Save... ⌘S
Ctrl + S
Save As... ⇧⌘S Ctrl + Shift + S
Save As Local Document...            ⌥⇧⌘S     Shift + Ctrl + Alt + S
Export Batch ⇧⌘E Ctrl + Shift + E
Export Selected ⌘E Ctrl + E
Export to an integrated third-party application (if an application integrated with XD is installed on your computer) ⌥⌘E Not available
Import ⇧⌘I Ctrl + Shift + I

Keys for Path/Pen

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
Switch to Pen tool P P
Convert Point Double-click Double-click
Asymmetric Control Point Alt
Snap Control Point Angle Shift
Snap Anchor Point Angle Shift
Add ⌥⌘U Ctrl + Alt + U
Subtract ⌥⌘S Ctrl + Alt + S
Intersect ⌥⌘I Ctrl + Alt + I
Exclude Overlap ⌥⌘X Ctrl + Alt + X
Convert to Path ⌘8 Ctrl + 8

Keys for Layers (Objects), Groups, Scroll groups, and Artboards

Menu Keyboard shortcut on macOs Keyboard shortcut on Windows
Group layers ⌘G Ctrl + G
Ungroup layers ⇧⌘G Ctrl + Shift +G
Make component ⌘K Ctrl + K
Lock/Unlock layer ⌘L Ctrl + L
Hide/Show layer ⌘, Ctrl + ,
Mask with shape ⇧⌘M Ctrl + Shift + M
Make repeat grid
⌘R Ctrl + R
Directly select a layer in a group/component ⌘Click layer in canvas Ctrl + click layer in canvas
Change layer opacity 1 to 9 (0 for 100%) 1 to 9 (or 0 for 100%)
Select artboard ⌘Click on blank part of artboard Ctrl + click on blank part of artboard
Draw shape from center ⌥Drag Alt + Drag
Draw shape with 1:1 aspect ratio (perfects square/circle) ⇧Drag Shift + Drag
Draw equilateral triangle Shift + Drag Shift + Drag
Show/ Hide artboard guides ⌘ + ; Ctrl + ;
Lock artboard guides Shift + ⌘ + ; Shift + Ctrl + ;
Move element by 10px  Shift + Arrows Shift +  Arrows
Resize element by 1px increment ⌘ + Arrows Alt + Arrows
Resize element by 10px increment ⌘ + Shift + Arrows Alt + Shift + Arrows
Select through overlapping layers ⌘ + Click Ctrl + Click
Edit padding Hover and drag on canvas + S Hover and drag on canvas + S
Mirror padding on opposing sides Alt + S Alt + S
Edit all sides Shift + S Shift + S
Horizontal scroll                     ⇧⌘H
                     Shift + Ctrl +H
Vertical scroll                    ⇧⌘V
                     Shift + Ctrl +V
Horizontal and vertical scroll                    ⇧⌘D
                    Shift + Ctrl +D

Keys for Align

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Left

⌃⌘←

Ctrl + Shift + ←

Center (horizontally)

⌃⌘C

Shift + C

Right

⌃⌘→

Ctrl + Shift + →

Top

⌃⌘↑

Ctrl +Shift + ↑

Middle (vertically)

⌃⌘M

Shift + M

Bottom

⌃⌘↓

Ctrl + Shift + ↓

Keys for Arrange

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Bring to Front

⇧⌘]

Shift + Ctrl + ]

Bring Forward

⌘]

Ctrl + ]

Send Backward

⌘[

Ctrl + [

Send to Back

⇧⌘[

Shift + Ctrl + [

Keys for Distribute

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Horizontal

⌃⌘H

Ctrl + Shift + H

Vertical

⌃⌘V

Ctrl + Shift + V

Keys for Text

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

Bold

⌘B

Ctrl + B

Italic

⌘I

Ctrl + I

Underline

⌘U

Ctrl + U

Increase font size

⇧⌘>

Ctrl + Shift + >

Decrease font size

⇧⌘<

Ctrl + Shift + <

Keys for Operations menu

Menu

Keyboard shortcut on macOS

Keyboard shortcut on Windows

From Center

Alt

Copy Paste Object

⌥ Drag

Alt + Drag

Constrain

Shift

Edit Text

Enter

Enter

Constrain Rotate

⇧ (15°)

Shift (15°)

Line Constrain Rotate

⇧ (45°)

Shift (45°)

Constrain From Center

⇧⌥

Shift + Alt

Direct Select

Ctrl

Switch between Design and Prototype mode

Ctrl + Tab

Ctrl + Tab

Keys for Tools menu

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
Select V V
Rectangle R R
Ellipse E E
Polygon Y Y
Line L L
Pen P P
Text T T
Artboard A A
Zoom
Enter zoom mode: Z Enter zoom mode: Z
Zoom to Selection ⌘3 Ctrl + 3
Eyedropper  I I

Keys for Interface and Viewing Options

Menu Keyboard shortcut on macOS Keyboard shortcut on Windows
Switch to Design mode
⌥1
Alt + 1
Switch to Prototype mode ⌥2
Alt + 2
Switch to Share mode ⌥3
Alt + 3
Zoom In
  • ⌘+, 
  • Option-Scrollwheel, 
  • Option-swipe (Magic Mouse)
  • Pinch out (trackpad)
  • Ctrl + +
  • Ctrl-Scrollwheel
  • Pinch out (trackpad)
Zoom Out
  • ⌘-, 
  • Option-Scrollwheel,
  • Option-swipe (Magic Mouse)
  • Pinch in (trackpad)
  • Ctrl + -
  • Ctrl-Scrollwheel
  • Pinch in (trackpad)
Zoom to Fit
⌘ 0 Ctrl + 0
100% ⌘ 1 Ctrl + 1
200% ⌘ 2 Ctrl + 2
Pan Spacebar Spacebar
Assets ⇧ ⌘ Y Ctrl + Shift + Y
Layers ⌘ Y Ctrl + Y
Show Layout Grid ⇧ ⌘ '
Shift + Ctrl + '
Show Square Grid ⌘ ' Ctrl + '
Fullscreen Mode ^⌘F  Not available
Switch between design and prototype mode ^Tab Ctrl + Tab
Switch between Windows (Files)

⌘-Tilde (~)

Not available
Increase or decrease a value in a field by 1 ↑ or ↓ ↑ or ↓

Increase or Decrease a value in a field by 10

Hold ⇧ and hit ↑ or ↓

Hold Shift and hit ↑ or ↓

Keys for Window menu

Menu

Keyboard Shortcut on macOS

Keyboard shortcut on Windows

Maximize

 

WIN ↑

Minimize

⌘M

WIN ↓

Preview

⌘⏎

Ctrl + Enter

Keys for operation modifiers

Menu

Keyboard Shortcut on macOS

Keyboard shortcut on Windows

Horizontal Pan

Shift + Scrollwheel

Shift + Scrollwheel

Vertical Pan

Scrollwheel

Scrollwheel

Keys for Selection and measuring distances between elements

Menu

Keyboard Shortcut on macOS

Keyboard shortcut on Windows

Enable measurements

Option (with an object selected)

Alt (with an object selected)

Distance from Selected Layer

Hold ⌥ and Hover over object/group/artboard

Hold Alt and Hover over object/group/artboard

Distance relative to Selected Group

Hold ⌥⌘ and Hover over an object in the group

Hold Ctrl + Alt  and Hover over an object in the group

Keys for Design Specs

Menu

Keyboard Shortcut on macOS

Keyboard shortcut on Windows

Zoom

⌘ + Mousewheel

⌘+, ⌘- 

Ctrl + Mousewheel

Ctrl +, Ctrl -

Reset zoom

⌘0

Ctrl + 0

Pan

↑, ↓, →, ←

Spacebar + Click-and-drag

↑, ↓, →, ←

Spacebar + Click-and-drag

Faster pan

Shift + ↑, ↓, →, ←

Shift + ↑, ↓, →, ←

Remove focus from artboard in Spec view

Esc

Esc

Navigate across linked artboards

Shift + Click

Shift + Click

Keys for Vector Editing

Menu

Keyboard Shortcuts on MacOS

Keyboard Shortcuts on Win

Start Editing Selected Vector Object

Return

 Enter

Stop Editing Selected Vector Object

Esc

 Esc

Switch Between Straight and Mirrored Control Points

Double-Click

 Double-Click

Disconnect Control Point Handle

⌥Drag

Alt + drag

Keys for Prototyping

Menu

Keyboard Shortcuts on MacOS

Keyboard Shortcuts on Win

See all connections in prototype mode

⌘A

Ctrl + A

Hide all wires 

Option

Alt

Preview

⌘Return

Ctrl + Enter

Start or stop recording the preview

^⌘R

Not available

Stop recording

Esc

Not available

Share prototype online

⇧⌘E

Ctrl + Shift + E

Navigate artboards in preview or shared prototype

Right or Left Arrow

 → or ←

Create a new line in the comment box of shared prototype link 

Enter or Shift + Enter

Enter or Shift + Enter

Submit comment entered in the comment box of shared prototype link

Cmd + Enter 

Ctrl + Enter 

Verwante informatie

Adobe-logo

Aanmelden bij je account