Symptoms

This document can help you resolve sluggish performance or system errors that occur while you use Adobe Bridge. System errors can manifest themselves in many different ways, including (but not limited to) the following:

  • A blank or flickering dialog box
  • A frozen cursor or screen
  • An error such as "The application 'unknown' has unexpectedly quit."
Different factors can cause system errors, including conflicts among device drivers, software, and hardware, and corrupt elements in specific files. Although a system error occurs only when you work with Bridge, Bridge isn't necessarily the cause. It could be the only application that is memory- or processor-intensive enough to expose the problem.

Troubleshooting steps

Try the following steps in the order listed.

1. Update to the latest version of Bridge.

Download the latest Bridge update by going to Help > Updates or from the Adobe website at http://www.adobe.com/downloads/updates.html.

2. Reset preferences, reset the default workspace, and purge the cache.

Damaged preferences or workspaces can cause unexpected behavior in Adobe Bridge. Purging the cache can fix display issues for thumbnail previews.

  1. Start Adobe Bridge and immediately press Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) until the Reset Settings dialog box appears.
  2. Select all three options--Reset Preferences, Reset Standard Workspaces, and Purge Entire Thumbnail Cache--and then click OK.

 You can also purge the cache by doing the following:

  1. Choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS).
  2. Select the Cache panel.
  3. Click Purge Cache.

Or, you can manually purge the cache by doing the following:

  1. Choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS).
  2. Select the Cache panel.
  3. Look at Location and note the path for the Cache folder.
  4. In the Explorer (Windows) or Finder, navigate to the Cache folder.
  5. Drag the Cache folder to the Recycling Bin (Windows) or Trash (Mac OS).

Note: You can some labels and ratings when you purge the cache.

For more information, see the Help topics:

3. Disable startup scripts.

Adobe Bridge can crash or not start if it encounters a corrupt startup script. Disable all startup scripts to see if it resolves the issue.

  1. In Adobe Bridge, choose Edit > Preferences (Windows) or Bridge > Preferences (Mac OS).
  2. Select Startup Scripts.
  3. Click Disable All, and then click OK.
  4. If Adobe Bridge works better with startup scripts disabled, enable the scripts one by one or in small groups to identify which script is problematic.

For more information, see the Help topic:

4. Temporarily disable programs that scan or manage disk activity.

Programs that scan or manage disk activity can conflict with Bridge as it writes cache files or connects to the Internet. Temporarily disable these programs, and run Adobe Bridge to see if crashes still occur, or if performance improves.

  • Programs that scan or manage disk activity include:
  • Virus protection software (for example, McAfee Virex, Norton Anti-Virus)
  • Firewall software (for example, ZoneAlarm)
  • Software that manages hard disk activity in the background (for example, Norton Utilities)
  • Software that stores deleted files or removes temporary files from the system (for example, Norton SystemWorks).

For instructions on how to disable a program, refer to its documentation. To disable firewall software, contact your system administrator.

5. Start Adobe Bridge with the Folders panel disabled.

The Folders panel can cause slowdowns when Adobe Bridge starts. Disable the Folders panel if you do not use it.

  • In Adobe Bridge, click the Window menu and deselect Folders Panel.

6. Disable the Preview and Metadata panels.

The Preview and Metadata panels use resources when generating thumbnails and when you navigate image content. If you don't use them, turn them off.

  • In Adobe Bridge, click the Window menu and deselect Preview Panel and Metadata Panel.

7. Set up Adobe Bridge to process smaller files.

Adobe Bridge can slow down when processing large files. By default, Adobe Bridge automatically processes thumbnails up to files 1000 MB. You can reduce this file size in Preferences.

  1. Choose Edit > Preferences > Thumbnails (Windows) or Bridge > Preferences Thumbnails (Mac OS).
  2. In the Performance and File Handling section, enter an amount such as 100 MB in the Do Not Process Files Larger Than field.

For more information, see the Help topic:

8. (Windows) Make sure that Adobe Bridge is not running in the background.

Sometimes if you navigate to a different folder while Adobe Bridge is generating thumbnails for images in the current folder, Adobe Bridge can freeze or crash. Before you restart Adobe Bridge after a crash, make sure that Adobe Bridge is not still processing files.

  1. Press Ctrl+Alt+Delete, and then select Task Manager.
  2. Select the Processes tab.
  3. Select Bridge.exe and click End Process.

9. Change the folder that Bridge opens with on startup.

By default, Bridge opens to the last folder that was open when Bridge was last closed. Bridge could open slowly or crash when trying to read a corrupted folder or corrupted images within a folder. Changing the folder that Adobe Bridge opens with could speed up the startup process or alleviate crashes. Reset the Adobe Bridge preferences to force Bridge to open to the desktop. See Solution 2 above for instructions on resetting Bridge preferences.

10. Make sure that Bridge is not set to open a folder that resides on a disconnected network on startup.

Bridge may not start if the folder that it is set to open to on startup resides on a network that has been disconnected. If Bridge is not starting, and you suspect that a disconnected network drive is the problem, reset the Bridge preferences upon startup to get Bridge to start. Bridge will open to the desktop after the preferences have been reset. See Solution 2 above for instructions on resetting Bridge preferences.

11. Update the graphics adapter driver.

Contact the video card manufacturer for the latest driver. To determine the manufacturer of the video card, view the properties for the video card in the System Profiler (Mac) or Device Manager (Windows). For information on using either, see OS manufacturer's documentation.

12. Perform system troubleshooting steps.

If the Adobe Bridge-specific solutions in this document don't resolve the problem, perform more general, system troubleshooting solutions. In particular, make sure that you're running the latest version of your software and that you have an up-to-date video card driver installed. For instructions, see Troubleshoot system errors and freezes | Adobe software on Windows or Troubleshoot system errors and freezes | Adobe software on Mac OS 10.x.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy