Troubleshooting instructions for error code 191 when installing XD on Windows.

ERROR: Failed to install UWP Appx Package

Error message

2 fatal error(s), 2 error(s), 0 warnings(s)

FATAL: Error (Code = 191) executing in command 'AddUWPAppxCommand' for package: 'UWPAssets', version:18.1.12.1

FATAL: Error occurred in install of package (Name: UWPAssets Version: 18.1.12.1). Error code: '191'

ERROR: hdhelper exe at C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\HDBox\HDHelper.exe failed to install UWP app with xml <AddUWPAppx>

<Name>Adobe.CC.XD</Name>

<Path>C:\adobeTemp\ETRAD65.tmp\1\SparklerApp\SparklerApp.appx</Path>

<Version>18.1.12.1</Version>

<ProcessorArchitecture>x64</ProcessorArchitecture>

<Publisher>CN=Adobe Systems Incorporated, OU=Adobe Systems, O=Adobe Systems Incorporated, L=San Jose, S=California, C=US, SERIALNUMBER=2748129, OID.2.5.4.15=Private Organization, OID.1.3.6.1.4.1.311.60.2.1.2=Delaware, OID.1.3.6.1.4.1.311.60.2.1.3=US</Publisher>

<LaunchURI>adbxd:</LaunchURI>

<UWPDependencies>

<UWPDependency>

<Name>Microsoft.VCLibs.140.00</Name>

<Version>14.0.25426.0</Version>

<ProcessorArchitecture>x64</ProcessorArchitecture>

<Publisher>CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US</Publisher>

<Path>C:\adobeTemp\ETRAD65.tmp\1\SparklerApp\Dependencies\x64\Microsoft.VCLibs.x64.14.00.appx</Path></UWPDependency>

<UWPDependency>

<Name>Microsoft.VCLibs.Desktop.140.00</Name>

<Version>14.0.25426.0</Version>

<ProcessorArchitecture>x64</ProcessorArchitecture>

<Publisher>CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US</Publisher>

<Path>C:\adobeTemp\ETRAD65.tmp\1\SparklerApp\Dependencies\x64\Microsoft.VCLibs.x64.14.00.Desktop.appx</Path></UWPDependency>

</UWPDependencies>

<UWPDeploymentOptions>

<ForceApplicationShutdown>false</ForceApplicationShutdown>

</UWPDeploymentOptions>

</AddUWPAppx>

with error code 1

ERROR: Failed to install UWP Appx Package

Root cause
Error code 191 occurs in the following scenarios:

  • Your computer login account does not have administrator privileges when installing XD.
  • Your computer does not meet the system requirements to install a Universal Windows Platform (UWP) app. For information on Adobe XD system requirements, see Adobe XD system requirements.

Troubleshooting

Before getting started, verify that your login account has administrator privileges:

  1. Press Windows + R keys on your keyboard.
  2. Type netplwiz and click OK.
  3. Ensure that Administrators is under Group in Users tab.

To enable: 

  1. Select the account you want to change within Users for this computer.
  2. Click Properties.
  3. Select Administrator as user account type within the Group Membership tab.
  4. Click Apply and click OK.

After troubleshooting, work through the following solutions sequentially, proceeding to the next solution if necessary.

Solution

Solution 1- Reset or update Microsoft store

To reset

  1. Type cmd in Windows search to open the command prompt window.
  2. In the command prompt window, type wsreset.exe and press Enter.
  3. Wait for Microsoft Store to launch.
  4. Try to install XD from the Creative Cloud Desktop app.

To update

  1. Type Microsoft Store in Windows search.
  2. Select the hamburger menu icon in the upper-right corner.
  3. Choose Downloads and updates.
  4. Click Get updates in the upper-right corner. Clicking this button updates Microsoft Store along with other installed apps.
  5. Proceed to install XD from the Creative Cloud desktop app. 

For more information, see https://support.microsoft.com/en-us/help/4026259/microsoft-store-check-updates-for-apps-and-games.

Solution 2- Install Microsoft 3D Viewer

  1. Install Windows 3D Viewer from MS Store (free UWP application).

  2. Proceed to install XD from the Creative Cloud desktop app.

Solution 3 - Verify that the following directories have read and write access

  1. C:\Windows\temp
  2. C:\Program Files\ WindowsApps
  3. C:\Users\<User Name>\AppData\Local\Temp
  4. C:\Users\<User Name>\AppData\Local\Packages
  5. Proceed to install XD from the Creative Cloud desktop app.

Solution 4- Enable sideloading on Windows

Adobe XD is a UWP app which is not installed from Microsoft Store. Hence, you have to enable sideloading on your machine.

To enable sideloading:

  1. Click the Windows icon in the lower-left corner of the desktop and select Settings.
  2. In the Settings window, search for developers settings window.
  3. Within developers settings window, select Sideload Apps.
  4. Try to install XD Creative Cloud desktop app. 

Solution 5- Enable Windows firewall

  1. Follow these instructions: https://support.microsoft.com/en-in/help/4028544/windows-10-turn-windows-defender-firewall-on-or-off.
  2. Proceed to install XD Creative Cloud desktop app. 

Solution 6- Verify that Windows registry has Trusted Apps enabled

  1. Type regedit in Windows search.
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Appx and change the value of AllowAllTrustedApps to 1.
  3. Proceed to install XD Creative Cloud desktop app. 

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy