Informazioni su come risolvere i problemi che possono verificarsi durante la stampa o l'esportazione in PDF da Adobe InDesign.

Eseguite le procedure esposte in questo documento nell'ordine in cui sono riportate fino a che il problema non viene risolto.

Potete anche trovare soluzioni a problemi di stampa ed esportazione sul sito Web all'indirizzo https://helpx.adobe.com/it/indesign.html.

Determinate il livello del problema

Quando si cerca di risolvere un problema di stampa o esportazione, la prima cosa da fare è determinare le condizioni in cui tale problema si verifica. Ad esempio, se l'errore si è verificato una sola volta oppure si ripete
regolarmente durante la stampa o l'esportazione di tutti o alcuni documenti o soltanto di un documento specifico. Le operazioni e i test seguenti consentono di definire la modalità e il momento in cui si verifica il problema, in modo da trovare una soluzione.

1. Riavviate il computer.

Se l'errore non si ripete, potrebbe essere stato causato da un problema di comunicazione temporaneo, da una scarsità di risorse di sistema o da altri fattori ambientali temporanei. Se dopo il riavvio del computer è possibile stampare o esportare senza errori, ma il problema si ripresenta dopo un certo periodo di tempo, è necessario risolverlo a livello di sistema.

2. Spegnete e riaccendete la stampante.

Se l'errore non si ripete, potrebbe essere stato causato da un problema della memoria della stampante. Se l'errore si ripete, proseguite con il passaggio 3.

3. Create un nuovo documento di esempio.

Se riuscite a stampare o ad esportare un nuovo documento, ma non l'originale, è necessario risolvere il problema a livello di documento.

4. Stampate o esportate utilizzando un'altra applicazione.

Se è possibile stampare da un'altra applicazione (WordPad, TextEdit), oppure esportare/salvare come PDF da un'altra applicazione (Illustrator, Photoshop), cercate di risolvere il problema a livello dell'applicazione.

5. Stampate mediante un'altra stampante.

Se è disponibile un'altra stampante, provate a stampare il documento su tale stampante. Se il problema non si ripresenta, accertatevi che la stampante originale sia accesa e online. Staccate e ricollegate i cavi della stampante, quindi eseguite una verifica automatica della stampante per verificare l'eventuale presenza di errori meccanici o cavi danneggiati. Se con i passaggi precedenti non riuscite ancora a identificare il problema, è necessario risolvere l'errore a livello di sistema.

6. Utilizzate un metodo diverso per creare il file PDF.

  • Se il problema si verifica durante l'esportazione in PDF da InDesign in Acrobat Standard, Pro o Pro Extended, provate a stampare sulla stampante Adobe PDF. Se utilizzate Mac OS v10.6 o versione successiva con Acrobat 9, consultate Opzione Salva come Adobe PDF di Acrobat 9.
  • Se il problema si verifica quando utilizzate la funzione di stampa per creare il file PDF, scegliete File > Esporta in PDF.

Risoluzione dei problemi di stampa o esportazione a livello di documento

Se l'errore non si verifica quando stampate o esportate un nuovo documento, è possibile che le impostazioni di stampa o esportazione del documento originale non siano valide, che un oggetto o font utilizzato nel documento sia danneggiato o che la struttura del documento sia danneggiata. Provate una o più delle seguenti soluzioni.

Nota:

a seconda della stampante utilizzata, le posizioni delle impostazioni possono variare ed essere diverse da quanto elencato nelle procedure seguenti. A questo proposito, consultate la documentazione della stampante.   

1. Esportate in IDML (InDesign CS4 e versioni successive) o INX (InDesign CS3 e versioni precedenti).

Il documento potrebbe essere danneggiato. Questo inconveniente potrebbe verificarsi dopo la conversione da una versione precedente di InDesign o da un documento QuarkXPress. L'esportazione in formato InDesign Markup Language (IDML) o InDesign Interchange (INX) può eliminare i dati all'origine del problema.

2. (Solo stampanti PostScript) Attivate il gestore errori PostScript.

Windows

  1. Scegliete File > Stampa.
  2. Fate clic sul pulsante Impostazioni.
  3. Se viene visualizzato il messaggio "Se l'impostazione di stampa desiderata è disponibile nella finestra Stampa di InDesign, impostatela in tale finestra al fine di evitare conflitti di stampa.", fate clic su OK.
  4. Fate clic con il pulsante destro del mouse sulla stampante e scegliete Proprietà.
  5. Nella scheda Generale, fate clic su Preferenze stampa.
  6. Fate clic su Avanzate.
  7. Espandete le Opzioni documento e successivamente le Opzioni PostScript. Se l'opzione Invia gestore errori PostScript non è impostata su Sì, fate clic sull'opzione e selezionate dal menu a comparsa.

Mac OS X

  1. Scegliete File > Stampa.
  2. Fate clic sulla stampante.
  3. Selezionate Gestione errori dal menu sotto il menu Predefiniti.
  4. Selezionate Stampa rapporto dettagliato, quindi fate clic su Stampa.

Se il problema è causato da un errore PostScript, una pagina con le informazioni di errore verrà stampata dal gestore errori PostScript. Consultate Risoluzione dei problemi relativi agli errori PostScript.

3. Escludete gli elementi grafici dal documento.

Escludete gli elementi grafici durante la stampa del documento

  1. Scegliete File > Stampa.
  2. Fate clic su Grafica, quindi selezionate Nessuno dal menu Invia dati.
  3. Fate clic su Stampa.

Escludete gli elementi grafici durante l'esportazione del documento

  1. Scegliete File > Esporta e selezionate Adobe PDF (stampa) come formato oppure "Salva con nome".
  2. Scegliete una posizione, quindi fate clic su Salva.
  3. Fate clic su Avanzate, quindi selezionate le tre caselle di controllo in Ometti per OPI, ovvero EPS, PDF eBitmap.
  4. Impostate lo standard PDF su Nessuno per consentire l'esclusione delle immagini.
  5. Fare clic su Esporta.

Se il documento viene stampato o esportato correttamente, uno o più elementi grafici della pagina potrebbero essere danneggiati. Rimuovete il 50% degli elementi grafici eliminando pagine o cornici grafiche su una singola pagina. Quindi, stampate o esportate il documento dopo ogni modifica per determinare se è un elemento grafico danneggiato nel gruppo rimosso a causare l'errore. Se riuscite a stampare o esportare il documento dopo una modifica, annullate la modifica ed eliminate il restante 50% delle pagine o degli elementi grafici. Verificate la persistenza dell'errore, quindi eliminate nuovamente il 50% e così via. Dopo aver identificato gli elementi grafici che generano errori costantemente, eliminateli e sostituiteli. Potrebbe essere necessario esportare di nuovo un elemento grafico dall'applicazione nella quale è stato creato.

Un processo di stampa riuscito correttamente senza elementi grafici può inoltre indicare un'insufficienza nella memoria della stampante. In tal caso, si possono avere inconvenienti come font sostituiti, elementi grafici mancanti o stampe incomplete. Provate a stampare intervalli di pagine o a semplificare la pubblicazione per verificare se è possibile eseguire la stampa con un numero ridotto di elementi grafici. Oppure scegliete una risoluzione di stampa inferiore.

Nota:

se il documento contiene soltanto elementi grafici, quando stampate otterrete una pagina vuota solo se in InDesign l'apposita opzione per stamparle è abilitata Selezionate Stampa pagine vuote nella sezione Generali della finestra di dialogo Stampa.

4. Escludete o riducete al minimo i font.

Escludete i font durante la stampa

  1. Scegliete File > Stampa.
  2. Fate clic su Grafica.
  3. Nella sezione Font, selezionate Nessuno dal menu Download.
  4. Fate clic su Stampa.

Riducete al minimo i font durante l'esportazione in PDF

Non potete escludere i font durante l'esportazione, ma è possibile ridurre al minimo il numero di font utilizzati.

  1. Scegliete Testo > Trova font.
  2. Nell'elenco Font del documento, fate clic sul primo font, quindi fate clic sull'ultimo tenendo premuto Maiusc per selezionare tutti i font presenti nell'elenco.
  3. Nell'elenco Sostituisci con: Famiglia font, selezionate un font che funziona senza problemi in altri documenti, ad esempio Arial o Verdana.
  4. Fate clic su Sostituisci tutto.
  5. Fate clic su Fine.
  6. Selezionate File > Esporta, quindi selezionate Adobe PDF come formato.
  7. Scegliete una posizione, quindi fate clic su Salva.
  8. Fare clic su Esporta.

Se il documento viene stampato o esportato correttamente, il problema potrebbe essere relativo ad uno dei font utilizzati nel documento. Se nel documento sono presenti molti font, la loro esclusione rende il documento meno complesso. Salvate il documento con un nuovo nome e quindi verificate i font uno alla volta per determinare se sono danneggiati. Nel caso in cui un font continui a creare problemi, verificate la presenza di molteplici istanze attive di tale font o scaricatelo di nuovo dal sito del produttore per essere certi che non sia danneggiato.

5. Accertatevi che i collegamenti siano validi.

Per visualizzare lo stato dei collegamenti, scegliete Finestra > Collegamenti. Scollegate o ricollegate tutti i file il cui nome sia preceduto da un punto interrogativo o da un altro simbolo. Per ulteriori informazioni sui collegamenti in InDesign, consultate Gestire i collegamenti agli elementi grafici.

6. Disattivate le impostazioni.

A volte gli errori sono originati da una particolare funzione del processo di stampa o esportazione che utilizza uno specifico contenuto del documento. Eliminate quanti più tipi di impostazioni possibile. Se
l'eliminazione delle impostazioni risolve il problema, attivatele nuovamente in gruppi per isolare il problema e identificare un'impostazione in particolare.

Nota:

A seconda della stampante in uso, alcune impostazioni potrebbero non essere disponibili.

Scegliete File > Stampa per aprire la finestra di dialogo Stampa. Modificate quindi le seguenti impostazioni nei pannelli indicati:

Pannello Generali

  • Impostate il numero di copie su 1.
  • Selezionate Pagine per disattivare Pagine affiancate.
  • Disattivate Stampa pagine mastro, Stampa oggetti non stampabili e Stampa guide e griglie linee di base visibili.
  • Impostate Stampa livello su Livelli visibili e stampabili.

Pannello Configurazione

  • Impostate Formato carta su Definito dal driver.
  • In Scala, impostate Larghezza e Altezza su 100%.
  • Disattivate Miniature e Porzione.

Pannello Indicatori e pagina al vivo

  • Disattivate Indicatori, Pagine al vivo e Area indicazioni.

Pannello Output

  • Impostate Colore su Composito non modificare.
  • Disattivate Abbondanza,Testo in nero e Simula sovrastampa.
  • In Gestione inchiostri, disattivate Alias inchiostro.

Pannello Grafica

  • Impostate Immagini: Invia dati su Nessuno o Tutti.
  • Impostate Font: Download su Nessuno o Tutti.
  • Impostate PostScript su Livello 2.
  • Impostate Formato dati su ASCII.

Pannello Gestione colore

  • Impostate Trattamento del colore su Consenti alla stampante PostScript di determinare i colori.
  • Attivate Mantieni i valori numerici CMYK.

Pannello Pagine (all'esterno della finestra di dialogo Stampa)

Selezionate tutte le pagine, fate clic con il pulsante destro del mouse e sceglieteAttributi pagina > Conversione trasparenza pagine affiancate > Nessuno (ignora trasparenza).

7. Risolvete i problemi relativi ai plug-in.

Eliminate i plug-in di terze parti dalla cartella Plug-in di InDesign, quindi riavviate InDesign. Se il problema persiste, spostate nuovamente i plug-in nella cartella Plug-in di InDesign. Se invece il problema non si verifica nuovamente, identificate i plug-in in conflitto:

  1. Scegliete Aiuto > Configura i plug-in (Windows) o InDesign > Configura i plug-in (Mac OS).
  2. Selezionate Tutti i plug-in per il set, quindi deselezionate tutte le opzioni nella sezione Mostra a eccezione di Terze parti. Create un elenco di tali plug-in.
  3. Uscite da InDesign e spostate i plug-in all'esterno della cartella Plug-in:
    • Windows: /Programmi/Adobe/Adobe InDesign [versione]/Plug-Ins
    • Mac OS: /Applicazioni/Adobe InDesign [versione]/Plug-Ins
  4. Riavviate InDesign e provate a ricreare il problema.
    • Se il problema non si ripresenta, ripetete i passaggi 3 e 4, aggiungendo di nuovo alcuni plug-in di terze parti alla cartella dei plug-in.
    • Se il problema si ripresenta, contattate lo sviluppatore dell'ultimo plug-in che avete spostato per richiedere un aggiornamento.

Per ulteriori informazioni, consultate Risoluzione dei problemi relativi a plug-in di terze parti.

8. Stampate o esportate da un nuovo account utente.

A volte, un account utente può risultare corrotto e impedire all'applicazione di leggere o scrivere alcuni file e cartelle. Create un nuovo account utente (senza eliminare l'originale), accedete a tale account e riprovate a stampare o esportare il documento.

Windows

Scegliete Start > Pannello di controllo > Account utente.

Mac OS X

Scegliete il menu Apple > Preferenze di sistema > Utenti e gruppi.

9. Determinate se il documento è danneggiato.

Risoluzione dei problemi di stampa o esportazione a livello di applicazione

Se si verifica un errore durante la stampa di un qualsiasi documento InDesign, provate una o più delle seguenti procedure per identificare la causa di un problema a livello di applicazione.

1. Ricreate i file delle preferenze di InDesign.

Se InDesign funziona in modo anomalo, spesso è sufficiente eliminare e ricreare le preferenze per risolvere il problema.

Esistono due modi per ricreare le preferenze:

  • Automaticamente: questo metodo elimina rapidamente i file delle preferenze correnti e quindi rigenera un nuovo set di file delle preferenze predefiniti. Le eventuali impostazioni personalizzate vengono tuttavia perse.

-oppure-

  • Manualmente: per non perdere le impostazioni personalizzate, rinominate i file delle preferenze correnti prima di ricreare un nuovo set di file delle preferenze predefiniti. In questo modo, se le nuove preferenze non risolvono il problema di stampa o esportazione, avete una copia di backup dei file delle preferenze originali (incluse le eventuali impostazioni personalizzate), che potrete utilizzare al posto dei nuovi file delle preferenze.

Ricreate automaticamente i file delle preferenze di InDesign

Nota:

la creazione di nuovi file delle preferenze di InDesign comporta l'eliminazione delle preferenze precedenti, incluse le eventuali impostazioni personalizzate. Per non perdere le impostazioni personalizzate, ricreate i file delle preferenze manualmente.

  1. Chiudete InDesign.
  2. Riavviate InDesign e premete immediatamente i tasti appropriati per il sistema operativo in uso:
    • Mac OS: Control + Opzione + Comando + Maiusc
    • Windows: Control + Alt + Maiusc
  3. Viene visualizzata una finestra di dialogo in cui si chiede se volete eliminare i file delle preferenze di InDesign. Fate clic su . InDesign viene avviato con le preferenze predefinite rigenerate.

Ricreate manualmente i file delle preferenze di InDesign

Rinominate i due file delle preferenze. Ad esempio, sostituite "InDesign SavedData" con "Backup InDesign SavedData" e "InDesign Defaults" con "Backup InDesign Defaults". I file delle preferenze si trovano nelle seguenti posizioni:

  • Mac OS X

    InDesign Defaults:

    Utenti/[utente]/Libreria/Preferences/Adobe InDesign/Versione [versione]/[lingua] /InDesign Defaults

InDesign SavedData:

Utenti/[nome utente]/Libreria/Caches/Adobe InDesign/Versione [versione]/[lingua]/InDesign SavedData

  • Windows XP

    InDesign Defaults:

    /Documents and Settings/[utente]/Dati applicazioni/Adobe/InDesign/Version [versione]/InDesign Defaults

Non visibile per impostazione predefinita. Fate clic qui per informazioni su come visualizzare i file nascosti.

InDesign SavedData:

/Documents and Settings/[utente]/Impostazioni locali/Dati applicazioni/Adobe/InDesign/Version[versione]/Caches/InDesign SavedData

  • Windows 7 e 8

InDesign Defaults:

C:\Utenti\DC-work\AppData\Roaming\Adobe\InDesign\Version 11.0\[lingua]\InDesign Defaults

Non visibile per impostazione predefinita. Fate clic qui per informazioni su come visualizzare i file nascosti.

InDesign SavedData:

/Utenti/[utente]/AppData/Local/Adobe/InDesign/Version[versione]/[lingua]/Caches/InDesign SavedData

Avviate nuovamente InDesign. InDesign crea un nuovo set di file delle preferenze predefiniti.

Se il problema di stampa o esportazione persiste, potete ripristinare le preferenze originali riassegnando ai vecchi file delle preferenze i rispettivi nomi originali, ovvero InDesign Defaults e InDesign SavedData.

2. (Solo per windows) Verificate che il driver di stampa sia aggiornato.

Installate il driver più recente per la stampante in uso:

3. (Windows, solo stampanti PostScript) Ottimizzate la velocità di stampa.

  1. Scegliete File > Stampa.
  2. Fate clic su Impostazioni, selezionate una stampante, fate clic su Preferenze e quindi su Avanzate.
  3. Espandete le Opzioni documento e successivamente le Opzioni Postscript.
  4. Selezionate Opzioni output PostScript.
  5. Scegliete Ottimizza per velocità dal menu a comparsa, quindi fate clic su OK.
  6. Fate clic su OK, quindi su Stampa.

4. Disattivate la funzione di protezione delle pagine nella stampante.

Per istruzioni sulla disattivazione di tale funzione, consultate la documentazione fornita con la stampante.

5. Collegate il computer alla stampante.

Se il problema si verifica quando stampate in rete, collegate il computer direttamente alla stampante e riprovate.

Se non è possibile effettuare tale collegamento, salvate il documento come file PostScript e inviatelo alla stampante utilizzando la riga di comando di un computer collegato direttamente alla stampante. 

6. Salvate il file come PDF sul disco rigido locale.

Se il problema si verifica durante l'esportazione come PDF in una posizione di rete, provate a salvare il file in formato PDF sul disco rigido locale.

L'instabilità della rete o problemi di autorizzazioni possono provocare errori durante l'esportazione in volumi di rete installati. Se riuscite ad esportare il file nel disco rigido locale ma non in una posizione di rete, chiedete al reparto IT di esaminare il problema.

Risoluzione dei problemi di stampa a livello di stampante

Risoluzione dei problemi di stampa su stampante PostScript

In caso di problemi durante la stampa su una stampante non PostScript, eseguite una o più delle procedure esposte di seguito e stampate dopo ogni operazione.

1. Utilizzate un driver di stampa aggiornato.

Scaricate il driver di stampa PostScript più recente perMac o Windows.

Nota:

se utilizzate una stampante di rete, è possibile che il driver di stampa utilizzato sia compatibile con il sistema operativo del server di stampa ma non con quello del computer. Per installare un driver di stampa compatibile con il sistema operativo, riconfigurate la stampante di rete utilizzando l'Installazione guidata stampante. Leggete Installate un driver di stampa compatibile con il sistema operativo in uso.

2. Utilizzate un file PPD aggiornato.

Un file PPD (PostScript Printer Description) descrive le funzionalità di una stampante PostScript in merito a impostazioni quali margini, colore e risoluzione. File PPD non corretti o non aggiornati possono aumentare i tempi di stampa. Configurate la stampante utilizzando il file PPD consigliato dal produttore.

Per ottenere un file PPD, contattate il produttore della stampante o scaricatelo dal sito Web di Adobe.

3. (Solo Windows) Impostate la stampante per riprodurre codici PostScript ottimizzati

Per Windows 7:

  1. Scegliete Start > Dispositivi e stampanti.
  2. Fate clic con il pulsante destro del mouse e scegliete Preferenze stampa > Avanzate.
  3. Espandete Opzioni documento e successivamente Opzioni PostScript.
  4. Impostate Opzione output PostScript su Massima portabilità.

4. Liberate spazio sul disco.

Verificate di disporre di spazio sufficiente sul disco rigido. Cercate di avere uno spazio libero pari ad almeno il 10% della capacità totale del disco rigido. Per creare ulteriore spazio libero, cercate ed eliminate i file temporanei (.tmp) dal computer e cancellate la cache su disco utilizzata dal browser Web. Per istruzioni su come cancellare la cache su disco, consultate la documentazione relativa al browser.

Per ulteriori informazioni su come liberare spazio su disco, consultate la documentazione relativa al sistema operativo (ad esempio, Suggerimenti per liberare spazio su disco nel PC per Windows o Incrementare lo spazio su disco per Mac OS).

5. Utilizzate una stampante locale.

Se stampate su una stampante di rete, provate a stampare il file da un computer connesso direttamente a una stampante locale. Se il file viene stampato correttamente, è probabile che il problema sia causato dalla rete. Contattate l'amministratore di rete per assistenza.

6. (Solo Windows) Installate un driver di stampa compatibile con il sistema operativo in uso.

Se state utilizzando una stampante di rete, installate un driver di stampa compatibile con il proprio sistema operativo. I server di stampa non sempre sono dotati dei driver per i sistemi operativi in esecuzione sui computer client. Di conseguenza, il driver di stampa potrebbe essere compatibile con il sistema operativo del server di stampa ma non con quello del computer.

Per Windows 7:

  1. Scegliete Start > Dispositivi e stampanti.
  2. Fate clic su Aggiungi stampante.
  3. Selezionate Aggiungi stampante locale.
  4. Scegliete Crea una nuova porta > Porta locale > Avanti.
  5. Immettete il nome della porta (ad esempio, \\[nomeserverdistampa]\[nomestampante]) e fate clic su OK.
  6. Seguite le istruzioni visualizzate a video per installare un driver che si adatti al produttore e al modello della stampante di rete.

Risoluzione dei problemi di stampa su stampante non PostScript

In caso di problemi durante la stampa su una stampante non Postscript, eseguite una o più delle procedure esposte di seguito e stampate dopo ogni operazione.

Nota:

alcune delle soluzioni presentate richiedono la modifica delle proprietà dei driver di stampa. I percorsi di proprietà specifiche variano in base alla stampante e al driver di stampa. Contattate il produttore della stampante o fate riferimento alla documentazione della stampante per ulteriori informazioni.

1. Eseguite la stampa come bitmap.

  1. Scegliete File > Stampa.
  2. Accertatevi che la stampante selezionata sia non PostScript, quindi selezionate il pannello Avanzate.
  3. Selezionate la casella di controllo Stampa come bitmap e selezionate una risoluzione adeguata per la stampante.

2. Assicuratevi che la stampante sia dotata di memoria sufficiente.

Per stampare a 300 dpi, la stampante deve avere almeno 2 MB di RAM disponibile. Per stampare a 600 dpi, la stampante deve avere almeno 4-6 MB di RAM. Per istruzioni su come determinare la memoria disponibile per la stampante, consultate la documentazione della stampante.

3. Utilizzate la modalità PostScript della stampante, se disponibile.

Per dettagli, consultate la documentazione della stampante.

4. (Solo per Windows) Passate al driver SVGA standard.

Passate al driver SVGA standard di Windows per determinare se è il driver video di terze parti a causare il problema. Se utilizzando il driver SVGA standard l'errore non si verifica, contattate il produttore della scheda video e richiedete driver più aggiornati. Se la versione in vostro possesso è la più recente, provate a utilizzare una risoluzione video diversa (ad esempio, 1024 x 768 anziché una risoluzione superiore).

Risoluzione dei problemi di stampa o esportazione a livello di sistema

Se non riuscite a stampare o ad esportare nulla da alcuna applicazione, contattate il supporto tecnico Apple, il supporto tecnico Microsoft o il produttore della stampante. Controllate sempre il collegamento fisico tra la stampante e il computer prima del processo, poiché il problema potrebbe essere causato semplicemente da un cavo non perfettamente collegato.

Considerate inoltre le modifiche apportate di recente al sistema che potrebbero aver compromesso il processo di stampa o di esportazione. Ad esempio:

  • Aggiornamento dell'hardware o aggiunta o rimozione di componenti hardware
  • Aggiunta, aggiornamento o eliminazione di programmi software
  • Installazione o eliminazione font
  • Connessione ad una rete
  • Cancellazione o eliminazione di file dal disco rigido
  • Errori di sistema casuali o errori in altre applicazioni

Spesso, il verificarsi di un problema di stampa è strettamente correlato all'applicazione di una modifica al sistema. Prendete nota delle modifiche al sistema e utilizzatele come dati per la risoluzione dei problemi di stampa e di altri problemi.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online