Informazioni su come risolvere i problemi relativi a file InDesign corrotti o danneggiati.

Un documento InDesign potrebbe essere danneggiato se si verifica un errore o un comportamento anomalo solo quando lavorate con tale documento. In InDesign è disponibile una funzione automatica di recupero dei documenti che consente di impedire danni dovuti ad arresti del sistema o a interruzioni di alimentazione. Questa funzione non può tuttavia impedire danni causati da altri problemi a livello di sistema, quali conflitti software, spazio su disco insufficiente o virus. La presente guida per la risoluzione dei problemi può consentire di identificare e risolvere gli errori nei documenti InDesign nonché i problemi a livello di sistema che possono apparire come danni al documento, ma che in realtà sono dovuti ad altre cause.

Verificate la presenza di problemi a livello di sistema

I problemi a livello di sistema possono causare errori e altri comportamenti anomali. Assicuratevi pertanto che il sistema non presenti anomalie prima di supporre che un documento è danneggiato. Ad esempio, prima di svolgere le procedure di risoluzione dei problemi riportate di seguito, eseguite un'utilità per il ripristino dei dischi e riaprite quindi il documento per verificare se gli errori sono stati corretti.

Windows: consultate la procedura che consente di verificare la presenza di errori nel disco rigido.

Mac OS: consultate Risoluzione dei problemi di avvio ed esecuzione di operazioni di manutenzione del disco.

Risolvete i problemi relativi al documento

Eseguite le procedure descritte nell'ordine in cui sono esposte fino a che non avete risolto il problema. 

Nota:

al termine di ogni procedura di risoluzione dei problemi, riavviate InDesign e aprite il documento per verificare se il problema è stato risolto. Aprite il documento in questo modo:

Scegliete File > Apri, selezionate il documento e quindi scegliete Copia. Salvate il documento con un altro nome e verificate se è stato corretto.

1. Eseguite una copia di backup del documento.

Prima di iniziare la procedura di risoluzione dei problemi, create una copia di backup del documento danneggiato. Alcune delle seguenti operazioni richiedono la modifica o l'eliminazione di informazioni presenti nel documento. Una copia di backup del documento consente di recuperare facilmente tali informazioni. Se il documento si trova su un volume di rete o su un supporto rimovibile (ad esempio, un CD o un'unità jump) spostatelo nel disco rigido locale.

2. Installate l’aggiornamento più recente di InDesign.

  • In InDesign, scegliete Aiuto > Aggiornamenti.

-oppure-

-oppure-

3. Ricreate i file delle preferenze.

InDesign archivia informazioni su plug-in, funzioni e sull'app stessa nei file preferenze: i file InDesign SavedData e InDesign Defaults. Un file delle preferenze di InDesign danneggiato può causare comportamenti anomali con un documento di InDesign. È possibile stabilire se il problema è correlato ai file preferenze semplicemente ricreandoli.

Nota:

la creazione di nuovi file delle preferenze di InDesign comporta il ripristino dei valori di default delle impostazioni e quindi la perdita di eventuali impostazioni personalizzate associate ai file delle preferenze originali. Per non perdere queste impostazioni personalizzate, rinominate i file delle preferenze originali.

Per ricreare i file preferenze di InDesign:

  1. Chiudete InDesign.

  2. Riavviate InDesign e premete immediatamente i tasti appropriati per il sistema operativo in uso:

    • Mac OS X: Control + Opzione +Comando + Maiusc
    • Windows: Control + Alt + Maiusc
  3. Quando viene richiesto di eliminare i file delle preferenze di InDesign, fate clic su. InDesign viene avviato con le impostazioni predefinite e i file delle preferenze rigenerati.

    Nota:

    Se non viene richiesto di eliminare i file delle preferenze, potete eliminare le preferenze manualmente.

  4. Aprite il documento e verificate se è stato corretto. Se il problema persiste, proseguite con il passaggio 4 descritto oltre.

    Eliminate o rinominate manualmente i file delle preferenze

    In alternativa, o in aggiunta, potete:

    • Eliminare manualmente i file delle preferenze (ad esempio, se non viene automaticamente richiesto di eliminare le preferenze all'avvio di InDesign, come nella procedura precedente).

    -oppure-

    • Rinominare manualmente i file delle preferenze (ad esempio, se ai file delle preferenze originali sono associate delle impostazioni personalizzate che non volete perdere).

    Nella tabella seguente, individuate il sistema operativo in uso per conoscere la posizione di tali file.

    SO Posizioni dei file delle preferenze
    Mac OS X

    InDesign Defaults

    Utenti/[utente]/Libreria/Preferences/Adobe InDesign/Version [versione]/[lingua]/InDesign Defaults

    InDesign SavedData

    Utenti/[utente]/Libreria/Caches/Adobe InDesign/Version [versione]/InDesign SavedData

    Windows XP

    InDesign Defaults

    C:\Documents and Settings\[utente]\Dati applicazioni\Adobe\InDesign\Version [versione]\InDesign Defaults

    Non visibile per impostazione predefinita. Fate clic qui per informazioni su come visualizzare i file nascosti.

    InDesign SavedData

    C:\Documents and Settings\[utente]\Impostazioni locali\Dati applicazioni\Adobe\InDesign\Version[versione]\Caches\InDesign SavedData

    Windows 7/8

    InDesign Defaults

    C:\Utenti\[utente]\AppData\Adobe\InDesign\Version [versione]\[lingua]\InDesign Defaults

    Non visibile per impostazione predefinita. Fate clic qui per informazioni su come visualizzare i file nascosti.

    InDesign SavedData

    C:\Utenti\[utente]\AppData\Local\Adobe\InDesign\Version [versione]\[lingua]\InDesign SavedData

    Dopo aver eliminato o rinominato i file, riavviate InDesign per ricreare i file delle preferenze, quindi aprite il documento per verificare se il problema è stato risolto.

    Se il problema persiste, ripristinate le preferenze originali eliminando i nuovi file delle preferenze e rinominando quelli precedenti con i nomi originali.

4. Salvate il documento in formato IDML (InDesign CS4 e versioni successive) o INX (InDesign CS3 e versioni precedenti).

  1. Aprite il file in InDesign.

  2. Selezionate File > Esporta.

  3. Dal menu Salva come, scegliete InDesign Markup (CS4 e versioni successive) o InDesign Interchange (CS3 e versioni precedenti).

  4. Specificate un nome e una posizione per il file, quindi fate clic su Salva.

  5. In InDesign, aprite il file IDML o INX esportato.

    Se il problema è risolto, continuate a utilizzare il file INX o di IDML in sostituzione del documento originale. Se il problema persiste, procedete con il passaggio successivo.

5. Risolvete gli errori relativi a documenti convertiti nell'applicazione di origine.

Se il documento è stato convertito da Adobe PageMaker, QuarkXPress, o da una versione precedente di InDesign, è necessario riconvertirlo. Se il problema si ripresenta, verificate la presenza di errori nel documento originale nell'app in cui è stato creato prima di convertirlo di nuovo. Un documento PageMaker o QuarkXPress danneggiato rimane probabilmente tale anche dopo la conversione.

Per informazioni sulla risoluzione dei problemi relativi a una pubblicazione danneggiata di PageMaker, consultate il documento relativo alla risoluzione dei problemi relativi a pubblicazioni danneggiate. Per informazioni sulla risoluzione dei problemi relativi a un documento danneggiato di QuarkXPress, visitate il sito Web di Quark.

6. Eliminate gli stili di carattere e di paragrafo.

Gli stili creati in InDesign o importati con file creati in altre applicazioni potrebbero essere danneggiati. Per verificare se lo sono, eliminate gli stili e salvate di nuovo il documento.

Per eliminare stili di carattere:

  1. In InDesign, aprite il documento e scegliete Testo > Stili di carattere.

  2. Nel pannello Stili di carattere, selezionate tutti gli stili tranne [Nessuno stile di carattere]. Per selezionare più stili, premete Ctrl (Windows) o Comando (Mac OS) mentre fate clic sugli stili.

  3. Dal menu Stili di carattere, selezionate Elimina stili.

  4. Salvate il documento e verificate se il problema è stato risolto. Se il problema persiste, provate ad eliminare gli stili di paragrafo.

Per eliminare stili di paragrafo:

  1. In InDesign, aprite il documento e scegliete Testo > Stili di paragrafo.

  2. Nel pannello Stili di paragrafo, selezionate tutti gli stili tranne [Nessuno stile di paragrafo]. Per selezionare più stili, premete Ctrl (Windows) o Comando (Mac OS) mentre fate clic sugli stili.

  3. Dal menu Stili di paragrafo, selezionate Elimina stili.

  4. Salvate il documento e verificate se è stato corretto. Se il problema persiste, proseguite con il passaggio successivo.

7. Verificate la presenza di danni ai font.

Per determinare se un problema è causato da un font danneggiato, sostituite tutti i font utilizzati nel documento con un font standard, ad esempio Arial o Times New Roman.

Se il problema si ripresenta, non è dovuto ai font. Se è stato risolto, è possibile che il font o i font originali siano danneggiati o obsoleti. Provate a reinstallare i font originali o cercate di ottenere le versioni aggiornate dal produttore del font.

8. Verificate la presenza di danni a oggetti o grafica.

Cercate di stabilire se il problema è causato da un elemento specifico di una pagina mastro o da una pagina del documento. Per isolare elementi, è necessario in primo luogo eliminare pagine vuote ed elementi non necessari, come quelli presenti su un tavolo di montaggio o un livello nascosto.

Per eliminare pagine:

  1. In InDesign, aprite il documento e scegliete Finestra > Pagine.

  2. Nel pannello Pagine, utilizzate lo strumento selezione per selezionare le pagine che si desidera eliminare. Premete Ctrl (Windows) o Comando (Mac OS) per selezionare più pagine oppure premete il tasto Maiusc per selezionare una serie contigua di pagine.

    Eliminare le pagine
    Selezionare le pagine da eliminare nel pannello Pagine.

  3. Nel pannello Pagine, fate clic sull’icona Elimina.

  4. Fate clic su OK per confermare l'eliminazione.

Se il problema si ripresenta dopo aver eliminato alcune pagine, eliminate metà delle pagine rimanenti e salvate il documento con un nuovo nome. Provate, quindi, a creare nuovamente il problema.

  • Se il problema si ripresenta, una delle pagine rimanenti potrebbe contenere un elemento danneggiato. Continuate a eliminare le pagine fino a che non trovate quella all'origine del problema.
  • Se il problema non si ripresenta, una delle pagine eliminate probabilmente conteneva un elemento danneggiato. Ripristinate le pagine eliminate fino a che non trovate la pagina che causa il problema.

Dopo aver determinato quale pagina causa il problema, rimuovete e sostituite gli elementi in essa presenti, tra cui elementi grafici importati, oggetti di disegno di InDesign e cornici di testo.

9. Copiate gli elementi di una pagina in un nuovo documento.

Eseguire la copia di elementi di una pagina in un nuovo documento spesso comporta la creazione di danni strutturali (interni). Se il problema persiste dopo aver copiato gli elementi di una pagina in un nuovo documento, eliminate gli elementi uno ad uno per determinare se il problema è causato da uno di questi.

Per copiare elementi di una pagina in un nuovo documento:

  1. In InDesign, aprite il documento originale.

  2. Selezionate File > Nuovo e fate clic su OK nella finestra di dialogo Nuovo documento.

  3. Selezionate Finestra > Affianca per visualizzare entrambi i documenti.

  4. Fate clic sul documento originale per attivarlo.

  5. Selezionate Finestra > Pagine per attivare il pannello Pagine.

  6. Trascinate una pagina o un set di pagine affiancate nella finestra del nuovo documento. InDesign copia la pagina o il set di pagine affiancate nel nuovo documento, aggiungendo pagine se necessario.

  7. Salvate il nuovo documento con un nuovo nome (diverso dal nome del documento originale) e provate a riprodurre il problema.

    • Se il problema persiste, il danno non è strutturale (ad esempio, su pagine mastro o di documenti). Eliminate gli elementi uno ad uno per determinare se il problema è causato da uno di questi.
    • Se il problema non si ripresenta, il danno è probabilmente strutturale. Ripetete i passaggi da 4 a 7 per ogni pagina o set di pagine affiancate rimanente.

10. Ottenete un'altra copia del documento.

Se avete ricevuto il documento via e-mail, FTP o supporto rimovibile (come un CD), cercate di ottenerne una copia in un altro modo oppure chiedete al mittente di inviarvelo di nuovo. Un supporto danneggiato o la trasmissione di un'e-mail difettosa possono provocare danni a un documento. Se il documento viene inviato via e-mail, chiedete al mittente di comprimerlo prima dell'invio (ad esempio, utilizzando WinZip o StuffIt di Smith Micro) per proteggere i dati.

Altri suggerimenti

Il problema non è stato risolto? Provate queste soluzioni.

Rimozione dei plug-in di terze parti.

Disinstallate i plug-in di terze parti da InDesign. A volte i plug-in possono danneggiare i file. Consultate Risoluzione dei problemi relativi ai plug-in di terze parti in InDesign.

Utilizzate un altro computer per aprire il documento.

Spostandosi in un diverso ambiente di sistema, è possibile rimuovere le variabili che causano il problema.

Visitate i forum utente di Adobe.

Non siete soli. Altri utenti potrebbero aver riscontrato problemi simili con un documento e aver pubblicato la soluzione. Consultate i forum di InDesign.

Ricreate il documento.

Se nessuna delle soluzioni precedenti ha esito positivo, ricreate il documento. Eseguite spesso copie di backup e verificate periodicamente il documento per assicurarvi che gli elementi importati non causino il problema.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online