单击开始 > 运行
上次更新日期:
2023年5月24日
问题
在安装或删除 Adobe Acrobat 时,您收到一条 Windows 错误消息,指示安装已挂起、未完成或已中断。Acrobat 安装失败,并且安装程序无法成功回滚未完成的安装。
可能的错误消息包括以下内容:
- “错误 1704。Adobe Acrobat 或 Adobe Reader 的安装当前已挂起。”
- “内部错误 2711。在功能表中未找到指定的功能名称‘PatchExtras’。”
- “错误 1500。另一个安装正在进行中。须完成另一个安装,然后才能继续进行此安装。”
原因
电源中断、系统过早关闭或系统出现问题会导致 Windows 安装程序损坏。已取消的安装会回滚安装操作,且不会导致安装挂起。
解决方案
要解决该错误,请执行以下任一解决方案中的步骤:
解决方案 1:停止任何正在进行的安装
注意:
此过程涉及编辑 Windows 注册表。Adobe 不为编辑注册表(其中包含重要的系统和应用程序信息)提供支持。请确保在编辑注册表之前对其进行备份。有关注册表的更多信息,请参阅 Windows 文档或联系 Microsoft。
-
-
键入 regedit ,然后单击确定。
-
导航到注册表项:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\,并检查是否存在 Inprogress 项。
-
删除该项,然后重新开始安装。
解决方案 2:取消注册 Windows Installer 服务后再对其重新注册。
-
单击开始 > 运行
-
键入 msiexec /unreg,然后单击确定。
-
单击开始 > 运行
-
键入 msiexec / regserver ,然后单击确定。