Řešení běžných potíží prohlížení souborů PDF z webové stránky.

Příznaky 

Běžné příznaky, když nelze zobrazit PDF na webu:

  • Prázdná stránka ve webovém prohlížeči
  • Červená ikona X
  • Poškozený ukazatel odkazu, například červený čtverec a modrý trojúhelník nebo modrý kruh
  • Chyba: „Spuštěnou aplikaci Adobe Acrobat/Reader nelze použít k zobrazení PDF souborů ve webovém prohlížeči. Požadována je aplikace Adobe Acrobat/Reader ve verzi 8 nebo 9. Aplikaci uzavřete a zkuste to znovu.“

Chcete-li vyřešit některé nejobvyklejší problémy se zobrazováním PDF, využijte níže uvedené pokyny v tomto pořadí: Aktaulizujte aplikaci Reader nebo Acrobat, opravte potíže s PDF, zkontrolujte nastavení prohlížeče, opravte nebo přeinstalujte aplikaci Reader nebo Acrobat.

Aktualizace aplikace Reader nebo Acrobat

Společnost Adobe každého čtvrt roku vydává bezplatné aktualizace zabezpečení. Nezapomeňte aktualizovat svoji verzi aplikace Reader nebo Acrobat na poslední verzi. Aktualizace často obsahují opravy běžných problémů. Chcete-li stáhnout nejnovější bezplatnou aktualizaci, postupujte následovně.

  1. Otevřete aplikaci Reader nebo Acrobat.

  2. Vyberte možnost Nápověda > Zkontrolovat aktualizace. 

    Acrobat 9 a starší: Pokud je k dispozici nová aktualizace, nainstaluje se automaticky.

    Acrobat X a XI: Klikněte na tlačítko Aktualizovat a pak na Instalovat.

    Acrobat DC: Pokračujte dalším krokem.

    Vyhledat aktualizace
  3. Po zobrazení dialogového okna programu pro aktualizaci, klikněte na tlačítko Stáhnout.

    Aktualizovat Acrobat
  4. Po dokončení stahování klikněte na ikonu instalace aplikace Acrobat. V okně programu pro aktualizaci aplikace Acrobat klikněte na položku Instalovat.

    Aktualizace je připravena
  5. Po dokončení instalace restartujte svůj počítač a znovu otestujte PDF a zkontrolujte, zda ho vidíte.

Řešení PDF

Obnovte nebo znovu načtěte stránku

Často vám pouhé obnovení stránky v prohlížeči umožní plně načíst PDF.

  • Podržte klávesu Shift a stiskněte tlačítko  Obnovit nebo  Znovu načíst v prohlížeči.

Zkuste zobrazit jiné PDF

Zkuste zobrazit jiné PDF. Například zkontrolujte, zda se tento vzorový formulář zobrazí v prohlížeči. Pokud se aplikaci Acrobat nebo Reader podaří otevřít vzorový formulář, pak může být druhý soubor PDF poškozen nebo má webový server potíže. Pokud je to možné, kontaktujte osobu nebo společnost, která spravuje webovou stránku.

Zkuste zobrazit soubor PDF na pevném disku

Určete, zda váš webový prohlížeč dokáže otevřít PDF z místního pevného disku a ne z webu. Pro tento test budete potřebovat PDF uložené v počítači.

  1. Ve webovém prohlížeči proveďte jeden z následujících úkonů:

    • Mac OS: Vyberte Soubor > Otevřít (nebo Otevřít soubor).
    • Windows: Stiskněte klávesy Control + O.
  2. Klikněte na položku Procházet.

  3. (Pouze Windows) Z nabídky Typy souborů vyberte možnost Všechny soubory.

    Vyberte všechny soubory
  4. Vyhledejte soubor PDF ve svém počítači, vyberte ho a pak klikněte na tlačítko Otevřít.

    Pokud se PDF otevře, může prohlížená webová stránka obsahovat problém. Obraťte se na osobu nebo společnost, která spravuje webovou stránku.

Řešení potíží prohlížeče a nastavení prohlížeče

Použití jiného webového prohlížeče

Některé podmínky vašeho počítače, například nastavení zabezpečení nebo soubory cookie prohlížeče vám mohou bránit v zobrazení PDF. Často je nejrychlejším řešením pokus o otevření stránky pomocí jiného prohlížeče. Vyzkoušejte některý z následujících prohlížečů, které jste ještě nevyzkoušeli:

 Google Chrome
 Mozilla Firefox
 Microsoft Internet Explorer
 Apple Safari

Seznam kompatibilních prohlížečů pro aplikace Reader a Acrobat naleznete v části Kompatibilní webové prohlížeče.

Přepněte do kompatibilního zobrazení (Internet Explorer)

Některé webové stránky se zobrazují lépe v kompatibilním zobrazení aplikace Internet Explorer. Kompatibilní zobrazení zobrazí stránku, jako by byla otevřena ve starší verzi prohlížeče.

Pokyny týkající se přepínání tohoto zobrazení naleznete v části  Opravit problémy se zobrazením pomocí kompatibilním zobrazení.

Restartujte počítač a zkuste znovu otevřít PDF

Restartujte počítač a pak znovu otevřete webovou stránku. Restartování vymaže paměť a mezipaměť počítače. Jednoduché časté restartování počítače vyřeší problémy se zobrazením.

Odstranění dočasných souborů sítě Internet (Internet Explorer, Firefox a Chrome)

Vymažte mezipaměť prohlížeče (někdy se nazývá dočasné soubory Internetu) a zajistěte tak, že prohlížíte čerstvou verzi stránky. 

Při výběru možností dávejte pozor. Vymažte pouze mezipaměť prohlížeče. Pokud odstraníte všechny dočasné soubory sítě Internet, můžete odstranit soubory cookie, které obsahují přihlašovací údaje a předvolby. Většina prohlížečů umožňuje vybrat typ obsahu, který chcete odstranit.

Vymazat historii
Dialogové okno prohlížeče Firefox Vymazat celou historii umožní smazat pouze mezipaměť prohlížeče.

Pokyny ohledně mazání mezipaměti prohlížeče naleznete v následujících článcích:

Firefox: Odebrat historii nedávného prohlížení stránek, hledání a stahování

Chrome: Smazat mezipaměť, historii a jiný data prohlížeče

Internet Explorer 8 až 11: Prohlížení a odstraňování historie prohlížeče

Internet Explorer 7Smazat historii webových stránek

Obnoví zobrazení PDF v předvolbách prohlížeče (Acrobat / Reader X nebo starší)

Zkuste obnovit předvolby zobrazení v prohlížeči pro vymazání problému se zobrazením.

  1. V aplikaci Reader nebo Acrobat klikněte pravým tlačítkem na okno dokumentu a vyberte možnost Předvolby zobrazení stránky.

    Předvolby zobrazení stránky
  2. Ze seznam nalevo vyberte možnost Internet.

    Vyberte položku Předvolby internetu
  3. Zrušte výběr možnosti Zobrazit PDF v prohlížeči a pak klikněte na tlačítko OK.

    Zrušte výběr možnosti Zobrazit PDF v prohlížeči
  4. Znovu zkuste otevřít PDF na webové stránce.

Zobrazte PDF ve 32bitové verzi prohlížeče Internet Explorer nebo Safari (pouze Windows Vista)

Tento postup se vztahuje pouze na uživatele Windows Vista s prohlížečem Internet Explorer 9 nebo starším.

Aplikace Acrobat a Reader jsou 32bitové aplikace systému Windows.Pokud se pokusíte otevřít PDF ve 64bitové verzi prohlížeče Internet Explorer, PDF se otevře v samostatném okně aplikace Acrobat nebo Reader, ne v prohlížeči Internet Explorer.

Poznámka:

Prohlížeč Internet Explorer 9 podporují pouze aplikace Reader 10.1 nebo Acrobat 10.1.

Chcete-li ověřit, zda používáte 32bitovou verzi prohlížeče Internet Explorer, využijte následující postup:

  1. V aplikaci Internet Explorer vyberte možnost Nápověda > Informace o aplikaci Internet Explorer. (U některých verzí aplikace Internet Explorer vyberte otazník v pravém horním rohu a vyberte možnost Informace o prohlížeči Internet Explorer.)

    Informace o prohlížeči Internet Explorer 9

    Pokud vidíte nápis „64bitová edice“ vedle verze, pak přejděte do kroku 2.

    Internet Explorer 64 bitů
  2. Chcete-li přepnout na 32bitový prohlížeč Internet Explorer, nejprve opusťte 64bitový prohlížeč Internet Explorer. Pak dvakrát klikněte na ikonu programu pro 32bitovou verzi:

    C:\Program Files (x86)\Internet Explorer\iexplore.exe

    Internet Explorer 32 bitů

Řešení aplikace Reader a Acrobat

Oprava aplikace Reader nebo Acrobat

Aplikace Reader nebo Acrobat se mohou poškodit. Oprava instalace představuje rychlý a bezpečný způsob, jak dané problémy vyřešit.

Oprava z aplikace Reader nebo Acrobat

Zvolte možnost Nápověda > Opravit instalaci.

Nápověda, Opravit instalaci

Oprava pomocí Ovládacích panelů (Windows)

Instalaci aplikace Acrobat nebo Reader můžete také opravit pomocí ovládacích panelů systému Windows.

  1. Zavřete aplikaci Reader nebo Acrobat.

  2. V nabídce Start klikněte na položku Ovládací panely.

    Spusťte ovládací panely
  3. V Ovládacích panelech proveďte v závislosti na používané verzi systému Windows jednu z následujících akcí:

    • (Windows 8/7/Vista): Klikněte na odkaz Programy a potom na odkaz Programy a funkce.
    • (Windows XP): Klikněte dvakrát na položku Přidat nebo odebrat programy.
  4. V seznamu programů vyberte aplikaci Adobe Reader nebo Adobe Acrobat.

  5. Klikněte na tlačítko Změnit a podle pokynů proveďte opravu aplikace.

    Pro opravu klikněte na položku Změnit
  6. Po dokončení procesu klikněte na tlačítko Dokončit.

Další volby

Pokud žádná z řešení v předchozích částech nevyřešila problém s prohlížením PDF, můžete zkusit následující pokročilé kroky.

Povolte doplněk prohlížeče Adobe PDF (Internet Explorer 8 a novější)

Ověřte, zda je doplněk prohlížeče Adobe PDF povolen.

  1. Spusťte aplikaci Internet Explorer a vyberte položku Nástroje > Spravovat doplňky.

  2. V části Typy doplňků vyberte možnost Panely nástrojů a rozšíření.

  3. V nabídce Zobrazit vyberte možnost Všechny doplňky.

    Všechny doplňky
  4. V seznamu doplňků vyberte položku Adobe PDF Reader.

    Poznámka:

    Nevidíte-li doplněk Adobe PDF Reader, zkuste jiné volby v nabídce. Na některých systémech se například modul objeví po výběru volby Spustit bez oprávnění.

  5. Klikněte na tlačítko Povolit.

    Poznámka:

    Pokud tlačítko obsahuje nápis Zakázat, pak je doplněk již povolen. Toto tlačítko přepíná mezi možnostmi Povolit a Zakázat v závislosti na stavu vybraného doplňku.

    Možnost Povolit nastaví doplněk Adobe PDF Reader jako aplikaci pro otevírání souborů PDF v prohlížeči.

    Možnost Zakázat tento doplněk vypne, takže nebude otevírat soubory PDF v prohlížeči.

    Povolit Acrobat Reader

Povolí doplněk prohlížeče Adobe PDF (Firefox)

Ověřte, zda je doplněk prohlížeče Adobe PDF (nppdf32.dll) povolen.

  1. Do adresního řádku aplikace Firefox zadejte: about:plugins

  2. Přejděte dolů do části s názvem Adobe Acrobat.

    Povoleno v aplikaci Firefox
  3. Ověřte, zda se soubor nazývá „nppdf32.dll“ a „Doplněk Adobe Acrobat pro Netscape“.
    Pokud tato položka není dostupná, nainstalujte poslední verzi aplikace Reader nebo Acrobat.

Spusťte aplikaci Acrobat nebo Reader v novém místním účtu pro správce

Vytvořte uživatelský účet se stejnými oprávněními, jako má účet, který používáte, když dochází k problému. Nebo vytvořte místní účet pro správce. Pokud k problému nedochází opakovaně při přihlášení do nového účtu, pak může dojít k poškození účtu původního uživatele.

Informace o nastavení uživatelského účtu naleznete v následujících zdrojích nebo se obraťte na svého správce sítě:

Windows XP: Přidání nového uživatele do počítače

Windows Vista/7/8: Vytvoření uživatelského účtu

Mac OS X: Nastavení uživatelů na vašem Macu

Optimalizace velkých souborů PDF

Pokud má soubor PDF velikost 4 MB nebo více, požádejte poskytovatele o optimalizaci souboru PDF. Informace o optimalizaci souborů PDF naleznete v části Optimalizace souborů PDF.

Zkontrolujte cestu k registrům pro aplikaci Acrobat nebo Reader (Windows)

Zřeknutí se odpovědnosti: Registry obsahují informace související se systémem, které jsou klíčové pro váš počítač a aplikace. Před úpravou registrů nezapomeňte vytvořit jejich záložní kopii. Společnost Adobe neposkytuje podporu týkající se problémů vyplývajících z nesprávné úpravy registru. Společnost Adobe důrazně doporučuje vyzkoušet si systém úprav před úpravou registrů. Další informace o registrech naleznete v dokumentaci systému Windows nebo se obraťte na společnost Microsoft.

  1. Přejděte na Start > Spustit.

  2. Zadejte regedit a klikněte na tlačítko OK.

  3. Otevřete klíč HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  4. Ověřte, zda je pro cestu, kde je nainstalována aplikace Acrobat nebo Reader, nastavena hodnota (Výchozí).

    • Výchozí cesta pro aplikaci Reader činí „C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe“.
    • Výchozí cesta pro aplikaci Acrobat činí „C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe“.

    Poznámka:

    Pokud není aplikace Acrobat nebo Reader nainstalována ve výchozí složce, ověřte, zda hodnota klíče (Výchozí) směřuje do skutečného umístění.

Video ukázku postupu naleznete v části Kontrola správné cesty registru.

Pokud výše uvedená položka registru neexistuje v systému, proveďte následující:

  1. Přejděte na Start > Spustit.

  2. Zadejte regedit a klikněte na tlačítko OK.

  3. Zálohujte aktuální soubor registrů:

    • V dialogovém okně Editor registrů vyberte možnost Soubor > Exportovat.
    • Zadejte název souboru a vyberte umístění.
    • Jako rozsah exportu vyberte možnost Vše.
    • Klikněte na možnost Uložit.
  4. Přejděte do možnosti Upravit > Nový > Klíč a vytvořte chybějící klíč HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  5. Přejděte do možnosti Upravit > Nový > Hodnota řetězce a pojmenujte tento klíč (Výchozí).

  6. Vyberte možnost (Výchozí) a pak přejděte na možnost Upravit > Modifikovat. Zadejte výchozí cestu (uvedena výše) do pole „Data hodnoty“ svého produktu.

  7. Restartujte svůj počítač.

Opravte klíč registrů HKCR\AcroExch.Document (Windows)

Je možné, že byl tento klíč poškozen, ukazuje na zastaralou verzi aplikace Acrobat nebo Reader nebo ukazuje na prohlížeč PDF třetí strany.

Zřeknutí se odpovědnosti: Registry obsahují informace související se systémem, které jsou klíčové pro váš počítač a aplikace. Před úpravou registrů nezapomeňte vytvořit jejich záložní kopii. Společnost Adobe neposkytuje podporu týkající se problémů vyplývajících z nesprávné úpravy registru. Společnost Adobe důrazně doporučuje vyzkoušet si systém úprav před úpravou registrů. Další informace o registrech naleznete v dokumentaci systému Windows nebo se obraťte na společnost Microsoft.

  1. Vyberte možnost Start > Spustit, zadejte hodnotu regedit do textového pole Otevřít dialogového okna Spustit a pak klikněte na tlačítko OK.

  2. Zálohujte aktuální soubor registrů:

    • V dialogovém okně Editor registrů vyberte možnost Soubor > Exportovat.
    • Zadejte název souboru a vyberte umístění.
    • Jako rozsah exportu vyberte možnost Vše.
    • Klikněte na možnost Uložit.
  3. Přejděte na klíč HKEY_CLASSES_ROOT\AcroExch.Document.

  4. Pravým tlačítkem klikněte na položku AcroExch.Document a vyberte možnost Odstranit. Ověřte, zda máte správný klíč a při zobrazení výzvy klikněte na tlačítko Ano.

  5. Pravým tlačítkem klikněte na položku AcroExch.Document.7 a vyberte možnost Odstranit. Ověřte, zda máte správný klíč a při zobrazení výzvy klikněte na tlačítko Ano.

  6. Toto video obsahuje postup.

     

Změňte záhlaví typu obsahu na webovém serveru (správci webu)

Pokud jste správci webu nebo máte oprávnění správce k webové stránce, nakonfigurujte webový server k odesílání záhlaví typu obsahu „aplikace/pdf“ pro soubory PDF. Pokyny naleznete v dokumentaci dodané s webovým serverem nebo v tomto článku podpory společnosti Microsoft.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online