Uložení pomocí funkce Optimalizace PDF (Acrobat Pro DC)

Optimalizace PDF poskytuje mnoho nastavení pro zmenšení velikosti souborů PDF. Některá nastavení v okně Optimalizace PDF jsou stejná jako nastavení, která jsou k dispozici při vytváření souboru PDF s použitím Distilleru. Zda použijete všechna tato nastavení nebo jen některá z nich závisí na tom, jak budete soubory používat a na základních vlastnostech, které tyto soubory musí mít. Ve většině případů jsou nejefektivnější výchozí nastavení – ušetří místo odstraněním vložených písem, kompresí obrazů a odstraněním položek, které již nejsou potřebné.

Dříve než budete optimalizovat soubor, je dobré prověřit využití místa v souboru. Výsledky kontroly využití místa vám mohou ukázat, kde lze nejlépe zmenšit velikost souboru. Velikost souboru PDF můžete zmenšit také pomocí příkazu Zmenšit velikost souboru.

Poznámka:

Některé metody komprese mohou změnit obrazy tak, že budou nepoužitelné v pracovním postupu pro tiskovou produkci. Před provedením změn, které nelze vzít zpět, byste měli experimentovat s různými nastaveními.

Otevření okna Optimalizace PDF

  1. V samostatném souboru PDF zvolte příkaz Soubor > Uložit jako jiný > Optimalizovaný PDF.

Poznámka:

Optimalizace PDF není dostupná, když je v nabídce Zobrazení vybraná volba Přeformátovat.

Prověření využití místa v PDF (Acrobat Pro DC)

Prověření využití místa vytvoří výkaz celkového počtu bytů použitých pro určité elementy dokumentu, včetně písem, obrazů, záložek, formulářů, pojmenovaných cílových míst a poznámek, a také zjistí celkovou velikost souboru. Výsledky jsou uvedeny v počtu bytů i v procentech z celkové velikosti souboru.

  1. Zvolte Soubor > Uložit jako jiný > Optimalizovaný PDF. Otevře se dialog Optimalizace PDF.
  2. Klepněte na tlačítko Prověřit využití místa nahoře v dialogovém okně.

Poznámka:

Využití prostoru lze ověřit také pomocí PDF v podokně Obsah. Zvolte příkaz Zobrazení > Zobrazit/Skrýt > Navigační panely > Obsah. Z nabídky voleb v podokně Obsah zvolte možnost Ověřit využití prostoru.

Optimalizace PDF (Acrobat Pro DC)

  1. Otevřete dialog Optimalizace PDF (Soubor > Uložit jako jiný > Optimalizovaný PDF).

  2. Chcete-li použít výchozí nastavení, zvolte Standardní z nabídky Nastavení a pak pokračujte krokem 6. Pokud změníte některé nastavení v dialogu Optimalizace PDF, nabídka Nastavení se automaticky přepne na Vlastní.

  3. V nabídce Změnit na kompatibilní s zvolte Zachovat stávající, chcete-li zachovat aktuální verzi PDF, nebo zvolte verzi aplikace Acrobat. (Volby dostupné v panelech se liší v závislosti na této volbě.)

  4. Zaškrtněte pole vedle panelu (například Obrazy, Písma, Průhlednost) a pak vyberte volby v příslušném panelu. Chcete-li, aby se během optimalizace nespouštěla žádná z možností v panelu, zrušte výběr pole daného panelu.

  5. (Volitelně) Chcete-li uložit přizpůsobená nastavení, klikněte na položku Uložit a nastavení pojmenujte. (Chcete-li odstranit uložené nastavení, vyberte jej v nabídce Nastavení a klikněte na možnost Odstranit.)

  6. Když máte vybrané požadované volby, klikněte na tlačítko OK.

  7. V dialogovém okně Uložit optimalizovaný jako klikněte na Uložit, aby se původní soubor PDF přepsal optimalizovaným souborem PDF, nebo zadejte nový název nebo umístění.

    Poznámka:

    Chcete-li optimalizovat několik dokumentů najednou, použijte možnost Výstup příkazu Průvodce akcí.

Volby funkce Optimalizace PDF (Acrobat Pro DC)

Chcete-li zmenšit velikost PDF, použijte volby z panelů v dialogovém okně Optimalizace PDF.

Panel Obrazy

V panelu Obrazy v dialogovém okně Optimalizace PDF můžete nastavit volby pro kompresi barevných, šedotónových a monochromatických obrazů a převzorkování obrazu.

Volby optimalizace PDF v Acrobatu
Změna kompatibility PDF v panelu Obrazy dialogového okna Optimalizace PDF v aplikaci Acrobat Pro DC.

Dle potřeby nastavte následující volby:

Převzorkovat dolů

Zmenší velikost souboru snížením rozlišení obrazů, při kterém se barvy původních obrazových bodů sloučí do větších bodů.

Poznámka: Maskované obrazy a obrazy menší než 16 x 16 obrazových bodů se nepřevzorkují.

Komprese

Zmenší velikost souboru odstraněním nepotřebných dat obrazových bodů. Všeobecně dává komprese JPEG a JPEG2000 lepší výsledky pro takové obrazy, jako jsou fotografie s postupnými přechody mezi barvami. ZIP je lepší volba pro ilustrace s velkými plochami vyplněnými plnými barvami nebo se vzorky složenými z plných barev. Pro monochromatické obrazy je komprese JBIG2 lepší než CCITT. Je k dispozici v okně Optimalizace PDF, nikoli však v Distilleru.

Kvalita

Dostupné pouze pro formáty JPEG a JPEG2000. Metody komprese JPEG a JPEG2000 jsou typicky ztrátové, jsou to tedy procesy, které trvale odstraní některá data obrazových bodů. Ztrátovou kompresi JPEG nebo JPEG2000 můžete pro barevné obrazy použít s různou úrovní ztrátovosti (minimální, nízká, střední, vysoká, maximální). Pro kompresi JPEG2000 můžete také určit bezeztrátovou kompresi, při které se neodstraní žádná obrazová data. Komprese pro monochromatické obrazy je bezeztrátová, kromě komprese JBIG2, která nabízí ztrátový i bezeztrátový režim komprese.

Velikost dlaždice

Dostupné pouze pro formát JPEG2000. Rozdělí obraz, který se komprimuje, na dlaždice zadané velikosti. (Pokud výška nebo šířka obrazu není přesným násobkem velikosti dlaždice, použijí se na okrajích neúplné dlaždice.) Obrazová data pro každou dlaždici se komprimují samostatně a mohou se i samostatně rozbalit. Doporučená je výchozí hodnota 256.

Optimalizovat obrazy pouze v případě zmenšení

Je-li tato volba vybrána a nastavení obrazu by způsobilo zvětšení velikost souboru, bude optimalizace tohoto obrazu přeskočena.

Panel Písma

Abyste zajistili přesnou shodu se zdrojovým dokumentem, měli byste vložit všechna písma použitá v dokumentu. Pokud se nevyžaduje přesná shoda a dáváte přednost menší velikosti souboru, můžete zvolit, že nechcete vložit písma pro text v latince a východoasijských jazycích (tradiční čínštině, zjednodušené čínštině, korejštině a japonštině). Při prohlížení na počítači, na kterém nejsou originální písma, se text v těchto jazycích zobrazí v náhradním písmu. Panel Písma v okně Optimalizace PDF obsahuje dva seznamy písem: písma, pro která je možné zrušit vložení a písma, jejichž vložení bude zrušeno. Pro některá písma nelze vložení zrušit a tato písma se v panelu Písma neobjeví. Chcete-li zrušit vložení písem v dokumentu, vyberte jedno nebo více písem v seznamu Vložená písma a klikněte na tlačítko Zrušit vložení. Pokud nechcete vložit podmnožiny vložených písem, odznačte volbu Dát všechna vložená písma do podmnožiny. Chcete-li zabránit zrušení vložení všech písem v dokumentu, zvolte možnost Nerušit vložení žádného písma.

Panel Průhlednost

Pokud PDF zahrnuje kresby a obrazy, které obsahují průhlednost, můžete použít přednastavení v panelu Průhlednost v okně Optimalizace PDF ke sloučení průhledností a zmenšení velikosti souboru. (Při sloučení se průhlednost začlení do odpovídající kresby pomocí jejího rozdělení na vektorové a rastrované oblasti.) Optimalizace PDF aplikuje volby průhlednosti na všechny stránky v dokumentu ještě před aplikováním dalších voleb optimalizace.

Pokud vyberete kompatibilitu Acrobat 4.0 a novější, zapne se panel Průhlednost a všechny průhlednosti v souboru se při optimalizaci sloučí. To zajistí kompatibilitu s Acrobatem 4.0 a staršími, které průhlednost nepodporují.

Když vytvoříte přednastavení sloučení průhledností, objeví se spolu s výchozími přednastaveními v panelu Průhlednost.

Poznámka:

Po uložení souboru nelze již sloučení průhledností vzít zpět.

Panel Vypustit objekty

V panelu Vypustit objekty můžete určit objekty, které chcete z PDF odstranit, a optimalizovat zakřivené čáry ve výkresech CAD. Můžete vypustit objekty vytvořené v aplikaci Acrobat DC a v jiných aplikacích. Když vyberete objekt, odstraní se všechny výskyty tohoto objektu v PDF.

V oblasti Vypustit objekty můžete vybrat následující volby:

Vypustit všechny akce odeslání, importu a obnovení formuláře

Zablokuje všechny akce vztahující se k odesílání nebo importu dat formuláře a obnoví pole formuláře. Tato volba zachová všechny objekty formuláře, se kterými jsou tyto akce spojeny.

Sloučit pole formuláře

Pole formuláře budou nepoužitelná, ale nezmění se jejich vzhled. Data formuláře se sloučí se stránkou a stanou se jejím obsahem.

Vypustit všechny akce JavaScriptu

Odstraní z PDF všechny akce, které používají JavaScript.

Vypustit všechny alternativní obrazy

Odstraní všechny verze obrazu kromě té, která je určená pro zobrazení na obrazovce. Některé soubory PDF obsahují více verzí stejného obrazu pro různé účely, například pro zobrazení na obrazovce s nízkým rozlišením a tisk s vysokým rozlišením.

Vypustit vložené miniatury stránek

Odstraní vložené miniatury stránek. Vložení miniatur je užitečné pro velké dokumenty, pro které může dlouho trvat vykreslování miniatur stránek, když kliknete na tlačítko Miniatury stránek.

Vypustit tagy dokumentu

Odstraní z dokumentu tagy, a tím se také odstraní možnosti usnadnění přístupu a přeformátování pro text.

Převést hladké čáry na křivky

Zmenší počet řídících bodů použitých k vytváření křivek ve výkresech CAD; výsledkem jsou menší soubory PDF a rychlejší vykreslování na obrazovce.

Detekovat a sloučit části obrazu

Hledá obrazy nebo masky, které jsou rozdělené na tenké řezy, a pokusí se sloučit tyto řezy do jednoho obrazu nebo masky.

Vypustit vložená nastavení tisku

Odstraní z dokumentu vložená nastavení tisku, například měřítko stránky a režim oboustranného tisku.

Vypustit vložený index prohledávání

Odstraní vložené indexy pro hledání, čímž se zmenší velikost souboru.

Vypustit záložky

Odstraní z dokumentu všechny záložky.

Panel Vypustit uživatelská data

Pomocí panelu Vypustit uživatelská data můžete odstranit všechny osobní informace, které nechcete šířit nebo sdílet s ostatními. Pokud nemůžete osobní informace najít, mohou být skryté. Skrytý text a informace týkající se uživatele můžete vyhledat pomocí příkazu Prozkoumat dokument (Nástroje > Redigovat > Odstranit skryté informace).

Vypustit všechny poznámky, formuláře a multimédia

Odstraní ze souboru PDF všechny poznámky, formuláře, pole formulářů a multimédia.

 

Vypustit informace o dokumentu a metadata

Odstraní informace ze slovníku informací o dokumentu a všechny streamy metadat. (Použijte příkaz Uložit jako, chcete-li obnovit streamy metadat v kopii PDF.)

 

Vypustit všechna data objektů

Odstraní z PDF všechny objekty.

 

Vypustit přiložené soubory

Odstraní všechny přiložené soubory, včetně příloh přidaných do PDF jako poznámky. (Optimalizace PDF neoptimalizuje přiložené soubory.)

 

Vypustit externí křížové odkazy

Odstraní vazby na jiné dokumenty. Vazby, které přecházejí na jiná místa uvnitř PDF, se neodstraní.

 

Vypustit privátní data jiných aplikací

Odstraní z dokumentu PDF informace, které jsou užitečné jen pro aplikaci, ve které byl dokument vytvořen. Nemá to vliv na funkčnost PDF, ale zmenší se tím velikost souboru.

 

Vypustit obsah skrytých vrstev a sloučit viditelné vrstvy

Zmenší velikost souboru. Optimalizovaný dokument vypadá jako původní PDF, ale neobsahuje žádné informace o vrstvách.

Panel Vyčistit

Volby v panelu Vyčistit v dialogu Optimalizace PDF odstraní z dokumentu nepotřebné položky. Mezi tyto položky patří elementy, které jsou zastaralé nebo nejsou potřebné pro zamýšlené použití dokumentu. Odstranění určitých prvků může výrazně ovlivnit funkčnost PDF. Standardně jsou vybrané pouze ty elementy, které nemají vliv na funkčnost. Pokud si nejste jisti následky odstranění dalších voleb, použijte výchozí nastavení.

Volby komprese objektů

Určuje, jak se má u souboru použít komprese Flate.

Použít Flate k zakódování streamů, které nejsou zakódované

Aplikuje kompresi Flate na všechny streamy, které nejsou zakódované.

Ve streamech, které používají kódování LZW, použít místo toho Flate

Aplikuje kompresi Flate na všechny streamy obsahu a obrazy, které používají kódování LZW.

Vypustit neplatné záložky

Odstraní záložky odkazující na stránky, které byly z dokumentu odstraněny.

Vypustit neplatné vazby

Odstraní vazby, které odkazují na neplatné cíle.

Vypustit pojmenovaná cílová místa, na která nevedou odkazy

Odstraní pojmenovaná cílová místa, na která nevedou interní odkazy ze stejného dokumentu PDF. Protože tato volba nekontroluje vazby z jiných souborů PDF nebo z webových stránek, v některých pracovních postupech nemusí být vhodná.

Optimalizovat obsah stránky

Převede všechny znaky konce řádku na znaky mezery, což zlepší kompresi Flate.

Optimalizovat PDF pro rychlé zobrazování z webu

Změní strukturu PDF tak, aby ho bylo možné stahovat z webových serverů po jednotlivých stránkách (byte-serving).

Povolení rychlého zobrazování z webu v PDF

Rychlé zobrazování z webu změní strukturu dokumentu PDF tak, aby se stahoval z webových serverů po jednotlivých stránkách (byte-serving). S rychlým zobrazováním z webu webový server posílá namísto celého PDF pouze požadovanou stránku. Tato volba je zvlášť důležitá u rozsáhlých dokumentů, jejichž stahování ze serveru může trvat dlouho.

Ověřte u správce webu, zda používaný software webového serveru podporuje stahování po stránkách. Chcete-li zajistit, aby se dokumenty PDF na webu zobrazovaly ve starších prohlížečích, můžete také na dokumenty PDF vytvořit vazby HTML (oproti skriptům ASP nebo metodám POST) a používat relativně krátké názvy cest (max. 256 znaků).

Ověření, zda v existujícím PDF je zapnuté Rychlé zobrazování z webu

  1. Otevřete PDF v aplikaci Acrobat DC a zvolte Soubor > Vlastnosti. V panelu Popis v dialogovém okně se podívejte vpravo dolů na nastavení Rychlé zobrazování z webu (Ano nebo Ne).

Kontrola nastavení předvolby pro Rychlé zobrazování z webu

Tímto postupem se ujistěte, že máte v aplikaci Acrobat DC nastavené zapnutí volby Rychlé zobrazování z webu při vytváření PDF.

  1. V dialogu Předvolby vyberte v části Kategorie položku Dokumenty.

  2. Na pravé straně dialogu v sekci Nastavení ukládání zkontrolujte, zda je vybraná volba Uložit jako optimalizuje pro rychlé zobrazování z webu, a klikněte na OK.

Povolení Rychlého zobrazování z webu pro existující PDF

Použijte tento postup, když jste již ověřili nastavení předvolby Rychlé zobrazování z webu a zkontrolovali vlastnosti PDF, abyste měli jistotu, že Rychlé zobrazování z webu ještě není v souboru zapnuté.

  1. Otevřete PDF.

  2. Vyberte položku Soubor > Uložit jako. Vyberte stejný název souboru a umístění.

  3. Když se objeví zpráva s dotazem, zda chcete přepsat existující soubor, klikněte na OK.

Poznámka:

V aplikaci Acrobat Pro můžete rychlé zobrazování z webu rychle nastavit pro celé složky souborů Adobe PDF pomocí akce Připravit pro publikování na webu. Viz téma Spuštění akce.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online