In this tutorial, you will open an InDesign document, add content, and create a DPS folio and article.

This tutorial requires basic knowledge of InDesign.

Open the source InDesign document

When you create articles for the Digital Publishing Suite (DPS), you can use either InDesign or HTML source files. In this first tutorial, you will create a DPS article based on an InDesign file.

  1. Make sure that you have downloaded the tutorial source files to a known location.

    Download the files from Tutorial Setup.

  2. Open InDesign CS6 or later.

  3. In the Pluralist_Folio folder, open the cover_h.indd file in the 00_Cover folder.

    If you are using an older version of InDesign (CS6 or later), open the .idml file and save the document as a cover_h.indd file in the 00_Cover folder.

  4. If desired, choose Window > Workspace > [Digital Publishing].

    The [Digital Publishing] workspace displays many of the panels used in the Digital Publishing Suite workflow. Feel free to modify this workspace or use any other workspace.

Add a movie overlay

First, let's add an interactive object to the InDesign document. In the Digital Publishing Suite, interactive objects are called "overlays" because they play on top of the static (non-interactive) content.

  1. In InDesign, choose File > Place.

  2. In the 00_Cover > Links folder, double-click Ritter_video_640-360.mp4.

  3. Click the loaded place cursor in the pasteboard to the left of "The Pluralist" logo, and then drag the video object to align to the left edge of the page below the horizontal guide.

  4. With the video object still selected, choose Object > Arrange > Send to Back so that the top part of the video appears behind the logo. Drag the video icon from the pasteboard to the center of the video.

    That's all the editing we'll do for now on this document.

  5. Preview the layout by choosing File > Folio Preview.

    Notice that clicking the video area activates the video overlay and starts playing the video. Close the Adobe Content Viewer window when you're done previewing.

    Choosing the Folio Preview option offers a quick and fairly reliable preview of the layout. The more reliable preview method is to preview on the target device such as an iPad. We'll do that later.

Create a folio and an article

In DPS, an app is the viewer that displays your content. An app consists of one or more folios. Each folio consists of one or more articles.

Use the Folio Builder panel to create a folio and add articles to that folio.

There are two ways to create articles. One method is to open the InDesign document and use the Add Article option. The other method is to import the article from the folders containing the source files.

  1. In InDesign, open the Folio Builder panel. (The Folio Builder panel is available when you choose Window > Folio Builder.)

    Signing in to the panel is optional
    Signing in to the panel is optional.

    Signing in to the panel is not required. If you don’t sign in, you can create offline folios and preview them on a connected iPad (Mac OS only). One advantage of signing in is that you can upload folios to the Folio Producer server and download them to an iPad or other device by signing in to the Adobe Content Viewer app. If you’re a Professional or Enterprise subscriber, signing in is also required to create folios for a multi-folio viewer app.

    If you have an Adobe ID verified to work with DPS, feel free to sign in.

  2. Use a verified Adobe ID to sign in. For more information about Adobe IDs, see Tutorial Setup.

    We recommend that you use an individual Adobe ID in these tutorials.

  3. In the Folio Builder panel, click Create New Folio to create a new folio, and set the following options. Click OK when you're done.

    • Specify a folio name such as “Pluralist_Summer.” The folio name is for internal reference only; it does not appear in the app.
    • Leave the Viewer Version set at 26.
    • Leave the Target Device as 1024x768.
    • Set the Orientation to landscape. You will create only a horizontal layouts for the articles in the folio.
    • Leave the default format as PDF.
    • Click the folder icons in the Cover Preview section and specify the cover_Pluralist_v.jpg and cover_Pluralist_h.jpg images in the Pluralist_Folio folder.
    Create a new folio
    Create a new folio

  4. Make sure that the cover_h.indd file is open. Save the changes.

  5. In the Folio Builder panel, choose Add Article from the panel menu to create an article. Specify the article name, such as “cover,” and click OK.

  6. In the Folio Builder panel, double-click the “cover” article, or click the arrow to the right of the article to display layout view.

    Notice that only the landscape layout appears.

    Landscape view of the Folio Builder panel
    Landscape view of the Folio Builder panel

Change folio and article properties

The Folio Builder panel includes three views: folio view, article view, and layout view.

  1. Experiment with navigating through the three panel views.

  2. Click the upper left arrow twice to return to folio view. Select the folio, and choose Folio Properties from the Folio Builder panel.

  3. Specify a Publication Name, such as “Pluralist.”

    The Publication Name is different from the Folio Name. The Publication Name is what appears in the viewer. The Folio Name is the internal reference that appears in the Folio Builder panel and in the Folio Producer.

    Folio Properties dialog box
    Folio Properties dialog box.

  4. If you have not already done so, specify images for the Cover Preview (located in the Pluralist_Folio folder), and the click OK.

    The cover preview appears in the viewer library. Cover previews are required to publish the app.

  5. In the Folio Builder panel, double-click the folio to browse to article view. Select the test article and choose Article Properties from the Folio Builder panel menu.

    Notice that the Articles Properties dialog box includes a Title field. The article title appears in the viewer. The article name appears in the Folio Builder panel and in the Folio Producer. When you create links to other articles, use the article name, not the article title.

    Article Properties dialog box
    Article Properties dialog box

  6. Specify the article properties, and click OK.

Import articles

You just created an article by opening the source document and choosing New Article. An alternate method is to import articles. You can import a single article or multiple articles if you use the required folder structure and filenaming conventions. For importing, each article folder should have InDesign documents with _v or _h suffixes to indicate whether they are vertical or horizontal.

When you import an article, point to an article folder. When you import multiple articles, point to a folio folder that contains article subfolders.

Note:

Before you import articles, open the source documents in the TutorialAssets folder to make sure that all the links are updated and the files are saved. See Tutorial setup.

  1. In article view, choose Import Article from the Folio Builder panel menu.

  2. For Article Name, type Meridien Ad.

  3. Click the Location folder icon, and navigate to the TutorialAssets > Meridien_Folio > WiFi_Ad folder. Click Open.

    Importing a single article
    Importing a single article

  4. Click OK to import and upload the article.

    Next, import multiple articles in a folio folder. When you import an entire folio, each subfolder in the folio folder is imported as a separate article.

  5. In article view, choose Import Article from the Folio Builder panel menu.

  6. Select Import Multiple Articles.

  7. Click the Location folder icon, and navigate to the TutorialAssets > CityGuide_Folio. Click Open.

  8. Click OK to import the articles in the folio folder.

    Folio Builder panel after importing articles
    Folio Builder panel after importing articles

    The articles are imported. If your folio folder includes a sidecar.xml file, the article properties are populated.

  9. Navigate to folio view, select the tutorial folio, and click Preview.

If you edit the source document of any article, the changes are not reflected in the preview until you update the article. Select the article, and choose Update from the Folio Builder panel.

Preview content

You can preview articles and folios using either the Desktop Viewer or the Adobe Content Viewer on a mobile device. The Desktop Viewer is a good way to quickly preview a layout, but you want to make sure that you preview on the iPad or other mobile device at some point.

  1. With the cover document open, choose File > Folio Preview.

  2. Exit the Desktop Viewer.

  3. Make sure that you have installed the Adobe Content Viewer app on any device that you want to use for previewing DPS content.

    The Adobe Content Viewer is available in the iOS App Store, the Google Play Store, and the Windows Store. The Adobe Content Viewer is designed for previewing DPS content.

  4. If you have a Mac OS computer, connect your device to your Mac OS computer. Start Adobe Content Viewer on the device.

  5. In the Folio Builder panel, select the Pluralist folio you created, click the Preview option at the button of the panel. Wait a moment for the menu to load, and then choose Preview on [device name].

If you’re using a Windows computer or prefer to preview folios through uploading and downloading, you can sign in to the Folio Builder panel and upload your folio to the Folio Producer. Then sign in to the Adobe Content Viewer on your device using the same Adobe ID you used to sign in to the Folio Builder panel. Make sure that your mobile device is connected to the internet.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy