Creación de botones

Puede crear botones que realicen una acción al exportar el documento a formato EPUB, PDF o SWF. Por ejemplo, puede crear un botón que salte a otra página o abra un sitio Web.

Configuración de los botones para reproducir películas en un PDF exportado

Al crear un botón, puede realizar alguna de las siguientes acciones:

Nota:

Cuando esté trabajando en los botones y diseñando documentos dinámicos, seleccione el espacio de trabajo Interactividad.

Creación de un botón

  1. Use la herramienta Pluma o una herramienta de dibujo, como la herramienta Rectángulo o Elipse para dibujar la forma del botón. Si fuera necesario, use la herramienta Texto para añadir texto al botón como, por ejemplo "Siguiente" o "Comprar".

    Nota:

    Si va a crear botones de navegación (como Página siguiente o Página anterior) para que aparezcan en varias páginas, añádalos a una página maestra y se evitará tener que crearlos en todas las páginas del documento. Estos botones se muestran en todas las páginas del documento a las que se les ha aplicado la página maestra.

  2. Use la herramienta Selección para seleccionar el marco de imagen, forma o texto que desee convertir.

    No ocurre lo mismo con una película, un sonido o un póster.

  3. Haga clic en el icono Convertir el objeto en un botón del panel Botones (elija Ventana > Interactivo > Botones). O elija Objeto > Interactivo > Convertir a botón.
  4. En el panel Botones, lleve a cabo uno de los procedimientos siguientes:
    • En el cuadro de texto Nombre, especifique el nombre del botón para distinguirlo del resto de botones que cree.
    • Especifique una o más acciones para determinar qué ocurre cuando se hace clic sobre el botón en el archivo PDF, SWF o EPUB de maquetación fija exportado. Consulte Crear botones interactivos.
  5. Utilice el panel Previsualización (Ventana > Interactivo > Previsualización de interactividad de EPUB/Vista previa de SWF) para probar el botón antes de exportar el documento al archivo PDF, SWF o EPUB de maquetación fija.

Añadir un botón del panel Botones de muestra

En el panel Botones de muestra se incluyen una serie de botones ya creados que pueden arrastrarse en el documento. Los botones de muestra incluyen efectos como desvanecimientos de degradado o sombras paralelas, con una ligera diferencia para la apariencia Al pasar sobre él. Los botones de muestra también tienen acciones asignadas. Por ejemplo, los botones de dirección de muestra están preconfigurados con las acciones Ir a página siguiente e Ir a página anterior. Puede editar estos botones para adaptarlos a sus necesidades.

El panel Botones de muestra es una biblioteca de objetos. Y tal y como ocurre con cualquier biblioteca de objetos, puede añadir botones al panel y eliminar aquellos que no desee utilizar. (Consulte Uso de bibliotecas de objetos). Los botones de muestra se almacenan en el archivo ButtonLibrary.indl, que se encuentra en la carpeta Presets/Button Library de la carpeta de la aplicación InDesign.

  1. Seleccione Botones de muestra en el menú del panel Botones para abrir el panel Botones de muestra.
  2. Arrastre un botón desde el panel Botones de muestra al documento. Si desea que los botones de navegación aparezcan en todo el documento, añádalos a una página maestra.
  3. Seleccione el botón usando la herramienta Selección y, a continuación, edite el botón como desee utilizando el panel Botones.

Durante la edición de los botones de muestra, tenga en cuenta lo siguiente:

  • Si añade texto a un botón, no olvide copiar y pegar el texto del estado de botón Normal al estado de botón Al pasar sobre él. De lo contrario, el texto que añada no aparecerá cuando el puntero del ratón pase por encima del botón en el archivo PDF, SWF o EPUB de maquetación fija.

  • Puede cambiar el tamaño de los botones. Si arrastra un par de botones de página siguiente/anterior, cambie el tamaño del primer botón, seleccione el segundo botón y elija Objeto > Volver a transformar > Volver a transformar.

Nota:

Pruebe el botón en el panel Previsualización.

Conversión de un botón en un objeto

Al convertir un botón en un objeto, el contenido del botón permanece en la página sin las propiedades del botón. También se elimina cualquier otro contenido asociado al resto de estados del botón.

  1. Use la herramienta Selección para seleccionar el botón.
  2. Elija Objeto > Interactivo > Convertir en objeto.

Crear botones interactivos

En InDesign, se pueden crear, editar y administrar efectos interactivos. Cuando el documento se exporta a PDF, SWF o EPUB de maquetación fija exportado, estas acciones interactivas pueden ser activas.

Por ejemplo, supongamos que desea crear un botón para reproducir un sonido en un documento PDF. Puede colocar el archivo de sonido en un documento de InDesign y crear un botón que reproduzca el sonido al presionarlo en el documento PDF.

En este ejemplo, hacer clic en el botón del ratón es el evento, y la reproducción del sonido es la acción.

Este botón se ha configurado para reproducir un sonido cuando se suelta el botón del ratón

Nota:

algunas acciones se admiten tanto en los archivos PDF como SWF/EPUB y otras solo se admiten en PDF o SWF/EPUB. Cuando seleccione una acción, evite las exclusivas de PDF si solo va a exportar a SWF o a EPUB de maquetación fija. Asimismo, evite elegir una acción exclusiva de SWF/EPUB si va a exportar a PDF.

Añadir acciones a botones

Se pueden asignar acciones a eventos diferentes. Por ejemplo, en un archivo PDF exportado, puede reproducir un sonido cuando el puntero del ratón entra en el área de botón y reproducir una película al hacer clic en el botón del ratón y soltarlo. También puede asignar varias acciones al mismo evento. Por ejemplo, puede crear una acción que reproduzca una película y defina la vista de zoom en Tamaño real.

  1. Use la herramienta Selección  para seleccionar el botón que ha creado.
  2. En el panel Botones, seleccione un evento como Al soltar, que determine el modo de activar las acciones.
  3. Haga clic en el botón de signo más junto a Acciones y seleccione la acción que se va asignar al evento.
  4. Especifique la configuración de la acción.

    Por ejemplo, si selecciona Ir a primera página, especifique el zoom. Si selecciona Ir a URL, especifique la dirección de la página Web. Algunas acciones como Ir a vista siguiente no tienen configuraciones adicionales.

  5. Si fuera necesario, continúe añadiendo tantas acciones como sea necesario para cada evento.

Nota:

Para probar el botón, exporte el documento a PDF, SWF o EPUB de maquetación fija y visualice el archivo exportado. Si va a exportar a PDF, asegúrese de que está seleccionada la opción Elementos interactivos. Si va a exportar a SWF, no olvide seleccionar Incluir botones.

Tipos de evento

Los eventos indican la manera de activar acciones en los botones cuando exporta el documento a PDF, SWF o EPUB. (En Acrobat, los eventos se denominan desencadenadores).

Al soltar

Soltar el botón del ratón tras hacer clic. Este es el evento que más se usa, ya que ofrece al usuario una última oportunidad para arrastrar el cursor fuera del botón y para no activar la acción.

Al hacer clic

Cuando se hace clic en el botón del ratón (sin soltarlo). A menos que tenga una razón concreta para usar Al hacer clic, es preferible usar Al soltar para que los usuarios puedan cancelar el comportamiento.

Al pasar sobre el objeto

El puntero del ratón entra en el área de botón definida por el cuadro delimitador del botón.

Al alejarse del objeto

El puntero del ratón sale del área de botón.

Con foco

Cuando el botón del archivo PDF recibe el foco mediante una acción del ratón o presionando la tecla Tabulación.

Sin foco

Cuando mueve el foco a un botón o campo de formulario diferente en el archivo PDF.

Tipos de acciones

Al crear una acción, se indica qué ocurre cuando el evento especificado se produce (normalmente cuando alguien hace clic en el botón). Puede definir que se produzcan las acciones siguientes al activar el tipo de evento:

Ir a destino

Salta al anclaje de texto especificado en el panel Marcadores o Hipervínculos. Consulte Creación de saltos a anclajes de texto.

Ir a la primera/última/siguiente/anterior página

Salta a la primera, última, siguiente o anterior página del archivo PDF, SWF o EPUB de maquetación fija. Seleccione una opción del menú Zoom para determinar cómo se mostrará la página.

Ir a URL

Abre la página web de la URL especificada.

Mostrar/Ocultar botones

Muestra u oculta los botones especificados en el archivo PDF, SWF o EPUB de maquetación fija exportado. Por ejemplo, si desea que un botón aparezca cuando se pasa el ratón sobre otro, puede ocultar el botón de destino hasta que se active y crear una acción que muestre el botón oculto cuando se pase sobre él. Consulte Mostrar otro botón al pasar sobre él.

Vídeo

Permite reproducir, pausar, detener o reanudar una película. Sólo las películas añadidas al documento aparecen en el menú de vídeo.

Sonido

Permite reproducir, pausar, detener o reanudar el clip de sonido seleccionado. Sólo los clips de sonido añadidos al documento aparecen en el menú Sonido.

Animación (SWF/EPUB)

Permite reproducir, pausar, detener o reanudar una animación. Sólo las animaciones añadidas al documento aparecen en el menú Animación.

Ir a página (SWF/EPUB)

Salta a la página del archivo SWF que especifique.

Ir a estado (SWF/EPUB)

Salta a un estado específico de un objeto de varios estados. Por ejemplo, si un objeto de varios estados incluye diferentes imágenes como estados, puede usar esta acción para visualizar una imagen concreta.

Ir al siguiente estado/Ir al estado anterior (SWF/EPUB)

Salta al estado anterior o siguiente de un objeto de varios estados. Estas opciones son muy útiles para hacer clic en una proyección de diapositivas. Consulte Creación de objetos de varios estados.

Ir a vista siguiente (PDF)

Salta a una página después de haber ido a la vista anterior. Al igual que el botón Adelante sólo está disponible en un explorador Web tras hacer clic en el botón Atrás, esta opción está disponible sólo si el usuario ha saltado a una vista anterior.

Ir a vista anterior (PDF)

Salta a la última página consultada del documento PDF o vuelve al último tamaño de zoom utilizado.

Abrir archivo (PDF)

Inicia y abre el archivo especificado. Si especifica un archivo que no sea PDF, el lector necesitará la aplicación nativa para abrirlo correctamente. Especifique una ruta de acceso absoluta (como C:\docs\sample.pdf).

Ver zoom (PDF)

Muestra la página según la opción de zoom especificada. Puede cambiar el nivel de zoom de la página (como el Tamaño real), la composición de página (como Continua - páginas opuestas) o la orientación de la rotación.

Editar o borrar acciones de botón

  1. Use la herramienta Selección para seleccionar el botón.
  2. En el panel Botones, lleve a cabo uno de los procedimientos siguientes:
    • Para desactivar acciones, quite la selección de la casilla de verificación situada junto al elemento. La desactivación de eventos y acciones puede ser útil para realizar pruebas.
    • Para cambiar el orden, arrastre y suelte acciones.
    • Para borrar una acción, selecciónela del cuadro de lista y haga clic en el botón Eliminar la acción seleccionada .
    • Para editar una acción, elija el evento al que se asigna la acción, seleccione la acción del cuadro de lista y cambie la configuración. Si tiene que sustituir la acción de un evento existente, elimínelo y añada una acción nueva.

Creación de saltos a anclajes de texto

Si crea un anclaje de texto en un documento de InDesign, puede configurar un botón para que salte hasta dicho anclaje, incluso si está en otro documento de InDesign. Use los paneles Marcadores e Hipervínculos para añadir anclajes de texto. No puede crear saltos de botones a marcadores que no sean anclajes de texto.

Nota:

si define un destino de hipervínculo en un botón, el hipervínculo no afectará al documento PDF, SWF o EPUB de maquetación fija exportado.

  1. Use la herramienta Selección para seleccionar el botón.
  2. En el panel Botones, seleccione el evento que activará el salto (Al soltar, por ejemplo).
  3. Haga clic en el signo más que hay junto a Acciones y seleccione Ir a destino.
  4. Seleccione uno de los documentos abiertos de InDesign del menú Documentos o haga clic en el icono de carpeta situado a la derecha del menú y especifique el archivo.
  5. Especifique un anclaje creado mediante el panel Marcadores o el panel Hipervínculos.
  6. Seleccione una opción del menú Zoom para determinar cómo se mostrará la página.

Nota:

si especifica un anclaje en otro documento, recuerde que debe exportar dicho documento de destino a PDF y que debe usar el mismo nombre de archivo que el documento de InDesign, sustituyendo la extensión INDD por PDF. Guarde los documentos PDF en la misma carpeta para que los vínculos sigan siendo válidos en Acrobat y Acrobat Reader.

Cambio de la apariencia del botón al pasar y hacer clic sobre él

Un botón se compone de un grupo de objetos individuales que representan, cada uno, una apariencia de botón (a menudo designada "estado"). Cada botón puede tener hasta tres apariencias: Normal, Al pasar sobre él y Clic. En el archivo exportado, se utiliza la apariencia Normal siempre que el puntero del ratón no se desplace hasta el área (Al pasar sobre él) ni se haga clic en el área del botón (Clic). Puede diferenciar las apariencias para que tengan una representación visual.

Por defecto, cualquier botón que cree se define con la apariencia Normal y contiene el texto o la imagen del botón. Cuando activa una apariencia nueva, se copia la apariencia Normal. Para distinguir una apariencia del resto, puede cambiar el color o añadir texto o imágenes.

Estados de un botón

A. El puntero no está sobre el área del botón (Normal). B. El puntero entra en el área del botón (Rollover) C. El puntero hace clic (Clic) 

Nota:

el área del botón en la que se puede hacer clic (segmento de trazado) viene determinada por el cuadro delimitador del estado de botón más grande. Por ejemplo, un botón redondo posee un segmento de trazado cuadrangular.

Cambio de las apariencias del botón

Si va crear un botón con varias apariencias (Normal, Al pasar sobre él y Clic), es recomendable terminar de diseñar el botón antes de activar otras apariencias. Si activa la apariencia Al pasar sobre él o Clic, se copia la apariencia Normal.

Algunos cambios afectan únicamente a las apariencias seleccionadas, mientras que otros afectan a todas las activas. Si selecciona una apariencia y aplica un color de fondo diferente o edita el texto, el cambio afecta sólo a la apariencia seleccionada. Si utiliza la herramienta Selección para mover o cambiar el tamaño del botón, el cambio afecta a todas las apariencias.

  1. Elija Ventana > Interactivo > Botones para mostrar el panel Botones.
  2. Con la herramienta Selección , seleccione el botón de la maquetación que desee editar.
  3. Haga clic en [Al pasar sobre él] para activar la apariencia Al pasar sobre él.

    La apariencia Normal se copia en Al pasar sobre él.

  4. Con Al pasar sobre él todavía seleccionado, cambie el aspecto del botón.
    • Para cambiar el color, en el panel Control, en el menú Trazo o Relleno, elija una muestra.
    • Para colocar una imagen en la apariencia, seleccione la imagen existente con la herramienta Selección directa o haga doble clic en la imagen de botón existente y, a continuación, seleccione Archivo > Colocar y haga doble clic en el archivo.
    • Para pegar una imagen en un marco de texto, cópiela en el Portapapeles, seleccione la apariencia en el panel Botones y elija Edición > Pegar dentro.
    • Para introducir texto, seleccione la herramienta Texto, haga clic en el botón y escriba el texto. También puede seleccionar Edición > Pegar dentro para copiar un marco de texto pegado.
  5. Para añadir la apariencia Clic, haga clic en [Clic] para activarla y siga el mismo procedimiento para modificarla.
  6. Pruebe las diferentes apariencias del botón en el panel Previsualización.

Nota:

Para modificar el tamaño de las miniaturas Apariencia de estado en el panel Botones, seleccione Opciones de panel en el menú del panel Botones, seleccione una opción y haga clic en OK.

Eliminación y desactivación de apariencias

  1. Seleccione la apariencia en el panel Botones.
  2. Lleve a cabo una de las siguientes acciones:
    • Para eliminar la apariencia Al pasar sobre él o Clic, haga clic sobre el icono de eliminar situado en la parte inferior del panel. La eliminación de una apariencia resulta especialmente útil si aplica numerosos cambios a la apariencia Normal y le interesa basar las apariencias Al pasar sobre él o Clic en la nueva apariencia Normal.
    • Para desactivar una apariencia sin eliminarla, haga clic en el icono de ojo junto a la apariencia para anular su selección. Los estados que estén desactivados no se exportan a los archivos PDF, SWF o EPUB de maquetación fija.

Nota:

no es posible eliminar o desactivar el estado Normal.

Creación de objetos de varios estados

Cree varias versiones de un objeto en el panel Estados de objeto. Un estado es una versión de un elemento de página. Un objeto que incluye varios estados se denomina objeto de varios estados.

Con el panel Estados de objeto, no hay límite para el número de estados que puede crear. Cada vez que cree un estado, se genera otra versión del elemento de página. En la página sólo habrá visible un estado. Para imprimir y exportar a PDF, sólo aparece el estado activo en el resultado final.

Creación de una proyección de diapositivas de objetos de varios estados

Uno de los usos más habituales de un objeto de varios estados es una proyección de diapositivas que permita a los que vean un archivo SWF hacer clic en un conjunto de imágenes. Por ejemplo, puede crear una proyección de diapositivas de 20 imágenes sin tener que colocar las imágenes en 20 páginas diferentes.

  1. Coloque las imágenes que aparecerán en la proyección de diapositivas.

    Para obtener los mejores resultados, asegúrese de que los marcos de imagen son del mismo tamaño.

    Un estado no tiene que ser un sólo elemento, puede ser una colección de elementos.

  2. Para apilar imágenes, selecciónelas y, en el panel Control, haga clic en Alinear centros horizontales y Alinear centros verticales .

  3. Con las imágenes seleccionadas, abra el panel Estados (Ventana > Interactivo > Estados de objeto) y haga clic en el botón Convertir selección en objeto de varios estados .

    La imagen aparece como estados en el panel Estados de objeto, y un marco discontinuo rodea las imágenes seleccionadas.

  4. Cree botones de navegación que activen las acciones Ir al estado siguiente e Ir al estado anterior cuando se suelte el botón del ratón. Consulte Creación de botones.

  5. Utilice el panel Previsualización (Ventana > Interactivo > Previsualización de interactividad de EPUB/Vista previa de SWF) para probar los botones de navegación.

  6. Exporte el documento a formato SWF. Consulte Documentos interactivos.

Edición de un objeto de varios estados

  1. Seleccione un objeto de varios estados.

  2. En el panel Estados de objeto, lleve a cabo uno de los procedimientos siguientes:

    • Para editar un estado, selecciónelo en el panel Estados de objeto y, a continuación, edítelo. Por ejemplo, puede añadir un trazado o relleno o cambiar el tamaño del objeto.

    • Para añadir un objeto a un estado existente, seleccione el objeto y el objeto de varios estados, a continuación, haga clic en el botón Añadir objetos a estado visible .

    • Para añadir un objeto a un objeto de varios estados, seleccione el objeto y el estado de varios estados y, a continuación, haga clic en el botón Convertir selección en objeto de varios estados .

    • Para duplicar un estado, seleccione un estado que sirva de base para el estado nuevo y elija Nuevo estado en el menú del panel. Añada, quite o edite el contenido del estado.

    • Para pegar objetos en un estado existente, corte o copie uno o varios objetos, seleccione el estado de varios objetos, seleccione el estado en el panel Estados de objeto y, en el menú del panel, elija Pegar en estado.

    • Para volver a convertir un objeto de varios estados en un conjunto de objetos independientes, seleccione el estado en el panel Estados de objeto y, en el menú del panel, seleccione Liberar estado en objetos. Para convertir en objetos todos los estados del objeto de varios estados, seleccione Liberar todos los estados en objetos.

    • Para eliminar un estado y quitar su contenido, seleccione el estado y, en el menú del panel, seleccione Eliminar estado.

    • Para ocultar el estado de varios objetos en el archivo exportado hasta que se active con un botón, en el menú del panel, elija Oculto hasta activación.

    • Para restaurar al primer estado todos los objetos de varios estados del documento, en el menú del panel, seleccione Restaurar todos los objetos de varios objetos al primer estado. Cuando selecciona un estado, el objeto permanece en ese estado, incluso si cierra y vuelve a abrir el documento. Esta opción es un método rápido para restaurar todos los objetos de varios estados.

Creación de zonas interactivas de botones

En algunos casos, puede preferir que el área de botón (llamada "segmento o vínculo de trazado") permanezca invisible hasta que se sitúe sobre ella el puntero del ratón. Por ejemplo, cuando desplaza el puntero sobre un botón en un mapa, puede mostrarse una imagen que represente una región y, al retirar el puntero de dicha zona, la imagen desaparece.

En el archivo PDF exportado, la imagen aparece al mantener el puntero sobre un segmento de trazado

Mostrar una imagen oculta al pasar sobre ella

Un método para conseguir un segmento de trazado es aplicar una imagen al estado Al pasar sobre él en el panel Botones. Para ello, cree un botón con un estado [Al pasar sobre él] que visualice una imagen y un estado [Normal] que no la visualice.

  1. Seleccione la imagen que desea usar como segmento de trazado. Compruebe que el marco de la imagen no tiene ningún borde ni fondo.

  2. En el panel Botones (elija Ventana > Interactivo > Botones), haga clic en la apariencia [Normal] para convertir la imagen seleccionada en un botón.

  3. En el panel Botones, haga clic en la apariencia [Al pasar sobre él] para activarla.

  4. Vuelva a hacer clic en la apariencia [Normal]. A continuación, seleccione la imagen con la herramienta Selección directa y elimínela.

    Compruebe que elimina la imagen (el contenido del marco), no el marco ni el contenido. Eliminar el marco elimina todo el botón.

  5. Previsualice el efecto de segmento trazado en el panel Previsualización.

Mostrar otro botón al pasar sobre él

Puede crear un segmento de trazado para que cuando haga clic o pase el ratón sobre él se visualice otro objeto. Para ello, cree dos botones, oculte uno y use la acción Mostrar/Ocultar botón para mostrar y ocultar el botón de destino.

  1. Cree un objeto para que se utilice como botón de origen. En el panel Botones, haga clic en el icono Convertir el objeto en un botón.
  2. Coloque la imagen que desea usar como botón de destino y conviértala en un botón.
  3. Seleccione la imagen de destino y, en la parte inferior del panel Botones, seleccione Oculto hasta activación.

    La imagen tiene que estar oculta en el documento exportado para que se pueda visualizar cuando se pase el ratón sobre el botón de origen o se haga clic en él.

  4. Seleccione el botón de origen y cree dos acciones diferentes, una para mostrar la imagen de destino y una segunda para ocultarla.

    Si desea que la imagen se muestre cuando el ratón se pase sobre el botón de origen, use los eventos Al pasar sobre él y Al alejarse del objeto. Si desea que la imagen aparezca al hacer clic en el botón de origen y desaparezca cuando se suelte, use los eventos Al hacer clic y Al soltar. En cualquier caso, use la acción Mostrar/ocultar botones para visualizar y ocultar el botón de destino. Consulte Crear botones interactivos.

  5. Pruebe los botones en el panel Previsualización.

Cambio de opciones de PDF para los botones

  1. Use la herramienta Selección para seleccionar el botón.
  2. En el menú del panel Botones, elija Opciones de PDF.
  3. Escriba una descripción que actúe como texto alternativo para los usuarios con problemas visuales.
  4. Indique si el botón se debe imprimir en el archivo PDF y haga clic en OK.

Definición del orden de tabulación de los botones

El orden de tabulación determina el campo siguiente (o el anterior) que se resaltará cuando un usuario presione Tab (o Mayús+Tab) en el documento PDF o SWF. El orden de tabulación incluye botones en capas ocultas, pero no incluye botones en páginas maestras.

  1. Vaya a la página que contiene los botones.
  2. Elija Objeto > Interactivo > Definir orden de tabulador.
  3. Seleccione cada botón que desee mover y arrástrelo a la nueva posición, o haga clic en los botones Mover hacia arriba o Mover hacia abajo. Cuando haya terminado, haga clic en Aceptar.

Si usa Acrobat para editar el PDF y añadir más botones o campos de formulario a la página, quizás deba especificar un nuevo orden en Acrobat.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea