Boletín de seguridad de Adobe

Actualizaciones de seguridad disponibles para Adobe After Effects | APSB21-54

ID del boletín

Fecha de publicación

Prioridad

ASPB21-54

20 de julio de 2021

3

Resumen

Adobe ha publicado una actualización de Adobe After Effects para Windows y macOS.Esta actualización soluciona varias vulnerabilidades críticas y moderadas. Esta vulnerabilidad podría dar lugar a la Ejecución de código arbitraria en el contexto del usuario actual.           

Versiones afectadas

Producto

Versión

Plataforma

Adobe After Effects

18.2.1 y versiones anteriores       

Windows

Solución

Adobe categoriza estas actualizaciones de acuerdo con las siguientes clasificaciones de prioridad y recomienda a los usuarios que actualicen su instalación a la versión más reciente a través del mecanismo de actualización de aplicación de escritorio de Creative Cloud. Para obtener más información, consulte esta página de ayuda.

Producto

Versión

Plataforma

Nivel de prioridad

Disponibilidad

Adobe After Effects

18.4

Windows y macOS

3

Adobe After Effects

17.7.1

Windows y macOS

3

En entornos administrados, los administradores de TI pueden utilizar la Admin Console para implementar aplicaciones de Creative Cloud a los usuarios finales. Consulte esta página de ayuda para obtener más información.

Nota:

CVE-2021-35996 se ha resuelto en Adobe After Effects 18.4 y versiones posteriores.

Detalles sobre la vulnerabilidad

Categoría de vulnerabilidad

Impacto de la vulnerabilidad

Gravedad

CVSS base score 

Números CVE

Out-of-bounds Read (CWE-125)

Arbitrary file system read

Moderate

3.3

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

CVE-2021-36018

CVE-2021-36019

Access of Memory Location After End of Buffer

(CWE-788)

Arbitrary code execution 

Critical 

7.8

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2021-36017

Out-of-bounds Write (CWE-787)

Arbitrary code execution 

Critical 

7.8

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2021-35993

CVE-2021-35994

Improper Input Validation

(CWE-20)

Arbitrary code execution 

Critical 

7.8

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2021-35995

Access of Memory Location After End of Buffer

(CWE-788)

Arbitrary code execution 

Critical 

8.8

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2021-35996

Reconocimientos

Adobe desea dar las gracias a las siguientes personas por informar sobre estos problemas y por colaborar con Adobe para ayudarnos a proteger la seguridad de nuestros clientes:   

  • CQY del equipo de Topsec Alpha (yjdfy) (CVE-2021-35996)
  • Mat Powell (@mrpowell) y Joshua Smith (@kernelsmith) de Trend Micro Zero Day Initiative (CVE-2021-35994, CVE-2021-35993)
  • Mat Powell de Trend Micro Zero Day Initiative (CVE-2021-36016, CVE-2021-36014, CVE-2021-36015)
  • Qiao Li de Baidu Security Lab en colaboración con Trend Micro Zero Day Initiative (CVE-2021-36019)

Revisiones

03 de agosto de 2021: Se actualizaron los agradecimientos para CVE-2021-35993

15 de octubre de 2021: se añadió una fila para la versión N-1.




For more information, visit https://helpx.adobe.com/security.html, or email PSIRT@adobe.com.

 Adobe

Obtén ayuda de forma más rápida y sencilla

¿Nuevo usuario?