Katso lisätietoja ja ohjeita napsauttamalla seuraavia linkkejä.

Rakenne-ruudun yleiskuvaus

Rakenne-ruutu näyttää hierarkkisessa muodossa julkaisun kohteet, jotka on merkitty XML-nimiöillä. Näitä kohteita sanotaan elementeiksi. Voit siirtää elementtejä Rakenne-ruudussa, kun haluat määrittää kohteiden järjestyksen ja hierarkian. Elementtiin kuuluu elementin tyypin ilmaiseva kuvake ja nimiön nimi.

Rakenne-ruutu
Rakenne-ruutu

A. Kolmio elementtien laajentamiseen tai kutistamiseen B. Elementti C. Tekstikatkelma D. Määrite 

Elementeissä voi olla myös seuraavat tiedot:

Sininen vinoneliö

Sininen vinoneliö elementin kuvakkeessa tarkoittaa, että elementti on liitetty sivun kohteeseen. Ellei sinistä vinoneliötä ole, elementtiä ei ole liitetty sivun kohteeseen.

Alleviivaus

Nimiön nimi on alleviivattu, jos sivun se kohde, jota elementti vastaa, on valittu. Jos esimerkiksi valitset tekstin, johon olet liittänyt Otsikko-nimiön, tekstin elementin sana Otsikko näkyy alleviivattuna Rakenne-ruudussa. Alleviivaus ilmaisee, vastaavatko sivulta valitut kohteet ja Rakenne-ruudun elementit toisiaan.

Tekstikatkelma

Elementin oikealla puolella voi näkyä nimiöidyn tekstin 32 ensimmäistä merkkiä. Niitä sanotaan tekstikatkelmaksi. Tekstikatkelmat helpottavat sivun sen kohteen tunnistamista, jota elementti vastaa.

Piste ja määrite

Määritteet sisältävät elementtiä koskevia metatietoja. Jos määritteet on liitetty elementtiin, elementin alapuolella näkyy musta piste sekä määritteiden nimet ja arvot.

Rakenne-ruudun käyttäminen

  • Avaa Rakenne-ruutu valitsemalla Näytä > Rakenne > Näytä rakenne.
  • Voit sulkea Rakenne-ruudun valitsemalla Näytä > Rakenne > Kätke rakenne tai napsauttamalla jakopainiketta.
  • Voit laajentaa tai kutistaa elementin (ja näyttää tai kätkeä sen alielementit) napsauttamalla sen vieressä olevaa kolmiota.
  • Voit muuttaa Rakenne-ruudun kokoa vetämällä jakopainiketta.
  • Jos haluat laajentaa tai kutistaa elementin ja kaikki sen sisältämät elementit, pidä Ctrl-näppäintä (Windows) tai komentonäppäintä (Mac OS) painettuna ja napsauta elementin vieressä olevaa kolmiota.
  • Jos haluat näyttää tai kätkeä tekstikatkelmat, valitse Rakenne-ruudun valikosta Näytä tekstikatkelmat tai Kätke tekstikatkelmat.

Rakenne-ruudun kuvakkeet

Seuraavat kuvakkeet tulevat näkyviin Rakenne-ruutuun:

Kuvake

Nimi

Käytä

 

Pääelementti

Kussakin julkaisussa on vain yksi pääelementti, jonka voi nimetä uudelleen mutta jota ei voi siirtää tai poistaa.

 

Juttuelementti

Viittaa nimiöityihin juttuihin (vähintään yksi linkitetty kehys).

 

Tekstielementti

Viittaa tekstikehyksessä olevaan nimiöityyn tekstiin

 

Grafiikkaelementti

Viittaa nimiöityyn kehykseen, jossa on sijoitettu kuva. Jokaisessa grafiikkaelementissä on href-määrite, joka määrittää linkitetyn tiedoston polun tai URL-osoitteen.

 

Sijoittamaton tekstielementti

Sijoittamaton tekstielementti, jota ei ole vielä liitetty sivun kohteeseen.

 

Sijoittamaton grafiikkaelementti

Sijoittamaton grafiikkaelementti, jota ei ole vielä liitetty sivun kohteeseen.

 

Taulukkoelementti

Edustaa taulukkoa.

 

Ylätunnisteen soluelementti

Edustaa taulukon ylätunnisterivillä olevaa solua.

 

Leipätekstin soluelementti

Edustaa taulukon leipätekstissä olevaa solua.

 

Alatunnisteen soluelementti

Edustaa taulukon alatunnisterivillä olevaa solua.

 

Tyhjä elementti

Tähän elementtiin on liitetty tyhjä kehys.

 

Määrite

Sisältää metatietoja, esimerkiksi avainsanoja tai linkitetyn kuvan sijainnin (HREF-määritteen).

 

Kommentti

Sisältää kommentteja, jotka näkyvät XML-tiedostossa, mutta eivät InDesign-julkaisussa.

 

Käsittelyohje

Sisältää ohjeen, joka laukaisee toiminnon sovelluksissa, jotka voivat lukea käsittelyohjetta.

 

DOCTYPE-elementti

Kertoo InDesignille, mitä DTD-tiedostoa XML-tiedoston vahvistamisessa käytetään.

Rakenteisten elementtien järjestäminen uudelleen

Voit muuttaa Rakenne-ruudun elementtien järjestystä ja hierarkkista asemaa. Noudata kuitenkin seuraavia sääntöjä:

  • XML-tiedoston rakenteen ylimmällä tasolla pitää olla yksi pääelementti. Kaikki muut elementit ovat pääelementin alaisuudessa. Rakenne-ruudussa saa olla pääelementin yläpuolella ainoastaan DTD-tiedosto (näkyy DOCTYPE-elementtinä), kommentteja ja käsittelyohjeita.

  • XML-hierarkian rakenteen muutokset voivat vaikuttaa nimiöityjen kohteiden ulkoasuun InDesign-sivuilla. Jos esimerkiksi tekstielementistä tehdään rakenteen jonkin toisen elementin alielementti, teksti siirtyy sivuasettelussa.

  • Taulukkosoluelementtiä ei voi vetää taulukkoelementtiin eikä taulukkoelementtiin voi vetää elementtejä.

  1. Tee Rakenne-ruudussa yksi seuraavista toimista:
    • Jos haluat siirtää elementtiä, vedä se uuteen paikkaan rakenteessa. Näyttöön ilmestyy vetäessäsi viiva, joka ilmaisee, mihin olet lisäämässä elementtiä. Viivan paksuus on merkkinä hierarkian sisäisestä tasosta.

    • Jos haluat tehdä elementistä jonkin toisen elementin alielementin, sijoita se yläelementin päälle (kunnes se korostuu) tai yläelementin muiden alielementtien joukkoon ja vapauta hiiren painike.

    • Jos haluat siirtää elementin hierarkiassa yhden tason alemmaksi, vedä elementti toisen yläelementin yläpuolelle ja liikuta hiirtä kevyesti vasemmalle, kunnes sijoittelua ilmaiseva viiva kattaa yläelementin leveyden.

    • Jos haluat kopioida tai leikata elementtejä, valitse elementit Rakenne-ruudusta ja valitse sitten Muokkaa > Kopioi tai Muokkaa > Leikkaa. Valitse elementti sen kohdan yläpuolelta, johon haluat lisätä elementin, ja valitse Muokkaa > Liitä.

Huomautus:

jos leikkaat elementin, elementti ja sisältö leikataan leikepöydälle, mutta kehys säilyy ennallaan.

Yläelementin lisääminen

Lisää Rakenne-ruutuun yläelementti, kun haluat säilyttää oikean XML-rakenteen tai järjestää sisällön paremmin. Ennen kuin voit lisätä uuden yläelementin, sinun täytyy valita elementit, joista tulee sen alielementtejä. Kun uusi yläelementti on lisätty, valitut alielementit siirtyvät yhden tason verran alemmas rakennehierarkiassa.

Rakenne-ruudun yläelementti
Alaelementit valittuina (vasemmalla): uusi lisätty yläelementti sisältää alaelementit (oikealla).

Rakenne-ruudun yläelementti
Alaelementit valittuina (vasemmalla): uusi lisätty yläelementti sisältää alaelementit (oikealla).

  1. Valitse Rakenne-ruudusta elementit, joista tulee uuden yläelementin alielementtejä. Pidä mielessä seuraavat:

    • Et voi valita Juurta eli päätason elementtiä.

    • Et voi valita Juttua eli juttutason elementtiä.

    • Elementtien on oltava samalla tasolla rakennehierarkiassa.

    • Elementtien on oltava peräkkäisiä.

    • Valinta ei saa sisältää taulukon soluja tai määritteitä.

  2. Valitse Rakenne-paneelin valikosta Uusi yläelementti tai napsauta kohdetta hiiren kakkospainikkeella (Windows) tai Ctrl-näppäin alhaalla (Mac OS) ja valitse Uusi yläelementti.

  3. Valitse uudelle yläelementille nimiö ja napsauta OK-painiketta.

Huomautus:

Voit lisätä uuden yläelementin nopeasti valitsemalla Nimiöt-paneelista Lisää nimiö ja napsauttamalla sitten paneelissa näkyvää nimiötä. Voit myös napsauttaa hiiren kakkospainikkeella (Windows) tai osoittaa Ctrl-näppäin alhaalla (Mac OS) Rakenne-ruudusta valitsemaasi elementtiä, valita Uusi yläelementti ja valita sitten elementin.

Määritteiden käsitteleminen

Määrite sisältää lisätietoja XML-elementistä. Kukin määrite sisältää nimen ja arvon. Määritteet näkyvät Rakenne-ruudussa. Niitä ei sijoiteta julkaisuun eikä käytetä julkaisun sisältönä. Lisää elementteihin määritteitä niitä tiedostoja ja sovelluksia varten, jotka käyttävät InDesignilla luomiasi XML-tiedostoja.

Kun nimiöit kuvan, InDesign luo automaattisesti href-määritteen, jonka arvo ilmaisee kuvatiedoston sijainnin levyllä. Tämän href-määritteen avulla muut tiedostot ja sovellukset pystyvät löytämään kuvan levyltä näyttämistä varten.

Määritteet
Määritteessä on nimi (tässä tapauksessa href) ja arvo.

Voit lisätä määritteitä kaikkiin elementteihin, paitsi DOCTYPE-elementtiin (DTD-tiedosto), kommentteihin tai käsittelyohjeisiin. Jos esimerkiksi haluat sisällyttää avainsanoja työnkulun seuraavalla sovelluksella etsittäväksi, voit luoda määritteen nimeltä avainsanat. Voit luoda määritteitä myös osoittamaan korvattua tekstiä, artikkelien otsikoita ja muita XML-sisältöön liittyviä tietoja.

Huomautus:

Jos käytät DTD-tiedostoa, tutki sen sisältöä, jotta näet, mitkä määritteet se sallii. Määritteiden nimien täytyy noudattaa DTD-tiedostoa samalla tavoin kuin nimiöiden nimien.

Huomautus:

InDesign tunnistaa erityiset nimiavaruusmääritteet, jotka voivat määrittää kappale- tai merkkityylejä, taulukko- ja taulukkosolutyylejä sekä ohjata tyhjiä tiloja. Lisätietoja on teknisessä XML-viiteoppaassa.

Lisää määrite

  1. Valitse elementti.
  2. Tee jokin seuraavista:
    • Napsauta Lisää määrite -painiketta .

    • Valitse Rakenne-ruudun valikosta Uusi määrite.

    • Napsauta hiiren kakkospainikkeella (Windows) tai osoita Ctrl-näppäin alhaalla (Mac OS) valittua elementtiä ja valitse Uusi määrite.

  3. Anna määritteelle nimi ja arvo ja napsauta sitten OK-painiketta.

Määritteiden näyttäminen tai kätkeminen Rakenne-ruudussa

  1. Valitse Rakenne-ruudun valikosta Näytä määritteet tai Kätke määritteet.

    Sinun pitää ehkä napsauttaa elementin vieressä olevaa kolmiokuvaketta, jotta näet elementin määritteet.

Määritteen muokkaaminen ja poistaminen

  1. Valitse Rakenne-ruudusta määrite.
  2. Tee jokin seuraavista:
    • Jos haluat muokata määritettä, kaksoisnapsauta sitä tai valitse Rakenne-ruudun valikosta Muokkaa.

    • Jos haluat poistaa määritteen, napsauta Poista-painiketta tai valitse Rakenne-ruudun valikosta Poista.

Href-määritteiden muokkaaminen

InDesign luo automaattisesti href-määritteitä kuvatiedostojen käsittelyä varten. Href-määrite ilmaisee kuvatiedoston sijainnin levyllä, jota kuvatiedosto voidaan näyttää. Kun nimiöit sijoitetun kuvan, InDesign luo href-määritearvon, joka sisältää kuvatiedoston polun ja tiedostonimen.

Reitti voi olla suora linkki, suhteellinen linkki samaan kansioon, jossa XML-tiedosto sijaitsee, tai suhteellinen linkki XML-tiedoston sisältävän kansion Kuvat-alikansioon. Suhteelliset polut vaihtelevat sen mukaan, mihin julkaisu on tallennettu.

  • Suoran linkin sisältävä href-määrite näyttää tällaiselta (Windowsissa ja Mac OS:ssä):

    href=file:///C:/Kuvat/Niitty.psd

    href=file:///Users/abhayc//Desktop/abc.jpg

  • Href-määrite, joka tarkoittaa XML-tiedoston kanssa samassa kansiossa sijaitsevaa kuvatiedostoa, näyttää tällaiselta:

    href=file:Niitty.psd

  • Href-määrite, joka tarkoittaa Kuvat-alikansiossa olevaa kuvatiedostoa, näyttää tällaiselta:

    href=file:///Kuvat/Niitty.psd

Voit määrittää uuden linkin kuvaan muokkaamalla href-määritettä. Voit myös muuttaa suoran linkin suhteelliseksi linkiksi, jotta kuvatiedosto on käytettävissä tiedostoja siirrettäessä.

  1. Kaksoisnapsauta Rakenne-ruudussa näkyvää href-määritettä. (Sinun on ehkä myös napsautettava kuvaelementin vieressä olevaa kolmiokuvaketta nähdäksesi määritteen.)
  2. Kirjoita arvoksi kuvan uusi polku ja napsauta sitten OK-painiketta.

Kommenttien ja käsittelyohjeiden lisääminen

InDesignilla voit lisätä XML-tiedostoon kommentteja ja käsittelyohjeita. Kirjoita kommentti, joka sisältää elementin kuvauksen. Kommentteja voidaan katsella Web-selaimilla ja tekstieditoreilla. Ne auttavat muita ymmärtämään XML-rakenteen ja XML-nimiöt. Käsittelyohje on sovelluskohtainen erikoiskomento. Voit esimerkiksi lisätä sivunvaihto-ohjeen, jotta sovellus, johon XML-tiedosto viedään, osaa sijoittaa sivunvaihdon oikeaan paikkaan. InDesignin käyttäjän luomat käsittelyohjeet on tarkoitettu muissa ohjelmissa käytettäviksi; InDesign itse ei toimi niiden mukaan.

Kommentit ja käsittelyohjeet näkyvät Rakenne-ruudussa. Voit siirtää, muokata ja poistaa kommentteja ja käsittelyohjeita samalla tavoin kuin muitakin Rakenne-ruudun elementtejä. Ne eivät voi kuitenkaan sisältää alielementtejä tai määritteitä.

InDesignin Rakenne-ruutu, jossa näkyy tekstikatkelmia
InDesignin Rakenne-ruutu, jossa näkyy tekstikatkelmia

A. Käsittelyohje B. Kommentti 

Kommentin lisääminen

  1. Valitse elementti, johon haluat lisätä kommentin.

    Huomautus:

    Jos haluat lisätä kommentin taulukkoon, valitse taulukkosoluelementti. Kommentteja voi lisätä taulukkosoluihin mutta ei taulukkoihin.

  2. Valitse Rakenne-ruudun valikosta Uusi elementti.
  3. Kirjoita kommentti Uusi kommentti -valintaikkunaan.

Käsittelyohjeen lisääminen

  1. Valitse elementti käsittelyohjetta varten.

    Huomautus:

    Jos haluat lisätä käsittelyohjeen taulukkoon, valitse taulukkosoluelementti. Käsittelyohjeita voi lisätä taulukkosoluihin mutta ei taulukkoihin.

  2. Valitse Rakenne-ruudun valikosta Uusi käsittelyohje.
  3. Kirjoita Kohde-ruutuun nimi, josta vietyä XML-tiedostoa lukeva sovellus tunnistaa käsittelyohjeen.
  4. Kirjoita Tiedot-ruutuun arvo, joka kertoo sovellukselle, mitä käsittelyohjeelle tehdään.

Kommenttien ja käsittelyohjeiden tarkasteleminen

  1. Valitse Rakenne-ruudun valikosta Näytä kommentit tai Näytä käsittelyohjeet.

Kommenttien ja käsittelyohjeiden muokkaaminen

  1. Valitse kommentti tai käsittelyohje.
  2. Tee jokin seuraavista toimista:
    • Kaksoisnapsauta kommenttia tai käsittelyohjetta.

    • Valitse Rakenne-ruudun valikosta Muokkaa.

  3. Muokkaa kommenttia tai käsittelyohjetta ja napsauta sitten OK-painiketta.

XML-sisällön vahvistaminen DTD-tiedostojen avulla

Julkaisun XML-sisällön vahvistaminen tarkoittaa rakenteen, elementtinimiöiden nimien ja määritteiden vertaamista DTD-tiedoston määrityksiin. DTD-tiedosto täytyy ladata julkaisuun, jotta sitä voitaisiin käyttää vahvistamisessa InDesignissa.

Huomautus:

Kun DTD-tiedosto ladataan, nimiöiden nimet tuodaan Nimiöt-paneeliin. Nämä tuodut nimiöiden nimet ovat lukittuja; niitä ei voi poistaa eikä nimetä uudelleen muuten kuin poistamalla DTD-tiedosto julkaisusta.

DOCTYPE-elementti näkyy Rakenne-ruudun yläosassa, jos DTD-tiedosto on ladattu julkaisuun. (DTD-tiedostot ladataan toisinaan automaattisesti, kun XML-tiedosto tuodaan.) Jos haluat vaihtaa julkaisun DTD-tiedoston, poista nykyinen DTD-tiedosto ja lataa uusi.

DTD-tiedostojen käyttäminen InDesignissa
DTD-tiedostojen käyttäminen InDesignissa

A. DOCTYPE-elementti DTD-tiedostosta (Rakenne-ruutu) B. Lukittu nimiö DTD-tiedostosta (Nimiöt-paneeli) 

DTD-tiedoston lataaminen

Kun lataat DTD-tiedoston, InDesign sisällyttää sen julkaisuun.

  1. Tee jokin seuraavista:
    • Valitse Rakenne-ruudun valikosta Lataa DTD.

    • Valitse Nimiöt-paneelin valikosta Lataa DTD.

  2. Valitse tuotava DTD-tiedosto ja napsauta Avaa-painiketta.

    Huomautus:

    Saat DTD-tiedostossa määritetyt nimiöt näkyviin valitsemalla Ikkuna > Apuohjelmat > Nimiöt, jolloin Nimiöt-paneeli avautuu.

DTD-tiedoston tarkasteleminen

DTD-tiedostot sisältävät ASCII-tekstiä. Niissä voi olla sisällytettyjä ohjeita ja selityksiä, jotka kuvaavat nimiöiden lisäämistä ja elementtien järjestämistä. InDesignissa voidaan katsella vain julkaisuun ladattua DTD-tiedostoa.

Katseltavaksi avattu DTD-tiedosto
Katseltavaksi avattu DTD-tiedosto

  1. Tee jokin seuraavista:
    • Valitse Rakenne-ruudun valikosta Näytä DTD.

    • Kaksoisnapsauta Rakenne-ruudussa näkyvää DOCTYPE-elementtiä.

    Huomautus:

    Jos haluat tulostaa DTD-tiedoston, kopioi koodi DTD-ikkunasta ja liitä se tekstinkäsittelyohjelmaan.

DTD-tiedoston poistaminen

  1. Valitse Rakenne-ruudun valikosta Poista DTD.

    InDesign poistaa InDesign-julkaisuun tallennetun DTD-tiedoston kopion eikä alkuperäistä DTD-tiedostoa. DTD-tiedostosta tuodut nimiöt säilyvät Nimiöt-paneelissa, mutta niitä ei lukita.

XML-rakenteen vahvistaminen

Julkaisua vahvistaessasi InDesign antaa varoituksen, jos XML poikkeaa DTD-tiedoston mukaisista säännöistä. Se ehdottaa tapoja, joilla XML muutetaan DTD-tiedoston vaatimusten mukaiseksi. Voit korjata virheet yksi kerrallaan tai tarkastella kaikkia virheitä samanaikaisesti erillisessä ikkunassa.

Rakenne-ruutu ja Ehdotukset-ruutu
Rakenne-ruutu ja Ehdotukset-ruutu

A. Ladattu DTD B. Virhe tai vahvistamisen estävä ehto C. Virheen kuvaus ja korjausehdotus D. Virhemäärä E. Vahvista-painike F. Katso kaikki virheet erillisessä ikkunassa 
Rakenne-ruutu ja Ehdotusnäkymä
Rakenne-ruutu ja Ehdotusnäkymä

A. DOCTYPE-elementti määritetystä DTD-tiedostosta B. Virhe tai vahvistamisen estävä ehto C. Virheen kuvaus ja korjausehdotukset D. Virhemäärä E. Vahvista-painike F. Katso kaikki virheet samanaikaisesti erillisessä ikkunassa 
  1. Valitse Näytä > Rakenne > Näytä rakenne.
  2. Napsauta Rakenne-ruudun Vahvista-painiketta .

    Huomautus:

    Voit vaihtaa pääelementin, jonka perusteella InDesign tekee vahvistuksen, valitsemalla Rakenne-ruudun valikosta DTD-asetukset.

  3. Voit korjata Ehdotukset-ruudussa näkyvät virheet joko napsauttamalla korjausehdotusta tai muokkaamalla XML-rakennetta ja nimiöitä suoraan Rakenne-ruutua ja Nimiöt-paneelia käyttämällä.
  4. Jos haluat tutkia muita virheitä, tee yksi seuraavista toimista:
    • Napsauta vasenta nuolta  tai oikeaa nuolta .

    • Näytä kaikki virheet samanaikaisesti erillisessä ikkunassa napsauttamalla virheikkunapainiketta .

    • Valitse Rakenne-ruudun valikosta Näytä virheluettelo.

Huomautus:

InDesign lopettaa vahvistamisen havaittuaan 250 virhettä. Kun tämä raja saavutetaan, Virhemäärä-ruutuun tulee plusmerkki.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö