This article gives you an overview of What's new with Adobe Flash Professional CS6.

Support for Adobe AIR 3.4 (Flash Professional CS6 Update 12.0.2 only)

By virtue of Flash Professional CS6 Update 12.0.2, Flash Professional extends support for AIR 3.4 and Flash Player 11.4. This update also allows Flash Professional to leverage features exposed by AIR 3.4 that enhance application development workflow for iOS devices.

  • Deploying AIR applications on iOS devices directly
  • Native iOS Simulator
  • High-resolution Retina Display Support for the new iPad

Toolkit for CreateJS 1.2

The Toolkit for CreateJS 1.2 release extends support for converting Buttons to HTML5. The update also includes fixes to several JSX related errors. Other issues such as omission of multiple empty keyframes have also been addressed in this update.

You can download and install Toolkit for CreateJS 1.2 from Adobe Extension Manager CS6. For more information on the Toolkit, see Using the Flash Professional Toolkit for CreateJS.

Mobile content simulation for AIR

The new mobile content simulator allows you to simulate Hardware keys, acceleromenter, Multi-touch, and Geo-location.

Choose network interface for remote debugging for AIR

When you publish an AIR app to an Android or iOS device, you can choose the network interface to use for remote debugging. Flash Pro will package the IP address of the selected network interface into the debug mode mobile application. The app can then auto-connect to the host IP to start a debug session when it launches on the target mobile device. To access the setting, choose File > Publish Settings, and then select the Deployment tab in the AIR Settings dialog box. For more information, see Packaging applications for AIR for iOS and Publishing for Adobe AIR for desktop articles.

 

Toolkit for CreateJS

The Adobe Flash Professional Toolkit for CreateJS is an extension for Flash Professional CS6 that enables designers and animators to create assets for HTML5 projects using the open source CreateJS JavaScript libraries. The extension supports most of the core animation and illustration capabilities of Flash Professional, including vectors, bitmaps, classic tweens, sounds, motion guides, animated masks, and JavaScript timeline scripting. With one click, the Toolkit for CreateJS exports the contents on the stage and in the library as JavaScript that can be previewed in the browser to help you start building expressive HTML5-based content in noTime.

The Toolkit for CreateJS is designed to help Flash Pro users make the transition to HTML5. It turns symbols in the Library and content on the Stage into cleanly formatted JavaScript that is understandable, editable and easily reusable by developers who can add interactivity using JavaScript and the CreateJS APIs that will be familiar to ActionScript 3 users. The Toolkit for CreateJS also publishes a simple HTML page that provides a quick way to preview the assets. For more information, see this article.

Export sprite sheets

You can now export a sprite sheet by selecting a symbol in the Library or on the Stage. A sprite sheet is a single graphic image file that contains all the graphic elements used in the selected symbol. The elements are arranged in tiled format in the file. You can also include bitmaps in the Library when selecting a symbol in the Library. To create a sprite sheet, follow these steps:

  1. Select a symbol in the Library or on the Stage.
  2. Right-click and choose Export Sprite Sheet.

High efficiency SWF compression

For SWFs that target Flash Player 11 or later, a new compression algorithm, LZMA, is available. The new compression can be up to 40% more efficient, particularly for files that contain a lot of ActionScript or vector graphics.

  1. Choose File > Publish Settings
  2. In the Advanced section of the dialog box, select the Compress movie option and choose LZMA from the menu.

Direct Mode publishing

A new window mode called Direct is available which enables hardware accelerated content using Stage3D. (Stage3D requires Flash Player 11 or later.)

  1. Choose File > Publish Settings
  2. Select HTML Wrapper.
  3. Select Direct from the Window Mode menu.

For more information see this article.

Support for Direct render mode in AIR plugins

This feature brings Flash Player's Direct mode rendering support for StageVideo/Stage3D to AIR applications. A new renderMode=direct setting can be used in the application descriptor file of an AIR application. Direct mode can be set for AIR for Desktop, AIR for iOS and AIR for Android.

Debug iOS through Wi-Fi

You can now debug AIR applications on iOS through Wi-Fi, including breakpoints, step-in and step-out, variable watcher, and trace.

For more information about debugging AIR applications, see AIR Debug Launcher.

Support for captive runtime for AIR

The Publish Settings dialog for AIR now has an option for embedding the AIR runtime into the application
package. An application with the runtime embedded can run on any desktop, Android, or iOS device without the shared AIR runtime installed.

Adobe recommends:

View the videos Adobe AIR with Captive Runtime Support for Mobile and Desktop.

Native extensions for AIR

You can incorporate native extensions into the AIR applications you develop in Flash Pro. By using native extensions, your applications can access all of the features of your target platform, even if the runtime itself doesn't have built-in support for them.

Get latest Flash Player from within Flash Pro

You can now go directly to the Flash Player download page on Adobe.com from the Help menu in Flash Pro.

Export PNG sequence

Use this feature to generate image files that Flash Pro or other applications can use to generate content. For example, PNG sequences are often used in gaming applications. This feature allows you to export a sequence of PNG files from a Library item or individual movie clips, graphic symbols, and buttons on the Stage.

  1. Select a single movie clip, button or graphic symbol in the Library or the Stage
  2. Right-click it to display the context menu.
  3. Choose Export PNG Sequence.
  4. In the system Save dialog, choose a location for the output. Click OK.
  5. In the Export PNG dialog box, set your options. Click Export to export the PNG sequence.

Keywords: What's new in Flash CS6, Flash Professional CS6 New Features, Flash CS6 New Features, What's new in Flash Professional CS6

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy