Dans ce guide détaillé, découvrez comment désinstaller ou supprimer Adobe Flash Player de votre ordinateur Mac puis supprime tous les fichiers associés supplémentaires.

Ces instructions sont ne sont PAS applicables à Flash Player livré avec Google Chrome. Consultez la page d'aide de Flash Player pour obtenir des instructions sur l'activation (ou la désactivation) de Flash Player dans différents navigateurs.

Si vous utilisez Windows, consultez la rubrique Désinstallation de Flash Player | Windows.

Informations sur Flash Player

Si Flash Player est installé sur votre ordinateur, la boîte suivante affiche la version de Flash Player et la version de votre système d’exploitation. Si Flash Player n’est pas installé, un message d’erreur s’affiche.

 

L’installation de Flash Player a échoué

Si l’installation de Flash Player échoue, suivez cette solution.

Solution : Télécharger et exécuter le programme de désinstallation

1. Identifiez votre version de Mac OS 

  • Cliquez sur l’icône Pomme et sélectionnez "A propos de ce Mac".

    La version de Mac OS apparaît dans la boîte de dialogue A propos de ce Mac.


2. Exécutez le programme de désinstallation applicable à votre version de Mac OS

Remarque :

La désinstallation de Flash Player (versions 11.5 et ultérieures) réinitialise les paramètres AutoUpdateDisable et SilentAutoUpdateEnable dans mms.cfg avec leurs valeurs par défaut :

  • AutoUpdateDisable=0
  • SilentAutoUpdateEnable=0

Si vous exécutez le programme de désinstallation de Flash Player dans le cadre du processus de déploiement, redéployez toutes les modifications personnalisées en sélectionnant AutoUpdateDisable ou SilentAutoUpdateEnable.

Exécutez le programme de désinstallation sur Mac OS X 10.4 et version ultérieure, notamment macOS

  1. Téléchargez le programme de désinstallation d’Adobe Flash Player :

    Le programme de désinstallation est téléchargé dans le dossier de téléchargement de votre navigateur par défaut.

  2. Dans Safari, sélectionnez Fenêtre > Téléchargements.

    Si vous utilisez Mac OS X 10.7 (Lion), cliquez sur l’icône de téléchargement affichée dans le navigateur.

    Cliquez sur l’icône Téléchargements

    Dans Mozilla, sélectionnez Outils > Téléchargements.

  3. Pour lancer le programme de désinstallation, cliquez deux fois dessus dans la fenêtre Téléchargements.

    Remarque : si la fenêtre du programme d’installation de Flash Player ne s’ouvre pas, dans le Finder, sélectionnez Aller > Bureau. Faites défiler vers le bas jusqu’à la section des périphériques et cliquez sur Désinstaller Flash Player.

  4. Pour exécuter le programme de désinstallation, cliquez deux fois sur son icône dans la fenêtre. Si un message apparaît dans lequel il vous est demandé si vous souhaitez ouvrir le fichier du programme de désinstallation, cliquez Ouvrir.

  5. Au démarrage du programme de désinstallation, cliquez sur Désinstaller.
  6. Mettez en signet cette page ou imprimez-la en vue d’utiliser le reste de ces instructions après la fermeture de votre navigateur.
  7. Pour fermer tous les navigateurs, cliquez sur le nom du navigateur dans la boîte de dialogue du programme de désinstallation, soit fermez chaque navigateur manuellement puis cliquez sur Réessayer.

    Remarque : ne cliquez pas sur Quitter dans la fenêtre du programme de désinstallation. Un arrêt du processus de désinstallation en résulterait.

  8. Lorsque vous fermez les navigateurs, le programme de désinstallation se poursuit automatiquement jusqu’à la fin de la désinstallation. Lorsqu’un message vous avertit que la désinstallation est terminée, cliquez sur Terminé.



  9. Supprimez les répertoires suivants :

    • <répertoire racine>/Bibliothèque/Préférences/Macromedia/Flash\Player
    • <répertoire racine>/Bibliothèque/Caches/Adobe/Flash\Player

Exécutez le programme de désinstallation sur Mac OS X 10.1 à 10.3

  1. Téléchargez le programme de désinstallation d’Adobe Flash Player :

  2. Sélectionnez Fenêtre > Téléchargements pour afficher le programme de désinstallation téléchargé.

  3. Enregistrez le fichier du programme de désinstallation dans un emplacement pratique.

  4. Pour lancer le programme de désinstallation, cliquez deux fois dessus dans la fenêtre Téléchargements.

  5. Pour exécuter le programme de désinstallation, cliquez deux fois sur son icône dans la fenêtre. Si nécessaire, entrez vos nom d’utilisateur de l’ordinateur et mot de passe, puis cliquez sur OK.

  6. Au démarrage du programme de désinstallation, cliquez sur Continuer.

  7. Mettez en signet cette page ou imprimez-la en vue d’utiliser le reste de ces instructions après la fermeture de votre navigateur. Fermez l’ensemble des navigateurs et autres applications qui utilisent Flash Player, notamment les applications de messagerie instantanée, les fichiers SWF et les projecteurs (fichiers EXE qui lisent les fichiers SWF). Dans le cas contraire, le programme de désinstallation ne peut pas aboutir (même s’il semble terminé).

    Une fois le programme de désinstallation terminé, la fenêtre se ferme automatiquement.

  8. Texte de l’étape

3. Vérifiez que la désinstallation est terminée

Pour vérifier que la désinstallation est terminée, procédez comme suit :

  1. Redémarrez l’ordinateur.
  2. Ouvrez votre navigateur et vérifiez le statut de Flash Player.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne