Versions : Illustrator CS2 à CS5

Sommaire

Adobe Illustrator est optimisé pour l’impression PostScript. En fait, bon nombre de fonctionnalités avancées d’Illustrator ne peuvent être décrites qu’en utilisant le langage de description de page PostScript. Les imprimantes non PostScript (Hewlett-Packard LaserJets, Canon BubbleJets ou Epson Stylus, par exemple) utilisent des langages de description de page qui ne sont pas des langages de programmation complets (PCL ou QuickDraw, par exemple) et ne peuvent pas décrire tous les objets et attributs des illustrations Illustrator. La plupart des imprimantes non PostScript utilisent les informations d’affichage, les ressources de l’ordinateur hôte et des pilotes d’impression exclusifs pour traiter les informations d’impression.

Lorsque vous imprimez depuis Illustrator sur une imprimante non PostScript, il est possible que des objets ne soient pas imprimés, ou le soient de manière incorrecte. Ce comportement peut varier en fonction des imprimantes et des versions du logiciel de l’imprimante. Les problèmes d’impression non PostScript peuvent se manifester sous différentes formes, notamment les suivantes (mais sans que cette liste soit exhaustive) :

  • Le texte ou les autres objets sont partiellement ou totalement absents de la page.
  • Une erreur système ou un blocage se produit.

Cependant, les étapes de dépannage ci-dessous peuvent vous aider à imprimer les documents Illustrator sur des imprimantes non PostScript. Dans certains cas, comme en présente d’imprimantes anciennes dont le pilote n’est plus mis à jour, les étapes de dépannage peuvent échouer à résoudre le problème ; vous devrez alors utiliser une solution de rechange. Plusieurs solutions de rechange sont indiquées à la fin de ce document.

Dépannage

Les tâches de cette section vous aideront à isoler les causes les plus fréquentes des problèmes d’impression survenant dans Illustrator. Avant de commencer, vérifiez que la cause du problème n’est pas due à un fichier Illustrator endommagé en ouvrant un nouveau fichier et en essayant de reproduire le problème. Si ce problème ne se reproduit pas dans un nouveau fichier, il est probable que votre fichier Illustrator est endommagé. Les informations sur le dépannage des fichiers Illustrator endommagés figurent dans le document 320318, « Troubleshoot damaged files (Illustrator 2 and later). »

Relancez toujours l’ordinateur après une erreur système pour actualiser la mémoire de l’ordinateur ; le problème peut devenir plus complexe si vous continuez à travailler sans redémarrer le système.

1. Mise à jour ou réinstallation du pilote de l’imprimante.

Prenez contact avec le fabricant de l’imprimante pour obtenir la toute dernière version du pilote de votre imprimante. Si vous utilisez déjà la toute dernière version du pilote de l’imprimante et que le problème persiste, désinstallez le pilote, puis réinstallez-le depuis les disques ou le cédérom d’installation d’origine.

2. Modification de l’option d’impression Bitmap dans Illustrator.

Si vous utilisez Illustrator pour Windows, changez le paramètre Imprimer au format Bitmap dans la boîte de dialogue Imprimer. Si l’option est sélectionnée, désélectionnez-la ; si elle est désélectionnée, sélectionnez-la.

Pour changer l’option, sélectionnez Fichier > Imprimer > Avancé et sélectionnez ou désélectionnez Imprimer au format Bitmap.

Remarque : si vous désactivez Imprimer au format Bitmap dans la boîte de dialogue Imprimer, Illustrator utilise les informations Graphic Display Interface (GDI) et le pilote d’imprimante pour créer des données d’impression vectorielles, ce qui est plus rapide mais peut provoquer une impression inégale sur certains périphériques.

3. Utilisation du langage PCL étendu.

Si vous utilisez Windows et que votre imprimante prend en charge un pilote PCL étendu, installez ce pilote d’imprimante. Pour savoir comment installer le pilote Étendu pour votre imprimante, consultez la documentation du périphérique ou prenez contact avec son fabricant.

4. Utilisation d’un pilote de carte graphique Windows standard.

Utilisez un pilote de carte graphique Windows standard en démarrant Windows en mode VGA :

  • Sous Windows Vista et Windows 7 : sélectionnez Activer la vidéo basse résolution (640 x 480) dans la liste des options de démarrage, puis appuyez sur Entrée. Si ce menu ne s’affiche pas, ou disparaît trop rapidement, sélectionnez Démarrer > Panneau de configuration, cliquez sur Système et maintenance et sélectionnez Paramètres système avancés. Sélectionnez l’onglet Avancé puis Paramètres dans la zone Démarrage et récupération et augmentez la valeur de l’option Afficher les systèmes d’exploitation pendant.
  • Dans Windows XP : relancez Windows, maintenez enfoncée la touche F8 lorsqu’un message vous y invite et sélectionnez Activer le mode VGA dans le menu. Si ce menu ne s’affiche pas, ou disparaît trop rapidement, sélectionnez Démarrer > Paramètres > Panneau de configuration, double-cliquez sur Système et cliquez sur Avancé. Sélectionnez Paramètres dans la zone Démarrage et récupération et augmentez la valeur de l’option Afficher les systèmes d’exploitation pendant.
  • Dans Windows 2000 : relancez Windows, maintenez enfoncée la touche F8 lorsqu’un message vous y invite et sélectionnez Mode VGA dans le menu. Si ce menu ne s’affiche pas, ou disparaît trop rapidement, sélectionnez Démarrer > Paramètres > Panneau de configuration, double-cliquez sur Système et cliquez sur l’onglet Avancé. Sélectionnez Démarrage et récupération et augmentez la valeur de l’option Afficher les systèmes d’exploitation pendant.

Si vous pouvez imprimer correctement depuis Illustrator avec le pilote SuperVGA ou VGA, alors le pilote de votre carte vidéo est peut-être endommagé, périmé ou incompatible avec le pilote de votre imprimante ou Illustrator. Pour obtenir un pilote de carte graphique à jour, prenez contact avec le fabricant de la carte.

5. Modification du format du texte.

Si le texte s’imprime mal ou ne s’imprime pas du tout, enregistrez une copie du fichier Illustrator, puis procédez de l’une des manières suivantes :

  • Appliquez un trait blanc de zéro point à la fonte.
  • Convertissez le texte en contours. Pour le texte de petite taille (24 points ou moins) appliquez un trait blanc de zéro point pour empêcher le trait de distordre les caractères convertis en contours.
  • Rastérisez le texte dans Illustrator en le sélectionnant avec l’outil Sélection et en choisissant l’option Objet > Rastériser.

6. Ajout d’un objet coloré masqué.

Si le texte en couleurs s’imprime en noir et s’il s’agit du seul élément coloré de la page, créez un objet masqué de la même couleur que le texte :

  1. sélectionnez l’outil Rectangle, puis dessinez un rectangle et peignez-le de la même couleur que le texte.
  2. Tracez un rectangle de taille suffisante pour couvrir complètement le rectangle créé à l’étape 1. Peignez le nouveau rectangle en blanc et placez-le de manière à couvrir le rectangle initial.

7. Modification de l’option d’impression des calques en Tous les calques.

Sélectionnez Fichier > Imprimer, cliquez sur Général et sélectionnez Tous les calques dans le menu Imprimer les calques.

8. Configuration d’une imprimante PostScript comme imprimante par défaut. (Windows uniquement)

Définissez une imprimante PostScript comme imprimante par défaut dans Windows. Pour définir une imprimante par défaut, sélectionnez Démarrer > Paramètres > Imprimantes (Windows XP, Windows 2000) ou Démarrer >Panneau de configuration > Matériel et audio > Imprimantes (Windows Vista). Cliquez avec le bouton droit de la souris sur l’imprimante voulue et choisissez Définir comme imprimante par défaut.

Remarque : même si vous ne disposez d’aucune imprimante PostScript, vous pouvez installer un pilote d’imprimante PostScript et le définir comme imprimante par défaut.

  1. Sélectionnez Démarrer > Paramètres > Imprimantes (Windows XP, Windows 2000) ou Démarrer > Panneau de configuration > Matériel et audio > Imprimantes (Windows Vista), puis choisissez Ajouter une imprimante.
  2. Suivez les instructions affichées en veillant à ajouter une imprimante PostScript (Apple LaserWriter Pro, par exemple) plutôt qu’une imprimante non PostScript (HP DeskJet, par exemple). Pour savoir comment utiliser l’Assistant d’ajout d’imprimante, consultez la documentation de Windows.

Pour imprimer depuis Illustrator sur une imprimante autre que l’imprimante par défaut sous Windows :

  1. Choisissez la commande Fichier > Imprimer.
  2. Sélectionnez l’imprimante dans le menu Imprimante.
  3. Cliquez sur Terminé pour fermer la boîte de dialogue Imprimer et conserver cette sélection ou cliquez sur Imprimer pour imprimer immédiatement.

9. Impression depuis une imprimante locale.

En cas de connexion à une imprimante en réseau, connectez l’imprimante directement à l’ordinateur. Si le fichier s’imprime correctement, la cause du problème peut être liée au réseau. Contactez l’administrateur réseau pour obtenir de l’aide.

Solutions de rechange

Si, après avoir suivi les étapes de dépannage, il vous est encore impossible d’imprimer sur une imprimante PostScript, les solutions de rechange suivantes peuvent vous aider à imprimer votre document Illustrator.

10. Enregistrement du fichier au format Portable Document Format (PDF).

Enregistrez le fichier Illustrator au format PDF en sélectionnant Acrobat PDF dans le menu contextuel de la boîte de dialogue Enregistrer sous, puis ouvrez et imprimez le fichier PDF depuis Adobe Reader.

11. Impression depuis une autre application.

Imprimez le fichier Illustrator depuis une autre application (Adobe Photoshop, ou Adobe InDesign, par exemple).

Remarque : d’autres applications peuvent également avoir des difficultés pour imprimer vers des imprimantes non PostScript. Il peut s’avérer nécessaire d’enregistrer ou d’exporter le fichier Illustrator dans un autre format (TIFF ou EPS, par exemple) ou d’essayer des applications différentes jusqu’à ce que l’illustration soit correctement imprimée.

12. Impression sur une autre imprimante.

Imprimez sur une imprimante PostScript ou sur une autre imprimante non PostScript.

Remarque : certains fabricants d’imprimantes non PostScript (par exemple Hewlett-Packard ou Epson) propose du matériel ou du logiciel PostScript pour leurs imprimantes. Pour déterminer la disponibilité du matériel ou logiciel PostScript pour votre imprimante, prenez contact avec le fabricant.

 

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne