使用圖庫項目

上次更新時間 2021年12月20日

請使用本主題,了解如何在 Dreamweaver 中建立圖庫項目,以及在文件中插入和編輯圖庫項目。

程式庫是一個特殊的 Dreamweaver 檔案,包含您可以置入網頁中的個別資產或資產副本的集合。圖庫中的資源就稱為「圖庫項目」。 您可以在程式庫中儲存的項目包括影像、表格、聲音,以及使用 Adobe Flash 建立的檔案。每當您編輯程式庫項目時,即可自動更新所有使用該程式庫項目的頁面。

例如,假設您正在為一間想要在每個頁面上顯示標語的公司建置大型網站。您可以建立一個程式庫項目來包含標語,並在每個頁面上使用該程式庫項目。如果標語變更,您可以變更程式庫項目,並自動更新每個使用該項目的頁面。

Dreamweaver 會將資料庫項目儲存在每個地點的本機根資料夾內的 Library 資料夾中。每個網站都有自己的程式庫。

您可以從文件正文區段中的任何元素建立程式庫項目,包括文字、表格、表單、Java applet、增效模組、ActiveX 元素、導覽列和影像。

對於連結項目(例如影像),程式庫只會儲存項目的參照。原始檔案必須保留在指定位置,資料庫項目才能正常運作。

即使如此,在圖庫項目中儲存影像還是相當有用。 例如,您可以在程式庫項目中儲存完整的 img 標記,這樣即可輕鬆變更影像在整個網站中的 alt 文字,甚至是其 src 屬性。(不過,請勿使用此技術來變更影像的 寬度 和 高度 屬性,除非您同時使用影像編輯器來變更影像的實際大小。)

如果圖庫項目含有連結,這些連結不一定能在新的網站中運作。 同時,圖庫項目中的影像也不會複製到新網站。

當您使用程式庫項目時,Dreamweaver 會在網頁中插入該項目的連結,而不是項目本身。也就是說,Dreamweaver 會將該項目的 HTML 原始程式碼副本插入文件中,並新增包含對原始外部項目參考的 HTML 註解。正是這個外部參考讓自動更新成為可能。

當您建立包含附加了 Dreamweaver 行為之元素的資料庫項目時,Dreamweaver 會將該元素和其事件處理常式 (指定哪個事件觸發動作的屬性,例如 onClick、onLoad 或 onMouseOver,以及事件發生時要呼叫哪個動作) 複製到資料庫項目檔案。Dreamweaver 不會將相關聯的 JavaScript 函式複製到資料庫項目中。相反地,當您將資料庫項目插入文件時,Dreamweaver 會自動將適當的 JavaScript 函式插入該文件的 head 區段中 (如果尚未存在)。

如果是以手工撰寫 JavaScript (就是不使用 Dreamweaver 行為來建立) 的話,便可以在使用「呼叫 JavaScript」行為執行程式碼時,使其成為圖庫項目的一部分。 如果您不使用 Dreamweaver 行為來執行程式碼,就不會將程式碼保留為圖庫項目的一部分。

編輯資料庫項目中的行為有特殊要求。資料庫項目不能包含樣式表,因為這些元素的程式碼是 head 區段的一部分。

根據選取範圍建立圖庫項目

在「文件」視窗中,切換至「設計」檢視並選取文件中要另存成圖庫項目的部分。

選取「工具 > 圖庫 > 將物件加入圖庫」。

輸入新資料庫項目的名稱,然後按一下 Enter 鍵 (Windows) 或 Return 鍵 (Macintosh)。

Dreamweaver 會將每個程式庫項目儲存為網站本機根資料夾的 Library 資料夾中的個別檔案 (副檔名為 .lbi)。

建立空的圖庫項目

確定在「文件」視窗中未選取任何項目。

如果選取了某個項目,該項目將會置入新的資料庫項目中。

在「資源」面板中,選取「圖庫」類別。

按一下面板底部的「新增圖庫項目」按鈕。

在項目仍處於選取狀態時,為其輸入一個名稱, 然後按下 Enter 鍵 (Windows) 或 Return 鍵 (Macintosh)。

將圖庫項目插入文件

當您 將資料庫項目新增到頁面時,實際內容會連同資料庫項目的 參考一併插入文件中。

請將插入點放在「文件」視窗中。

在「資源」面板中,選取「圖庫」類別。

請執行下列其中一項作業:
  • 將圖庫項目從「資源」面板拖曳到「文件」視窗中。
備註

若要在文件中插入圖庫項目的內容,但是不包含項目的參考,請按 Control (Windows) 或 Option (Macintosh) 並同時將項目拖曳到「資源」面板的「圖庫」類別之外。 如果以這種方式插入項目,就可以在文件中編輯此項目,但是當您更新使用該圖庫項目的頁面時,並不會同時更新文件。

  • 選取圖庫項目,並按一下「插入」。

編輯圖庫項目和更新文件

編輯資料庫項目時,您可以更新 所有使用該項目的文件。如果您選擇不要更新,文件 仍會與資料庫項目保持關聯;您可以稍後再更新。

您可以重新命名項目以中斷其與文件或範本的連線、從網站的程式庫刪除項目,並重新建立遺失的程式庫項目。

編輯圖庫項目

在「資源」面板中,選取「圖庫」類別。

選取圖庫項目。

按一下「編輯」按鈕,或按兩下圖庫項目。

Dreamweaver 會開啟新視窗, 類似於文件視窗,以供編輯資料庫項目。灰色 背景表示您正在編輯資料庫項目而非 文件。

進行變更,然後加以儲存。

指定是否在使用該圖庫項目的本機網站上更新文件。 選取「更新」以立即進行更新。 如果選取「不要更新」,則文件會等到您選擇「工具 > 圖庫 > 更新目前頁面 (或更新頁面)」後,才進行更新。

更新目前文件以 使用所有資料庫項目的目前版本

選取「工具 > 圖庫 > 更新目前頁面」。

更新使用特定程式庫項目的整個網站或所有文件

選取「工具 > 圖庫 > 更新頁面」。

在「查詢」彈出式選單中,指定要更新的項目:
  • 若要更新所選網站中的所有頁面以使用所有程式庫項目的目前版本,請選取「整個網站」,然後從相鄰的彈出式選單中選取網站名稱。

  • 若要更新目前網站中使用該程式庫項目的所有頁面,請選取「使用的檔案」,然後從相鄰的彈出式選單中選取程式庫項目名稱。

確定已在「更新」 選項中選取「資料庫項目」。

若要同時更新範本,請也選取「範本」。

按一下「開始」。

Dreamweaver 會依照 指示更新檔案。如果您選取了「顯示記錄」選項,Dreamweaver 會產生一個報告,顯示檔案 是否已成功更新,以及其他資訊。

重新命名圖庫項目

在「資源」面板中,選取「圖庫」類別。

選取圖庫項目,暫停一下,然後再按一下該圖庫項目 (請勿按兩下;按兩下會開啟該項目以進行編輯)。
最後輸入新的名稱。
在別的地方按一下,或是按 Enter 鍵 (Windows) 或 Return 鍵 (Macintosh)。
指定是否要更新使用該項目的文件,請選擇「更新」或「不要更新」。

從圖庫中刪除圖庫項目

刪除資料庫項目時,Dreamweaver 會將其從資料庫中移除,但不會 變更任何使用該項目的文件內容。

在「資源」面板中,選取「圖庫」類別。

選取圖庫項目。
按一下「刪除」按鈕或按下 Delete 鍵, 然後確認您要刪除該項目。

如果刪除圖庫項目,就無法使用「還原」進行復原。 不過,您還是可以重新建立該項目。

重新建立遺失或已刪除的資料庫 項目

在您的其中一個文件中選取該項目的實例。
按一下「屬性」檢視窗 (「視窗」> 「屬性」) 中的「重新建立」按鈕。

自訂資料庫 項目的反白顯示

您可以透過設定 反白顯示偏好設定來自訂資料庫項目的反白顯示 色彩以及顯示或隱藏反白顯示。

變更資料庫 項目的反白顯示色彩

選取「編輯 > 偏好設定」(Windows) 或「Dreamweaver > 偏好設定」(Macintosh)。
在「偏好設定」對話框左側的清單中選取 「反白顯示」類別。
按一下「資料庫項目」色彩方塊,然後使用檢色器選取 反白顯示色彩 (或在文字方塊中輸入十六進位色彩值)。
選取「顯示」來在「文件」視窗中顯示醒目提示顏色。
按一下「確定」。

在「文件」視窗中顯示或隱藏醒目提示

若要顯示標示,請選取「檢視 > 設計檢視選項 > 視覺輔助 > 隱藏元素」。 若要隱藏標示,請取消選取「隱藏元素」。

編輯資料庫項目的屬性

您可以使用「屬性」檢視器來開啟程式庫項目進行編輯、將選取的程式庫項目從其來源檔案中分離,或使用目前選取的程式庫項目覆寫項目。

選取文件中的圖庫項目。
在屬性檢視器 (視窗 > 屬性) 中選取下列其中一個選項:

原始檔

顯示資料庫項目來源檔案的檔案名稱和位置。您無法編輯這項資訊。

開啟

開啟圖庫項目的原始檔以進行編輯。 這相當於在「資產」面板中選取項目並按一下「編輯」按鈕。

從原始檔中分離

中斷選取的資料庫項目與其來源檔案之間的連結。您可以在文件中編輯分離的項目,但它不再是資料庫項目,當您變更原始項目時也不會更新。

重新建立

使用目前的選取範圍來覆寫原始的圖庫項目。 如果原始資料庫項目遺失或意外刪除,請使用此選項重新建立資料庫項目。

讓資料庫項目可在文件中編輯

如果您已將資料庫項目新增至文件,而且想要針對該頁面特別編輯該項目,您必須中斷文件中的項目與資料庫之間的連結。一旦您讓資料庫項目的執行個體變成可編輯,當資料庫項目變更時,該執行個體就不會更新。

請在目前文件中選取圖庫項目。
在「屬性」檢視器 (「視窗」>「屬性」) 中按一下「從原始項目分離」。

編輯圖庫項目中的行為

若要編輯資料庫項目中的行為,您必須先將項目插入文件中,然後讓項目在該文件中變成可編輯。進行變更後,您可以重新建立資料庫項目,使用文件中編輯後的項目取代資料庫中的項目。

開啟含有圖庫項目的文件。

記下資料庫項目的名稱以及其包含的確切標記。您稍後會需要這項資訊。

選取資料庫項目,然後在「屬性」檢視器 (「視窗」>「屬性」) 中按一下「從原件分離」。
選取已附加行為的元素。
在「行為」面板 (「視窗」>「行為」) 中,按兩下您要變更的動作。
在出現的對話框中進行變更,然後按一下「確定」。

在「資源」面板中,選取「圖庫」類別。

記錄原始資料庫項目的確切名稱和大小寫;選取它,然後按一下「刪除」按鈕。
在「文件」視窗中,選取構成資料庫項目的所有元素。

請小心選取與原始資料庫項目完全相同的元素。

在「資源」面板中,按一下「新增圖庫項目」按鈕,然後使用相同的拼字和大小寫,為新項目指定與您所刪除項目相同的名稱。

若要更新網站其他文件中的圖庫項目,請選取「工具 > 圖庫 > 更新頁面」。

在「查詢」彈出式選單中,選取「使用的檔案」。
在相鄰的彈出式選單中,選取您剛才建立的資料庫項目名稱。
在「更新」選項中,確定已選取「資料庫項目」,然後按一下「開始」。
當更新完成時,請按一下「關閉」。