了解如何在 Dreamweaver 中於檢視之間切換,重疊顯示、並排顯示及調整文件視窗大小。

註解:

Dreamweaver CC (含) 以後版本的用戶介面已經簡化了。因此,您在 Dreamweaver CC 和更新版本中可能會找不到本文所描述的一些選項。如需詳細資訊,請參閱本文

在文件視窗中切換檢視

您可以在「文件」視窗的「程式碼」檢視、「分割程式碼」檢視、「設計」檢視、「程式碼與設計」檢視 (「分割」檢視) 或「即時檢視」中檢視文件。您也能選擇以橫向或縱向顯示「分割程式碼」檢視或「程式碼和設計」檢視 (預設為橫向顯示)。

註解:

設計檢視選項無法供流變格線文件使用。

切換到程式碼檢視

  1. 請執行下列其中一項作業:
    • 選取「檢視 > 程式碼」。

    • 在「文件」工具列中,按一下「程式碼」按鈕。

       

       

切換到分割程式碼檢視

「分割程式碼」檢視會將文件分割成兩部分,讓您可以同時處理兩個程式碼區段。

  1. 選取「檢視 > 分割程式碼」。

切換到設計檢視

在「文件」工具列中,按一下「即時」選項旁邊的下拉式清單,然後按一下「設計」。若要切換到完整設計檢視,請按一下「設計」按鈕。

同時顯示程式碼和設計檢視

 

在「文件」工具列中,按一下「分割」按鈕。然後按一下「即時」選項旁邊的下拉式清單,再按一下「設計」。

 

垂直或水平分割檢視

  1. 務必確保您位於「分割」檢視中 (「分割程式碼」或分割的「設計/即時」檢視)。

  2. 若要垂直分割檢視,請選取「檢視 > 垂直分割」。若要水平分割檢視,請取消選取「檢視 > 垂直分割」。

重疊或並排顯示文件視窗

如果您一次開啟多份文件,則可重疊顯示或並排顯示這些文件。

重疊顯示文件視窗

  1. 選取「視窗>重疊顯示」。

並排顯示文件視窗

  • (Windows) 選取「視窗>水平並排」或「視窗>垂直並排」。
  • (Macintosh) 選取「視窗 > 並排顯示」。

調整文件視窗大小

狀態列會顯示「文件」視窗的目前尺寸 (以像素為單位)。若要設計擁有特定最佳大小的頁面,您可以將「文件」視窗調整為任何預先決定的大小、編輯這些預先決定的大小或建立新的大小。

當您在「設計」或「即時檢視」中變更了頁面的檢視大小時,只會變更檢視大小的尺寸。文件大小會保持不變。

除了預先決定與自訂的大小外,Dreamweaver 也會列出媒體查詢中指定的大小。當您選取與媒體查詢對應的大小時,Dreamweaver 會使用媒體查詢來顯示頁面。您也可以變更頁面方向,以預覽行動裝置的頁面,在行動裝置中,頁面版面通常會根據裝置握持的方式變更。

如果要調整文件視窗的大小,請從「文件」視窗底部的「視窗大小」彈出式選單中,選取其中一種大小。

將文件視窗大小調整為預先決定的大小

  1. 從「文件」視窗底部的「視窗大小」彈出式選單中選取其中一種大小。Dreamweaver CS5.5 及後續版本提供了擴充的選擇清單,包括適用於常見行動裝置的各項選擇 (如下圖所示)。
    調整文件視窗大小

    顯示出來的視窗大小反映出瀏覽器視窗內不含邊框的尺寸;監視器大小或行動裝置會列在右側。

    註解:

    如果不需要那麼精準地調整大小,請使用作業系統調整視窗大小的標準方法,如拖曳視窗的右下角。

    註解:

    (僅適用於 Windows)「文件」視窗中的文件預設為最大化,而且文件在最大化時,您便無法調整其大小。若要解除文件的最大化狀態,請按一下文件右上角的解除最大化按鈕

變更視窗大小彈出式選單中所列的值

  1. 從「視窗大小」彈出式選單中選取「編輯大小」。
  2. 按一下「視窗大小」清單中的任何寬度或高度值,並輸入新值。

    若只要將「文件」視窗調整為特定寬度 (高度保持不變),請選取高度值並刪除它。

  3. 按一下「描述」方塊以輸入與特定大小相關的描述性文字。

在視窗大小彈出式選單中加入新的大小

  1. 從「視窗大小」彈出式選單中選取「編輯大小」。
  2. 在「寬度」欄中最後一個值底下的空白處按一下。
  3. 輸入「寬度」和「高度」的值。

    若只要設定「寬度」或「高度」,只要將其中一個欄位保留空白即可。

  4. 按一下「描述」欄位以輸入與新增之大小相關的描述性文字。

    例如,可以在 800 x 600 像素的監視器項目旁輸入 SVGA一般 PC,並在 832 x 624 像素的監視器項目旁輸入 17 吋 Mac。大部分的監視器可以調整成各種像素尺寸。

  5. 按一下「套用」,然後關閉對話方塊。

    您的新視窗大小現在可用於「視窗大小」彈出式選單中。

設定視窗大小和連線速度

  1. 選取「編輯 > 偏好設定」(Windows) 或「Dreamweaver > 偏好設定」(Macintosh)。
  2. 從左邊的「類別」清單中選取「視窗大小」。

  3. 視需求自訂視窗大小。

Dreamweaver 中的報表

您可以在 Dreamweaver 中執行報表,以尋找內容、疑難排解或測試內容。您可以產生下列類型的報表:

搜尋

可讓您搜尋標籤、屬性和標籤內的特定文字。

參考

可讓您搜尋有用的參考資訊。

驗證

可讓您檢查程式碼或語法錯誤。

瀏覽器相容性

可讓您測試文件中的 HTML,以查看是否有任何標籤或屬性不受目標瀏覽器支援。

連結檢查程式

可讓您發現並修正無效、外部和孤立的連結。

網站報表

可讓您改進工作流程並測試網站中的 HTML 屬性。工作流程報表包含取出者、最近修改的項目和設計備註;HTML 報表包含可結合巢狀字體標籤、輔助功能、沒有替代文字、多餘的巢狀標籤、可移除的空標籤和無標題文件。

FTP 記錄

可讓您檢視所有 FTP 檔案傳送活動。

伺服器除錯

可讓您檢視 Adobe® ColdFusion® 應用程式的除錯資訊。

註解:

Dreamweaver CC 和更新版本已移除對 ColdFusion 的支援。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策