Soluzioni ai problemi più comuni relativi alla visualizzazione di file PDF su un sito Web.

Sintomi 

Sintomi comuni quando non è possibile visualizzare un file PDF sul Web:

  • Una pagina vuota nel browser Web
  • Un'icona con una X rossa
  • Un indicatore di collegamento interrotto, come un quadrato rosso oppure un triangolo o cerchio blu
  • Errore: "Non è possibile utilizzare la versione di Adobe Acrobat/Reader in esecuzione per la visualizzazione di file PDF all'interno di un browser web. È richiesto Adobe Acrobat o Reader versione 8 o 9. Uscire e riprovare".

Per risolvere alcuni dei problemi più comuni relativi alla visualizzazione di file PDF, seguite le istruzioni riportate di seguito in questo ordine: aggiornare Reader o Acrobat, correggere problemi con il file PDF, controllare le impostazioni del browser, riparare o reinstallare Reader o Acrobat.

Aggiornare Reader o Acrobat

Adobe rilascia trimestralmente aggiornamenti gratuiti per la protezione. Accertatevi di aggiornare la vostra versione di Reader o di Acrobat all'ultima versione. Tali aggiornamenti spesso comprendono correzioni ai problemi comuni. Scaricate l'aggiornamento gratuito più recente.

  1. Aprite Reader o Acrobat.

  2. Scegliete ? > Ricerca aggiornamenti. 

    Acrobat 9 e versioni precedenti: se è disponibile un nuovo aggiornamento, viene installato automaticamente.

    Acrobat X e XI: fate clic su Aggiorna, quindi fate clic su Installa.

    Acrobat DC: continuate con il passaggio successivo.

    Verificare la presenza di eventuali aggiornamenti
  3. Quando viene visualizzata la finestra di dialogo Updater, fate clic su Scarica.

    Aggiornare Acrobat
  4. Al termine del download, fate clic sull'icona di installazione di Acrobat. Nella finestra di Acrobat Updater, fate clic su Installa.

    L'aggiornamento è pronto
  5. Una volta completata l'installazione, riavviate il computer e provate di nuovo il file PDF per verificare se è possibile visualizzarlo.

Soluzioni PDF

Aggiornare o ricaricare la pagina

Spesso, il semplice aggiornamento della pagina nel browser consente al file PDF di caricarsi completamente.

  • Tenete premuto il tasto Maiusc e premete i pulsanti  Aggiorna o  Ricarica nel browser.

Provate a visualizzare un altro file PDF

Provate a visualizzare un altro file PDF. Per esempio, verificate se questo modulo di esempio viene visualizzato nel vostro browser. Se Acrobat o Reader riescono ad aprire il modulo di esempio, allora l'altro file PDF potrebbe essere danneggiato o potrebbe essere il browser Web ad avere problemi. Se possibile, contattate la persona o la società che gestisce il sito Web.

Provare a visualizzare un file PDF sul disco rigido

Determinate se nel browser Web è possibile aprire un file PDF dal disco rigido locale anziché dal Web. Per questa prova, è necessario disporre di un file PDF salvato sul computer.

  1. Nel vostro browser Web, effettuate una delle seguenti operazioni:

    • Mac OS: scegliete File > Apri (o Apri file).
    • Windows: Premete Ctrl + O.
  2. Fate clic su Sfoglia.

  3. (Solo Windows): dal menu Tipo file, scegliete Tutti i file.

    Scegliete tutti i file
  4. Individuate un file PDF sul computer, selezionatelo e fate clic su Apri.

    Se il file PDF viene aperto, il sito Web che stavate visualizzando potrebbe avere un problema. Contattate la persona o la società che gestisce il sito Web.

Soluzioni relative al browser e alle impostazioni del browser

Utilizzate un altro browser Web

Alcune caratteristiche del computer in uso, come le impostazioni di protezione o i cookie del browser, possono impedirvi di visualizzare un file PDF. Spesso la soluzione più veloce è quella di provare ad aprire la pagina mediante un browser diverso. Se non lo avete già fatto, provate alcuni tra i seguenti browser:

 Google Chrome
 Mozilla Firefox
 Microsoft Internet Explorer
 Apple Safari

Per un elenco di browser compatibili con Reader e Acrobat, consultate Browser Web compatibili.

Passare a Visualizzazione compatibilità (Internet Explorer)

Alcuni siti Web sono visualizzati meglio nella Visualizzazione compatibilità di Internet Explorer. La Visualizzazione compatibilità mostra una pagina come se fosse di una versione precedente del browser.

Per istruzioni su come passare a questa visualizzazione, consultate Risoluzione dei problemi di visualizzazione dei siti Web con Visualizzazione Compatibilità.

Riavviare il computer e provare a riaprire il file PDF

Riavviate il computer, quindi aprite di nuovo la pagina Web. Il riavvio svuota la memoria e la cache di memoria del computer. Con il semplice riavvio del computer spesso si risolvono i problemi di visualizzazione.

Eliminare i file Internet temporanei (Internet Explorer, Firefox e Chrome)

Svuotate la cache del browser (a volte chiamata file temporanei Internet) per verificare che sia visualizzata una versione aggiornata della pagina. 

Fate attenzione durante la selezione delle opzioni. Svuotate solo la cache del browser. Se si rimuovono tutti i File temporanei Internet, si rischia di eliminare i cookie contenenti le informazioni di accesso e le preferenze. La maggior parte dei browser consentono di scegliere il tipo di contenuto che si desidera eliminare.

Cancellare la cronologia
La finestra di dialogo di Firefox Cancella tutta la cronologia ti consente di eliminare solo la cache del browser.

Per le istruzioni sullo svuotamento della cache del browser, consultate i seguenti articoli: 

Firefox: eliminate la cronologia di navigazione, ricerca e download

Chrome: eliminate la cache, la cronologia e altri dati del browser

Internet Explorer da 8 a 11: visualizzate e modificate la cronologia del browser

Internet Explorer 7eliminate la cronologia delle pagine Web

Ripristinare la preferenza Visualizza PDF nel browser (Acrobat/Reader X o versioni precedenti)

Provate a ripristinare la preferenza di visualizzazione nel browser per eliminare il problema di visualizzazione.

  1. In Reader o Acrobat, fate clic con il pulsante destro del mouse sulla finestra del documento e selezionate Preferenze di visualizzazione pagina..

    Preferenze di visualizzazione pagina
  2. Dall'elenco a sinistra, selezionate Internet.

    Selezionate le preferenze Internet
  3. Deselezionate Visualizza PDF nel browser, quindi fate clic su OK.

    Deselezionate l'opzione Visualizza PDF nel browser
  4. Provate ad aprire di nuovo il file PDF dal sito Web.

Visualizzare il file PDF nella versione a 32 bit di Internet Explorer o Safari (solo Windows Vista)

Questa procedura è valida solo per gli utenti di Windows Vista con Internet Explorer 9 o versioni precedenti.

In Windows, Acrobat e Reader sono applicazioni a 32 bit. Se provate ad aprire un file PDF in una versione di Internet Explorer a 64 bit, il PDF non viene aperto in Internet Explorer, bensì in una versione autonoma di Acrobat o Reader.

Nota:

Internet Explorer 9 è supportato solo da Reader 10.1 o Acrobat 10.1.

Per verificare che stiate utilizzando una versione a 32 bit di Internet Explorer, procedete come segue:

  1. In Internet Explorer, scegliete ? > Informazioni su Internet Explorer. (In alcune versioni di Internet Explorer, per accedere alle informazioni sull'applicazione è sufficiente selezionare il punto interrogativo nell'angolo in alto a destra.)

    Informazioni su Internet Explorer 9

    Se viene visualizzato il messaggio "Edizione a 64 bit" accanto alla versione, passate al punto 2.

    Internet Explorer a 64 bit
  2. Per passare a Internet Explorer a 32 bit, prima uscite da Internet Explorer a 64 bit. Poi fate doppio clic sull'icona del programma per la versione a 32 bit:

    C:\Programmi (x86)\Internet Explorer\iexplore.exe

    Internet Explorer a 32 bit

Soluzioni Reader e Acrobat

Riparare Reader o Acrobat

È possibile che Reader o Acrobat siano danneggiati. La riparazione dell'installazione è un buon metodo per risolvere rapidamente il problema.

Riparazione all'interno di Reader o Acrobat

Scegliete ? > Ripara installazione.

?, Ripara installazione

Riparazione tramite il Pannello di controllo (Windows)

Potete anche riparare l'installazione di Acrobat o Reader utilizzando il Pannello di controllo di Windows.

  1. Chiudete Reader o Acrobat.

  2. Fate clic su Start > Pannello di controllo.

    Avviate il Pannello di controllo
  3. Nel Pannello di controllo, effettuate una delle seguenti operazioni, a seconda della versione di Windows:

    • (Windows 8/7/Vista) Fate clic su Programmi, quindi su Programmi e funzionalità.
    • (Windows XP) Fate doppio clic su Installazione applicazioni.
  4. Nell'elenco dei programmi, selezionate Adobe Reader o Adobe Acrobat.

  5. Fate clic su Modifica e seguite le istruzioni per riparare l'applicazione.

    Per riparare, fate clic su Modifica
  6. Al termine della procedura, fate clic su Fine.

Soluzioni avanzate

Se nessuna delle soluzioni nelle sezioni precedenti risolve il problema con la visualizzazione dei file PDF, si possono provare i seguenti passaggi avanzati.

Abilitare il componente aggiuntivo per browser Adobe PDF (Internet Explorer 8 e versioni successive)

Verificate che il componente aggiuntivo per browser Adobe PDF sia attivato.

  1. Aprite Internet Explorer e selezionate Strumenti > Gestione componenti aggiuntivi.

  2. In Tipi di componenti aggiuntivi, selezionate Barre degli strumenti ed estensioni.

  3. Nel menu a comparsa Mostra, selezionate Tutti i componenti aggiuntivi.

    Tutti i componenti aggiuntivi
  4. Nell’elenco dei componenti aggiuntivi, selezionate Adobe PDF Reader.

    Nota:

    Se non vedete il componente aggiuntivo Adobe PDF Reader, provate le altre opzioni del menu. Ad esempio, su alcuni sistemi, il componente aggiuntivo diventa visibile se si seleziona Esegui senza autorizzazione.

  5. Cliccate il pulsante Abilita.

    Nota:

    Se il pulsante viene visualizzato come Disabilita, il componente aggiuntivo è già attivato. Questo pulsante consente di attivare e disattivare, a seconda dello stato del componente aggiuntivo selezionato.

    Abilita permette al componente aggiuntivo di PDF Reader di aprire i file PDF nel browser.

    Disabilita disattiva il componente aggiuntivo e non permette l'apertura dei file PDF nel browser.

    Abilitare Acrobat Reader

Abilitare il componente aggiuntivo per browser Adobe PDF (Firefox)

Verificate che il componente aggiuntivo per browser Adobe PDF (nppdf32.dll) sia attivato.

  1. Nella barra degli indirizzi di Firefox, digitate about:plugins

  2. Scorrete verso il basso fino a visualizzare la sezione denominata Adobe Acrobat.

    Abilitato in Firefox
  3. Verificate che in Nome file venga visualizzato come "nppdf32.dll" e "Adobe Acrobat Plug-In for Netscape".
    Se questa voce non è disponibile, installate l'ultima versione di Reader o Acrobat.

Eseguire Acrobat o Reader in un nuovo account amministratore locale.

Create un account utente che disponga delle stesse autorizzazioni di quello in uso al momento in cui si è verificato il problema. In alternativa, create un account amministratore locale. Se il problema non si ripete quando accedete al nuovo account, l'account utente utilizzato in precedenza potrebbe essere danneggiato.

Per informazioni sull'impostazione di un account utente, consultate le seguenti risorse, oppure contattate l'amministratore di rete:

Windows XP: per aggiungere un nuovo utente al computer

Windows Vista/7/8: creare un account utente

Mac OS X: configurare gli utenti su Mac

Ottimizzare i file PDF di grandi dimensioni

Se il file PDF ha dimensioni pari o superiori a 4 MB, richiedete al provider di ottimizzare il file PDF. Per informazioni sull'ottimizzazione di file PDF, consultate Ottimizzare file PDF.

Controllare il percorso del Registro di sistema di Acrobat o Reader (Windows)

Dichiarazione di non responsabilità: il registro contiene informazioni relative al sistema, essenziali per il computer e le applicazioni. Prima di modificare il registro, eseguite una copia di backup dello stesso. Adobe non fornisce supporto per problemi derivanti da una modifica inappropriata del registro. Il registro deve essere modificato solo da utenti che hanno esperienza nella modifica di file di sistema. Per ulteriori informazioni sul registro, consultate la documentazione di Windows o contattate Microsoft.

  1. Scegliete Start > Esegui.

  2. Digitate regedit e fate clic su OK.

  3. Accedete alla chiave HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  4. Assicuratevi che sia impostato il valore (Predefinito) per il percorso in cui è installato Acrobat o Reader.

    • Il percorso predefinito per Reader è "C:\Programmi(x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe".
    • Il percorso predefinito per Acrobat è "C:\Programmi(x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe".

    Nota:

    Se Acrobat o Reader non sono installati nel percorso predefinito, verificate che al valore (Predefinito) della chiave corrisponda il percorso effettivo.

Per guardare un video dimostrativo su questa procedura, consultate Verificare il corretto percorso del registro.

Nel caso in cui la chiave di registro indicata sopra non esista nel sistema, procedete come segue:

  1. Scegliete Start > Esegui.

  2. Digitate regedit e fate clic su OK.

  3. Eseguite il backup del file del registro di sistema corrente:

    • Nella finestra di dialogo Editor del Registro di sistema, scegliete File > Esporta.
    • Digitate un nome e selezionate un percorso per il file.
    • Per Intervallo di esportazione, scegliete Tutto.
    • Fate clic su Salva.
  4. Scegliete Modifica > Nuovo > Chiave e create la chiave mancante HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  5. Scegliete Modifica > Nuovo > Valore stringa e per questa chiave immettete il nome (Predefinito).

  6. Selezionate (Predefinito) e accedete a Modifica > Modifica. Digitate il percorso predefinito (indicato sopra) nel campo Dati valore del prodotto.

  7. Riavviate il computer.

Riparare la chiave di registro HKCR\AcroExch.Document (Windows)

È possibile che questa chiave sia danneggiata, punti a una versione obsoleta di Acrobat o Reader o punti a un visualizzatore PDF di terze parti.

Dichiarazione di non responsabilità: il registro contiene informazioni relative al sistema, essenziali per il computer e le applicazioni. Prima di modificare il registro, eseguite una copia di backup dello stesso. Adobe non fornisce supporto per problemi derivanti da una modifica inappropriata del registro. Il registro deve essere modificato solo da utenti che hanno esperienza nella modifica di file di sistema. Per ulteriori informazioni sul registro, consultate la documentazione di Windows o contattate Microsoft.

  1. Scegliete Start > Esegui, digitate regedit nella casella di testo Apri della finestra di dialogo Esegui, quindi fate clic su OK.
    .

  2. Eseguite il backup del file del registro di sistema corrente:

    • Nella finestra di dialogo Editor del Registro di sistema, scegliete File > Esporta.
    • Digitate un nome e selezionate un percorso per il file.
    • Per Intervallo di esportazione, scegliete Tutto.
    • Fate clic su Salva.
  3. Accedete a HKEY_CLASSES_ROOT\AcroExch.Document.

  4. Fate clic con il pulsante destro del mouse su AcroExch.Document e scegliete Elimina. Verificate di disporre della chiave corretta e fate clic su a ogni prompt.

  5. Fate clic con il pulsante destro del mouse su AcroExch.Document.7 e scegliete Elimina. Verificate di disporre della chiave corretta e fate clic su a ogni prompt.

  6. Questo video illustra le procedure esposte.

     

Modificare l'intestazione del tipo di contenuto nel server Web (amministratori Web)

Nel caso dei webmaster o degli utenti con diritti amministrativi per un sito Web, è necessario configurare il server Web per l'invio delle intestazioni del tipo di contenuto "application/pdf" per i file PDF. Per istruzioni, consultate la documentazione fornita con il server Web, oppure leggete questo articolo di assistenza di Microsoft.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online