La presente guida dettagliata contiene informazioni su come disinstallare o rimuovere Adobe Flash Player dal vostro computer Mac ed eliminare tutti i file correlati.

Queste istruzioni NON sono applicabili a Flash Player incluso in Google Chrome. Visitate la pagina della guida di Flash Player per istruzioni su come attivare (o disattivare) Flash Player in vari browser.

Gli utenti Windows possono consultare°Disinstallazione di Flash Player | Windows.

Informazioni su Flash Player

Se Flash Player è installato nel computer in uso, la casella seguente visualizza la versione di Flash Player e del sistema operativo. Se Flash Player non è installato, viene visualizzato un messaggio di errore.

 

Installazione di Flash Player non riuscita

Se Flash Player non viene installato correttamente, seguite la procedura indicata di seguito per eseguire nuovamente l'installazione.

Soluzione: scaricate ed eseguite il programma di disinstallazione

1. Verificate la versione di Mac OS in uso 

  • Fate clic sull'icona Apple e scegliete Informazioni su questo Mac.

    La versione del sistema operativo Mac è visualizzata nella finestra di dialogo Informazioni su questo Mac.


2. Eseguite il programma di disinstallazione corrispondente alla versione di Mac OS in uso

Nota:

a partire da Flash Player 11.5, la disinstallazione di Flash Player ripristina le impostazioni AutoUpdateDisable e SilentAutoUpdateEnable in mms.cfg sui valori predefiniti, che sono:

  • AutoUpdateDisable=0
  • SilentAutoUpdateEnable=0

Se eseguite il programma di disinstallazione di Flash Player come parte del processo di distribuzione, è necessario ridistribuire tutte le modifiche personalizzate apportate ad AutoUpdateDisable o a SilentAutoUpdateEnable.

Esegui il programma di disinstallazione in Mac OS X 10.4 e versioni successive, compreso macOS

  1. Scaricate il programma di disinstallazione di Adobe Flash Player:

    Per impostazione predefinita, il programma di disinstallazione viene scaricato nella cartella Download del browser.

  2. In Safari, scegliete Finestra > Download.

    Se utilizzate Mac OS X 10.7 (Lion), fate clic sull'icona Download visualizzata nel browser.

    Fate clic sull'icona dei download.

    In Mozilla, scegliete Strumenti > Download.

  3. Per aprire il programma di disinstallazione, fate doppio clic sulla relativa voce nella finestra di download.

    Nota: se la finestra del programma di installazione di Flash Player non viene visualizzata, scegliete Vai > Scrivania nel Finder. Scorrete verso il basso fino alla sezione Dispositivi e fate clic su Disinstalla Flash Player.

  4. Per eseguire il programma di disinstallazione, fate doppio clic sulla relativa icona nella finestra. Se viene visualizzato un messaggio per confermare se aprire il file del programma di disinstallazione, fate clic su Apri.

  5. Quando il programma di disinstallazione si avvia, fate clic su Disinstalla.
  6. Aggiungete la pagina ai segnalibri o stampatela, in modo da poter utilizzare il resto delle istruzioni dopo la chiusura del browser.
  7. Per chiudere tutti i browser, fate clic sul nome del browser nella finestra di dialogo del programma di disinstallazione, oppure chiudete ciascun browser manualmente e fate clic su Riprova.

    Nota: non fate clic su Esci nella finestra del programma di disinstallazione, poiché interrompe il processo di disinstallazione.

  8. Dopo aver chiuso i browser, il programma di disinstallazione continua automaticamente finché la disinstallazione non viene completata. Quando viene visualizzato il messaggio con la notifica che la disinstallazione è riuscita, fate clic su Fine.



  9. Eliminate le seguenti directory:

    • <directory principale>/Libreria/Preferences/Macromedia/Flash\ Player
    • <directory principale>/Libreria/Caches/Adobe/Flash\ Player

Esegui il programma di disinstallazione su Mac OS X dalla versione 10.1 alla versione 10.3

  1. Scaricate il programma di disinstallazione di Adobe Flash Player:

  2. Scegliete Finestra > Download per visualizzare il programma di disinstallazione scaricato.

  3. Salvate il file del programma di disinstallazione in una posizione di vostra scelta.

  4. Per aprire il programma di disinstallazione, fate doppio clic sulla relativa voce nella finestra di download.

  5. Per eseguire il programma di disinstallazione, fate doppio clic sulla relativa icona nella finestra. Se richiesto, immettete il nome utente e la password del computer e fate clic su OK.

  6. All'avvio del programma di disinstallazione, fate clic su Continua.

  7.  Aggiungete la pagina ai segnalibri o stampatela, in modo da poter utilizzare il resto delle istruzioni dopo la chiusura del browser. Chiudete tutti i browser e altre applicazioni che utilizzano Flash Player, come quelle di messaggistica istantanea, file SWF e proiettori (file EXE che riproducono file SWF), altrimenti non è possibile portare a termine la disinstallazione (anche se appare completa).

    Una volta terminata la disinstallazione, la finestra si chiude automaticamente.

  8. Testo del passaggio

3. Verificate che l'installazione sia stata completata

È possibile verificare che la disinstallazione venga completata effettuando le seguenti operazioni:

  1. Riavviate il computer.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online