Use the Liquify filter

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and Adobe services
    1. Photoshop and Adobe Stock
    2. Creative Cloud Libraries
    3. Creative Cloud Libraries in Photoshop
    4. Grid and guides
    5. Creating actions
    6. Undo and history
    7. Default keyboard shortcuts
    8. Touch capabilities and customizable workspaces
    9. Use the Touch Bar with Photoshop
    10. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export cloud documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. System requirements 1.x | Photoshop on the iPad
    23. System requirements 2.x | Photoshop on the iPad
    24. Edit your image size
    25. Livestream as you create in Photoshop on the iPad
    26. Correct imperfections with the Healing Brush
    27. Create brushes in Capture and use them in Photoshop
  5. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud doc sync logs
    8. Share access and edit your cloud documents
  6. Workspace
    1. Workspace basics
    2. Create documents
    3. Use the Touch Bar with Photoshop
    4. Microsoft Dial support in Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Quickly share your creations
    13. Place Photoshop images in other applications
    14. Preferences
    15. Default keyboard shortcuts
    16. Rulers
    17. Show or hide non-printing Extras
    18. Specify columns for an image
    19. Undo and history
    20. Panels and menus
    21. Place files
    22. Position elements with snapping
    23. Position with the Ruler tool
    24. Presets
    25. Customize keyboard shortcuts
    26. Grid and guides
  7. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Export files in Photoshop
    4. Device Preview
    5. Copy CSS from layers
    6. Slice web pages
    7. HTML options for slices
    8. Modify slice layout
    9. Work with web graphics
    10. Create web photo galleries
  8. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  9. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  10. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  11. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  12. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  13. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  14. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  15. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Fill and stroke selections, layers, and paths
    14. Draw with the Pen tools
    15. Create patterns
    16. Generate a pattern using the Pattern Maker
    17. Manage paths
    18. Manage pattern libraries and presets
    19. Draw or paint with a graphics tablet
    20. Create textured brushes
    21. Add dynamic elements to brushes
    22. Gradient
    23. Paint stylized strokes with the Art History Brush
    24. Paint with a pattern
    25. Sync presets on multiple devices
  16. Text
    1. Work with OpenType SVG fonts
    2. Format characters
    3. Format paragraphs
    4. How to create type effects
    5. Edit text
    6. Line and character spacing
    7. Arabic and Hebrew type
    8. Fonts
    9. Troubleshoot fonts
    10. Asian type
    11. Create type
    12. Text Engine error using Type tool in Photoshop | Windows 8
    13. World-Ready composer for Asian Scripts
    14. How to add and edit text in Photoshop
  17. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  18. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  19. Saving and exporting
    1. Save files in graphics formats
    2. Save your files in Photoshop
    3. File formats
    4. Save and export video and animations
    5. Save PDF files
    6. Digimarc copyright protection
  20. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  21. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  22. 3D and technical imaging
    1. Creative Cloud 3D Animation (Preview)
    2. Print 3D objects
    3. 3D painting
    4. 3D panel enhancements | Photoshop
    5. Essential 3D concepts and tools
    6. 3D rendering and saving
    7. Create 3D objects and animations
    8. Image stacks
    9. 3D workflow
    10. Measurement
    11. DICOM files
    12. Photoshop and MATLAB
    13. Count objects in an image
    14. Combine and convert 3D objects
    15. 3D texture editing
    16. Adjust HDR exposure and toning
    17. 3D panel settings
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors

Liquify filter overview

The Liquify filter lets you push, pull, rotate, reflect, pucker, and bloat any area of an image. The distortions you create can be subtle or drastic, which makes the Liquify command a powerful tool for retouching images as well as creating artistic effects. The Liquify filter can be applied to 8‑bits per-channel or 16‑bits per-channel images.

Photoshop Distorting an image using the Liquify filter
Distorting an image using the Liquify filter

Tools, options, and an image preview for the Liquify filter are available in the Liquify dialog box. To display the dialog box, choose Filter > Liquify. Select Advanced Mode to access more options.

Magnify or reduce the preview image

Select the Zoom tool in the Liquify dialog box, and click or drag in the preview image to zoom in; hold down Alt (Windows) or Option (Mac), and click or drag in the preview image to zoom out. Alternatively, you can specify a magnification level in the Zoom text box at the bottom of the dialog box.

Select the Hand tool in the Liquify dialog box, and drag in the preview image. Alternatively, hold down the spacebar with any tool selected, and drag in the preview image.

Liquify filter enhancements (Creative Cloud only)

In the Creative Cloud version of Photoshop, the Liquify filter is significantly faster than previous versions. The Liquify filter now supports Smart Objects, including Smart Object video layers, and is applied as a smart filter.

Another enhancement to the Liquify filter is an added behavior for the Reconstruct tool. If you hold down the alt (Windows) or Option (Mac OS) key while dragging the tool across a warp, the Reconstruct tool smooths a warp rather than scaling back or removing it.

Applying Liquify as a smart filter (Creative Cloud only)

The Liquify filter supports Smart Objects, including Smart Object video layers, and is applied as a smart filter. When applying the Liquify filter to a Smart Object, meshes are now automatically saved into your document. Meshes applied to Smart Objects are compressed and re-editable when reapplying the Liquify filter. Keep in mind that the embedded meshes, even compressed ones, increase the file size.

To apply the Liquify filter as a smart filter:

  1. In the Layers panel, select a Smart Object layer.
  2. Choose Filter > Liquify.

Face-Aware Liquify

Introduced in Photoshop CC 2015.5 release

The Liquify filter features advanced face-aware functionality that automatically identifies eyes, noses, mouths, and other facial features, making it easy for you to adjust them. Face-Aware Liquify is great for retouching portrait photos, creating caricatures, and doing much more.

You can use Face-Aware Liquify as a smart filter for non-destructive editing. See Apply smart filters in Photoshop to understand how.

Prerequisite: Enable the graphics processor

As a prerequisite to using Face-aware Liquify functionality, ensure that the graphics processor is enabled in your Photoshop preferences.

  1. Choose Edit > Preferences > Performance.
  2. In the Graphics Processor Settings area, select Use Graphics Processor.
  3. Click Advanced Settings. Ensure that Use Graphics Processor To Accelerate Computation is selected.
  4. Click OK.

These settings are enabled by default when you launch Photoshop for the first time. If you have questions regarding GPU usage in Photoshop, consult this document.

Adjust facial features using on-screen handles

  1. In Photoshop, open an image with one or more faces.
  2. Select Filter > Liquify. Photoshop opens the Liquify filter dialog.
  3. In the Tools panel, select (Face tool; keyboard shortcut: A). The faces in the photo are automatically identified.
Faces automatically identified
Faces automatically identified

  1. When you hover the pointer over the faces, Photoshop displays intuitive on-screen controls around them. Adjust the controls to make adjustments to the faces. For example, you can increase the eye size or decrease the face width.
  2. When you're satisfied with the changes, click OK.

Adjust facial features using sliding controls

  1. In Photoshop, open an image with one or more faces.
  2. Select Filter > Liquify. Photoshop opens the Liquify filter dialog.
  3. In the Tools panel, select (Face tool; keyboard shortcut: A).

    The faces in the photo are automatically identified and one of the faces selected. The identified faces are also listed in the Select Face pop-up menu in the Face-Aware Liquify area of the Properties panel. You can select a different face by clicking it on the canvas or selecting it from the pop-up menu.
Select face
The Select Face field

  1. Adjust the sliders in the Face-Aware Liquify area to make appropriate changes to the facial features.

Move the slider options for the left and right eyes to apply independent/asymmetrical effects to the eyes.

Eye settings - asymmetrical effects

Click the link icon  to lock the settings for the left and right eyes together. This option helps apply symmetrical effects to the eyes.

Eye settings - symmetrical effects

Nose settings

Mouth settings

Face Shape settings

  1. When you're satisfied with the changes, click OK.
Piezīme.

You can use a combination of on-screen handles and sliding controls for better control over Face-Aware Liquify changes.

Useful considerations

  • Face-Aware Liquify functionality works best on facial features facing the camera. For best results, rotate any titled faces before applying the settings.
  • The Reconstruct and Restore All options don't apply to Face-Aware Liquify changes. Use Reset and All options in the Face-Aware Liquify area to reset the changes applied to a selected face and all faces, respectively.

Distortion tools

Several tools in the Liquify dialog box distort the brush area when you hold down the mouse button or drag. The distortion is concentrated at the center of the brush area, and the effect intensifies as you hold down the mouse button or repeatedly drag over an area.

Forward Warp tool 

Pushes pixels forward as you drag.

Piezīme.

Shift-click with the Warp tool, the Push Left tool, or the Mirror tool to create the effect of dragging in a straight line from the previous point you clicked.

Reconstruct tool 

Reverses the distortion you’ve already added, as you hold down the mouse button and drag.

Twirl Clockwise tool 

Rotates pixels clockwise as you hold down the mouse button or drag. To twirl pixels counterclockwise, hold down Alt (Windows) or Option (Mac OS) as you hold down the mouse button or drag.

Pucker tool 

Moves pixels toward the center of the brush area as you hold down the mouse button or drag.

Bloat tool 

Moves pixels away from the center of the brush area as you hold down the mouse button or drag.

Push Left tool 

Moves pixels to the left when you drag the tool straight up (pixels move to the right if you drag down). You can also drag clockwise around an object to increase its size, or drag counterclockwise to decrease its size. To push pixels right when you drag straight up (or to move pixels left when you drag down), hold down Alt (Windows) or Option (Mac OS) as you drag.

Distortion tool options

In the tool options area of the dialog box, set the following options:

Brush Size

Sets the width of the brush you’ll use to distort the image.

Brush Density

Controls how a brush feathers at the edge. An effect is strongest in the center of the brush and lighter at the edge.

Brush Pressure

Sets the speed at which distortions are made when you drag a tool in the preview image. Using a low brush pressure makes changes occur more slowly, so it’s easier to stop them at exactly the right moment.

Brush Rate

Sets the speed at which distortions are applied when you keep a tool (such as the Twirl tool) stationary in the preview image. The higher the setting, the greater the speed at which distortions are applied.

Stylus Pressure

Uses pressure readings from a stylus tablet. (This option is available only when you are working with a stylus tablet.) When selected, the brush pressure for the tools is the stylus pressure multiplied by the Brush Pressure value.

Distort an image

Piezīme.

If a type layer or a shape layer is selected, you must rasterize the layer before proceeding, making the type or shape editable by the Liquify filter. To distort type without rasterizing the type layer, use the Warp options for the Type tool.

  1. Select the layer you want to distort. To change only part of the current layer, select that area.
  2. Choose Filter > Liquify.
  3. Freeze areas of the image that you don’t want to alter.
  4. Choose any of the liquify tools to distort the preview image. Drag in the preview image to distort the image.
  5. After distorting the preview image, you can:
    • Use the Reconstruct tool  or Reconstruct Options to fully or partially reverse the changes.

    • Use other tools to change the image in new ways.

  6. Do one of the following:
    • Click OK to close the Liquify dialog box and apply the changes to the active layer.

    • Click Cancel to close the Liquify dialog box without applying changes to the layer.

    • Hold down Alt (Windows) or Option (Mac OS) and click Reset to revert all distortions to the preview image and reset all options to their defaults.

    Piezīme.

    You can use the Edit > Fade command to create additional effects.

Freeze and thaw areas

You can freeze areas that you don’t want to modify or thaw frozen areas to make them editable again. You can also invert both frozen and thawed areas.

Freeze areas

By freezing areas of the preview image, you protect those areas from changes. Frozen areas are covered by a mask that you paint using the Freeze Mask tool . You can also use an existing mask, selection, or transparency to freeze areas. You can view the mask in the preview image to help you apply distortions.

Using the Freeze Mask tool

Select the Freeze Mask tool  and drag over the area you want to protect. Shift-click to freeze in a straight line between the current point and the previously clicked point.

Using an existing selection, mask, or transparency channel

If you’re applying the Liquify filter to a layer with a selection, layer mask, transparency, or alpha channel, choose Selection, Layer Mask, Transparency, or Quick Mask from any of the five icons’ pop‑up menu in the Mask Options area of the dialog box. This determines how areas of the preview image are frozen or masked.

Freezing all thawed areas

Click Mask All in the Mask Options area of the dialog box.

Inverting thawed and frozen areas

Click Invert All in the Mask Options area of the dialog box.

Showing or hiding frozen areas

Select or deselect Show Mask in the View Options area of the dialog box.

Changing the color of frozen areas

Choose a color from the Mask Color pop‑up menu in the View Options area of the dialog box.

Mask options with the Liquify filter

When you have an existing selection, transparency, or mask in an image, that information is retained when the Liquify dialog box opens. You can choose one of the following mask options:

Replace Selection 

Shows the selection, mask, or transparency in the original image.

Add To Selection 

Shows the mask in the original image, so that you can add to the selection using the Freeze Mask tool. Adds selected pixels in channel to the current frozen area.

Subtract From Selection 

Subtracts pixels in channel from the current frozen area.

Intersect With Selection 

Uses only pixels that are selected and currently frozen.

Invert Selection 

Uses selected pixels to invert the current frozen area.

Piezīme.

If a selection exists, the filter limits the preview and processing to the rectangular area containing that selection. (For rectangular marquee selections, the selected area and preview are identical, so choosing Selection from the mask option menus above has no effect.)

Thaw areas

To thaw frozen areas so they’re editable, do any of the following:
  • Select the Thaw Mask tool , and drag over the area. Shift-click to thaw in a straight line between the current point and the previously clicked point.

  • To thaw all frozen areas, click the None button in the Mask Options area of the dialog box.

  • To invert frozen and thawed areas, click Invert All in the Mask Options area of the dialog box.

Work with meshes

Using a mesh helps you see and keep track of distortions. You can choose the size and color of a mesh, and save the mesh from one image and apply it to other images.

  • To show a mesh, select Show Mesh in the View Options area of the dialog box, and choose a mesh size and mesh color.

  • To only show a mesh, select Show Mesh and then deselect Show Image.

  • To save a distortion mesh, after distorting the preview image, click Save Mesh. Specify a name and location for the mesh file, and click Save.

  • To apply a saved distortion mesh, click Load Mesh, select the mesh file you want to apply, and click Open. If the image and distortion mesh aren’t the same size, the mesh is scaled to fit the image.

  • To apply the last saved distortion mesh, click Load Last Mesh.

  • (Creative Cloud) Meshes are automatically saved in your document. Meshes applied to Smart Objects are compressed and re-editable.

Piezīme.

(Creative Cloud) Embedded meshes, even compressed ones, increase file size.

Work with backdrops

You can choose to show only the active layer in the preview image, or you can show additional layers in the preview image as a backdrop. Using the Mode options, you can position the backdrop in front of or behind the active layer to keep track of your changes, or to line up a distortion with another distortion made in a different layer.

Piezīme.

Only the active layer is distorted, even if other layers are displayed.

Showing the backdrop

Select Show Backdrop, and then choose Background from the Use menu and an option from the Mode menu.

Showing changes to the target layer without showing the backdrop

Select All Layers from the Use menu. Setting the Opacity to 0 shows only the target layer with the full effects of the Liquify filter. Setting the Opacity to a higher value shows less of the Liquify filter’s effect on the target layer.

Changing the blending between the target layer and the backdrop

Specify a Opacity value.

Determining how the target layer and the backdrop are combined in the image preview

Choose an option from the Mode menu.

Hiding the backdrop

Deselect Show Backdrop in the View Options area of the dialog box.

Reconstruct distortions

After you distort the preview image, you can use a variety of controls and reconstruction modes to reverse changes or redo the changes in new ways. Reconstructions can be applied two ways. You can apply a reconstruction to the entire image, smoothing out the distortion in unfrozen areas, or you can use the reconstruction tool to reconstruct specific areas. If you want to prevent reconstruction of distorted areas, you can use the Freeze Mask tool.

Photoshop Reconstruction based on distortions in frozen areas
Reconstruction based on distortions in frozen areas.

A. Original image B. Distorted with frozen areas C. Reconstructed in Rigid mode (using button) D. Thawed, edges reconstructed in Smooth mode (using tool) 

Reconstruct an entire image

Click Reconstruct in the Reconstruct Options area of the dialog box. Then, in the Revert Reconstruction dialog box, specify an amount and click OK.

Remove all distortions

Click Restore All in the Reconstruct Option area of the dialog box. This removes distortions even in frozen areas.

Reconstruct part of a distorted image

  1. Freeze areas you want to keep distorted.
  2. Select the Reconstruct tool  and specify brush options in the Tool Options area of the dialog box.
  3. Drag over the area you want to reconstruct. Pixels move more quickly at the brush center. Shift-click to reconstruct in a straight line between the current point and the previously clicked point.
Adobe logotips

Pierakstieties savā kontā