Troubleshooting instructions to resolve XD plugin installation issues.

Issues

In the XD Plugin Manager, the available plugins display a warning sign against the Install button and does not install.

You may face the following issues while installing plugins in XD:

  • Error message such as Failed to update.
  • Issue with the plugin name.
  • Error messages like Extraction failure, or file system error, or plugin not compatible, or unknown error.

Plugin Manager install or update errors

If the Plugin Manager fails to install or update a plugin, an error message appears in the Plugin Manager user interface. 

plugin-error

Permission issues

You might encounter permission issues causing XD not to extract plugin data to the XD plugin destination.

Some of the possible errors due to permission issue can be:

  • NSCocoaErrorDomain: 513
  • errno 13
  • errno 2

Refer to How to fix permission errors on mac OS.

Plugin xdx install error

You might encounter install issues after double clicking .xdx plugin packages.

xdx install error
xdx install error

Possible error messages

  • Plugin not compatible

The download plugin extracted but there was an issue with plugin description file (manifest). Try re-downloading the plugin.

  • Extraction failure

The compressed plugin file is corrupt, missing one of the plugin files or ran out of disk space, Ensure that you have enough free disk space and try re-downloading the plugin

  • File system error

These are usually permission errors or disk space related. Ensure that you have enough disk space and refer to How to fix permission errors on mac OS.

  • Unknown Error

Root cause

This error is due to permission issues on /Users/<user name>/Library/Application Support/Adobe.

The pattern of root cause for the error messages can be as errno: A or NSCocoaErrorDomain B, where A and B represent an integer number provided by operating system.

A sample error message dialog is shown below for your reference: 

Sample error message
Sample error message

Piezīme.

The integer number may differ for macOS and Windows. 

How to fix permission errors on macOS

Follow these steps to learn how to fix permission errors on mac OS:

  1. Open the Finder and  navigate to /Users/<user name>/Library/Application Support/.

    To enable the Library folder (if hidden):

    1. Select the Go menu and choose Home or from the Favorites section in the Finder, select <user name>.
    2. Select the View menu and choose Show View Options.
    3. From the pop-up menu, select Show Library Folder.
    Show Library Folder
    Show Library Folder
  2. Select the Adobe folder and choose File > Get Info.

  3. In the Adobe Info menu, deselect the Locked option within the General section and enter an administrator name and password.

    Locked option
    Locked option
  4. Within the Sharing & Permissions section, select your <user name> and change its privilege to Read & Write. If the privilege is already set to Read & Write, proceed to step 5.

  5. Click the gear icon below the Sharing & Permissions section and choose Apply to enclosed items.

    Gear icon
    Gear icon
  6. Close the Adobe Info menu to cascade the changes.

If the problem persists, visit Adobe Help Center for the solution. 

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