طرق لإعادة استخدام الرسومات والنص

يوفر InDesign طرق متعددة لإعادة استغلال الرسوم والنص.

القصاصات

القصاصة هي ملف يحتوي على كائنات ويصف أماكنها بالنسبة للكائنات الأخرى الموجودة على الصفحة أو حيز الصفحة. (راجع استخدام القصاصات.)

مكتبات الكائنات

توفر مكتبة الكائنات مكان ملائم لتخزين العناصر مثل الشعارات والشرائط الجانبية والنصوص الجاذبة والعناصر المتكررة الأخرى. (راجع استخدام مكتبات الكائنات.)

القوالب

القالب هو مستند يتضمن أماكن مؤقتة للنص والرسوم. (راجع استخدام قوالب المستند.)

استخدام القصاصات

القصاصة هي ملف يحفظ كائنات ويصف أماكنها بالنسبة للكائنات الأخرى الموجودة على الصفحة أو حيز الصفحة. استخدم القصاصات لإعادة استخدام ووضع كائنات الصفحة بشكل مناسب. إنشاء قصاصة بحفظ كائنات في ملف قصاصة، والذي له امتداد .IDMS. (الإصدار السابق من InDesign يستخدم الامتداد .INDS) عندما تقوم بوضع ملف قصاصة في InDesign، يمكنك تحديد ما إذا كانت الكائنات توضع في أماكنها الأصلية أو حيث تقوم بالنقر. يمكنك تخزين قصاصات في مكتبة الكائنات وفي Adobe Bridge كذلك على قرصك الصلب.

تبقى محتويات القصاصات على ارتباطها بالطبقة عندما تقوم بوضعهم. عندما تحتوي قصاصة على تعريفات مصادر وتلك المصادر تكون موجودة أيضًا في المستند الذي نسخت إليه، تستخدم القصاصة تعريفات المصدر في المستند.

يمكن فتح القصاصات التي تقوم بإنشائها في InDesign CS5 في InDesign CS4، ولكن لا يمكن ذلك في أية إصدارات سابقة أخرى من InDesign.

إنشاء القصاصات

  1. قم بتنفيذ أحد الإجراءات التالية:
    • باستخدام أداة التحديد، حدد إطار أو أكثر، ثم اختر File > Export. من قائمة Save As Type (في Windows) أو Format (في Mac OS)، اختر InDesign Snippet. اكتب اسم للملف، ثم انقر Save.

    • باستخدام أداة التحديد، حدد كائن أو أكثر، ثم اسحب التحديد إلى سطح مكتبك. تم إنشاء الملف. أعد تسمية الملف.

    • حدد كائنًا أو أكثر، ثم اسحب التحديد إلى لوحة Mini Bridge. تم إنشاء الملف. أعد تسمية الملف.

    • اسحب عنصر من منظر الهيكل إلى سطح المكتب.

إضافة قصاصة إلى مستند

  1. اختر File > Place.
  2. قم بتحديد ملف قصاصة (*.IDMS أو *.INDS) أو أكثر.
  3. انقر مؤشر القصاصة المحملة حيث تريد أن تكون الزاوية العليا اليسرى من ملف القصاصة.

    إذا وضعت علامة الإدخال في إطار نص، فإن القصاصة توضع في النص ككائن مرتبط.

    تبقى كل الملفات محددة بعد أن تضع القصاصة. بالسحب، يمكنك ضبط موضع كل الكائنات.

  4. إذا قمت تحميل أكثر من قصاصة، انزلق وانقر مؤشر القصاصة المحملة لوضع الآخرين.

ملاحظة:

يمكنك سحب ملف قصاصة من سطح مكتبك إلى مستند InDesign ونقر حيث تريد أن تكون الزاوية العليا اليسرى.

اختر كيفية وضع القصاصة

بدلاً من وضع كائنات قصاصة طبقاً لمكان النقر فوق صفحة ما، يمكنك وضعهم في أمكانهم الأصلية. على سبيل المثال، إطار النص الذي يظهر في منتصف صفحة عندما تم جعله جزء من قصاصة يمكن أن يظهر في نفس المكان عندما تضعه كقصاصة.

  1. من تفضيلات معالجة الملفات، اختر الموقع الأصلي من قائمة وضع في للاحتفاظ بمواقع الكائنات الأصلية في القصاصات. اختر موقع المؤشر من قائمة وضع في، وذلك لتضمين القصاصات وفقًا لموضع النقر فوق الصفحة.

ملاحظة:

يمكنك ضغط Alt (في Windows) أو Option (في Mac) لتخطي إعدادات الوضع التي حددتها لمعالجة القصاصات. على سبيل المثال، إذا حددت وضع عند مكان المؤشر لكنك تريد أن تضع كائنات القصاصة في أماكنها الأصلية، ابق مفتاح Alt/Option مضغوطاً عندما تنقر مؤشر القصاصة المحملة على الصفحة.

استخدام مكتبات الكائن

مكتبات الكائنات تساعدك في تنظيم الرسومات، النص، والصفحات التي تستخدمها بشكل شبه دائم. يمكنك أيضاً إضافة أدلة المساطر، الشبكات، الأشكال المرسومة، والصور المجموعة في مكتبة. يمكنك إنشاء مكتبات متعددة حسب حاجتك- على سبيل المثال، يمكنك إنشاء مكتبات كائن مختلفة لمشاريع أو عملاء مختلفين.

أثناء العمل، يمكنك فتح مكتبات متعددة بمقدار ما تتيح ذاكرة النظام. مكتبات الكائنات يمكن مشاركتها عبر الخوادم وعبر بيئات العمل لكن يمكن لشخص واحد فقط فتح المكتبة في وقت واحد. إذا شملت مكتبة كائن ملفات نص، تأكد من أن خطوط الملف متوفرة ونشطة في كل الأنظمة التي ستدخل إلى المكتبة.

عندما تقوم بإضافة عنصر صفحة، مثل رسم، إلى مكتبة كائن، يحتفظ InDesign بكل الخصائص التي تم إدراجها أو تطبيقها. على سبيل المثال، إذا قمت بإضافة رسم من مستند InDesign إلى مكتبة، فإن نسخة المكتبة ستقوم بتكرار الأصل بما في ذلك معلومات الربط الأصلية، بحيث يمكنك تحديث الرسم عندما يتغير الملف في القرص.

إذا قمت بحذف الكائن من مستند InDesign، سيظل مصغر الكائن يظهر في لوحة المكتبة، وتبقى كل معلومات الرابط كما هي. إذا قمت بنقل أو حذف الكائن الأصلي، ستظهر أيقونة رابط مفقود بجوار اسم الكائن في لوحة الروابط في المرة التالية تقوم فيها بوضعه في وثيقتك من لوحة المكتبة.

مع كل مكتبة كائن يمكنك التعرف والبحث عن عنصر بالعنوان، بتاريخ إضافته إلى المكتبة أو بالكلمات المفتاحية. يمكنك أيضاً تبسيط عرض مكتبة كائن بترتيب عناصر المكتبة وعرض مجموعاتها الفرعية. على سبيل المثال يمكنك إخفاء كل العناصر ما عدا ملفات EPS.

مكتبة كائنات في لوحة المكتبة
مكتبة كائنات في لوحة المكتبة

A. اسم ومصغر كائن B. الزر Library Item Information C. الزر Show Library Subset D. الزر New Library Item E. الزر Delete Library Item 

عندما تقوم بإضافة عنصر إلى مكتبة كائنات، فإن InDesign يحفظ كل خصائص الصفحات، النص، والصورة تلقائياً، ويحافظ على العلاقات بين مكتبات الكائنات وعناصر الصفحة الأخرى بالطرق التالية:

  • العناصر المجمعة في مستند InDesign عند السحب إلى لوحة المكتبة تبقى مجمعة عندما يتم سحبهم إلى خارج لوحة المكتبة.

  • يحتفظ النص بتنسيقه.

  • أنماط الفقرة وأنماط الحرف وأنماط الكائن التي لها نفس أسماء الأنماط المستخدمة في المستند الهدف يتم تحويلهم إلى أنماط المستند الهدف، وأولئك الذين لهم أسماء مختلفة يتم إضافتهم إلى المستند.

  • يتم الاحتفاظ بالطبقات الأصلية لكائن عندما يكون خيار طبقات تذكر اللصق محددًا في قائمة لوحة الطبقات.

إنشاء مكتبة كائن

توجد مكتبة الكائنات كملف مسمى على القرص. عندما تقوم بإنشاء مكتبة كائنات، تحدد أين يتم تخزينها. عندما تقوم بفتح مكتبة ما، تظهر على هيئة لوحة يمكنك تجميعها مع أي لوحة أخرى، ويظهر اسم ملف المكتبة في صفحة اللوحة. إغلاق مكتبة كائنات يزيلها من الرؤية الحالية، لكن لا يحذف ملفها.

يمكنك إضافة أو حذف كائنات، عناصر صفحة محددة، أو كل عناصر الصفحة في أو من مكتبة الكائنات. يمكنك أيضاً إضافة أو نقل كائنات مكتبة من مكتبة إلى أخرى.

  1. اختر File > New > Library.
  2. في مربع الحوار CC Libraries، يمكنك اختيار متابعة استخدام مكتبات كائن InDesign أو يمكنك استخدام CC Libraries لتنظيم جميع الأصول الابتكارية واستعراضها والوصول إليها. لمزيد من التفاصيل، راجع مكتبات Creative Cloud - التعاون ومزامنة الأصول ومشاركتها.

  3. حدد اسم ومكان للمكتبة، وانقر فوق Save. تذكر أن الاسم الذي تحدده يصبح اسم المكتبة في صفحة لوحة المكتبة.

فتح مكتبة موجودة

  1. قم بتنفيذ أحد الإجراءات التالية:
    • إذا قمت بالفعل بفتح مكتبة حالياً (ولم تقم بإغلاقها)، اختر ملف المكتبة من القائمة Window.

    • إذا لم تقم بفتح مكتبة، اختر ملف > فتح، وحدد مكتبة أو أكثر. في Windowsن تستخدم ملفات المكتبة الامتداد INDL. يحول InDesign المكتبات المفتوحة حديثاً من إصدارات سابقة من البرنامج إلى تنسيق مكتبة جديدة؛ يطلب منك أن تقوم بحفظ تلك المكتبات باسم جديد.

إغلاق مكتبة.

  1. انقر صفحة المكتبة التي تريد أن تقوم بإغلاقها.
  2. قم بتنفيذ أحد الإجراءات التالية:
    • اختر Close Library من القائمة Object Library panel.

    • اختر اسم ملف المكتبة في قائمة Window.

حذف مكتبة

  1. - في Explorer (نظام Windows) أو Finder (نظام Mac OS)، اسحب ملف مكتبة إلى Recycle Bin (نظام Windows) أو Trash (نظام Mac OS). في Windows، ملفات المكتبة لها الامتداد INDL.

إضافة كائن أو صفحة إلى مكتبة

  1. قم بتنفيذ أي من الإجراءات التالية:
    • اسحب كائن أو أكثر من نافذة المستند إلى لوحة مكتبة كائنات نشطة.

    • حدد كائنًا أو أكثر في نافذة المستند، وانقر فوق زر New Library Item في لوحة Object Library.

    • حدد كائنًا أو أكثر في نافذة المستند، واختر Add Item في قائمة لوحة Object Library.

    • اختر Add Items On Page [number] As Separate Objects في قائمة لوحة Object Library لإضافة كل الكائنات على هيئة كائنات مكتبة منفصلة.

    • اختر Add Items On Page [number] في قائمة لوحة Object Library لإضافة كل الكائنات على هيئة كائن واحد.

    • اسحب عنصر من لوحة الهيكل إلى لوحة Object Library.

ملاحظة:

إذا قمت بالضغط على مفتاح Alt (في Windows) أو مفتاح Option (في Mac OS) أثناء تنفيذك لأيٍّ من الأوامر السابقة، ستظهر شاشة معلومات العنصر بمجرد إضافة العنصر إلى المكتبة.

إضافة كائن من مكتبة إلى مستند ما

  1. قم بتنفيذ أحد الإجراءات التالية:
    • اسحب كائن من قائمة Object Library panel إلى نافذة مستند.

    • في لوحة مكتبة الكائنات، حدد كائن، واختر Place Item(s)من قائمة Object Library panel. تضع هذه المستند الكائن في إحداثياته س، ص الأصلية.

    • اسحب عنصر XML إلى العنصر الأصل في لوحة Structure أو إلى الصفحة.

إدارة كائنات مكتبة

استخدم لوحة مكتبة كائنات لإدارة الكائنات.

تحديث مكتبة كائنات بعنصر جديد

  1. في نافذة المستند، حدد العنصر الذي تريد إضافته إلى لوحة المكتبة.
  2. في لوحة المكتبة، حدد الكائن الذي تريد استبداله، ثم اختر Update Library من قائمة Object Library panel.

نسخ أو نقل كائن من مكتبة إلى أخرى

  1. اسحب صفحة لوحة مكتبة من مجموعة لوحة مكتبة الكائنات لفصلهم، بحيث يمكنك رؤية المكتبتين في نفس الوقت.
  2. قم بتنفيذ أحد الإجراءات التالية:
    • لنسخ كائن من مكتبة إلي أخرى، اسحب عنصر من صفحة مكتبة إلى أخرى.

    • لنقل كائن خارج مكتبة إلى أخرى، اضغط مع الاستمرار على مفتاح Alt (في Windows) أو مفتاح Option (في Mac OS)، ثم اسحب عنصرًا من صفحة لوحة مكتبة إلى أخرى.

حذف كائن من مكتبة كائنات

  1. في لوحة مكتبات الكائنات، اختر كائن، وقم بتنفيذ أي من الإجراءات التالية:
    • انقر فوق الزر Delete Library Item.

    • اسحب العنصر إلى الزر Delete Library Item.

    • اختر Delete Item‏(s) في قائمة لوحة Object Library.

تغيير عرض مكتبة الكائنات

يمكن أن تعرض مكتبة الكائنات على هيئة مصغرات أو قائمة نصية. يمكنك ترتيب المصغرات أو القائمة النصية حسب اسم الكائن، السن، أو النوع. يعمل عرض القائمة النصية وخيارات الترتيب بأفضل ما يمكن إذا قمت بعمل كتالوج للكائنات.

  1. قم بتنفيذ أي من الإجراءات التالية:
    • لعرض الكائنات على هيئة مصغرات، اختر Thumbnail View أو Large Thumbnail View من قائمة Object Library panel.

    • لعرض الكائنات على هيئة قائمة نصية، اختر List View من قائمة لوحة Object Library.

    • لترتيب الكائنات، اختر Sort Items من قائمة لوحة Object Library، واختر طريقة الترتيب.

عرض كل الكائنات

  1. اختر Show All في قائمة Object Library panel.

عرض، إضافة، أو تحرير معلومات مكتبة

في مكتبات الكائنات الضخمة أو الكبيرة، يمكن تصنيف معلومات المكتبة باستخدام أسماء الكائنات حسب نوع الكائن، أو بالكلمات التوصيفية.

  1. في لوحة مكتبة الكائنات، قم بتنفيذ أي مما يلي:
    • قم بالنقر المزدوج على أي كائن.

    • حدد كائنًا، وانقر فوق زر Library Item Information.

    • حدد كائنًا، واختر Item Information من قائمة لوحة Object Library.

  2. اعرض أو قم بتغيير Item Name، Object Type، أو Description options حسب الضرورة، وانقر فوق OK.

البحث عن كائنات في مكتبة

عندما تقوم بالبحث عن كائنات، يتم إخفاء كل الكائنات ما عدا نتائج بحثك. يمكنك أيضاً استخدام خصائص البحث لإظهار وإخفاء فئات معينة من الكائنات. على سبيل المثال يمكنك عرض عناصر كائن يوجد في اسمها كلمة "نجم".

  1. اختر إظهار مجموعة فرعية في قائمة لوحة مكتبة الكائنات، أو انقر فوق الزر Show Library Subset.
  2. قم بتنفيذ أحد الإجراءات التالية:
    • للبحث في كل كائنات المكتبة، حدد Search Entire Library.

    • للبحث ضمن الكائنات المعروضة حاليًا في المكتبة (لتحسين بحث سابق)، حدد Search Currently Shown Items.

  3. اختر فئة من القائمة الأولى في قسم المعاملات.
  4. في القائمة الثانية، حدد ما إذا كانت الفئة التي حددتها في القائمة الأولي يجب أن يتم شمولها أو استثنائها من البحث.
  5. إلى يمين القائمة الثانية، اكتب كلمة أو تعبير تريد البحث عنه ضمن الفئة المحددة.
  6. لإضافة فئة بحث، انقر فوق More Choices حتى خمس مرات، كل نقرة تضيف شرط بحث. لإزالة فئة بحث، انقر اختيارات أقل حسب الضرورة، كل نقرة تزيل شرط من البحث.
  7. لعرض تلك الكائنات التي تطابق كل فئات البحث فقط، حدد مطابقة الكل. لعرض الكائنات التي تطابق أي من شروط البحث، حدد مطابقة أي واحد.
  8. انقر فوق OK، لبدء البحث.

ملاحظة:

لإظهار كل الكائنات مرة أخرى، اختر Show All من قائمة Object Library panel.

ترحيل أصول مكتبة الكائن لـ CC Libraries

تساعدك مكتبات Creative Cloud على تنظيم أصولك الابتكارية واستعراضها والوصول إليها. في InDesign، يمكنك استخدام CC Libraries كبديل لمكتبات الكائنات.

ملاحظة:

تواصل InDesign دعم مكتبات الكائنات.

تتيح لك InDesign ترحيل أصول مكتبة الكائن إلى CC Libraries.

  1. في لوحة مكتبة الكائن، انقر فوق الزر "ترحيل" لترحيل كل الأصول من المكتبة الحالية.

    بدلاً من ذلك، يمكنك تحديد العديد من الأصول من المكتبة، انقر بزر الماوس الأيمن واختر الخيار لترحيل الأصول المحددة.

  2. في مربع الحوار "نقل الأصول"، اختر الخيار لترحيل الأصول إلى مكتبة Creative Cloud جديدة أو مكتبة موجودة.

لمزيد من التفاصيل حول CC Libraries، راجع مكتبات Creative Cloud - التعاون ومزامنة الأصول ومشاركتها.

مكتبات Creative Cloud - التعاون ومزامنة الأصول ومشاركتها
مكتبات Creative Cloud - التعاون ومزامنة الأصول ومشاركتها
مكتبات Creative Cloud - التعاون ومزامنة الأصول ومشاركتها

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت