User Guide Cancel

Create and manage hyperlinks

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Customize your workspace in InDesign
      3. Toolbox
      4. Set preferences
      5. Touch workspace
      6. Default keyboard shortcuts
      7. Document recovery and undo
  3. Create and layout documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Create book files
      7. Add basic page numbering
      8. Number pages, chapters, and sections
      9. Convert QuarkXPress and PageMaker documents
      10. Share content
      11. Understand a basic managed-file workflow
      12. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
      2. Align and distribute objects using rulers
      3. Measure objects using the Measure tool
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. South-East Asian Scripts
      4. Arabic and Hebrew features in InDesign
      5. Create type on a path
      6. Bullets and numbering
      7. Glyphs and special characters
      8. Text composition
      9. Text variables
      10. Generate QR codes
      11. Edit text
      12. Align text
      13. Wrap text around objects
      14. Anchored objects
      15. Linked content
      16. Format paragraphs
      17. Format characters
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Auto Style text
      3. Work with Style Packs
      4. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Spell check and language dictionaries
      1. Check spelling, autocorrect, and dynamic spelling
      2. Create, add, and manage dictionaries and words
      3. Change dictionary preferences
      4. Duden dictionary
    6. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    7. Styles
      1. Paragraph and character styles
      2. Map, export, and manage styles
      3. Object styles
      4. Drop caps and nested styles
      5. Work with styles
      6. Leading
    8. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    9. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
    10. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Frames and objects
      10. Align and distribute objects
      11. Linked and embedded graphics
      12. Integrate AEM assets
    11. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Understand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Find and replace
    1. Find and replace text
    2. Find and replace fonts
    3. Find and replace glyphs
    4. Find and replace using GREP expressions and queries
    5. Find and replace objects
    6. Find and replace colors
    7. Search options to find and replace
  6. Share
    1. Work with InDesign cloud documents (Beta)
    2. Common questions about InDesign cloud documents (Beta)
    3. Share and collaborate        
    4. Share for Review
    5. Review a shared InDesign document
    6. Manage feedback 
  7. Publish
    1. Place, export, and publish
      1. Publish online
      2. Publish online dashboard
      3. Copy, insert graphics
      4. Export content for EPUB
      5. Adobe PDF options
      6. Export content to HTML
      7. Export to Adobe PDF
      8. Export to JPEG format
      9. Export HTML
      10. DPS and AEM Mobile overview
      11. Supported File Formats
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  8. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting
  9. Troubleshooting
    1. Fixed issues
    2. Crash on launch
    3. Preference folder read-only issue
    4. Troubleshoot file issues
    5. Unable to export PDF
    6. InDesign document recovery

Learn how to create, style, edit, and manage hyperlinks.

You can create hyperlinks so a viewer can select a link to jump to other locations in the same document, other documents, or websites. Export your InDesign document to an Adobe Interactive PDF, ePub, or HTML to view and select hyperlinks.

Try the app!

Follow along with any project to learn how to create and work with hyperlinks.

Before you proceed, here are some common terminology and information to get you started:

  • Source: Hyperlinked text, text frame, or graphics frame.
  • Destination: URL, file, email address, page text anchor, or shared destination that opens on selecting the hyperlink.
  • A source can jump to only one destination, but any number of sources can jump to the same destination.
  • If you want to generate the source text from the destination text, insert a cross-reference.

You can create hyperlinks to pages, URLs, text anchors, email addresses, and files. If you create a hyperlink to a page or text anchor in a different document, exported the InDesign files to the same folder.

You can hyperlink to an external location like a URL, File, or Email. When you specify a URL, you can use any valid Internet resource protocol: http://, file://, ftp://, or mailto://.

When you create a hyperlink to a file, selecting the hyperlink in the exported Adobe Interactive PDF, ePub, or HTML file opens the file in its native application. Ensure you share the specified file with the exported PDF, ePub, or HTML file.

  1. Select some text, frame, or graphic.

  2. Select Type > Hyperlinks & Cross-References > New Hyperlink.

  3. Follow the steps in the New Hyperlink panel:

    URL

    • Link To: Select URL from the drop-down.
    • Destination: Enter the URL.

    You can also use Buttons to link to web pages.

    File

    • Link To: Select File from the drop-down.
    • Path: Enter the file location.

    Email

    • Link To: Select Email from the drop-down.
    • Address: Enter the email address.
    • Subject Line: Enter the subject for the email.
  4. Select Shared Hyperlink Destination if you want to save the URL, File, or Email in the Hyperlinks panel for easy reuse.

    You can set or change the formatting of your hyperlink text in the Appearance tab and provide the alternate text in the Accessibility tab.

  5. Select OK.

  1. Select some text, frame, or graphic.

  2. Select Type > Hyperlinks & Cross-References > New Hyperlink.

  3. Follow the steps in the New Hyperlink panel:

    Page

    • Document: Select the document from the drop-down.
    • Page: Enter the page number.
    • Zoom Setting: Select from Fixed, Fit View, Fit in Window, Fit Width, Fit Height, Fit Visible, or Inherit Zoom.

    You can also use Buttons to link to web pages.

    Text Anchor

    • Document: Select the document from the drop-down.
    • Text Anchor: Select an anchor from the drop-down.

    Shared Destination

    • Document: Select the document from the drop-down.
    • Name: Select an anchor or any saved URL, file, or email from the drop-down.
  4. Select Shared Hyperlink Destination if you want to save the URL, File, or Email in the Hyperlinks panel for easy reuse.

    You can set or change the formatting of your hyperlink text in the Appearance tab and provide the alternate text in the Accessibility tab.

  5. Select OK.

Do you want to style hyperlink text? You can change the hyperlink or cross-reference source appearance in the exported PDF ePub, or HTML file.

Character Style: Select a character style to apply to the hyperlink source. By default, InDesign applies the Hyperlink style to the selected text or object. You can easily select a style from the Style drop-down in the New Hyperlink dialog box for text. For a non-text object, InDesign applies a design time visual identifier to the links – a dotted line around the object with the color inherited from layer color.

You can also specify the following options to further customize the appearance of your hyperlink source:

Type

Select Visible Rectangle or Invisible Rectangle.

Highlight

Select Invert, Outline, Inset, or None. These options determine the hyperlink’s appearance when you select it in the PDF, ePub, or HTML file.

Color

Select a color for the visible hyperlink rectangle.

Width

Select Thin, Medium, or Thick to determine the thickness of the hyperlink rectangle.

Style

Select Solid or Dashed to determine the style of the hyperlink rectangle.

You can find and convert URLs in your document to hyperlinks.

  1. Select Type > Hyperlinks & Cross-References > Convert URLs To Hyperlinks.

  2. Set the following options in the Convert URLs to Hyperlinks panel:

    • Scope: Indicate whether your want to convert URLs in the Document, Story, or Selection.
    • Apply to Hyperlink: Check and select the Character Style from the drop-down.
  3. Select Find to locate the next URL and then select Convert or Convert All.

Use the Hyperlinks panel to edit, delete, reset, or locate hyperlinks. In InCopy, you can manage hyperlinks only if the story is checked out for editing.

  1. Select Window > Interactive > Hyperlinks to view the Hyperlinks panel.

  2. Select any hyperlink source from the list and select the Hyperlinks panel menu   icon > Edit Hyperlink.

  3. Make changes to the Destination, Appearance, or Accessibility sections, then select OK.

  1. Select Window > Interactive > Hyperlinks to view the Hyperlinks panel.

  2. Select the item or items you want to remove, and then select the Delete   icon.

    When you remove a hyperlink, the source text or graphic remains.

Renaming the hyperlink source changes the way it appears in the Hyperlinks panel.

  1. Select Window > Interactive > Hyperlinks to view the Hyperlinks panel.

  2. Select any hyperlink source from the list and select the Hyperlinks panel menu   icon > Rename Hyperlink.

  3. Enter the new name in the Rename Hyperlink dialog.

  1. Select Window > Interactive > Hyperlinks to view the Hyperlinks panel.

  2. Select any hyperlink source from the list and select the Hyperlinks panel menu   icon > Hyperlink Destination Options.

  3. Update the Destination and Type from the dropdown, and enter the Name to edit the hyperlink destination.

    Select Delete or Delete Unused to delete the hyperlink destination.

You can include additional text, text frame, or graphics frame to an existing hyperlink.

  1. Select the range of text, the text frame, or the graphic frame that will act as the new hyperlink source.

  2. Select Window > Interactive > Hyperlinks to view the Hyperlinks panel.

  3. Select any hyperlink source from the list and select the Hyperlinks panel menu   icon.

    • Select Reset Hyperlink to hyperlink all the selected text.

    • Select Update Hyperlink to update hyperlinks to external documents.

  1. Select Window > Interactive > Hyperlinks to view the Hyperlinks panel.

  2. Select any hyperlink source from the list and select the Hyperlinks panel menu   icon.

    • Select Go to Source to find the hyperlink text in the document.

    • Select Go to Destination:

      • You'll jump to the location if the destination is a Page or Text Anchor if the destination is within the document
      • If the Destination is external, InDesign starts or switches to your web browser to display the destination.

When you import a Microsoft Word document with hyperlinks into InDesign, you'll view a box or border around the hyperlink URLs. The InDesign document inherits a blue swatch and the document inherits a Hyperlink character style that underlines the text and applies the blue color.

You can delete individual swatches and replace them with different ones.

Do you want to delete the box around the hyperlinks imported from Microsoft Word?

  1. Select Window > Interactive > Hyperlinks to view the Hyperlinks panel.

  2. Select any hyperlink source from the list and select the Hyperlinks panel menu   icon > Edit Hyperlink.

  3. Select the Appearance tab, and select Invisible Rectangle from the Type drop-down.


Related resources

Talk to us

We would love to hear from you. Share your thoughts with the Adobe InDesign Community

Adobe logo

Sign in to your account