User Guide Cancel

Publish Online

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Toolbox
      3. Set preferences
      4. Touch workspace
      5. Default keyboard shortcuts
      6. Document recovery and undo
      7. Capture extension
  3. Create and lay out documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Create book files
      7. Add basic page numbering
      8. Number pages, chapters, and sections
      9. Convert QuarkXPress and PageMaker documents
      10. Share content
      11. Understand a basic managed-file workflow
      12. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. Arabic and Hebrew features in InDesign
      4. Create type on a path
      5. Bullets and numbering
      6. Glyphs and special characters
      7. Text composition
      8. Text variables
      9. Generate QR codes
      10. Edit text
      11. Align text
      12. Wrap text around objects
      13. Anchored objects
      14. Linked content
      15. Format paragraphs
      16. Format characters
      17. Find/Change
      18. Spell check and language dictionaries
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Work with Style Packs
      3. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    6. Styles
      1. Paragraph and character styles
      2. Map, export, and manage styles
      3. Object styles
      4. Drop caps and nested styles
      5. Work with styles
      6. Leading
    7. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    8. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
      11. Forms
    9. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Align and distribute objects
      10. Linked and embedded graphics
      11. Integrate AEM assets
    10. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Undertand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Share
    1. Work with InDesign Cloud documents
    2. InDesign cloud documents | Common questions
    3. Share and collaborate        
    4. Share for Review
    5. Review a shared InDesign document
    6. Manage feedback 
  6. Publish
    1. Place, export, and publish
      1. Publish Online
      2. Copy, insert graphics
      3. Export content for EPUB
      4. Adobe PDF options
      5. Export content to HTML
      6. Export to Adobe PDF
      7. Export to JPEG format
      8. Export HTML
      9. DPS and AEM Mobile overview
      10. Supported File Formats
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  7. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting
  8. Troubleshooting
    1. Fixed issues
    2. Crash on launch
    3. Preference folder read-only issue
    4. Troubleshoot file issues
    5. Unable to export PDF
    6. InDesign document recovery

InDesign's Publish Online feature helps you repurpose your print documents by creating their digital version. You can publish and share any InDesign document - from a simple pdf to a document that includes buttons, slideshows, animation, audio, and video.

Here are two sample interactive documents:

Here's a list of the supported layouts, formats, and features for Publish Online feature in InDesign:

Multiple page spread

You can create an InDesign document that contains spreads with more than two pages, the published document displays multiple pages on a spread in the same way as they are displayed in InDesign.

Publish documents with multiple page sizes

You can publish documents that contain pages of different sizes. The published document maintains the size of individual pages and appropriately displays the content on all pages.

Text hyperlinks

You can add hyperlinks to your text. Here are some hyperlink types supported by InDesign:

  • URLs
  • Emails
  • Page destinations
  • TOC markers
  • Index markers
  • Cross references

Image resolution

You can add images with the published output resolution of 96 PPI which is the default value for better quality images.

Mobile and Tablet experience

Mobile and tablet views

You get a rich mobile viewing experience of your published InDesign documents.

  • Smoother page transitions with a swipe gesture.
  • Display of Share dialog on the full screen
  • Mobile optimized thumbnail layout for better viewing and accessibility.

The tablet view includes an easy-to-use scrollable thumbnail view.

Sharing options

You can choose to share your published documents on Facebook, Twitter and over email. You can also provide your viewers with the option to download your document as PDF.

Transparency effect

You can add transparency and other effects with blending modes. The only exceptions are text frames, groups, buttons, objects with animation, and MSOs overlapping with objects containing transparency.

Update published documents

You can update a published document by updating the source and republishing it.

Publish an InDesign document online

  1. Open an InDesign document, and select File > Publish Online.

    You can see the Publish Online dialog.

  2. In the General tab of the Publish Online dialog, enter the following information:

    Title

    Title of the online document. This name is displayed as the browser title of the published output.

    The title is also displayed in the Recently Published menu (File > Recently Published) and the Publish Online Dashboard.

    Description

    Description of the online document.

    This is displayed in the Publish Online dashboard and on Facebook if you share the document there.

    Pages

    Choose to export All or a Range of pages from the current document.

    Export As

    Specify how pages are displayed online in web browser.

    Single

    Displays a single page at a time on browser

    Spreads

    Displays two pages at a time in the web browser.

    Allow viewers to download the document as a PDF (Print)

    Allows users to download your document in PDF Print format.

    Hide the Share and Embed options in the published document

    Allows you to hide the share or embed buttons on your published document.

    If you're republishing an existing document. Click Update Existing Document and select the appropriate document title from the Choose an existing document to update drop-down list. Change the publish online settings as required.

  3. In the Advanced tab, enter the following information:

    Choose Thumbnail

    Choose the cover for your published document. This thumbnail is displayed in Publish Online dialog with the title and description while uploading. This thumbnail also appears when you share the document on Facebook.

    First Page

    Specify that the first page of the InDesign document is used as the cover thumbnail

    Chosen Page

    Choose a page of the InDesign document to be used as the cover thumbnail

    Choose Image

    Select an external image as the cover thumbnail

    Image Settings

    Specify how the images of the documents are to be exported

    Automatic **recommended**

    InDesign decides how the document images should be exported, keeping in consideration performance optimization. The available options are JPEG, GIF, and PNG.

    Resolution

    Specify the resolution of the images. Available options are Standard (InDesign-optimized) and HiDPi (InDesign-optimized for high resolution).

    Note: HiDPi images might increase page loading time and the amount of data viewers must download.

    JPEG Image Quality

    When Image Format is set to JPEG, this option provides multiple options for image quality.

    GIF Options Palette

    When Image Format is set to GIF, this option provides multiple palettes for GIF rendering.

  4. Select Publish to publish the document online.

    The Publish Online dialog is displayed with:

    • The thumbnail, title, and description on the left side.
    • The process on the right side.

    Click Cancel Upload to stop and roll back the upload process.

    Click Close to minimize this dialog box to the Publish Online button in the App bar.

     Minimizing the Publish Online dialog box does not stop online publish process. However, you can continue to work in the current or any other InDesign document.

  5. Click Publish Online in the App bar to open the Publish Online dialog box.

  6. After the document is published online, choose the following options in the Publish Online dialog box:

    View Document

    Open the online document in your default web browser.

    Copy

    Copy the URL for the online document.

    Share on Facebook

    Share the document URL on your Facebook page.

    Share on Twitter

    Tweet the document URL.

    Email the URL

    Share the document using your default email client.

Output of online document

The published online document provides a number of viewing and sharing options.

Viewing and sharing options for a published online document

Toggle Thumbnails

Show/Hide the thumbnail dock that displays the thumbnails for all the pages in the published output.

Zoom in

Zoom into the current page.

Zoom out

Zoom out of the current page.

Full Screen

View the current page in full screen mode.

Share

Opens the Share Publication dialog that provides options to copy the current document URL or share the document on Facebook, Twitter, or by email.

Embed

Opens the Embed on your site dialog. You can copy the code from the Embed code section to embed a particular document on your site. You can also specify a start page for your document and the embedded output opens on the selected page number. Within Embed options, check Disable full screen for embed window if you do not want the users to view the document in full screen.

Download PDF

Download the output in the PDF-Print format.

Volume - Turn off

Mute all audio in the current document.

Report Abuse

Open the Report Abuse dialog. This dialog provides the options for type of abuse and your details.

 Share and Embed options are not available if you have selected Hide the Share and Embed options in the published document option while publishing the document. 

Recently published documents

The Recently published menu displays the list of the last five documents published.

Click a document in this list, to open the published output in your default browser.

  1. To view the recently published documents list, choose File > Recently Published.


You can see your published files and analytics information of your online documents in the Publish Online Dashboard. Choose FilePublish Online Dashboard, for Documents and Analytics.

Documents in Publish Online dashboard

See the list of published documents, their Name, Sharing, and the Date Modified information. You can sort your documents by their name or modified date.

Overview of the documents in Publish Online dashboard
Documents in Publish Online dashboard

Sort      

Sorts your documents as per the selected option: Name or Modified. You can also select Reverse Order to toggle between ascending and descending order of your selection.

Thumbnail/List View  

Click this to toggle between Thumbnail View or List View of the published documents.

Share  

Opens the Share Publication dialog that provides options to copy the current document URL or share the document on Facebook, Twitter, or by email.

View Analytics   

Opens the Publication Analytics dialog that provides the analytics data for individual documents.

 

You can see the data for the last 30 days. However, you can choose to see the data for the last 7 days, 30 days, 90 days, 6 months, 1 year, or Since published.

More options  

Provides Embed and Delete options.

Embed: Opens the Embed on your site dialog. You can copy the code from the Embed code section to embed a particular document on your site. You can also specify a start page for your document, and the embedded output opens on the selected page number. Within Embed options, check Disable full screen for embed window if you don't want the users to view the document in full screen.

Delete: Deletes a particular document.

Hover on any document to see a check box on the left side. You can check multiple documents for bulk delete.

Analytics in Publish Online dashboard

See the number of published documents and insights for all the documents.

You can see the data for the last 30 days. However, you can choose to see the data for the last 7 days, 30 days, 90 days, 6 months, 1 year, or Since published.

Analytics tab in Publish Online dashboard
Analytics in Publish Online dashboard

Views

Number of times your published documents have been viewed.

Visitors

Number of users who have viewed your published documents.

Avg. Read Time

Average time spent by a user interacting with your published document per view.

Total Read Time

Total time spent by all the users while actively viewing your published documents.

Views on Devices

Distribution of total views across desktop, mobile, and tablet devices.

 The Publish Online Dashboard is now in-sync with the theme of your computer.

Publish online is now more secure!

On using embedded HTML content in InDesign documents, InDesign now supports select websites on publishing these documents online.

Any unsupported HTML content will appear blocked in the published document.


Related topics

Talk to us

We would love to hear from you. Share your thoughts with the Adobe InDesign Community

Adobe logo

Sign in to your account