El proceso de codificación

Para codificar un elemento de vídeo o audio, agréguelo a la cola de codificación en Adobe Media Encoder y, a continuación, seleccione ajustes preestablecidos o cree su propia configuración personalizada de codificación. Puede indicar a la aplicación que comience la codificación cuando haya agregado un elemento a la cola, o bien que espere hasta que usted decida comenzar la codificación.

Adición de un elemento a la cola de codificación: Arrastre archivos de vídeo o audio a la cola de Adobe Media Encoder.

Codifique el elemento con ajustes preestablecidos: Seleccione los formatos y los ajustes preestablecidos de los menús emergentes Formato y Ajustes preestablecidos cuando el elemento esté en la cola. O bien, elija un ajuste preestablecido del navegador preestablecido y arrástrelo a cualquier elemento de la cola. Para obtener más información, consulte Codificación mediante ajustes preestablecidos.

Codifique el elemento mediante ajustes personalizados: seleccione el elemento, elija Edición > Ajustes de exportación y seleccione los ajustes. Para obtener más información, consulte Codificación mediante ajustes personalizados.

Para iniciar automáticamente la codificación de elementos en la cola (o para desactivar esta función), en el cuadro de diálogo Preferencias, seleccione o anule la selección de la opción Iniciar cola automáticamente cuando esté inactiva durante. Para obtener más información, consulte el artículo Preferencias.

Pantalla de AME
Ventana principal de Adobe Media Encoder

Importación de elementos a la cola de codificación

  • Para agregar archivos de vídeo o de audio, realice una de las acciones siguientes:
    • Arrastre uno o más archivos a la cola desde el escritorio o el explorador de medios.
    • Haga clic en el botón Agregar origen y elija uno o varios archivos.
    • Haga doble clic en un área vacía del panel Cola y seleccione uno o varios archivos.
  • Para agregar una secuencia de Adobe Premiere Pro, realice una de las acciones siguientes:
    • Navegue dentro de un proyecto de Adobe Premiere Pro en el Explorador de medios y haga clic para arrastrar secuencias a la cola.
    • Elija Archivo > Agregar secuencia de Premiere Pro, seleccione un proyecto de Premiere Pro y, luego, elija una o varias secuencias de ese proyecto.
    • Haga clic en una secuencia del panel Proyecto de Adobe Premiere Pro y arrástrela a la cola.
    • Haga clic en un proyecto de Premiere Pro en el escritorio y arrástrelo a la cola.
  • Para agregar una composición de Adobe After Effects, realice una de las acciones siguientes:
    • Navegue dentro de un proyecto de Adobe After Effects en el Navegador de medios y arrastre y coloque composiciones en la cola.
    • Elija Archivo > Agregar composición de After Effects, seleccione un proyecto de After Effects y, luego, elija una composición de ese proyecto.
    • Haga clic en una composición del panel Proyecto de After Effects y arrástrela a la cola.
    • Haga clic en un proyecto de After Effects en el escritorio y arrástrelo a la cola.

Detención de la codificación

  • Seleccione Archivo > Detener archivo actual para detener la codificación del elemento actual. Adobe Media Encoder continúa codificando el resto de los elementos de la cola.
  • Elija Archivo > Detener cola para detener la codificación de todos los elementos que hay en la cola.

Interpretación de los elementos de la cola de codificación

Cuando Adobe Media Encoder importa un recurso de vídeo, intenta determinar la proporción de píxeles, la velocidad de fotogramas y el orden de campos para ese recurso, así como la forma de interpretar la información del canal alfa (transparencia). Si Adobe Media Encoder se equivoca respecto a alguna de estas características, el usuario puede asignar explícitamente la interpretación correcta.

  1. Seleccione uno o más elementos de la cola de codificación.

  2. Elija Archivo > Interpretar material de archivo. También puede hacer clic con el botón derecho en el archivo y elegir Interpretar material de archivo.

    interpret selection
    Selección de Interpretar material de archivo

  3. Elija los ajustes de interpretación adecuados.

    iterpret window
    Cuadro de diálogo de Interpretar material de archivo

Identificación de los elementos que faltan en la cola de codificación

Antes de codificar, puede identificar los orígenes y las salidas de la cola a los que les faltan elementos. Este proceso ayuda a detectar y corregir problemas antes de codificar. Al lado de los orígenes o las salidas a los que les faltan elementos, aparece un estado de advertencia. Pase el ratón sobre el icono para ver un resumen del error asociado a este problema. 

Adobe Media Encoder muestra un icono de advertencia en los siguientes casos:

  • Cuando los proyectos de Premiere Pro contienen medios sin conexión. En este caso, Adobe Media Encoder utiliza medios de proxy en sustitución del conjunto que falta. Si no hay ningún proxy, se utiliza un gráfico que muestra el mensaje “Medios sin conexión”.
  • Cuando faltan fuentes en los proyectos de Premiere Pro.
  • Cuando faltan efectos en los proyectos de Premiere Pro.
  • Cuando faltan archivos en los efectos de superposición. 
Identificación de elementos que faltan
Identificación de elementos que faltan

Carpetas de inspección de Adobe Media Encoder  

Puede configurar Adobe Media Encoder para que busque los archivos en determinadas carpetas denominadas carpetas de inspección. Cuando Adobe Media Encoder busca un archivo de audio o de vídeo ubicado en una carpeta de inspección, codifica el archivo utilizando los ajustes de codificación asignados a la carpeta y, posteriormente, exporta el archivo codificado a una carpeta de salida creada dentro de la carpeta de inspección.

El panel Carpetas de inspección de Adobe Media Encoder se puede utilizar para agregar y administrar carpetas. Para agregar una carpeta de inspección, realice una de las acciones siguientes:

  1. Elija Archivo > Agregar carpeta de inspección y seleccione una carpeta.
  2. Haga doble clic en un área vacía del panel Carpetas de inspección y seleccione una carpeta.
  3. Cree una carpeta en el Explorador (Windows) o Finder (Mac OS) y, a continuación, arrástrela al panel Carpetas de inspección.

Cuando haya creado la carpeta de inspección, verá su nombre en la columna izquierda del panel Carpetas de inspección.

Los elementos agregados a la cola de codificación mediante la carpeta de inspección se codificarán junto con los otros elementos de la cola cuando se inicie la cola.

Nota:

Si ha seleccionado la preferencia “Iniciar cola automáticamente cuando esté inactiva durante”, la codificación comenzará cuando haya transcurrido el periodo de tiempo especificado después de que la carpeta de inspección haya agregado un elemento nuevo a la cola de codificación.

Nota:

Deje activada la opción Codificar automáticamente las carpetas de inspección para codificar, de forma automática, los elementos cuando se agreguen a la carpeta de inspección.

Adición de ajustes preestablecidos

Puede elegir un formato y un ajuste preestablecido en los menús emergentes de la carpeta de inspección, junto al nombre de la carpeta. O bien, arrastre un ajuste preestablecido a la carpeta de inspección desde el Navegador preestablecido.

Creación de salidas en varios formatos desde un solo elemento de origen mediante las carpetas de inspección

Puede generar varias salidas con una sola operación mediante carpetas de inspección. Por ejemplo, en el caso de que quiera generar una película en formato AVI y una imagen en miniatura en formato JPEG al transcodificar un objeto de vídeo. Siga estos pasos para crear estos archivos con una sola operación:

  1. Con el Explorador (Windows) o Finder (Macintosh), cree una carpeta llamada “Mi_carpeta_de_inspección”, por ejemplo.

  2. Para crear una carpeta de inspección, haga clic en el botón Agregar carpeta y, a continuación, desplácese a la carpeta que acaba de crear, “Mi_carpeta_de_inspección”.

    1. Haga clic en Formato y seleccione MPEG4 en el menú emergente.

    2. Haga clic en Ajuste preestablecido y seleccione el ajuste deseado en el menú emergente.

      preset and format
      Menú emergente de formato y ajustes preestablecidos

    3. Haga clic en Carpeta de salida. Seleccione una ubicación en la que desee generar el resultado.

      Output Folder
      Carpeta de salida

  3. Cree un nuevo elemento Carpeta de inspección que también apunte a la carpeta “Mi_carpeta_de_inspección”, tal como lo hizo en el paso 2.

    1. En el menú Formato, seleccione AVI.

    2. Seleccione un ajuste preestablecido en el menú Ajuste preestablecido y, a continuación, haga clic en Aceptar.

    3. Haga clic en Carpeta de salida. Seleccione una ubicación en la que desee generar el resultado.

  4. Cree un nuevo elemento Carpeta de inspección que también apunte a la carpeta “Mi_carpeta_de_inspección”, tal como hizo en los pasos 2 y 3.

    1. En el menú Formato, seleccione JPEG.

    2. Seleccione un ajuste preestablecido en el menú Ajuste preestablecido y, a continuación, haga clic en Aceptar.

    3. Haga clic en Carpeta de salida. Seleccione una ubicación en la que desee generar el resultado.

  5. Haga clic en el archivo de origen, arrástrelo a “Mi_carpeta_de_inspección” y, a continuación, haga clic en el botón Iniciar cola. El proceso de codificación empieza automáticamente si está activada la opción Codificar automáticamente las carpetas de inspección.

Cuando haya terminado, cada archivo estará en las ubicaciones de salida esperadas.

Nota:

El ajuste preestablecido debe ser personalizado y hay que desactivar la opción Exportar como secuencia. Solo se exportará el primer fotograma del vídeo, que suele ser negro.

Nota:

Las carpetas de inspección no admiten secuencias de imágenes fijas como material de origen. Si se coloca un conjunto de imágenes fijas en la carpeta inspeccionada, cada archivo de imagen fija se agregará a la cola como elemento independiente en vez de agregar toda la secuencia como un solo elemento de material de archivo.

Guardado de la cola de codificación

La cola de codificación y todos los ajustes de codificación se guardan automáticamente al salir de Adobe Media Encoder.

La cola de codificación también se guarda automáticamente cuando un usuario inicia la codificación.

Para guardar la cola de codificación manualmente, elija Archivo > Guardar cola.

Nota:

Desactive la casilla Preferencias > Retirar archivos completados de la cola al salir, en caso de que quiera mantener en la cola los elementos codificados que se hayan completado al cerrar y reiniciar Adobe Media Encoder.

Eliminación de elementos de la cola de codificación

  1. Seleccione el elemento o los elementos que desee eliminar de la cola de codificación.

  2. Haga clic en el botón Eliminar, elija Editar > Borrar o presione la tecla Suprimir.

    Delete file new
    Eliminación de elementos de la cola de codificación

Duplicación de elementos en la cola de codificación

  1. Seleccione el elemento o los elementos que desee duplicar en la cola de codificación.

  2. Realice una de las acciones siguientes:

    • Haga clic en el botón Duplicar, elija Editar > Duplicar
    • Presione Ctrl + D (Windows) o Comando + D (Mac OS)
    • Haga clic con el botón derecho en el archivo y elija Duplicar.
    Duplicate item
    Duplicar elemento

Omisión de elementos de la cola de codificación

Omisión de elementos

  1. Seleccione el elemento o los elementos que desee omitir de la cola de codificación.

  2. Elija Editar > Omitir selección o haga clic con el botón derecho del ratón en el archivo y elija Omitir selección.

    Skip selection
    Omitir selección

Restablecimiento de un archivo omitido para codificación

  1. En la cola de codificación, seleccione los elementos que desee restablecer al estado Preparado.

  2. Elija Editar > Restaurar estado o haga clic con el botón derecho del ratón en el archivo y seleccione Editar > Restaurar estado.

    Reset status
    Restablecimiento del estado de un archivo omitido

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea