FrameMaker system requirements

Your computer must meet the outlined minimum technical specifications to install and use FrameMaker.

Applicable for: FrameMaker September 2022 and Summer 2020 releases. For the system requirements of earlier versions of FrameMaker, visit this page.

FrameMaker (September 2022 release)

Release

Minimum specifications

Processor

Core i5 or faster processor

Operating system    

64-bit version of Microsoft Windows 11 or 10

JRE

8

RAM

4 GB or higher 

Hard disk space

5 GB of available hard disk space for installation; additional free space required during installation. (Note that you cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)

Maximum supported screen resolution

4K (3840 x 2160 at 150% scale, 8-bit depth, aspect ratio 16:9)

Internet

This software will not operate without activation. Internet connection and registration are required for software activation, validation of subscriptions, and access to Online Services.

Phone activation is not available.

Supported software

  • Microsoft Word 2013 or Microsoft 365 (only document downloaded from Microsoft 365)
  • Acrobat Desktop application’s latest version, Pro (2017 release), or XI
  • OpenText Documentum
  • Microsoft SharePoint Online or 2013
  • Adobe Experience Manager 6.5, 6.4, or 6.3
  • Adobe Experience Manager Guides

Supported browsers

The latest version of:

  • Google Chrome
  • Mozilla Firefox
  • Microsoft Edge
  • Internet Explorer 11 (basic certification)

Summer 2020 release of FrameMaker

Release

Minimum specifications

Processor

Core i5 or faster processor

Operating system    

64-bit version of Windows 11 or 10

Opmerking:

Update 4 of FrameMaker Summer 2020 release and higher versions are compatible with Windows 11 and 10. Update 3 and earlier releases of FrameMaker Summer 2020 release are compatible with Windows 10 only.

JRE

8

RAM

4 GB or higher 

Hard disk space

5 GB of available hard disk space for installation; additional free space required during installation. (Note that you cannot install on a volume that uses a case-sensitive file system or on removable flash storage devices)

Maximum supported screen resolution

4K (3840 x 2160 at 150% scale, 8-bit depth, aspect ratio 16:9)

Internet

This software will not operate without activation. Internet connection and registration are required for software activation, validation of subscriptions, and access to Online Services.

Phone activation is not available.

Supported software

  • Word 2013 or Microsoft 365 (only document downloaded from Microsoft 365)
  • Acrobat Desktop application’s latest version, Pro (2017 release), or XI
  • OpenText Documentum
  • SharePoint Online or 2013
  • Adobe Experience Manager 6.5, 6.4, or 6.3
  • Adobe Experience Manager Guides

Supported browsers

The latest version of:

  • Google Chrome
  • Mozilla Firefox
  • Edge
  • Internet Explorer 11 (basic certification)

Language versions

This product is available in the following languages:

  • English
  • Deutsch
  • Français
  • 日本語
Let op:

FrameMaker does not support installation in multiple locales on the same system. Install FrameMaker only in your preferred locale.

Where do I get started?

 Adobe

Krijg sneller en gemakkelijker hulp

Nieuwe gebruiker?