User Guide Cancel

Improve Illustrator performance

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Create documents
      3. Toolbar
      4. Default keyboard shortcuts
      5. Customize keyboard shortcuts
      6. Introduction to artboards
      7. Manage artboards
      8. Customize the workspace
      9. Properties panel
      10. Set preferences
      11. Touch Workspace
      12. Microsoft Surface Dial support in Illustrator
      13. Recovery, undo, history, and automation
      14. Rotate view
      15. Rulers, grids, and guides
      16. Accessibility in Illustrator
      17. Safe Mode
      18. View artwork
      19. Use the Touch Bar with Illustrator
      20. Files and templates
    3. Tools in Illustrator
      1. Tools at a glance
      2. Select tools
        1. Selection
        2. Direct Selection
        3. Group Selection
        4. Magic Wand
        5. Lasso
        6. Artboard
      3. Navigate tools
        1. Hand
        2. Rotate View
        3. Zoom
      4. Paint tools
        1. Gradient
        2. Mesh
        3. Shape Builder
      5. Text tools
        1. Type
        2. Type on a Path
        3. Vertical Type
      6. Draw tools
        1. Pen
        2. Add Anchor Point
        3. Delete Anchor Point
        4. Anchor Point
        5. Curvature
        6. Line Segment
        7. Rectangle
        8. Rounded Rectangle
        9. Ellipse
        10. Polygon
        11. Star
        12. Paintbrush
        13. Blob Brush
        14. Pencil
        15. Shaper
        16. Slice
      7. Modify tools
        1. Rotate
        2. Reflect
        3. Scale
        4. Shear
        5. Width
        6. Free Transform
        7. Eyedropper
        8. Blend
        9. Eraser
        10. Scissors
  3. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  4. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Upgrade cloud storage for Adobe Illustrator
      4. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  5. Add and edit content
    1. Drawing
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Image Trace
      7. Simplify a path
      8. Define perspective grids
      9. Symbolism tools and symbol sets
      10. Adjust path segments
      11. Design a flower in 5 easy steps
      12. Perspective drawing
      13. Symbols
      14. Draw pixel-aligned paths for web workflows
    2. 3D effects and Adobe Substance materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Map artwork over 3D objects
      4. Create 3D objects
      5. Create 3D Text
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Duplicate objects
      8. Rotate and reflect objects
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Add text and work with type objects
      2. Create bulleted and numbered lists
      3. Manage text area
      4. Fonts and typography
      5. Format type
      6. Import and export text
      7. Format paragraphs
      8. Special characters
      9. Create type on a path
      10. Character and paragraph styles
      11. Tabs
      12. Text and type
      13. Find missing fonts (Typekit workflow)
      14. Update text from Illustrator 10
      15. Arabic and Hebrew type
      16. Fonts | FAQ and troubleshooting tips
      17. Create 3D text effect
      18. Creative typography designs
      19. Scale and rotate type
      20. Line and character spacing
      21. Hyphenation and line breaks
      22. Text enhancements
      23. Spelling and language dictionaries
      24. Format Asian characters
      25. Composers for Asian scripts
      26. Create text designs with blend objects
      27. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Create a drop shadow
      4. Appearance attributes
      5. Create sketches and mosaics
      6. Drop shadows, glows, and feathering
      7. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Create animations
      5. Slices and image maps
  6. Import, export, and save
    1. Import
      1. Place multiple files
      2. Manage linked and embedded files
      3. Links information
      4. Unembed images
      5. Import artwork from Photoshop
      6. Import bitmap images
      7. Import Adobe PDF files
      8. Import EPS, DCS, and AutoCAD files
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Use Illustrator artwork in Photoshop
      2. Export artwork
      3. Collect assets and export in batches
      4. Package files
      5. Create Adobe PDF files
      6. Extract CSS | Illustrator CC
      7. Adobe PDF options
      8. File information and metadata
  7. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  8. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  9. Troubleshooting 
    1. Crash issues
    2. Recover files after crash
    3. File issues
    4. Supported file formats
    5. GPU device driver issues
    6. Wacom device issues
    7. DLL file issues
    8. Memory issues
    9. Preferences file issues
    10. Font issues
    11. Printer issues
    12. Share crash report with Adobe
    13. Improve Illustrator performance

Learn how to make Illustrator run quickly and efficiently on Windows and macOS.

Several factors affect how efficiently Adobe Illustrator performs, such as your operating system, hardware configuration, workflow, and selected options. If you notice Illustrator running more slowly than usual, try the techniques provided for optimizing not only Illustrator performance but the performance of your other apps as well.

The hero is a visual representation of optimizing operating system, hardware and working on Illustrator effectively with characters working on the system, color themes and outline view

Before you begin, ensure that you have installed the latest version of Illustrator.

 Update Illustrator

Click the tabs below to view and follow the listed steps to improve your Illustrator performance.

By configuring your operating system to run efficiently, you increase the amount of memory available to apps, which helps them run smoothly. Here are several steps to optimize Windows and macOS and improve Illustrator performance.

Manage fonts

Ensure that you:

  • Install only the fonts you need to improve system performance and the performance of apps that access fonts.
  • Use a font management utility to help you manage many fonts.

Use a PostScript printer driver

Non-PostScript printer drivers can conflict with Illustrator. Therefore, Adobe recommends you set a PostScript printer driver as the default printer in macOS. The PostScript printer has to be connected to your computer directly or via a network to complete the following steps.

Step 1. Set a PostScript printer as the default printer

  1. From the Apple menu, choose System Preferences, then click Printers & Scanners.

  2. If a PostScript printer isn't listed, click +, navigate to a PostScript printer, and click Add.

  3. Select a PostScript printer from Default Printer pop-up menu.

Step 2. Configure Illustrator to print to a non-default printer

  1. Open any document in Illustrator, and choose File > Print.

  2. In the Print dialog box, choose Adobe PostScript File or the name of the printer from the Printer menu and click Save.

 If the interface is customized, then some procedures vary. For example, the path to navigate to the Control Panel may vary. Choose Start > Settings > Control Panel or Start > Control Panel, depending on your version of Windows. 

Increase available memory

To increase performance, choose the right size for your paging file (the area of the hard drive that stores virtual memory). Choose a hard drive not used for the Illustrator scratch disk for best performance. Administrator rights are required to change the paging file size. Illustrator performs best when the paging file's maximum size is about three times the amount of installed RAM.

  1. Quit all apps.

  2. Choose Start > Control Panel > System > Advanced system settings.

  3. In the System Properties dialog box, choose the Advanced tab.

  4. Click Settings in the Performance section, and then choose the Advanced tab.

  5. In the Virtual Memory section, click Change.

  6. Clear the Automatically manage paging file size for all drives check box.

  7. From the Drive list, select a hard drive that has at least three times the amount of your computer's installed RAM. For example, if your computer has 64 MB of RAM, select a hard drive that has at least 192 MB of free space.

Disable driver features

Some video adapter drivers offer advanced settings for accelerating or modifying graphics display. Sometimes, these settings can adversely affect screen redraw performance in Illustrator. Disable driver-specific features to determine the best settings for use with Illustrator. For more information, see the documentation for your video adapter.

Manage fonts

Ensure that you:

  • Install only the fonts you need to improve system performance and the performance of apps that access fonts. 
  • Use a font management utility to help you manage many fonts.

Limit startup applications

Apps that start automatically on Windows compete with Illustrator for available RAM.

 To prevent apps from starting automatically, do the following:

  1. Quit all apps.

  2. Start Windows Explorer.
  3. Disable startup apps by moving all icons and shortcuts from the Startup folder (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) to another folder.

  4. Restart Windows.

To close apps specified to start automatically in the registry, do the following:

  1. Restart Windows and press Ctrl+Shift+Esc.

  2. Choose the Processes tab. Select an app name, and then click End Task.

  3. Restart Illustrator. If Illustrator performance improves, then contact the application's manufacturer for assistance to permanently disable it from starting automatically. 

  4. Repeat steps 2-5 for each remaining startup app.

After restarting, check if the Illustrator performance improves or not and re-enable shortcuts and icons. For more information, see Take control of your Windows start-up

Re-enable shortcuts and icons

If Illustrator performance does not improve after limiting start-up applications and restarting, do the following:

  1.  Add the icons and shortcuts back to the Startup folder and re-enable the them in Windows Explorer.

  2. Isolate the performance problem to one or more programs and place them in the Startup folder using Windows Explorer and re-enable their icons and shortcuts.

If the performance of Illustrator improves after restarting Windows, do the following:

  1. Restart your computer after re-enabling each set of icons and shortcuts and testing Illustrator performance.

  2. Repeat this process until the performance of Illustrator degrades. 

  3. Isolate the icon or shortcut that is causing the performance issue and remove it again. Contact the program's manufacturer to see if an update is available.

The hardware you use affects Illustrator performance: the faster the processor or hard drive, the faster Illustrator can process information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing and defragmenting drives, can also improve performance.

Choose your operating system and try the steps below to optimize hardware:

Use a faster processor

The speed of your computer's central processing unit (CPU) affects the speed of Illustrator. Because Illustrator manipulates large quantities of data and performs many calculations, its speed depends on the processor's speed. Consider using a computer with a faster processor.

Install additional RAM

If Illustrator has insufficient RAM, it uses hard disk space (virtual memory, scratch disk, or both) to process information. Illustrator is fastest when it can process information in memory without using a hard disk.

Optimize disk space

Here are a few ways to optimize disk space:

  • Check your hard disk for errors or defragment files with a third-party disk utility (for example, Norton Utilities). If you're running macOS, the drive must be repaired with a third-party disk utility.
  • Save your files to drives with faster access speeds. For example, use an internal hard drive rather than a network server or external drive.

Use a faster processor

The speed of your computer's central processing unit (CPU) affects the speed of Illustrator. Because Illustrator manipulates large quantities of data and performs many calculations, its speed depends on the processor's speed. Consider using a computer with a faster processor.

Install additional RAM

If Illustrator has insufficient RAM, it uses hard disk space (virtual memory, scratch disk, or both) to process information. Illustrator is fastest when it can process information in memory, without using a hard disk.

Optimize disk space

Here are a few ways to optimize disk space:

  • Check your hard disk for errors, defragment files, and make the best use of available hard disk space by using the CHKDSK.exe and Disk Defragmenter programs. For more information on Windows, see Improve performance for Windows.
  • Save your files to drives with faster access speeds. For example, use an internal hard drive rather than a network server or external drive.
  • If you want to save a file to a network or external drive, save the file to an internal hard drive. Then close the file and use Windows Explorer to copy it to the network or external drive.

Use a PostScript printer

For best results when printing from Illustrator, use a PostScript printer. Most non-PostScript printers rely on display information, host computer resources, and proprietary printer drivers to relay print information to the printer. Therefore, they can take much longer to print than a PostScript printer.

The way you work in Illustrator—especially the way you view artwork—can affect Illustrator performance. Here are some ways to use Illustrator features efficiently.

First half of the image shows the artwork in normal view with colors and the second half shows the image in outline view.
Outline view

Outline View hides paint attributes, displaying the artwork as unfilled paths. Working in Outline View can speed the display of complex artwork that contains gradients or patterns. Outline View also makes editing objects hidden behind other filled objects easier.

To display an Illustrator document in Outline View, choose View > Outline. To learn more, see View artwork.

You can create custom views of your document. Custom views enable you to quickly change the view mode, magnification, scroll position, and layer options.

To create a custom view of an Illustrator document, set the view attributes you want to save. Choose View > New View and enter a name in the New View dialog box. 

You can change the resolution of raster effects to optimize Illustrator performance. To change the resolution of raster effects, do the following: 

  1. Choose Effect > Document Raster Effects Settings

  2. In the Resolution pop-up menu, do one of the following:

    • Choose Screen if you're editing files and click OK. Illustrator uses a resolution of 72 ppi for raster effects, increasing display speed.
    • Choose High if you're printing files and click OK. Illustrator uses a resolution of 300 ppi for raster effects, decreasing printing speed but increasing print quality.

For more information, see About raster effects.

Use the Layers panel to organize and modify the artwork. When you hide layers and thumbnails that contain complex artwork or high-resolution bitmap images, Illustrator redraws the screen faster.

To hide a layer, click the   icon to the left of the layer name. To hide all but the selected layer, Alt-click (Windows) or Option-click (for macOS) the   icon.

The Layers panel can display thumbnails for top-level layers, nested layers, groups, and objects. Choose Panel Options from the Layers panel menu and reduce the number of thumbnails. 

For more information, see Hide layers.

The first image shows how to open Panel options from the Layer panel menu. The second image shows a list of options in Layer Panel Options.
Layer panel options

Overprint Preview provides an "ink preview" that approximates how blending, transparency, and overprinting appear in color-separated output. To enhance performance, avoid using Overprint Preview.

To enable and disable Overprint Preview, choose View > Overprint Preview. To learn more, see About overprinting.

Artboards represent the regions that can contain printable artwork. To optimize performance, consider deleting unused or unnecessary Artboards.

To manage your Artboards, choose Window > Artboards. Select an artboard you want to remove and click Delete. For more information, see Delete artboards.

When you work with an embedded bitmap image and your system doesn't have enough RAM, Illustrator uses hard disk space as a scratch disk. It takes longer to access information on a hard disk than it does to access information in memory. Therefore, using a portion of the hard disk as virtual memory can decrease performance. If you need more memory to work in Illustrator, Adobe recommends installing more RAM.

By default, Illustrator uses the system drive as its primary scratch disk. Change the Illustrator primary scratch disk setting to your fastest hard drive.

To change the scratch disk preference, choose your operating system and do the following:

  1. Choose Edit > Preferences > Plug-ins & Scratch Disk.

  2. Choose a hard disk from the Primary pop-up menu. If you work with large images and have more than one hard disk, choose another disk from the Secondary pop-up menu.

  3. Click OK and restart Illustrator.

  1. Choose Illustrator > Preferences > Plug-ins & Scratch Disk.

  2. Choose a hard disk from the Primary pop-up menu. If you work with large images and have more than one hard disk, choose another disk from the Secondary pop-up menu.

  3. Click OK and restart Illustrator.

Illustrator Document Profiles contain default patterns, gradients, graph designs, colors, color libraries, and brushes that appear in new Illustrator documents. These files also determine zoom level, window size, viewing preferences, and scroll position for new documents. To minimize the file size of new documents, remove unnecessary swatches and brushes from Illustrator's new document profiles.

Templates let you create documents that share common settings and design elements. You can minimize the file size of new documents by removing unnecessary swatches, symbols, graphic styles, and brushes from templates.

For instructions on creating template files, see Files and Templates.

Embedded bitmap images (for example, TIFF, BMP, or Photoshop EPS) can dramatically increase the size of an Illustrator document, causing slower performance. To improve performance, enable the Link option when you place a bitmap image. The Link option references the placed image on the hard disk.

  1. Choose File > Place.

  2. In the Place dialog box, select Link.

If a service bureau requires embedded images, save a copy of the files. Select Include Linked Files in the Illustrator Native Format Options or EPS Format Options dialog box. For more information, see Import artwork files.

If a document contains linked EPS images with high-resolution previews, Illustrator redraws the screen slower as you edit artwork. To enable Illustrator to redraw the screen more quickly, use low-resolution EPS previews. Choose your operating system and do the following:

  1. Choose Edit > Preferences > File Handling & Clipboard.

  2. Select Use Low Resolution Proxy For Linked EPS and click OK.

  1. Choose Illustrator > Preferences > File Handling & Clipboard.

  2. Select Use Low Resolution Proxy For Linked EPS and click OK.

The Links Panel Options dialog box includes a Show DCS Transparency Interactions option. If this option is selected, the Links panel displays a yellow icon to identify linked DCS EPS graphics that are transparent or overlap transparent objects. Because this option forces Illustrator to regularly determine if linked EPS files interact with transparency, it can decrease performance.

To disable the Show DCS Transparency Interactions option, do the following:

  1. Select Windows > Links. From the Links panel menu, choose Panel Options.

  2. Deselect Show DCS Transparency Interactions and click OK.

The Navigator panel displays a thumbnail view of your current artwork for easy navigation. The processing time required to update the thumbnail each time you change the document depends on the complexity of your artwork. To improve screen redraw speed in a complex document, hide the Navigator panel. Choose Windows and deselect the Navigator

You can set up custom views to more efficiently zoom to particular areas of your document. For more information, see View artwork.

The Anti-alias Artwork option smooths text and graphics by blending the color of an object's edge pixels with the color of adjacent pixels. However, this process can cause slow screen redraw. To disable this option, choose your operating system and do the following:

Images of the same artwork that show how the design looks when anti-aliased artwork is disabled and enabled.

A. Anti-aliased artwork when disabled B. Anti-aliased artwork when enabled 

  1. Choose Edit > Preferences > General.

  2. Deselect Anti-aliased Artwork and click OK.

Images of the same artwork that show how the design looks when anti-aliased artwork is disabled and enabled.

A. Anti-aliased artwork when disabled B. Anti-aliased artwork when enabled 

  1. Choose Illustrator > Preferences > General.

  2. Deselect Anti-aliased Artwork and click OK.

The Simplify command reduces the number of anchor points in paths and path shapes, reducing file size and increasing performance. To apply the Simplify command, select the desired path or object and choose Object > Path > Simplify.

For more information on the Simplify command, see Simplify paths.

Smart Guides allow you to create, align, edit, and transform Illustrator objects relative to other objects. If you've many objects in your artwork, Illustrator requires more time to display Smart Guides. To disable Smart Guides, choose View and deselect Smart Guides.

For more information on Smart Guides, see Rulers, grids, and guides.

Related resources

Apart from optimizing the operating system, and hardware and using Illustrator efficiently, you can also fix GPU performance to boost Illustrator performance. Check these articles to learn about other related issues:

Join the conversation

If you have a question to ask or an idea to share, come and participate in Adobe Illustrator Community. We'd love to hear from you.

Adobe logo

Sign in to your account